App could not be installed from Windows Store, Error code:0x80240031


  • installation_failed_app

    i have tried many times but same error exits only with this app (Perfect 365), rest all apps are being installed easily and  are working.
    how can i install this app(Perfect 365) and what does this error code mean.

    Wednesday, December 26, 2012 7:30 PM


All replies

  • [View details - Error code: 0x80240031]

    how can i install this app(Perfect 365) and what does this error code mean.

    Probably not as much as the (undisclosed) "something happened" symptom.   FWIW I would try running ProcMon to see what is going on.   For one thing it might expose any other diagnostics which are being created.
    Wednesday, December 26, 2012 8:02 PM
  • The error message tells you that the file has a wrong format:

    err 0x80240031
    # for hex 0x80240031 / decimal -2145124303
      WU_E_INVALID_FILE                                              wuerror.h
    # The file is in the wrong format.
    # 1 matches found for "0x80240031"

    Do you use a firewall or AV tool which may corrupt the files?

    "A programmer is just a tool which converts caffeine into code"

    Wednesday, December 26, 2012 9:02 PM
  • I to am getting this error trying to update from Win 8 x64 Pro Upgrade edition to Win 8.1. Only using Windows defender and Windows Firewall. A couple things to note:

    1. My connection to the Internet on this machine is through my phone only, currently have no other means of reaching the Internet, so could this possibly be ISP related? Does the "Windows Store" use some other port rather than 80 or 8080? What ports does it use? No documentation on this...

    2. I ran a system refresh, same exact results. Using "sfc /scannow" finds no errors. I'm close to backing up and FFR-ing at this point.

    3. Updates through good old "Windows Update" from control panel install just fine. System (including drivers) are all up-to-date.

    4. Other app updates (for "Sports" "Music" and "Video" apps) will not install from the store either. These fail with 0x80072f8 though.

    5. Tried "wsreset" and got the same results. I'm admin on the machine and account is tied to my MS Live account.

    I'm at a loss here. Ideas?

    Sunday, October 20, 2013 5:14 PM
  • I'm getting this error too.

    I could be wrong but I'm assuming it's because of our internet connections not being very reliable. Somewhere along downloading the download becomes corrupted.

    Try leaving your computer downloading at a time of day when you'll get a good connection and not doing anything else on it.

    Saturday, October 26, 2013 10:57 PM
  • Same thing here.

    I have tried a dozen times to download the file. It gets about 1GB of the 2.1 GB file and dies.

    I really hate Microsoft. This downloading from the store is just stupid!


    Saturday, December 14, 2013 9:07 PM