Vista Unidentified Network Problem After Windows Update


  • Hi,

    We have a Sony Vaio VGN-TT280N comouter in our domain. We installed Vista Business + SP2 on it. Everything worked without problem. However, after applying Windows Updates and a restart, computer couldn't get an IP from DHCP server. Computer couldn't get IP from wireless router either.

    KB article on Microsoft Support ( also didn't work.

    There are almost 30 updates applied and we couldn't find the one that caused the problem. There are no group policy applied from the domain controller.

    Have you experienced a problem like this?
    Tuesday, December 15, 2009 8:44 AM

All replies

  • Access to the Internet network is working? (printers and shared folders)

    If so, try a firmware update of your router.


    Tuesday, December 15, 2009 11:13 AM
  • The problem is not related with router I think... Problem arises just after the updates are installed. There are other Vista PC's in the network that are connected to the network successully.

    Tuesday, December 15, 2009 11:16 AM
  • Has some anti virus or firewall?

    Try disabling them.

    Also check in safe mode with networking if you can access the network normally.

    Tuesday, December 15, 2009 12:00 PM
  • Nope :( No 3rd party software exist and Windows Firewall and Defender is closed.

    Safe mode also didn't help...
    Tuesday, December 15, 2009 12:08 PM
  • Restart the DHCP Client service, with the startup type automatic.
    (use the command line: SERVICES.MSC)

    Go into the registry editor,

    HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ services \ Dhcp
    HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ services \ Dhcp \ Parameters
    HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ Tcpip \ Parameters

    User Adion the LocalService and assign Full Control permission, the keys above.

    Tuesday, December 15, 2009 12:32 PM
  • Don't mean to resurrect this thread, but I ran into a similar situation.

    I am using vista home 32-bit, and just last night I ran windows update. It had 8 recommended updates, and when I clicked view only 7 were check-marked. So I put a check near the unchecked one, which had a name similar to the others. I left the download/install updates on those 8 items overnight, and when I woke up I rebooted.

    I had no internet access on my vista PC that I just updated overnight. My Xbox 360, and other computer with XP Pro SP3 were fine. After resetting my modem/router and restarting several times to no avail, I started searching on the internet for 'unidentified network' problems. After about 3 hours of searching and trying everything I could like internet/network settings and registry edits, I came across a post that said the simplest thing; 'make sure you have no malware/spyware'. So I ran a quick scan of malwarebytes anti-malware program, and it found 16 objects infected.

    After a reboot, it was finally letting me connect to the internet again. I updated the databse for malwarebytes and am running a full-scan right now so far and nothing has come up yet.

    I'm suspecting one of the vista updates was false and the one that was un-checked that I checked was probably the malicious 'fake update', which is smart/evil whatever you want to call it that they disguised that file to look like the others with a similar name and even under 'recommended'.

    So, be careful what updates you install and if one of the 20+ solutions out there for this problem don't work, run a malware scan.
    Monday, February 22, 2010 10:46 PM