none
Windows 7 Sound & Display Drivers (M-Audio & Nvidia)

    General discussion

  • Hi,
    When i first installed Windows 7 everything looked cool and was installed. I think that's a very good job from Microsoft! Everything was ok in my case except some problems descibed below... and the logon screen, why is it 16bit? looks like it, because it's faster? or .PNG maybe? i dont kow :S but i still love and use Seven :)) i have a XP partition as well.  

    ========================================================================
    Display drivers + Nforce
    ========================================================================

    <<<<Problems>>>>

    1.> Where is the Nvida control panel?

    2.> WDM Drivers? (i know them from a long time ago, but what is WDM actualy? i still do not know that?  can someone tell me what WDM is? or is it    very unimportant :)

    3.> And the Nvidia Nforce drivers...? internet (my Ethernet Card) works, so it must be installed, see more below. 


    <<<<Answers>>>>

    1.> First by doing the "Windows Update" and downloading the newest WDM drivers, Geforce 9800 GX2 SSC from EVGA (for me) that solved the problem of    the Nvidia control panel.

    2.>Check the Nvidia Windows 7 page! http://www.nvidia.com/object/windows_7.html for new Windows 7 64 &   32 bit Nvidia Geforce Display drivers!

    3.>About Nforce, I installed 15.23_nforce_winvista64_international_whql (64bit in my case :P)
      found on page: http://www.nvidia.com/Download/Find.aspx?lang=en-us (for my Nforce 650i SLI
      chipset)


    ====================================================================
    M-audio sound device driver problems:
    ====================================================================


    <<<<Problem>>>>

    -> A major problem is the crackling sound. it's a reason to uninstall or better called "format" Windows 7 of your hard drive patition.
        There are official drivers for Windows 7 from M-audio. 


    <<<<Answers>>>

    1.> For my M-Audio (Firewire = Apple USB... lol) Audiophile i use NOT!! the newest FW_V64_5.10.00.5055v2.exe Vista 64bit driver from M-Audio. I use the  FW_5034_x64 driver (Beta XP driver) for Windows 7 :D can be found here: http://www.touslesdrivers.com/index.php?v_page=23&v_code=7855

    2.> I still had some crackling problems.. i solved it this way !! 
           Install the "Sony 8032 OHCI i.LINK(IEEE 1394) PCI Host Controller" ! (Texas Instruments)  
           Instead of the pre-installed one. Just manual install the driver, and sure it has no ''driver cetificate'' :)  

    3.> And also download the "update_for_windows_7_beta_x64_kb961367" some Mp3 fix :) (64bit)   http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=0c56bf3c-9370-4fda-b4c8-5dc63d55626d

     It all works fine over here ;) maybe some crackles at the Windows sounds sometimes, but not in normal Mp3 etc...  audio playback
     and sure ASIO works! I use Traktor Pro Scratch and it works fine.

     Good luck! Siroy® :))


    System Info:
     
    Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7000) (7000.winmain_win7beta.081212-1400)Language: Dutch (Regional Setting: Dutch)
    System Manufacturer: Paradigit
    Processor: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz (4 CPUs), ~2.4GHz
    Memory: 4094MB RAM
    Page File: 1502MB used, 6985MB available
    DirectX Version: DirectX 11
    DxDiag Version: 6.01.7000.0000 64bit Unicode
    Display Device: NVIDIA EVGA GeForce 9800 GX2 SSC
    Monitor: iiyama 22" ProLite E2201B
    Native Mode: 1680 x 1050 (59.954Hz)
    Sound Device: M-Audio Firewire Audiophile
    Mainboard: MSI P6N SLI V2








    • Moved by Ronnie VernonMVP, Moderator Monday, March 09, 2009 1:51 AM Request (Moved from Windows 7 Performance to Windows 7 Hardware Compatibility)
    • Edited by siroy Tuesday, March 10, 2009 12:00 PM
    Sunday, March 08, 2009 9:03 PM

All replies