locked
How to Enable NUMA mode on Hyper-V in W10? RRS feed

  • Question

  • I cannot find a likely forum for my question, so please move this to where it belongs.

    Can I and if so, how do I Enable NUMA Mode on Hyper-V running under W10 x64 Professional?  I currently have NUMA mode enabled on my AMD 3970X processor (32 cores/64 threads). 

    Thanks much and enjoy, John.

    Wednesday, July 15, 2020 12:19 AM

Answers

  • You could configure NUMA in the processor settings of a VM in Hyper-V manager.

    For more detals you may refer to the this link

    https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2012-r2-and-2012/dn282282(v=ws.11)


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by johnhc2 Wednesday, July 15, 2020 7:14 PM
    Wednesday, July 15, 2020 7:19 AM
  • Thanks, Ian Xue.  Please note that I am asking about W10 not Windows Server 2012.  At the very top of your link it says: Applies To: 'Windows Server 2012.'  I have played with the screen you show which looks the same as yours except the numbers.  It does agree as to the "NUMA nodes: 1".  My W10 x64 Pro VM shows NUMA nodes are not Enabled in W10 Task Manager.  I am asking how to Enable NUMA on my W10 VM running on my W10 host (with NUMA) Enabled.  Thanks and enjoy, John.

    My host task manager - 8 NUMA nodes.

    • Marked as answer by johnhc2 Wednesday, July 15, 2020 7:14 PM
    • Unmarked as answer by johnhc2 Wednesday, July 15, 2020 7:15 PM
    • Marked as answer by johnhc2 Wednesday, July 15, 2020 7:17 PM
    Wednesday, July 15, 2020 3:54 PM
  • Ian Xue, disabling Dynamic Memory allow NUMA to work.  Thanks for your help.  Enjoy, John.

    • Marked as answer by johnhc2 Wednesday, July 15, 2020 7:22 PM
    Wednesday, July 15, 2020 7:22 PM

All replies

  • A single AMD processor is a NUMA node.  You'd need two processors to have more than one
    Wednesday, July 15, 2020 12:40 AM
  • Thanks, gettnmorebetter.  My real machine has 8 NUMA nodes.  Hope there is a way.  Thanks and enjoy, John.
    Wednesday, July 15, 2020 12:47 AM
  • You could configure NUMA in the processor settings of a VM in Hyper-V manager.

    For more detals you may refer to the this link

    https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2012-r2-and-2012/dn282282(v=ws.11)


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by johnhc2 Wednesday, July 15, 2020 7:14 PM
    Wednesday, July 15, 2020 7:19 AM
  • Thanks, Ian Xue.  Please note that I am asking about W10 not Windows Server 2012.  At the very top of your link it says: Applies To: 'Windows Server 2012.'  I have played with the screen you show which looks the same as yours except the numbers.  It does agree as to the "NUMA nodes: 1".  My W10 x64 Pro VM shows NUMA nodes are not Enabled in W10 Task Manager.  I am asking how to Enable NUMA on my W10 VM running on my W10 host (with NUMA) Enabled.  Thanks and enjoy, John.

    My host task manager - 8 NUMA nodes.

    • Marked as answer by johnhc2 Wednesday, July 15, 2020 7:14 PM
    • Unmarked as answer by johnhc2 Wednesday, July 15, 2020 7:15 PM
    • Marked as answer by johnhc2 Wednesday, July 15, 2020 7:17 PM
    Wednesday, July 15, 2020 3:54 PM
  • Ian Xue, disabling Dynamic Memory allow NUMA to work.  Thanks for your help.  Enjoy, John.

    • Marked as answer by johnhc2 Wednesday, July 15, 2020 7:22 PM
    Wednesday, July 15, 2020 7:22 PM