Windows 7 Printer mapping problem


  • I have a problem that many have experienced i.e. "Windows cannot connect to the printer. Operation failed with error 0x0000000d."
    I never experienced this before with XP and Vista 64-bit and have now encountered this problem under 3 Windows 7 64-bit Ultimate machines.
    The printer is connected to my Netgear ReadyNAS via USB. The solution that I have seen/read that is widely used is to add a local printer under LPT2 and to run the DOS command "net use LPT2: \\Server Name\Printer Name".
    This solution seemed to have worked with one PC but on another, I persistently get "System error 85 has occurred. The local device name is already in use."
    Can someone offer a better solution rather than this workaround.
    It's obviously a problem with Windows 7 since it is occurring consistently.
    Friday, February 05, 2010 6:35 PM

All replies

  • Hi,


    This "System error 85" can occur if the drive letter that is being mapped by the net use command is already mapped in the user's properties. To resolve this issue, change the drive letter mapping in the logon script or in the home drive to correct the overlap of drive letters.


    For more information, please refer to the following article:


    Error Message: System Error 85 Has Occurred. The Local Device Name Is Already in Use


    Meanwhile, regarding the 0x0000000d error when trying to map the printer, please also try the suggestions from the link below:


    windows cannot connect to the printer. Error 0x0000000d




    Tuesday, February 09, 2010 8:53 AM
  • Hi,
    Thanks for the suggestion but there is no mapping to that drive letter. Here are the first few lines of my script:

    net use * /d /yes

    net use LPT2: \\MarvelNAS\SLP440 mArVe1U5 /USER:Zeus

    Tuesday, February 09, 2010 8:58 AM
  • Hi,

    Please open My Computer window or Disk Management and assure that the mapped drive is available. Then, please refer to the following article to disconnect the original mapped printer and map the printer again.

    How to print to a network printer from an MS-DOS-based program

    If the error persists, please try other suggestions from the following link:

    windows cannot connect to the printer. Error 0x0000000d



    Wednesday, February 10, 2010 3:01 AM
  • Thanks again Novak but you're really giving me the information that I already had when I posted this problem. The real issue is with Windows 7 as it never existed with any previous Windows version.
    What you're proposing is a workaround and not a solution. Nevertheless, I've given up trying to troubleshoot the problem and reinstalled Windows and using the workaround that I already know of. This takes a lot of fiddling around and eventually it worked. But seriously, if Microsoft wants users to take them and Windows 7 seriously, something that simple should not be allowed to fail in a newly released OS, don't you think especially considering it has always worked in previous Windows versions?
    Wednesday, February 10, 2010 7:09 AM
  • I have a similar problem I Think ( see my today post "Adding an USB shared printer (win2K computer) on a laptop running windows 7 " )

    It seems to be a microsoft network windsows 7 approach problem?


    Wednesday, February 10, 2010 1:31 PM
  • Too right! However, I never encountered this problem before Win7. The USB printer has been hooked up to the NAS (several different NAS' over the years and the current on is a Netgear ReadyNA) and has always worked since XP until Vista 64-bit. Win 7 64-bit Ultimate ALWAYS fails. I've had it on a few different machines and reinstalled it on some numerous times and can confidently say it is definitely Windows 7. I can't recall if I encountered this under Win RC.
    Wednesday, February 10, 2010 1:39 PM