none
Drivers for Sierra Wireless MC5725 Modem on T61p

    Question

  • I am trying to get the Sierra Wireless MC5725 Modem working on my T61p on Windows 7 RC, using verizon. The install did not install a driver for this. I have tried to install the Vista driver, but no go. I cannot find another dirver to download.

    Does anyone have any suggestions about how to get this working.

    Thanks
    Thursday, June 04, 2009 4:51 AM

Answers

  • Yes, this problem was resolved by going to http://www-307.ibm.com/pc/support/site.wss/MIGR-67954.html and downloading 7mwc03ww.exe. Once I expanded it I run it (C:\DRIVERS\WIN\WWANSR\Driver\MC5720AC.msi twice. The first time it created a bunch of serial ports and other devices. The second time I ran it those disappear and the Sierra modem appeared in the device manager. I am not sure why I had to run it twice, but that is what worked for me.
    • Marked as answer by Adam M MCP Saturday, June 13, 2009 6:36 PM
    Saturday, June 13, 2009 6:34 PM

All replies

  • Hi MattDJ,
     have checked the Lenovo & Sierra sites for drivers, usually drivers from your manufacturer are your best choice, The Sierra drivers should be the better, but since this is a Lenovo/IBM I would try them first.

    Regards Fagan
    • Proposed as answer by Jacrabbit Monday, June 15, 2009 8:14 AM
    Monday, June 08, 2009 9:59 AM
  • Yes, this problem was resolved by going to http://www-307.ibm.com/pc/support/site.wss/MIGR-67954.html and downloading 7mwc03ww.exe. Once I expanded it I run it (C:\DRIVERS\WIN\WWANSR\Driver\MC5720AC.msi twice. The first time it created a bunch of serial ports and other devices. The second time I ran it those disappear and the Sierra modem appeared in the device manager. I am not sure why I had to run it twice, but that is what worked for me.
    • Marked as answer by Adam M MCP Saturday, June 13, 2009 6:36 PM
    Saturday, June 13, 2009 6:34 PM
  • Glad that it works Matt, lets think it will stay that way!!!

    Regards Fagan
    Monday, June 15, 2009 8:16 AM