none
Deleted RRS feed

All replies

  • Hello,

    do you have any updates on this problem?

    thx

    Monday, March 11, 2013 2:35 PM
  • Are you using wireless network with Hyper-V virtual switch? Does authentication starts working when you disable hyper-v wireless switch?
    Monday, March 11, 2013 8:36 PM
  • I am experiencing this same issue as well through a wired connection.

    After starting up, I have to go into the Hyper-V Virtual Switch properties, change it from External to Internal, let my actual NIC authenticate and connect to our network. Then I switch back from Internal to External and let the Virtual Switch take over the physical NIC again.

    I have tried playing with the Authentication tab for the vEthernet connection, but matching the physical NIC settings does not work AND I've noticed that these settings "reset" every time I reboot the system.

    Tuesday, April 16, 2013 12:55 PM
  • We're seeing the same issue on a Windows 8 client machine running Hyper-V on our network as well.  Does anyone have any ideas we could try?
    Wednesday, May 1, 2013 1:57 PM
  • Hi,

    are there any news regarding this issue? I experience a similar behavior. IEEE 802.1X and certificate auto-enrollment is configured via GPO and works find without Hyper-V Switch. If the Hyper-V Switch is configured for the external network adapter 802.1X stops working. 

    I see that both network adapters (physical and virtual) have the same 802.1X Config.

    Is it possible that the new adapter does not have the .1X config on the hypervisor and instead on the virtual host? This would make ist possible that the VM has it's own certificate.

    Best Regards,
    Michael

    Tuesday, June 25, 2013 11:16 AM
  • I am also experiencing the same issue. Did anyone end up with a solution to this? 

    Mark Dordoy

    Wednesday, November 13, 2013 10:34 AM
  • Any update? Has anyone called Microsoft Support to report this defect?
    Wednesday, November 13, 2013 8:12 PM
  • Have you found some kind of work around ?
    We are implementing 802.1x in our enviorment and all of the machines that have a Vitual switch in hyper-V with external access and host access stop working with the 802.1x

    This must be a known issue and MS must have a work around.

    Best regards,
    Valdi Hafdal


    best regards, Valdi Hafdal

    Wednesday, December 4, 2013 7:38 PM
  • Not so far. Did anyone Check with Windows 8.1? BR Michael
    Wednesday, December 4, 2013 10:54 PM
  • Same issue on Windows 8.1 - as soon as the physical NIC is used for the Hyper-V switch authentication fails on the host and guests, no EAP packets can be seen on the physical switch from either.

    If the physical port is force authenticated then the same configuration works absolutely fine.

    Has anybody confirmation from Microsoft if this is intended to work or if this is actually a bug?

    Monday, December 9, 2013 6:49 PM
  • We're still seeing the same behavior in Windows 8.1.  One of our network techs and I just worked through every possible permutation of .1x authentication - computer account, computer certificate, user account, user certificate.  Each of them would pass .1x authentication with Hyper-V not enabled, or with an internal virtual switch, but as soon as we turned the onboard NIC into a Hyper-V external switch, .1x authentication stopped.  We verified on the Cisco switch that the EAPOL packets were not even reaching the switch.

    We'd love to use Hyper-V in our production environment, but we must have .1x authentication enabled due to the requirements of our industry.  Looks like this is something that Microsoft has to step up to fix.

    Tuesday, January 28, 2014 10:13 PM
  • Any Update of how to resolve this issue? i encounter the same problem here. mine was a win8 box,i have updated all the patches from microsoft .


    yoke88
    IM:yoke-msn@hotmail.com

    Monday, March 3, 2014 5:00 AM
  • We're still seeing the same behavior in Windows 8.1.  One of our network techs and I just worked through every possible permutation of .1x authentication - computer account, computer certificate, user account, user certificate.  Each of them would pass .1x authentication with Hyper-V not enabled, or with an internal virtual switch, but as soon as we turned the onboard NIC into a Hyper-V external switch, .1x authentication stopped.  We verified on the Cisco switch that the EAPOL packets were not even reaching the switch.

    We'd love to use Hyper-V in our production environment, but we must have .1x authentication enabled due to the requirements of our industry.  Looks like this is something that Microsoft has to step up to fix.


    Same here as well. I saw the problem on Windows 8 originally and upgrading to 8.1 had zero effect. Has anyone tried with the new Windows 8.1 Update 1 installed?
    • Edited by Brachus12 Monday, April 21, 2014 12:19 PM spelling mistakes
    Monday, April 21, 2014 12:19 PM
  • I have tried with windows 8.1 update 1 installed ,but the problem still exist

    yoke88
    IM:yoke-msn@hotmail.com

    Tuesday, April 22, 2014 1:02 AM
  • Any update on the issue from Microsoft? Or do we have to wait for Windows 10?

    Rao

    Monday, October 27, 2014 9:50 AM
  • Just throwing in my hat here as I too am running Windows 8.1 update 1 and still have the problem whereby .1x authentication  is not possible when Hyper V is enabled.
    Tuesday, December 2, 2014 8:56 PM
  • Hello,

    I got official statement from Microsoft that 802.1x with Hyper-V on Windows 8.1 is not working by design.

    • Proposed as answer by c_altair Thursday, June 11, 2015 6:54 PM
    • Unproposed as answer by c_altair Thursday, June 11, 2015 6:54 PM
    Thursday, December 4, 2014 1:41 PM
  • Any solution for Hyper-V?
    I'm having to use Virtualbox !!
    Thursday, June 11, 2015 6:55 PM
  • Hi

    seems the same with windows 10 =(

    Any update of how to resolve this issue?

    Regards

    Mattias

    Monday, August 1, 2016 12:13 PM