none
Sending a message to Win 7 host with msg.exe

    Question

  • Hi,

    I'm trying to send a message with the msg.exe to a Win 7 host. But I always got the error "Error [5]:Access is denied". What I have to do to get the permission to send a message to the host?
    Wednesday, October 07, 2009 2:06 PM

Answers

  • Hi Sven,

    Could you please take following steps to troubleshoot the issue?


    1. Open the Registry Editor.
    2. In the left pane, locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server

    3. In the right pane, ensure value of AllowRemoteRPC key is 1. If not, please change it to 1.
    4. Quit Registry Editor and Reboot the computer.
    5. Run MSG command in a elevated CMD window.

    Hope it helps.

    Thursday, October 08, 2009 9:37 AM

All replies

  • Hi Sven,

    Could you please take following steps to troubleshoot the issue?


    1. Open the Registry Editor.
    2. In the left pane, locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server

    3. In the right pane, ensure value of AllowRemoteRPC key is 1. If not, please change it to 1.
    4. Quit Registry Editor and Reboot the computer.
    5. Run MSG command in a elevated CMD window.

    Hope it helps.

    Thursday, October 08, 2009 9:37 AM
  • I completed this registry fix and for the first time ever, I was successfully sending messages to all the computers in my network! I was so happy. then, a few hours later, and ever since, when i try to send a message it says "USERNAME does not exist or is disconnected" where USERNAME is the name of the user i'm trying to send a message to. this is so frustrating because it was working FINE after the registry fix, and nothing changed except the time of day.. and now it wont work. i checked and the AllowRemoteRPC value is still "1". i can type NET VIEW and all the other computers in the network show up. i can still share files through homegroup and print remotely. this is stupid. i hate windows 7.
    NOW what???
    Thursday, October 29, 2009 9:22 AM
  • Hi Sven and Ronnie,

    Please let me first describe about my expierences with msg.exe between different computers: After setting the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server to 1 (on all involved computers) msg.exe works between two Windows7 Enterprise hosts and between a Terminalserver (Windows Server 2008 & Windows Server 2003)  and a Windows7 host as administrator@domain and as one and the same user@domain! That means, that user administrator@domain can send messages to any user@domain (on any host) with the command:

    msg username /server:hostname message

    and user halodrio@domain can send messages with the same command to all users hallodrio@domain on any host (regardless the group membership of halodrio). If any other user@domain tries to send halodrio a message the error "hallodrio does not exist or is disconnected" appears. But if the user hallodrio@domain is in the administrator group of the target host the message appears correct! This works really only if hallodrio@domain is in the adminstrator group (it does not work neither hallodrio is in the Remote Desktop User group nor in the Power User group).

    To clarify:

    User hallodrio@domain has to be in the Administrator group on the target host to be possible sending a message to any user@domain on the target host!

    I'd like to note why we are using this command. We are running batch jobs which take sometimes a lot of time (several days or weeks) and for these big jobs it's often essential to check the processed intermediate data (to see that everything goes wright) and these messages should receive all involved collegues. Of course it's not a solution to put all these users in the Administrator group!

    So I hope anybody in this forum knows which permissions are exactly required on the target host for receiving a message with msg.exe?! Then it should be easy to give these permissions the users from whom are wanted to receive messages (without giving them administrator rights).

     

    Thursday, April 15, 2010 2:03 PM
  • Hi Guys,

    we have over 500 windows 7 ent stations, i was wondering if there is a way of sending a message using msg.exe from a server to users of a specific group ?

    many thanks for your help Ryan

    Thursday, August 12, 2010 8:15 AM
  • Does anyone have any updates on this issue?

    I want to send a message to all users in my domain at once, for notifications purposes. 

    We used to ( "net send * Hello" )

    This command used to send a message to the entire domain computers. I tried "msg * Hello" but the only one who is getting this message is ME.

    I have tried this "msg * /server dc.domain.local" and the results was just one msg on the dc screen.

     

    Regards

    Black Spider

     

    Wednesday, January 26, 2011 2:10 PM
  • Having same issues as Black Spider. We arn't operating with a server, just a handful of computers in a Windows 7 Homegroup. when i try a 'cmd: netview' I see all of the pc's listed.

    The cmd i've been trying is

    >msg Reception /server:reception-pc "message"

    I get "Reception does not exist or is disconnected"

    I have the Reg. key on all PC's to allow remote rpc.

    Even my send to all >msg * "message"  only sends the message to myself.

    Am i missing a step for Home group messaging? should the Severname be my homegroup, or the target pc?

    Wednesday, February 09, 2011 7:49 PM
  • dont know if this helps but

    msg /server:IP console TEXT

    ex. msg /server:101.01.111.10 console hello

    Monday, February 14, 2011 9:44 PM
  • Hi Sven and Ronnie,

    Please let me first describe about my expierences with msg.exe between different computers: After setting the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server to 1 (on all involved computers) msg.exe works between two Windows7 Enterprise hosts and between a Terminalserver (Windows Server 2008 & Windows Server 2003)  and a Windows7 host as administrator@domain and as one and the same user@domain! That means, that user administrator@domain can send messages to any user@domain (on any host) with the command:

    msg username /server:hostname message

    and user halodrio@domain can send messages with the same command to all users hallodrio@domain on any host (regardless the group membership of halodrio). If any other user@domain tries to send halodrio a message the error "hallodrio does not exist or is disconnected" appears. But if the user hallodrio@domain is in the administrator group of the target host the message appears correct! This works really only if hallodrio@domain is in the adminstrator group (it does not work neither hallodrio is in the Remote Desktop User group nor in the Power User group).

    To clarify:

    User hallodrio@domain has to be in the Administrator group on the target host to be possible sending a message to any user@domain on the target host!

    I'd like to note why we are using this command. We are running batch jobs which take sometimes a lot of time (several days or weeks) and for these big jobs it's often essential to check the processed intermediate data (to see that everything goes wright) and these messages should receive all involved collegues. Of course it's not a solution to put all these users in the Administrator group!

    So I hope anybody in this forum knows which permissions are exactly required on the target host for receiving a message with msg.exe?! Then it should be easy to give these permissions the users from whom are wanted to receive messages (without giving them administrator rights).

     

    Hi,

     

    Did you find a solution for your problem? I have exactly the same and I tried to modify DCOM security without success.

     

    Thank you.

    Friday, July 08, 2011 7:51 AM
  • I ran into an issue where MSG wasn't sending.

    Command:

    MSG * /SERVER:computer.domain.com Hello

    I found that if I used the IP it would get sent.  I tried adding a period to the end of .com and it sent.  So it seems to be an issue with DNS and/or IPv6.

    Command:

    MSG * /SERVER:192.168.1.1 Hello

    or

    MSG * /SERVER:computer.domain.com. Hello

    Tuesday, January 10, 2012 5:18 PM
  • Isn't it too hard to fix? Maybe third-party software will solve your problem. I mean LanTalk Lan messenger, which have command line interface to send messages and special read-only mode of the client to avoid chatting.
    • Proposed as answer by McFly78Banned Tuesday, May 29, 2012 8:15 AM
    • Unproposed as answer by McFly78Banned Tuesday, May 29, 2012 8:15 AM
    Saturday, May 05, 2012 2:59 PM
  • you must have windows professional or higher

    if you do,

    1 go to credential manager

    2 click add a windows credential

    3 type the name of the computer, username and password of the computer that you are trying to contact

    4 computers that you are trying to contact most be in the same network as you.

    good luck it took me months to get it properly working

    i miss net send

    Friday, August 03, 2012 11:30 PM
  • you must have windows professional or higher

    if you do,

    1 go to credential manager

    2 click add a windows credential

    3 type the name of the computer, username and password of the computer that you are trying to contact

    4 computers that you are trying to contact most be in the same network as you.

    good luck it took me months to get it properly working

    i miss net send


    Wow! Thanks it is really solve my "error 5" problem!
    Monday, October 29, 2012 8:53 AM
  • have to open TCP 445 on firewall inbound rules

    Through GPO the line is:     445:TCP:*:enabled:mesazhet_msgexe

    Tuesday, June 18, 2013 3:11 PM
  • Thank you for this. It really helped me fixed my problem with msg erros.
    Tuesday, January 07, 2014 5:31 AM