none
Attempting to configure IP routing on Windows 7 Pro - question.

    Question

  • I have a Windows 7 Pro system called "Micropress" that has 2 nics that I have enabled IP routing on.
    Nic 1 has a single port that is connected to LAN1 with ip address of 10.1.1.37/24. 
    Nic 2 has 2 ports.  Nic2-portA (10.10.10.1/24) is connected to LAN2.  Nic2-portB(20.20.20.1/24) is connected to LAN3.
    I can ping from the Windows 7 system to ip's on LAN1, 2, and 3 but I can't ping from LAN1 to LAN2, LAN2 to LAN3, etc.  
    What I am trying to do is successfully route traffic thru the Windows computer so that devices on each network can communicate with each other for file sharing, etc.  This is a corporate network running a Windows 2003 domain with internal DNS, etc.  In other words this ain't no workgroup configuration.  Please help.  I can't figure out what I am doing wrong.  I have a diagram at this link http://www.polyengineering.com/filedownload/Micropress-Diagram.jpg that will help give a picture of this environment.
    thanks.

    Thursday, March 31, 2011 2:25 PM

Answers

  • Hi,

     

    Thanks for posting in Microsoft TechNet Forum.

     

    I would like to suggest you try to enable the following configurations:

     

    1.    The IPEnableRouter registry entry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\Tcpip\Parameters\IPEnableRouter

    Set registry entry to 1 (data type is REG_DWORD)

     

    2.    Enable the Routing and Remote Access service.

     

    Regarding the IP routing function of Windows, I would like to share the following article with you, please kindly refer to the IP routing chapter:

     

    TCP/IP Fundamentals for Microsoft Windows

     

    Hope it helps.

     

    Alex Zhao

    TechNet Subscriber Support in forum.

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, April 1, 2011 9:43 AM
    Moderator
  • I have solved my issue.  My problem was I needed to add routes into my network router so it could find the 10.10.10.x and 20.20.20.x networks.
    Something like this:

    eg  10.10.10.0    255.255.255.0   10.1.1.37

         20.20.20.0    255.255.255.0   10.1.1.37


    My Windows system was configured properly.  Hope this helps someone that may run into this in the future.

    Alex - thanks anyway.

    Friday, April 1, 2011 6:08 PM

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet Forum.

     

    I would like to suggest you try to enable the following configurations:

     

    1.    The IPEnableRouter registry entry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\Tcpip\Parameters\IPEnableRouter

    Set registry entry to 1 (data type is REG_DWORD)

     

    2.    Enable the Routing and Remote Access service.

     

    Regarding the IP routing function of Windows, I would like to share the following article with you, please kindly refer to the IP routing chapter:

     

    TCP/IP Fundamentals for Microsoft Windows

     

    Hope it helps.

     

    Alex Zhao

    TechNet Subscriber Support in forum.

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, April 1, 2011 9:43 AM
    Moderator
  • I have solved my issue.  My problem was I needed to add routes into my network router so it could find the 10.10.10.x and 20.20.20.x networks.
    Something like this:

    eg  10.10.10.0    255.255.255.0   10.1.1.37

         20.20.20.0    255.255.255.0   10.1.1.37


    My Windows system was configured properly.  Hope this helps someone that may run into this in the future.

    Alex - thanks anyway.

    Friday, April 1, 2011 6:08 PM