Unable to delete files from an FTP site using Windows 10 File Explorer RRS feed

  • Question

  • since the previous thread is locked, I'm re-posting this question to see if anyone has a real fix for this problem, or if Microsoft is even aware of it. 

    The original post is found here:

    The issue is this: after some time of using an FTP server, Windows stops deleting files when you tell it to. You can upload (copy-paste) to it, but you can't delete. I know this issue is present in the spring Creator's update (1703), as that's where I have users experiencing this problem. It's present on two different FTP servers, networks, and two different computers (those are just the ones who have told me). Based on the linked thread and the Feedback app, it appears to be an issue on other builds of Windows as well and has been for several years.

    The only workaround I've found is to create a new folder on the FTP site, in the same sub-folder where you're trying to delete files. After creating the folder, go ahead and delete it. Then try to delete nearby files. For some reason, simply the act of creating a new folder re-establishes whatever "stale" credentials were in place.

    Sunday, May 20, 2018 10:55 AM

All replies

  • Hi,

    Thank you for sharing your experience and your efforts on this issue.

    What's the OS build for your Windows 10 1709 client machine? Please run command line "winver" to check.

    As Microsoft have released Window 10 version 1803 as the latest system version, would you check it on Windows 10 version 1803 again to check if it was fixed now?

    Are there any error messages occur when user try to delete file?

    Are there any error codes recorded in Event Viewer\Windows Logs\System?

    Try to delete file use the following command line to check the result.

    rd /s filepath


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Monday, May 21, 2018 8:46 AM
  • deleting files when you tell it to.

    Have you tried using the command line instead of a GUI?  Doing that may give you some insight on what is happening otherwise (or it may be an effective workaround).

    Robert Aldwinckle

    Tuesday, May 22, 2018 1:23 AM
  • Hi,

    I have exactly same issue as ken29147.

    After a while, downloading and deleting files on FTP (in my case empty folders) via file explorer, deleting folders will stop working. Didn't tried command line connection yet.

    My Windows version is 1803 (Build 17134.48).

    Thanks for any advice.

    • Edited by Jan 87 Friday, June 1, 2018 11:58 AM
    Friday, June 1, 2018 11:26 AM
  • Ken, 

    Just curious, what is the FTP server? I am wonder if this is the result of using FTP on Windows Server hosts, or if it is only on a Linux/appliance host? Or does it not matter.. 

    I have a Windows 2012R2 FTP server here in my office, but i don't have the same issues on my Windows 10 1803 system when i try to delete files, folders, or whatever, as long as i meet the permissions requirements. 

    That said this is a stand alone FTP system without a domain on the back end, and is in its own VLAN network, so all permissions are local to the server.. 

    Have you tried using a 3rd party client like WinSCP or Filezilla? (does it thow any errors or log anything funky in these clients that maybe windows doesn't log?) 


    Friday, June 1, 2018 2:22 PM