none
APIPA - Disabling IP autoconfiguration in Vista

    Question

  • Hi, does anybody of you know, how to disable ip autoconfiguration (APIPA) in Windows Vista? I've been looking for it for some time, and haven't found anything useful. Thanks for any help...
    Sunday, November 18, 2007 6:07 PM

Answers

  • Hi Dan Lukes,

     

    Thank you for your information.

     

    Please understand that Windows system (including Windows Vista) will continue trying to acquire an IP address from a DHCP Server after it uses an APIPA IP address. This means that APIPA does not prevent a computer from getting IP address from DHCP Server.

     

    I compared the DHCP Discover packets between the one that a computer does not get an APIPA IP address and the one that it gets an APIPA IP address, and find that there seems to be no different. As a result, suppose APIPA does not prevent a computer from passing the 802.1x authentication.

     

    In other words, APIPA is a function which takes effect after the DHCP failure. Disabling APIPA generally is not a valid solution for DHCP-related problems.

     

    In conclusion, if a Windows Vista computer fail to get an IP address from DHCP Server, please confirm if the DHCP Server supports the BROADCAST flag. For more information, please refer to the following KB article:

     

    Windows Vista cannot obtain an IP address from certain routers or from certain non-Microsoft DHCP servers

    http://support.microsoft.com/kb/928233

     

    Hope it helps.

     

    Sincerely,

    Joson Zhou

    Microsoft Online Community Support

     

    Monday, December 03, 2007 11:21 AM
    Moderator

All replies

  • Hi,

     

    To disable APIPA, please refer to the following KB articles (which also apply to Windows Vista):

     

    http://support.microsoft.com/kb/220874
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;244268

     

    Sincerely,

    Joson Zhou

    Microsoft Online Community Support

     

    Wednesday, November 21, 2007 6:36 AM
    Moderator
  • KB articles mentioned above didn't solve the problem. APIPA is still enabled, even after registry modification. Known methods which worked on Windows XP seems to be uneffective on Windows Vista.

    So question remains. Do anybody know how to turn off APIPA on Windows Vista?

    Wednesday, November 21, 2007 10:17 AM
  • Hi,

     

    Do you mean the system still gets an IP address within the 169.254.x.x range after the registry value "IPAutoconfigurationEnabled" has been set to 0 for the LAN adapter?

     

    Have you rebooted the box after setting the registry value?

     

    I have performed a local test for it, and my testing machine could not get IP address automatically if I set the registry value to 0.

     

    As a result, please export the registry key and the IP configuration and upload them to us for further research:

     

    1.    Registry key:
    =========

    a. Click Start, and type Regedit in the Start Search box to open Registry Editor.
    b. Navigate to the registry key: HKLM\SYSTEM\CurrentControlSet\Services\Tcpip.
    c. Right-click the key Tcpip and select export.
    d. Export the key to a .txt file (we call it reg.txt).

    2.    IP configuration:
    =========

    a. Click Start, and type cmd in the Start Search box to open Command Prompt.
    b. Type: ipconfig /all > c:\ipconfig.txt

    After that, please upload the reg.txt and ipconfig.txt to the following space:
    https://sftasia.one.microsoft.com/choosetransfer.aspx?key=af5d61d5-558d-44c9-9c39-b85d9a274609
    Password: o95*GGLwws

     

    Thanks.

     

    Sincerely,

    Joson Zhou

    Microsoft Online Community Support

     

    Thursday, November 22, 2007 9:23 AM
    Moderator
  • Hello,

    I have the same problem. I am an user of school network for dormitories, but the administrator warned me that I must disable IP autoconfiguration if I don't want to be disconnected from the network. On Windows XP I was able to disable it by editing the registry, but not in Vista, as I have bought new notebook, with Vista Bussiness installed. The registry editing was not successfull, could you please give me some advice?


    Thanks.

    Michal M.
    Thursday, November 22, 2007 10:33 AM
  • Unfortunatelly, I can confirm no

    HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\IPAutoconfigurationEnabled

    nor

    HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<guid>\IPAutoconfigurationEnabled


    will disable APIPA on Vista.

    It seems there are two APIPAs within Vista. First is the same as within previous versions. It's implemented within dhcpsvc.dll - see the DhcpRegFillParams() function. It respect all of the registry settings (IPAutoconfigurationEnabled/IPAutoconfigurationSeed/IPAutoconfigurationAddress/IPAutoconfigurationSubnet/IPAutoconfigurationMask)

    The second implementation seems to be brand new for Vista. It's implemented within tcpip.sys driver - see the Ipv4AddLinkLayerSuffixAddresses() function. This implementation seems not to be affected by a registry settings.

    Please note the analysis above may not be correct as I has no access to Windows source code nor developpers documentation. Ignore it if it's not applicable. We can be sure the recommended registry modification doesn't disable the APIPA on Vista only.


    By the way - i think I know why the Vistas doesn't see the DHCP server even if it is avaiable within network. It is because conflict between 802.1x authentication layer and DHCP client. DHCP client start it's work start too early - before the network link has been authenticated. Short DHCP timeout expire before sucessfull authentization so DHCP server is false-considered as unreachable. Where this kind of bug shall be reported ?
    Friday, November 23, 2007 4:40 PM
  • Hi all,

     

    Please confirm: is it because Windows Vista machine cannot get the IP address from DHCP server that you would like to disable APIPA?

     

    If so, I think disabling APIPA will not be a solution to the DHCP problem. You may refer to the following KB articles and check if they can help:

     

    http://support.microsoft.com/kb/942971

    http://support.microsoft.com/kb/931550

     

    Thanks.

     

    Sincerely,

    Joson Zhou

    Microsoft Online Community Support

     

    Monday, November 26, 2007 10:21 AM
    Moderator
  • You are true - there are two problems, but they are partially related only.  We trying to resolve only one of them here.

    First - DHCP client start to communicate before 802.1x authentication layer finished it's work. The network is unavaiable at all before network card become authenticated, so the DHCP server is unavaiable. Its bug in network stack layering. This bug is not new on Vista. The XP has the same bug. Yes - very short DHCP timeout on Vistas makes things worse as the user needs to wait for next round from DHCP client before he got working connectivity. It's annoyning, but this thread is not dedicated to this particular bug.

    Second - APIPA is problem alone. APIPA is nice mechanism created for the networks without central management of IP adresses. It's not our case. We have central network management. The computer are allowed to use the address that has been dedicated to it only. No computer is allowed to use statically configured address nor random address. If the computer can't obtain an IP address from DHCP server for whatever reason, then it must not use any.

    Even if we resolve the first problem, the second will not disapear - there are uncounted reason for DHCP fail - misconfigured firewall that blocked required communication, virus, broken files or a misconfiguration that case the DHCP client cease to run. In all cases - the computer administrator mus resolve the primary problem. In the meantime, it is not allowed to use a random address that are not driven by centralised management.

    We can disable APIPA on all systems that implement it but Vista. So question remain - how to disable APIPA on Vistas.

    Wednesday, November 28, 2007 11:15 AM
  • Hi Dan Lukes,

     

    Thank you for your information.

     

    Please understand that Windows system (including Windows Vista) will continue trying to acquire an IP address from a DHCP Server after it uses an APIPA IP address. This means that APIPA does not prevent a computer from getting IP address from DHCP Server.

     

    I compared the DHCP Discover packets between the one that a computer does not get an APIPA IP address and the one that it gets an APIPA IP address, and find that there seems to be no different. As a result, suppose APIPA does not prevent a computer from passing the 802.1x authentication.

     

    In other words, APIPA is a function which takes effect after the DHCP failure. Disabling APIPA generally is not a valid solution for DHCP-related problems.

     

    In conclusion, if a Windows Vista computer fail to get an IP address from DHCP Server, please confirm if the DHCP Server supports the BROADCAST flag. For more information, please refer to the following KB article:

     

    Windows Vista cannot obtain an IP address from certain routers or from certain non-Microsoft DHCP servers

    http://support.microsoft.com/kb/928233

     

    Hope it helps.

     

    Sincerely,

    Joson Zhou

    Microsoft Online Community Support

     

    Monday, December 03, 2007 11:21 AM
    Moderator
  • True: APIPA doesn't prevent a computer from passing the 802.1x.

    True: APIPA is a function which takes effect after the DHCP failure.

    But it's not answer to question how to disable such function on the environmemt where it's unnecesarry and break the security policies nor why DHCP handshaking start before network card become fully operational (e.g. authenticated).

    The KB928233 is related to BROADCAST flag of DHCP request. It's no time related problem - if a client has the problem, it has the problem all the times. It client can obtain the DHCP response anytime then it confirm the client and server has no problem with BROADCAST flag everytime.

    But I want to remember - there are two problems - DHCP act too early (so it fail) AND APIPA when DHCP fail (for whatever reason). Even we will find the solution for the first problem, the main problem is the second. I respect the
    "APIPA is a function which takes effect after the DHCP failure" but it resolve nothing in our particular environment and is security risk only.

    So question remain - how to disable APIPA on network with central IP management where no other methods are allowed to assign addresses to computer. It's important security question. The network monitoring will detect any unauthized use of IP address and immediatelly block the station access as it classify it as intruder or dangerously misconfigured.



    Friday, January 11, 2008 1:54 PM
  • I also have a need to disable APIPA here in Vista. My Stonegate firewall acts as a DHCP relay agent to my Windows 2k3 DHCP server. However, the Stonegate is preset to receive BOOTP discover packets only from source IP of 0.0.0.0, anything from a 169 address gets dropped. I've tried setting the AutoIpConfigurationAddress from the 169 to 0.0.0.0 instead, rebooted the machine and the interface STILL gets the same 169 address!

    The question here isn't about whether APIPA should ethically be on or off, the user should have the choice. Sadly that doesn't seem to be the case. Seems to me disabling it is impossible, another unintended "quirk" of Vista. Roll on SP2.
    Thursday, February 07, 2008 3:00 AM
  • I've had exact the same problems. It turned out that the Vodafone Mobile Connect Software for UMTS Cards caused this behaviour. After deinstalling the whole package, the DHCP requests had the source address of 0.0.0.0 again, and workes fine so far.

    this was not related to microsofts APIPA but to vodaphones implementation of the mcc driver. you have to disable tcp/ip optimization twice (first disable a checkbox, second disable installtion of programm feature in the setup routine).

    This is tricky because in most cases anti-spoofing acls on routers will kill your dhcp request before it will be handled by the dhcp-relay agent.

    cheers, p0lar
    Tuesday, February 12, 2008 6:42 PM
  • I experienced the same issue with a sonicwall tz170w, assuming the APIPA assigned address was a spoof attempt.

    I can't take credit for this fix, but it works.

    Click the Start button. Select All Programs > Accessories. Right click Command Prompt and click Run as administrator.
    Type regedit.exe and press enter. Go to the following location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentCon
    trolSet\Services\Tcpip\Parameters
    Right click this entry and select New Dword.
    Rename the new entry ArpRetryCount (leave it set to 0 by default).
     Restart the computer.
    Reassociate with the SonicWALL. You should notice a successful connection.
    This solution was obtained from the following:
    http://www.annoyances.org/exec/forum/winvista/1173910051




    Friday, February 15, 2008 3:47 AM
  • need to know how to disable APIPA without going into the registry. I have users on my network who use VISTA that cannot connect. I will not go into their machines to modify their registry. The only action I will take is tell them to uninstall Vista and get a real operating system like Windows XP.

     

    The only action I will take is to tell them to call the tech support that is servicing their machine, or uninstall Vista as it's a crappy OS. In other words, I have users who use XP that can access my network fine, Everyone who is using vista cannot and I will not go into their registry just because Vista is a crappy OS.

     

    There is nothing wrong with my network. every other machine on it works fine. From the XP machines, to the Xbox 360 to even the little PSP. The only users that cannot connect are the vista users and I refuse to modify any portion of my network just because vista has this stupid bug. Additionally, any OS that requires you to change the registry is a bad OS. So the only thing I will tell my customers is uninstall Vista and get a real OS that works. Unless someone here can tell me how to disable APIPA and the autoconfiguration addressing with simple, 8th grade english instructions that any user, in any language can understand and complete. Bear in mind that some of my clients do not speak english, or english is not their first or second language.

    Wednesday, February 27, 2008 1:56 PM
  • Currently Vista does not honor this registry key. You may check following link:

    http://131.107.112.14/WindowsServerFeedback/feedback/ViewFeedback.aspx?FeedbackID=311626

     

    Monday, May 19, 2008 8:59 PM
  • bummer

    Friday, June 06, 2008 8:48 PM
  • bummer

    Friday, June 06, 2008 8:51 PM
  • Hello All,

     

    I tried to reproduce this issue on Vista RTM and SP1.
    1) When the key IPAutoconfigurationEnabled=0 is under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Paramters the issue does NOT reproduce.

    ie Sytem dont go to the Autoconfig address..


    2) When the key IPAutoconfigurationEnabled=0 is under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Paramters\Adapters\{GUID} the issue does reproduce. Ie: That interface still obtains auto config IPv4 address.

     

    I observed same behavior in Vista RTM and SP1. Global IPAutoconfigurationEnabled=0 works but per interface IPAutoconfigurationEnabled=0 doesn’t work (ie: repro.)

    Can you try disabling globally (IPAutoconfigurationEnabled=0  key under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Paramtersand then Reboot and try to repro the issue?

     

    Disabling globally should work.

    Thanks.

    Saturday, July 19, 2008 1:32 AM
  • Yenel Yildirim [MSFT] ,

    I must say I think you are mistaken.  There is no
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Paramters

    If you mean HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Paramters this is the same as 2000/XP and it DOES NOT WORK.  I have no clue what you're running, but IT DOES NOT WORK on Vista.

    Any fix PLEASE?  This issue should never have been broken in the first place.
    Wednesday, August 19, 2009 9:15 PM
  • I have 2 laptops both running VISTA sitting side by side.  One connects with DHCP and no issues to my wireless network.  the second continues to try to comming using autoconfig.  Have yet to determine why and it is driving my nuts.
    Thursday, August 20, 2009 1:47 AM

  • For me, this problem appears to have been fixed under Vista by the suggestion by Yenel Yildirim [MSFT] above.  Note however that the spelling is "Parameters", not "Paramters" as in his post.

    When I add the key IPAutoconfigurationEnabled=0 (the value is DWORD) under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Parameters
    then I do not (so far) get an IP automatically assigned (the one which had been assigned was always inappropriate, and seemed to take presidence in certain circumstances even over my statically assigned ip address).

    I'm no expert in this matter and haven't tested extensively (and don't know how to), but this appears to have worked.
    Monday, December 14, 2009 11:04 AM
  • Hello All,

    I have the same issue and after trying all the above it worked out being something so simple!!

    we had a brown out and i had 2 jobs come in that after turning there computers back on they didnt have any network drive etc, after a quick look i noticed that the IP was a Local IP and couldnt contact the domain. as i said i tried all the above and nothing worked until i saw there was a small 5 port Linksys Router sitting between the wall and the PC. i pulled the power out and waited the 10 sec and reconnected the power and BAM i had network.

    i would suggest that it you are having this issue then restart the routers that sit between the PC and the domain.
    Wednesday, February 10, 2010 8:22 PM
  • Most of the Vista machines are getting DHCP ok.  A few aren't getting DHCP at all, but when I run ipconfig /renew they get an IP address right away.  All machines have been configure the same as all XP client's I'm running.  The XP clients all work as expected (waiting until they get a proper IP address before displaying logon screen).

    To me, this suggests an issue where Windows Vista is accepting an APIPA address, and not trying to re-obtain an IP address from the DHCP server.

    I'm working around the issue on Windows Vista by creating a startup script then executes a custom program to detect and issue ipconfig /renew if either an APIPA or 0.0.0.0 address is assigned.  So far, this is working well.
    Thursday, February 11, 2010 2:50 AM
  • Good.. Rocking!!

    Abosultely good.

    You are amazing.

    No words for appreciate you.

    How great you are!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!1111

    May thanks!

    KUDOS For your help!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    Thursday, March 18, 2010 6:38 PM
  • Jason, I am sorry but you are incorrect. We have issues with Vista Business. If not on LAN(internal network) a APIPA is given. Users must be members of Administrators and must got into network connection and tell it to Repair....otherwise stays on APIPA address. Not a router issue...only a VISTA network connection issue. Cindy
    Thursday, March 25, 2010 4:26 PM
  • dcindy8,

    Yuup, I'm seeing the same exact issue.  Hoping the move the Windows 7 helps, but I have my doubts.

    I've given up on Windows Vista, what a pile!  Sorry to anyone still dealing with Vista, I feel you pain.

     

    Thursday, March 25, 2010 8:18 PM
  • hi there, i had been in same problem.

    I already do the step regedit>HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces/?  >edit > new >value name:  DhcpConnEnableBcastFlagToggle, 

    value data : i had try both 1 and 0 alternately and restarted, but when i ipconfig/all it still says: autoconfiguration  .... yes.

     

    I want to turn of auto configuration as i have my own network.. After this, shall I set up a DHCP server inside my Window server 2003 ?

    Disable dhcp client services?

    or any configuration I can still do to disabled this auto configuration. I need solution in order i can do my sniffing network for my projects.

    thanks everyone that reading. waiting for solution ...hyeeeeeyyyayaaa..

    Friday, March 26, 2010 2:06 AM
  • i had tried this toooo:

     

    C:\Users\bitylin>netsh interface ipv4 show interface <enter>

    C:\Users\bitylin>netsh interface ipv4 set interface 8 dadtransmits=0 store=persistent <enter>

     

    where the 8 is the interface  listed  network card ldx number.

    when i restarted, ipconfig/all auto configuration enabled----yes..
    i want it No.

    Friday, March 26, 2010 2:52 AM
  • I tried here too:   http://support.microsoft.com/default.aspx/kb/220874?p=1 

    from here:

    For Windows 2000, Windows XP, and Windows Server 2003, APIPA can be disabled by adding the "IPAutoconfigurationEnabled" DWORD registry entry with a value of 0x0 to the following registry key:


    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\<Adapter GUID>

    Note The <var style="-webkit-box-sizing: border-box;">Adapter GUID</var> subkey is a globally unique identifier (GUID) for the computer's LAN adapter.

     

     

    from my ipconfig/all

    Wireless LAN adapter Wireless Network Connection:

     

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : Broadcom 802.11b/g WLAN

       Physical Address. . . . . . . . . : 00-1A-73-9A-C6-B0

       DHCP Enabled. . . . . . . . . . . : Yes

       Autoconfiguration Enabled . . . . : Yes

       Link-local IPv6 Address . . . . . : fe80::3ceb:69e6:f149:57be%19(Preferred)

       IPv4 Address. . . . . . . . . . . : 192.168.1.4(Preferred)

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Lease Obtained. . . . . . . . . . : Friday, March 26, 2010 12:00:52 PM

       Lease Expires . . . . . . . . . . : Saturday, March 27, 2010 12:00:52 PM

       Default Gateway . . . . . . . . . : 192.168.1.1

       DHCP Server . . . . . . . . . . . : 192.168.1.1

       DNS Servers . . . . . . . . . . . : 192.168.1.1

       NetBIOS over Tcpip. . . . . . . . : Enabled

     

    Ethernet adapter Local Area Connection:

     

       Media State . . . . . . . . . . . : Media disconnected

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : Marvell Yukon 88E8039 PCI-E Fast Ethernet

     Controller

       Physical Address. . . . . . . . . : 00-16-D3-F1-4E-92

       DHCP Enabled. . . . . . . . . . . : No

       Autoconfiguration Enabled . . . . : Yes

     

    Ethernet adapter Local Area Connection 2:

     

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet

    1

       Physical Address. . . . . . . . . : 00-50-56-C0-00-01

       DHCP Enabled. . . . . . . . . . . : No

       Autoconfiguration Enabled . . . . : Yes

       Link-local IPv6 Address . . . . . : fe80::5104:d189:3557:8f00%20(Preferred)

       IPv4 Address. . . . . . . . . . . : 192.168.17.1(Preferred)

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Default Gateway . . . . . . . . . : 192.168.2.1

       DNS Servers . . . . . . . . . . . : 192.168.1.2

       NetBIOS over Tcpip. . . . . . . . : Enabled

     

    Ethernet adapter Local Area Connection 3:

     

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet

    8

       Physical Address. . . . . . . . . : 00-50-56-C0-00-08

       DHCP Enabled. . . . . . . . . . . : No

       Autoconfiguration Enabled . . . . : Yes

       Link-local IPv6 Address . . . . . : fe80::a007:d5d1:5548:ca8d%21(Preferred)

       IPv4 Address. . . . . . . . . . . : 192.168.1.8(Preferred)

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Default Gateway . . . . . . . . . : 192.168.1.1

       DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1

                                           fec0:0:0:ffff::2%1

                                           fec0:0:0:ffff::3%1

       NetBIOS over Tcpip. . . . . . . . : Enabled

     

    Is this mean i success turn off the APIPA???thanks..

    Friday, March 26, 2010 5:30 AM
  • I have tried all the above solutions, but it hasn't worked for me. I am connecting to my Shaw Cable internet. But I can never get an IP, i just get the IPV4 autoconfig IP. All the registry changes havent made it work, i've done them all. I even installed Service pack 2 for Vista. I dont know what else to do.
    Sunday, June 06, 2010 4:17 PM
  • Had the same issue on a Win7 box.  Tried all the steps mentioned here in this article without luck.  Then brainstormed (i.e. googled the ____ out of it) and came up with this:

    netsh winsock reset catalog (reset winsock entries)
    netsh int ip reset reset.log hit (reset TCP/IP stack)

    Rebooted the box, it works great again, however APIPA is still enabled.  Oh well.

    Thursday, June 24, 2010 5:48 PM
  • thanks its work in vista i have tried all above but for me  this is working

     

    netsh winsock reset catalog (reset winsock entries)
    netsh int ip reset reset.log hit (reset TCP/IP stack)

    Rebooted the box, it works great again, however APIPA is still enabled.  Oh well.

    thanks for the jrbowne69


    RB
    Friday, January 07, 2011 5:46 PM
  • Had similar issues as all above users, Win 2k8R2x64 wouldn't take a Static or DHCP Assigned IP, kept defaulting back to this horrible feature.

     

    None of the Reg keys worked, thankfully the NetSH commands did the trick.

     

    Feature request:

    Disable Autoconfiguration Yes/No I'm logged in as the damn administrator, why can't I make this choice?

    Wednesday, April 06, 2011 11:31 PM
  • Had the same issue on a Win7 box.  Tried all the steps mentioned here in this article without luck.  Then brainstormed (i.e. googled the ____ out of it) and came up with this:

    netsh winsock reset catalog (reset winsock entries)
    netsh int ip reset reset.log hit (reset TCP/IP stack)

    Rebooted the box, it works great again, however APIPA is still enabled.  Oh well.

    JR you are awesome! I ran into the same problem after a motherboard reinstall... this reset did exactly what it needed!  

    Thanks again.

     

    Thursday, October 13, 2011 1:18 PM
  • Hi all,

     

    Please confirm: is it because Windows Vista machine cannot get the IP address from DHCP server that you would like to disable APIPA?

     

    If so, I think disabling APIPA will not be a solution to the DHCP problem. You may refer to the following KB articles and check if they can help:

     

    http://support.microsoft.com/kb/942971

    http://support.microsoft.com/kb/931550

     

    Thanks.

     

    Sincerely,

    Joson Zhou

    Microsoft Online Community Support

     

    Joson Zhou,

    On this page: http://support.microsoft.com/kb/942971
    appears the instruction "Click Start, point to Programs, point to Administrative Tools, and then click DHCP."
    But on my Vista machine (where I am Administrator), Start -> Programs has no category Administrative Tools, so I cannot follow the instruction.
    Please advise.

    Sincerely,
    Richard Pasco


    Friday, May 17, 2013 4:14 PM
  • A few aren't getting DHCP at all, but when I run ipconfig /renew they get an IP address right away.
    I am not so lucky.  When I run "ipconfig /renew" I get "could not contact DHCP server."  Yes, Windows 7 machine on the same network gets an IP address right away.
    I tried adding a DWORD DhcpConnEnableBcastFlagToggle and setting it to 1 but that doesn't seem to help.
    Friday, May 17, 2013 5:21 PM