none
Hyper-V Manager unable to connect to server "Local computer" RRS feed

  • Question

  • Whenever I launch hyper-v and try to connect to my local computer, I get this error. I have tried disabling hyper-v in windows settings, and re enabling it after a restart. I have renamed my computers host-name. I have also deleted the files in C:\Users\Public\Documents\Hyper-V\Virtual Hard Disks" and C:\ProgramData\Microsoft\Windows\Hyper-V". I also just updated windows to the most recent version. I would really like to fix this issue, is there anything else I should try.

    Error:

    An error has occurred while attempting to connect to server "%hostname%. Check that the VM management service is running and that you are authorized to connect to the server.

    Hyper-V encountered an error trying to access an object on computer %hostname% because the object was not found. The object may have been deleted. Verify that the VM management service is running.


    • Edited by bailey8 Saturday, August 24, 2019 1:51 AM
    Saturday, August 24, 2019 1:47 AM

Answers

  • On a separate forum I found this solution and my problem is fixed.

    Open "Window Security"

    2. Open "App & Browser control"

    3. Click "Exploit protection settings" at the bottom

    4. Switch to "Program settings" tab

    5. Locate "C:\WINDOWS\System32\vmcompute.exe" in the list and expand it

    6. Click "Edit"

    7. Scroll down to "Code flow guard (CFG)" and uncheck "Override system settings"

    8. Start vmcompute from powershell


    • Marked as answer by bailey8 Saturday, August 24, 2019 1:56 AM
    Saturday, August 24, 2019 1:56 AM

All replies

  • On a separate forum I found this solution and my problem is fixed.

    Open "Window Security"

    2. Open "App & Browser control"

    3. Click "Exploit protection settings" at the bottom

    4. Switch to "Program settings" tab

    5. Locate "C:\WINDOWS\System32\vmcompute.exe" in the list and expand it

    6. Click "Edit"

    7. Scroll down to "Code flow guard (CFG)" and uncheck "Override system settings"

    8. Start vmcompute from powershell


    • Marked as answer by bailey8 Saturday, August 24, 2019 1:56 AM
    Saturday, August 24, 2019 1:56 AM
  • Hi ,

    Good to hear that you have solved this issue by yourself. In addition, thanks for sharing your solution in the forum as it would be helpful to anyone who encounters similar issues.

    If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Monday, August 26, 2019 3:11 AM