usb modem driver for windows 7

    General discussion

  • Does Reliance data card ZTE cdma 1X  work under windows 7 & core 2 duo ?

    if so, get me link of that driver.

    Thursday, March 25, 2010 6:26 AM

All replies

  • Could you give us the exact model rather than saying ZTE cdma 1X as there's a few model, simply name one there are ZTE MG880

    Have you try inserting it on your comp yet and even if it doesn't work, you could alway run the driver in xp or vista compatible mode and run as adminstrator

    The download link is as follow but prior to download you need to know the exact model of the reliance data card

    Thursday, March 25, 2010 7:37 AM
  • Assuming you have installed "Reliance NetConnect ZTE MG880 V3.48.15" package of approx 7 MB on WIndows7 & still not able to use Reliance NetConnect device.

    Without uninstalling the setup, please follow below steps:

    1. Right Click on "Computer" & select "Manage"
    2. Attach Device to USB
    3. You should see 3 new entries under "Other Devices"
    4. Right Click on 1st entry i.e. "Data Interface" & Click on "Update Device Software"
    5. Select "Browse My Computer for Driver Software"
    6. Locate "C:\Program Files\ZTE CDMA1X MODEM\driver\Vista\X86" in BROWSE dialog-box & click on NEXT
    7. "Installting Driver Software" Screen should come
    8. It should install either of 3 Drivers i.e. ZTE USB Modem FFFD or ZTE Voice Port FFFD (COM5) or ZTE Voice Port FFFD (COM6). There should be 1 lesser entry in "Other Devices"
    9. Repeat steps for other 2 entries & you should automatically get remaining 2 drivers
    10. Ready to use Reliance NetConnect & Explore World...
    Monday, August 30, 2010 2:10 PM
  • Thanks Ramesh.Its working now :)
    Thursday, April 28, 2011 5:13 AM
  • Windows driver ZTE ac2736 unable to install on Windows 8 Release Preview

    Reliance netconnect unable to install the new software ,Phone modem installation failed

    here is the download link

    I did the above steps,But im getting the same error, The set up file is installing but the driver for modem is not installing,I tried to install manually,

    I opened device manager , it was indicating 5 unknown data interface tab,right clicked updated device software 4 times & it installed 

     1.ZTE Diagnostic port FFF1

     2. ZTE GPS port FFF1

    3 ZTE Service port FFF1

    4.ZTE Voice port FFF1

    while the 5th Data interface i right clicked tried to update the software,i got the following message.

    windows encountered a problem installing a driver software for this device

    Windows found driver software for your device but encountered an error while attempting to install it


    The system cannot find the file specified.

    Thursday, June 28, 2012 2:56 AM
  • Thanks... Same problem for Reliance Netconnect+ AC 2738..

    I tried that way.. It has 4 Data Interface drivers. 3 successfully installed. But 4 th one not found..

    GPS missing.. However its working.. Thanks

    Cholavendhan Selvaraj

    Saturday, August 10, 2013 4:37 PM
  • Thanks ,

    that is working...

    Monday, October 21, 2013 9:57 AM
  • Thanks ,

    that is working...

    Dinesh singh


    Monday, October 21, 2013 9:58 AM
  • Thanks ,

    that is working...

    Dinesh singh


    Monday, October 21, 2013 9:59 AM