none
No internet access in Windows 7 RC

    Question

  • I installed the 64 bit version of Windows 7 RC.  Now, none of my browsers can access the internet.  I have complete access to my network and my widgets that rely on the internet appear to be working.  Also, the Network Center reports that I have internet access, but I do not.  Thanks
    Thursday, May 07, 2009 12:54 AM

Answers

  • @JerryN_ISP,

    Thanks for pointing out the  "##Id_String2.6844F930_1628_4223_B5CC_5BB94B87 9762 ##" service. I think I may have found a better solution than the registry hack. change the "##Id_String2.6844F930_1628_4223_B5CC_5BB94B87 9762 ##" service from Automatic Start up to Automatic (Delayed Start). This worked for me on a reboot and would seem to confirm my earlier suspicion that it is a timing issue. By delaying the start up of this service until other pieces are in place when this service starts the internet can now be found.



    Steve


    Saturday, November 21, 2009 1:04 AM

All replies

  • Hi robertbackus:
       Have you checked to make sure your preferred browser is set to be the default driver?  Can you get to Windows Update?
    Thursday, May 07, 2009 1:13 AM
  • Thanks for the response but I do not know what you mean by "default driver".  Also, I have Opera, Firefox, Chrome and IE installed, none of them connects to the internet, this despite the fact that the windows trouble shooter reports that I can connect to websites.  I actually restored my backup of Vista, completely removed all anti-virus programs and reinstalled Windows 7 RC.  Same problem.
    Friday, May 08, 2009 3:27 PM
  • are you wired or wireless?
    Friday, May 08, 2009 3:30 PM
  • I have tried it both ways.  It is really weird.  By the way I also installed RC on my laptop and it works fine except that none of the programs show when I click the all programs tab in the start menu.  But, this is an RC release.
    Friday, May 08, 2009 6:20 PM
  • what happens when you use Firefox to go to google.com or some other web site?
    Friday, May 08, 2009 6:24 PM
  • Hi robertbackus:
         OOPS............I've posted so many responses concerning installing drivers I goofed....I meant to say which browser is set as  your default browser?
    Friday, May 08, 2009 7:29 PM
  • No matter which browser I use if I try to go to google.com or any web site the browser reports that the site is unavailable.  Thanks
    Saturday, May 09, 2009 8:24 PM
  • Chrome is my default browser, but of the four I use all report that any site I try to connect to is unavailable.
    Saturday, May 09, 2009 8:25 PM
  • is firewall blocking you

    Asus P5Q3 Deluxe WiFi, Intel E8500 processor, 4gb DDR3 Gskill, Evga Nvidia Geforce 9800GT 512mb, onboard Marvel lan, onboard Ralink Wifi, Onboard Soundmax, 1 500gb Sata 2 hard drive, 1 sata DVD drive. Win Bus 64, Win 7 64, Mac os x 10.5.6
    Saturday, May 09, 2009 8:28 PM
  • I have the same problem. The only way I can access the Internet is by disabling the network adapter and enabling it again immediately afterwards. The network connection is then identified correctly for some reason. Unfortunately I have to do this every time Windows 7 starts up.
    Saturday, May 09, 2009 8:53 PM
  • hi mate i have the same problem but to get internet access you need to disable and then enable your network adaptor every time windows boots up.
    Saturday, May 09, 2009 9:21 PM
  • No, the fire wall is not blocking me as I have the same problem with the firewall disabled.

    Thanks Rob
    Monday, May 11, 2009 4:57 AM
  • Well, if that is what it will take to get RC  to work I will stick with Vista, which is slow but works fine.  I am going to continue trying.  thanks Rob
    Monday, May 11, 2009 4:59 AM
  • Similar problem. I also have to disable the network adapter and enabling it again immediately after, every time that I start windows. It’s very annoying.

    The funny thing is that I have the same version of Windows 7 installed in another machine and it works fine.

    Reading the forums there must be hundreds of people experiencing this same problem. Is this a fault of windows 7 RC that requires a patch?

    Wednesday, May 20, 2009 9:38 AM
  • I tried the disabling and reinabling of the network adaptor and this did not help me.  I wonder what the issue is?  It does seem that many people have the problem.  I hope Microsoft in monitoring these forums to see this problem which seems fairly wide spread.  On my laptop the problem I have is that the programs list is not populated so I had to create shortcuts to each program.  At this point I have restored vista on each of my computers.  Still, someone must have a real fix for this issue.  It makes me nervous enough not to want to buy Windows 7 but to stick with Vista, which, since SP1, is quite useable, if slow---

    Thanks for the response.

    Friday, May 22, 2009 3:22 AM
  • try assigning static ip instead of using dhcp, works for me
    • Proposed as answer by Planet-II Saturday, May 23, 2009 7:30 AM
    Saturday, May 23, 2009 7:30 AM
  • I have the same problem. Disabling the network card not always work, some times it does. I have a intel network card.
    I am writing this message using firefox under ubuntu!
    Does Microsoft as nothing to say about this issue, from the RC release, that i read this problem in many sites.


    Sunday, May 31, 2009 7:31 PM
  • You folks having issues need to provide make / model / chipset / firmware...blah blah

    Running a few commands and posting the returned info would help as well

    netsh interface ip show config
    netsh diag ping adapter 1

    Sunday, May 31, 2009 9:35 PM
  • After disabling network card and enabling it again, e got my internet connection working till next reboot.
    I ran netsh interface ip show config, and the result was:

    Configuration for interface "Local Area Connection"
        DHCP enabled:                         Yes
        IP Address:                           192.168.1.64
        Subnet Prefix:                        192.168.1.0/24 (mask 255.255.255.0)
        Default Gateway:                      192.168.1.254
        Gateway Metric:                       0
        InterfaceMetric:                      20
        DNS servers configured through DHCP:  192.168.1.254
        Register with which suffix:           Primary only
        WINS servers configured through DHCP: None

    Configuration for interface "Bluetooth Network Connection"
        DHCP enabled:                         Yes
        InterfaceMetric:                      50
        DNS servers configured through DHCP:  None
        Register with which suffix:           Primary only
        WINS servers configured through DHCP: None

    Configuration for interface "Loopback Pseudo-Interface 1"
        DHCP enabled:                         No
        IP Address:                           127.0.0.1
        Subnet Prefix:                        127.0.0.0/8 (mask 255.0.0.0)
        InterfaceMetric:                      50
        Statically Configured DNS Servers:    None
        Register with which suffix:           Primary only
        Statically Configured WINS Servers:   None


    Next, as you kindly suggested I ran diag ping adapter 1
    and the result was:


    'diag' is not recognized as an internal or external command,
    operable program or batch file.

    I have a router, and a local network, the local access to other computers always work, just the internet access, every time I start the machine, doesn’t work. I already talked to my internet provider, and it isn't their problem, as I stated before with ububtu internet works every time. I reset the router several times; in a case the internet access becomes available, I couldn’t understand the reason.

    Some times disabling the net work card doesn’t work.

    I have a Toshiba Satellite P100. The network card is a

    Intel Pro 1000 PL
    Intel Pro wireless 3945ABG

    When the internet is down, i can't ping any internet server, but the name is correctly resolved.

    Thanks for your support,




    Monday, June 01, 2009 8:46 PM
  • I have the exact same problem. Running 64 bit Win 7 after I upgraded this morning from 64 bit Win 7 beta, I can not access the internet on the machine with the ethernet connection, though I can over wifi. My router is working just fine as I can reach the router site. Please, I really need some help. Right now I have ipv6 disabled, and ipv4 set to automatic. Any ideas for other settings?
    Okay, came across this- http://forums.techguy.org/windows-vista-7/836507-no-internet-access-win-7-a.html . I also am able to access google through their ip address.
    Wednesday, July 01, 2009 10:51 PM
  • Fixed it. Just like the guy at that link, I had eset and bitdefender, and I just got rid of both of them.
    Wednesday, July 01, 2009 11:27 PM
  • I use Windows 7 RC (7100) at work. I connect to the internet over LAN with static IP and I have yellow triangle in the connection icon in tray. If I put the cursor over it, I can read: "Network No internet access".If I restart the PC in safe mod the internet work fine.
    Monday, August 03, 2009 7:57 AM
  • I've got this issue as well with W7 Final (not the RC).  I'm running on a domain at work, have no virus checker installed (yet - this is a fresh install), firewall is off, etc.  I can access the interweb no problem, but the network centre says:

    Access type:  No Internet Access

    The notification area has the ! triangle icon in it and it says:



    Currently connected to:

    THEDOMAIN
    No Internet Access




    IE works fine - no need to give it any additional settings, Firefox gets to the web too no problem.  Visual Studio fails to load the RSS feeds on the start page when I fire it up. 
    Friday, August 07, 2009 3:07 PM
  • I too have the local access only (No Internet Connection) issue, on two machines, my HP Pavilion notebook and my custom built MSI K9A2 Platinum based machine; both are running the 64 bit Win 7 RTM. This problem did not initially exist with the RC, but after a Windows Update of the RC it started and began almost immediately with the clean installation of the RTM. On the note book this problem exists with both wired and wireless.

    The best work around I've found is to open the Network and Sharing Center, select Change Adapter Settings, right click on the connection you want to use (local area (wired) or Wireless) and disable the connection then renable the connection. A lot of search results seem to stop there but I found this doesn't always work so I go back to the Network Sharing Center and click on the Red X in the network map (indicating no Internet Access) which launches a trouble shooting wizard by the time the first step of the wizrd completes the Red X in the map is gone and internet access is esgtablished so I don't have to go through the brain dead remainder of the wizard that will ask me if I want to look for a solution on line.  (Let's see, I have a problem with obtaining an Internet connection and the wizard wants to know if I'd like to look for a solution on the Internet, sure that makes sense)

    I did find that MSI had a new chipset driver for my motherboard and once I installed it the problem with the desktop machine local access only/no internet connection appears to be resolved, however it does take 15-20 seconds after boot up for the network connection to settle down and become available. No updated chipset drivers for the HP notebook so I don't know if that would also resolve the problem on the notebook.

    That disabling and re-enabling the network connection solves this problem it would seem that the problem is a timing issue of when, or the order, the loading of the network is occuring on boot up. That a newer chipset driver appears to resolve the problem would seem to indicate that there isn't enough robustness in the OS to either retry the netowork connectivity or a relianse on a flag or something in the new drivers that isn't in the older drivers. There appears to be a large number of people experiencing this issue, I hope MS will address it as the continual disable and re-enable of the network connecton on boot up is a pain.


    Steve
    Wednesday, August 19, 2009 4:52 PM
  • I am surprised that the problem still crops up in the final version.  The problem seems pret. ty widespread among 64 bit usersI had really wanted to upgrade to Windows 7 but imagine that I will wait until I buy a machine with it preinstalled.
    Thursday, August 20, 2009 3:01 PM
  • I have the same problem (no internet access) but my version is 32-bit

    and all what I have done is changing the TCP/Ipv4 settings of my wireless adapter i.e don't let windows obtain your ip address automatically >>> its working with me guys
     
    see the images

    http://img194.imageshack.us/img194/8645/capture2x.png

    http://img197.imageshack.us/img197/1696/captureoae.png


    try and tell me the results


    good luck
    Sunday, August 23, 2009 1:28 AM
  • I have a very similar problem - No Internet Access - and can't get it to work.  I have a dell 2900 that I'm trying to get Win7 to work on.  I upgraded from Vista 64 to Win7 64.  On my network I have a private area - 192.168.0.x and a public area.  I have 60 Verizon FIOS public addresses - FIOS is switched to my house so my default gateway is on the Verizon network.  I have 12 computers on my network - some on the public address space and some private through a Netgear VPN router that provides my NAT/PAT and DHCP to my private area.  All are on the same physical Ethernet with switches.  The environment works for all my other computers and worked with this Dell running Windows 2003 server.

    The Win7 64 installed as an upgrade from Vista - without problem.  The machine has 2" Broadcom BCM5708C NetXtreme II GigE (NDIS VBD Client)" built in NICs.  I've disabled (from CMOS) one of them.  I want the machine to have a static public address.  When I configure it that way, it can't ping the default gateway (on Verizon) but it can talk to any of the machines on my public network.  When I run the diagnostic it says that I have to enable DHCP - which when I do that it gets a private address from my Netgear router - 192.169.0.x - and the machine works fine.  I've spent many hours trying to figure this out and I'm going crazy - what can be in the way?  I've tried to disable every service (e.g. firewall, network security) imaginable to make it work.  I've tried a different NIC (Linksys) with the same result.  I've tried to turn off my Netgear router with no difference.  I've disabled IPv6 with no result.  It refuses to talk to the Verizon gateway but works fine through NAT/PAT.

    Sunday, November 01, 2009 9:20 PM
  • I have a solution for this, although it takes some work. Heres the steps I went through to fix it:

    Run CMD as Administrator
    Execute route print
    if the first two entries in your routing table start with 0.0.0.0 then type this:

    route delete 0.0.0.0

    open up services

    restart the DHCP service

    This fixed it for me and allows full and normal internet functioning. The thing is everytime you restart the computer you have to do it again so I just leave this one running.

    Cheers

    Jerry

    <<EDIT>> I figured out a permanent solution to this issue. Ignore the above unless your chicken!! Here's the permanent fix that worked for me

    Look in services..if the first entry looks something like this: "##Id_String2.6844F930_1628_4223_B5CC_5BB94B87 9762 ##" run regedit and search for that string. I found it twice. Delete that entry then reboot. Presto no more internet troubles.
     
    <</EDIT>>
    Friday, November 20, 2009 9:53 PM

  • Look in services..if the first entry looks something like this: "##Id_String2.6844F930_1628_4223_B5CC_5BB94B87 9762 ##" run regedit and search for that string. I found it twice. Delete that entry then reboot. Presto no more internet troubles.
     
    <</EDIT>>

    Okay, but still no offical answer?  Hmmmmm.  I'd like to know why as well as how . ;)
    Friday, November 20, 2009 11:24 PM
  • This is an interesting tip. I did find this as the first service and I did find it in the registry, but more than two times. It was at
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\Bonjour Service
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\Bonjour Service
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Bonjour Service

    In all three Bonjour service entries the ##id_String ... was in both the Description and Display Name.

    When you say "delete that entry" are you referring to the Description and DisplayNames or the entire Bonjour service nodes?

    While this registry hack may work let me also provide a bit more information about my experience. My HP laptop continues to plague me with no internet connectivity If I start up and immediately log in when prompted. However, If I start up and wait about a minute (never timed it) after the log in prompt before logging in Internet connectivity is available. Usually I don't wait so have to go to the Network and Sharing Center to disable and re enable te adapter.

    My desktop machine also has the ##id_String ... in Services and the same three registry locations listed above, but it has no problems with internet connectivity on start up.

    I did have the no internet connectivity with the desktop machine but after updates to the chipset and NIC drivers the problem went away.

    It would be nice if there was some official word on this, both acknowledgment of the issue and a suggest remedy.


    Steve
    Saturday, November 21, 2009 12:51 AM
  • @JerryN_ISP,

    Thanks for pointing out the  "##Id_String2.6844F930_1628_4223_B5CC_5BB94B87 9762 ##" service. I think I may have found a better solution than the registry hack. change the "##Id_String2.6844F930_1628_4223_B5CC_5BB94B87 9762 ##" service from Automatic Start up to Automatic (Delayed Start). This worked for me on a reboot and would seem to confirm my earlier suspicion that it is a timing issue. By delaying the start up of this service until other pieces are in place when this service starts the internet can now be found.



    Steve


    Saturday, November 21, 2009 1:04 AM
  • As the guy who started this thread back in May I want to know how you figured this out.  Amazing I say.  I bought and installed Windows 7 Professional as a clean install and started to have the same problem after a couple of weeks.  I could get internet access by disabling and re-enabling my network connection, often several tries were required.  Why microsoft did not correct this problem on its own is beyond me.

    Thanks for your answer that I see Microsoft has approved.

    Rob Backus
    Wednesday, December 09, 2009 10:05 PM
  • Thanks Robert. I actually figured it out by just hacking away at it for a while. Once I took a look in services and saw that odd ID string I disabled the service and it fixed the problem. I took a chance and did the reg hack and it worked. :)
    Wednesday, December 09, 2009 10:09 PM
  • Great thread, but there's still no solution for those of us without the Bonjour service on our machines.

    I thought I had it solved by simply enabling and disabling my Realtek NIC, but last night I had to disable and enable my network card, reboot my rooter, and separately enable and disable IV4 and IV6 several times before the dreaded yellow triangle disappeared.

    Why isn't there an explanation or a fix that works every time?
    • Proposed as answer by wraithiis Thursday, December 10, 2009 9:38 AM
    Thursday, December 10, 2009 5:40 AM
  • I've found an easy solution that has worked on my PCs.  I think someone else already mentioned the fix, but didn't elaborate on it much.  Anyway, I've been having this exact same problem with Windows 7 Home Premium, on 2 separate computers.  I've spent the entire day checking my network, updating drivers, reading threads.  My problems actually started after this last update, which I didn't get around to installing until last night.  Up until today, my computers would connect, with internet access, within 5-8 secs or so.  Today, 2 of my PCs started taking upwards of a few minutes to gain internet access.  Sometimes, they wouldn't gain internet access at all, unless I disabled and re-enabled my network connection.  Anyway, I found a solution that has worked on both of my PCs.  They now both connect to my network, and gain internet access within 5-8 secs again.
     
    I went into the windows services, stopped windows defender, and disabled it.  Rebooted.  Problem solved. 

    I realize some folks may not be comfortable with that, but it has worked for both of my machines.  I've rebooted both, dozens of times, and things are definately back to normal.  I run other antivirus and antispyware software anyway, so I really didn't need windows defender to begin with.  But, I didn't think it could be the cause of my internet access problems.  I also had this same problem in the Windows 7 Beta.  I too was hoping they would have this fixed by the official release time.  Anyway, hopefully that helps out a few folks at least, and sorry if I'm repeating something that someone else has already proposed as the solution.  I didn't have time to read every thread, and this is the first one I came too that seemed pertinent to the problems I was having. 
    Thursday, December 10, 2009 9:52 AM
  • Thanks for this tip.  I tried it on December 9th and as of today (the 12th) I have had an internet connection with no problems.

    Rob Backus
    Sunday, December 13, 2009 2:09 PM
  • For those of you that have no internet access when booting windows 7 until you disable and re-enable your network connection; try this.  Click on start/run/and type services.msc /go to Bonjour service and click on properties / change it to delayed start / problem solved.  Let me know if this works.  Happy Holidays......
    • Proposed as answer by IAMKB1 Friday, January 01, 2010 7:07 PM
    Thursday, December 31, 2009 8:19 PM
  • This is what I noticed in my very limited network world.

    If you use a Static and you are behind a router, the pcs are having trouble resolving the names correctly.
    I didnt have this problem (Or at least didnt notice it until I switched to Windows7).

    I put in a static ip address.
    I put in my default gateway.
    I made the DNS server the same IP as my gateway router IP address.
    this makes my router forward DNS inquiries to the service provider (Comcast).

    I didnt start/stop any services.
    I didnt have to hack any registry entries.


    Seems to be working for me now.
    Let me know if it works for anyone else.

    • Proposed as answer by IAMKB1 Friday, January 01, 2010 7:12 PM
    Friday, January 01, 2010 7:11 PM
  • @JerryN_ISP,

    Thanks for pointing out the  "##Id_String2.6844F930_1628_4223_B5CC_5BB94B87 9762 ##" service. I think I may have found a better solution than the registry hack. change the "##Id_String2.6844F930_1628_4223_B5CC_5BB94B87 9762 ##" service from Automatic Start up to Automatic (Delayed Start). This worked for me on a reboot and would seem to confirm my earlier suspicion that it is a timing issue. By delaying the start up of this service until other pieces are in place when this service starts the internet can now be found.



    Steve



    Thanks for this one (delayed start).  Disabling & re-Enabling the local area connection did work for me every time, but still a PITA.  Restarted and shut down and started several times now and always have internet access now.

    With a cable modem, I imagine I have a dynamic IP address, but clearly another Win7 issue.

    Windows 7 Ultimate
    ASUS P5Q-Deluxe motherboard
    Saturday, January 02, 2010 3:21 PM
  • Hi

    Bonjour Services has caused this problem since the beginning, it is usually installed by Apple IToons and some Adobe software installations.
    Mine was installed by Adobe Photoshop I believe.  I have literally seen hundreds of people reporting this problem and it seems to be the main reason that people are having connection problems .

    I was able to uninstall it in the normal manner through Add Remove Programs.
    Buy I have seen people who said that it didn't appear in their uninstall list.
    If you don't see it try running web search for Bonjour Services, to identify the service.

    I had to do this on both my original computer and my new FNW that I got a couple of weeks ago, both after installing my Adobe CS software.
    Once it was removed the problem went away permanently on on both computers.

    It seems that, by now this problem should have been resolved, by either Apple, Adobe or Microsoft since it has been so wide spread.

    Mike


    Saturday, January 02, 2010 3:37 PM
  • you guys rock ,
    I had the same problem. I could not find a bonjour services entry but did have the id string (which I found to be bonjour).
    Once I did the delayed start no problem!! Thanks again.
    JD
    Monday, January 04, 2010 8:53 PM
  • I had success with running the troubleshooter till it said it was connected and then immediately using the reset pinhole on my D-Link DIR 655.  I'm cabled to it, but the wireless computers seem to be OK now too.

    Good Luck,

    Bill
    Thursday, January 07, 2010 3:00 PM
  • I had the same problem with the Bonjour service as others.  Deleting the String suggested did not correct the problem.  Setting the service to Automatic (Delayed Start) fixed the problem.  Thanks for the suggestion.
    Monday, January 11, 2010 8:05 PM
  • PROBLEM SOLVED!!

    Right i'm betting this will solve the problem for at least half the people on here. Just last week my mate calls me up saying he has a brand new laptop but cannot get it to connect to the internet. So I go to his house to check it out for him and sure enough says connected but then like most of you says no internet access. I take his laptop to my house try it on my known to be working home network and the problem still existed. So now we were definitely dealing with a fault with the laptop and not the broadband connection. Anyway long story short I try all sorts of solutions and quite a few from this site as well but as most of you know nothing works. As im bout to give up an tell him to take the cursed laptop back to the stanky shop he got it from I get a brainwave, I think its a brand new laptop and i'm pretty sure its a software fault so what has been installed since he bought it. 
      Simple answer is the Internet service providers disk that is the idiots guide to setting up yer home network. In his case it was the UK firm Virgin media. My friend being fairly rubbish with computers gets his new router and broadband connection and first thing he does is stick in their cd to follow their foolproof instructions to setting it up and it installs other junk as well like their help files etc. Anyway I go to control panel and uninstall all the Virgin media stuff and hey presto connects first time. 
      I think this will be the solution for quite a few of you so get into control panel and uninstall programs like this 1 at a time then try your connection to see if it works. one of the programs in there will be interfering with your conn.
      I have had problems in the past with isp software disks from BT and TalkTalk and to be honest they are not needed at all. Also check any other programs which you have installed recently it could be them, for example a while ago I installed a program to let my playstation eye web cam work on my pc and it interfered with so much other stuff it had me going crazy trying to figure out the cause.
      Hope this helps at least 1 of you sorry for rambling on.
    Thursday, January 14, 2010 12:22 AM
  • Same problem here.
    Any solution?
    Tuesday, February 02, 2010 7:42 AM
  • entering services and changing "##Id_String2.6844F930_1628_4223_B5CC_5BB94B87 9762 ##" delayed start worked for me. it was the first service in the list
    hope this helps people
    Sunday, February 07, 2010 11:58 AM
  • I am having the same problem.   However I do not have bonjour installed anywhere, and I disabled windows defender and still no dice.  MY connection is fine if I plug in the ethernet cable directly, but trying to connect wirelessly to any network, says connected but no internet access.  The only thing suggested in this forum that I have not tried is manually assigning the IP address, and was wondering if someone can help me with this..? (Can I do this and still use multiple public networks?)  Also, I noticed one person did not have Bonjour services but still had that ID string..?  Will this ID string show up under services or am I looking in the wrong place?  Any help would be GREATLY appreciated, I have been at this for weeks and am uber frustrated.  Thanks.

    Also curious I am using an old router and a new ISP, this possibly have anything to do with it?


    [EDIT]  So I just realized that my wireless works fine in Safe Mode, which leads me to believe it is due to a system process, not the router/adapter... any ideas?

    Thanks.

    !!!  So check this out... got it working.. this was my fix...

    Went into services and changed IP Helper  service to delayed start... fixed everything.  Yay!
    Thursday, February 25, 2010 1:34 AM
  • Another service that can cause this problem is the "National Instruments mDNS Responder Service", which you might have if you installed Labview or a NI data acquistion card.  If this service is running, try disabling it.
    • Proposed as answer by SSSL_IT Friday, April 01, 2011 11:10 AM
    Tuesday, March 02, 2010 10:24 PM
  • Hi Robo99:
        I don't know if you've solved your problem,  but if you haven't I resolved a similar problem with one of my PCs which has an Asus motherboard by downloading and installing the latest update for my network drivers.  It was marked "Beta" but is working fine. 
       Prior to updating the network driver I had been using the drivers that were installed with Win7.
    In order to connect to the internet after coming out of sleep,  I had to disable and then re-enable the network driver to connect.  Now when waking up from sleep,  the PC connects immediately to the net.
    Sunday, March 14, 2010 6:07 PM
  • Your solution worked for me, and works even after a reboot.

    Thanks.

    Monday, April 19, 2010 9:46 PM
  • I have the opposite issue. Can connect to the internet and in fact my exchange email... I can even use REALVNC and desktop connection... but I can not browse my network or connect to mapped network drives, much less create a mapped network drive...
    Friday, May 21, 2010 1:26 PM
  • I experienced the same problem and tried all the solutions suggested here - none worked.

    I have two wireless networks one worked the other didn't. Comparing the properties of the two connections the one that didn't work had a VPN Driver attached to it and the VPN client was not connected. I removed the VPN Driver and internet access was restored. I just have to remember to enable and disable VPN accordingly.

    Obvious really - but might help someone.

     

    Tuesday, June 22, 2010 8:40 AM
  • The solution for me was to replace my router with a newer one, I think that my old DI604 was not compatible with Windows 7. By the way the only computer with the problem was running with Windows, every one else on Linux Ubuntu was running fine. You might draw some conclusions...
    Saturday, June 26, 2010 4:08 PM
  • well after scratching my head for over 20 hours, i have found what the problem is with the windows7 wireless connectivity. Its not the static ip , DNS , internet browser or the drivers. All you have to do is to " Set the connection manually, not automatically and enter the " 8 digit "  code from the back of your wireless router . it will randomly give u a pasword, that you can change later. !! now that windows7 shall not forget the gateways to the router..

     

    THanks...

    Thursday, August 05, 2010 6:02 AM
  • It seems there are different scenarios for this problem. I want to report mine and how it is solved in case it is useful for some other people.

    I have a Toshiba Satellite with 802.11n wireless adapter and my wireless access router is Trendnet TEW-631BRP.  Initially the Network and Sharing Center showed the Internet connection was fine but I tried both IE and FF to browse some common sites and it fails at least 90% of the time. It seemed the connection to the network which has multiple computers was (i.e. I could see other computers and browse their shared folders). After trying many methods suggested in this thread without success, I finally went to the properties of the wireless adapter (Realtek RTL8292E) and changed the Wireless Mode from IEEE802.11b/g/n to IEEE802.11b/g and the Internet connection became available and in good quality immediately.  Apparently the n modes of the adapter and the router are not compatible.  

     


    hz
    Monday, August 23, 2010 10:30 PM
  • Jerry,  I believe I have tried everything on this entire list of solutions on this Topic, but I still have the same problem - Cannot gain access to the Internet.  I can gain access when in Safe Mode w/ Networking, but not in Normal Windows Mode.

    My question is HOW do I locate this ##Id_String....... you show in your ANSWER above? I've gone into REGEDIT and attempted a FIND of that value, but nothing even close shows at the end of the Registry Search.  Is this value / located outside the SYSTEM REGISTRY?  Thanks!

    Friday, October 22, 2010 4:39 PM
  • Ok, this same problem cropped up this past weekend on my sons Dell xps800 Win7HmProfessional...I searched the problem here and found this thread and another. I tried without success on some of the proposed solutions and worked myself up to a significant level of frustration. Finally I decided to try to call Dell since the computer is still under warranty (less than a year old). Luckily I got someone who I could understand.

    Here is the solution which worked 100% for me and it is REALLY EASY. I will try to get the essential steps here but you may need to look for a little bit of additional info if not used to working with the CMD prompt box.

    Start button enter CMD in the search box, this brings up the black command line box. Then go to the small Black Icon for the cmd window at the bottom of the screen -- Right click that and choose Run as Administrator. This opens yet one more Black command line box this is the one you will type into from now on.

    type in the following with the " _ " being a space      netsh_winsock_reset    then hit enter.

    Then you'll get a message that includes Restart is Required... Close these black boxes and all other open windows/programs and restart the computer.  

    Viola  your problem is fixed.

    Monday, November 01, 2010 2:47 PM
  • I have a new Dell Studio 1555 that I have spent all weekend trying to get connected!  very frustrated at this point -After trouble shooting I get this message "the wireless network connection does not have a valid IP configuration and gateway default is not active??"  I did what you mentioned with the CDM and the black box but I didn't do the second step you mentioned.  Do you think this will help me with connecting since we have different computers?
    Monday, November 01, 2010 9:26 PM
  • Like many people here, I have the same problem. I have a Toshiba Satellite A505. One day, my computer decided not to be able to identify the network that I am connected too. Every diagnosis or troubleshoot has me re-enter my WEP key but that does nothing. I did the command box thing, that didnt work. I tried disableing then enabling my network adapter, and that didn't work. Of course I've rebooted countless times, and even tried to update my network drivers and such. Ive even stumped my friends who are managers at charter and an employee at geek squad. please help.

    Monday, January 10, 2011 1:20 AM
  • I had this problem after an automatic Windows update.

    Setting   "##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762 ##"   to Automatic (delayed start) seems to have worked. Many thanks!

    To recap how to do this:

    For those of you that have no internet access when booting windows 7 until you disable and re-enable your network connection; try this.  Click on start/run/and type services.msc /go to Bonjour service or "##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762 ##" and click on properties / change it to delayed start.

    (Mine was String1 - other people report String2)

     

     

    Friday, February 04, 2011 9:12 AM
  • I have the exact same problem! now is Feb.10, 2011, but the issue is still alive... does this issue cased by Windows 7 system? if yes, so surprised the problem is still existed...

    Hope the solution in this thread can solve my problem. In China mainland, so many people has similar problem, and no answer for it, it drives me crazy :(  now I really understand why all my friends who use laptop with Windows XP system...

    Thursday, February 10, 2011 9:28 AM
  • Just disable the Bonjour service in services!

    I had this problem for many weeks now and it was driving me absolutely nuts! It was almost to the point where I was tethering my connection through my phone full-time to stay productive. After troubleshooting and finally closely comparing my notebook's wireless performance with my girlfriend's model (which is the same as mine), I came to the conclusion that it was hardware. However, I was 100% certain. I thought to myself that it was only the "internet" that was dropping and I still had access to local resources (ie. wireless printer, file server etc.) so I figured I'd search the net one more time before submitting my notebook for service the following day. And I found this thread.

    ALL I CAN SAY IS THANK GOD I FOUND THIS THREAD. I WISH I COULD BUY EVERYONE IN HERE A CASE OF BEER BUT I'M TOO POOR. BUT MANY, MANY THANKS.

    DOWN WITH APPLE AND DOWN WITH BONJOUR SERVICE.

     

    Warm regards,

    Eugene

    Thursday, February 10, 2011 11:58 AM
  • Hi GeorgeCarey,

    I tried this solution last night, unfortunately and strange, No Bonjour service in my list!  @_@   T_T

    How I can go to "##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762 ##" ? I did like this: -Start  -Run  -Type ##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762 ##  -I got a Warning dialog "Can't find, please try again"

    Could you please help me figure out this?

     

    BTW, I am from Beijing,China, and my laptop's system is Chinese version of Windows 7 Home, I don't know if there is something different from Win 7 English version...  I also searched solutions via Chinese forums and found lots of people in China has such kind of problem, and seems no reliable answer for it, so they have to re-install XP system...

     

    Many many thanks!

    Juner
    Friday, February 11, 2011 3:54 AM
  • Another service that can cause this problem is the "National Instruments mDNS Responder Service", which you might have if you installed Labview or a NI data acquistion card.  If this service is running, try disabling it.

    This was my issue.  diabled service and all ok
    Friday, April 01, 2011 11:11 AM
  • HI!!!

     

    I still have the same problem and I don't have Ntional instruments.... neither Bonjour services, any idea?

     

    thanks!!

    Monday, April 25, 2011 12:22 AM
  • Hopefully you are still checking this thread or you get this reply as a notification as some sort but i tried this response and i still have no internet connection :( i have called microsoft; dell, the manufacturer of my laptop and belkin, the manufacturer of my wireless adapter and none of them could help me. I'm an 18 y.o. girl so I don't understand much of the abbreviations in this thread but I've done my best and none of these seem to work! Do you have any other solutions?
    Tuesday, August 16, 2011 8:34 AM
  • This worked like a charm for me:

    Click on start/run/and type services.msc /go to ##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762 ##" and right-click, select properties & change it from Automatic to delayed start.

    Thanks Guys!!!!

     

    Saturday, August 27, 2011 12:49 PM
  • Dito..

    ? Very strange

    Tuesday, September 06, 2011 1:10 PM
  • Disabling Bonjour Service fixed this problem for me immediately.
    • Proposed as answer by stooch1122 Tuesday, September 06, 2011 3:18 PM
    Tuesday, September 06, 2011 3:17 PM
  • I had a similar problem on a Win 7 Home Premium PC, and after reading this thread, it occurred to me to ask, how does Windows determine whether it has internet access or not?  Googling that, I found this link which explains it quite well:

    http://blog.superuser.com/2011/05/16/windows-7-network-awareness/

    and even shows how to set up your own server for Windows to check.

    What it tells me mainly is that anything that blocks www.msftncsi.com or dns.msftncsi.com will cause the problem.  There's also a registry hack that turns off the testing, in which case Windows assumes that it has internet access.

    I had noticed that even though it said I didn't have internet access, I actually did.  I also had local network access.

    Hopefully this will help someone out there with this annoying problem. And Microsoft, if you're listening, clicking on the warning triangle should bring up an explanation of why it thinks it does not have internet access, e.g. "Unable to ping www.msftncsi.com" or something like that.

     

     

    Thursday, October 13, 2011 5:03 PM
  • I noticed this happens when you log in as an administrator , as soon as I tried a different user in the domain I was able to get internet acess puzzling.
    Friday, November 11, 2011 5:59 PM
  • Hey everyone... 

    I tried all of this:

    1. Searching for Bonjour in the Services (and the string). <Neither Existed on this computer>

    2. Looked for Misc programs / services that had anything to do with internet / IP / wireless.

    3. Disabled IP Helper service <nothing>

    4. Disabled Windows Defender

    5. Realized this was a brand new HP and erased HP wireless connection helper

    6. kept deleting / stopping / delaying unnecessary services.

    7. I restarted the computer after every change i made.

    8. eventually the icon in the bottom right showed it was fully connected, tried to use internet, but to no avail

    9. Ran the Diagnostics tool on Internet Explorer after it said it was fully connected, and BAM!

    10. Windows Firewall was stopping me from connecting to the internet... it did a fix and now it runs fine. (i ran a diagnostics before all of this, and it didnt say that, so... idk what was wrong.)

    Monday, November 14, 2011 5:34 AM