windows 7 refuses to login to windows 2000 server


  • I have an old server i use for storing files and backups. Been a great solid machine.
    however, when i upgraded to windows 7 ultimate i'm having big issues connecting to the server

    I have added the login/password on windows 2000 as i have done in the past
    but when accessing the machine from windows 7 it asks for login and password and states that it's incorrect
    i even try with other login/password combination i know work as i access windows 2000 with these from windows xp machines.

    i put the network as home networking and i dont have anything shared on my windows 7 machine.
    i also changed the workgroup name to match what my old network name is and what my windows 2000 server is as well.

    any suggestions?
    Wednesday, November 18, 2009 8:58 PM


All replies

  • Hi Madz,

    You can try to modify the authentication setting to test the issue.

    Here are some information for Windows Vista. They also applied to Windows 7.

    • Cannot Authenticate to a Shared Folder from a Windows Vista-based Computer

    If you cannot authenticate when accessing a shared folder from a Windows Vista-based computer on a computer running a version of Windows prior to Windows XP (such as Windows 98 or Windows 95), a computer running an operating system other than Microsoft Windows, or to a network device, the cause might be a mismatch in the configured support for NTLM 2, an authentication protocol that is used for file and printer sharing connections. By default, Windows Vista is configured to use NTLM 2.

    To resolve this issue, you can do one of the following:

    • Enable NTLM 2 support on the computer or device to which the Windows Vista-based computer is attempting to connect. For computers running versions of Windows prior to Windows XP, see How to enable NTLM 2 authentication. For computers running operating systems other than Windows, see the operating system's product documentation for information about how to enable NTLM 2 support. For network devices, see the device's product documentation or Web site for information about how to enable NTLM 2 support or download a firmware update that supports NTLM 2. This is the preferred solution.

    • If you cannot update the computers running operating systems other than Windows or your network devices to support NTLM 2, change the HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\LMCompatibilityLevel registry value on the computer running Windows Vista to 1. This solution is not recommended.

    Hope it helps.

    • Marked as answer by Robinson Zhang Friday, November 27, 2009 2:43 AM
    • Unmarked as answer by the_madz Friday, November 27, 2009 3:40 AM
    Friday, November 20, 2009 5:29 AM
  • It did not work

    it simply will not log into the windows 2000 server no matter what login/password i use.. even if i use login/password combinations that i can log in from a windows xp machine.

    do you have to set up anything different in windows 2000 server to allow windows 7 to log in?
    Friday, November 27, 2009 3:40 AM
  • I was having the same problem but on a w2k3 domain...try logging in like so.
    exaple username = JoeDoe
    example domain = JOEDOE.LOCAL

    when you try to login to the domain from your W7 machine type

    Username = JOEDOE\JoeDoe
    pasword = password

    mine would not allow the login unless the domain was used first for some reason.
    hope it helps

    P.S I am not in front of the computer right now so I can't be positive to weather it was a forward slash or back slash
    so try both.

    Friday, November 27, 2009 6:20 AM
  • I am haveing the same problem, have no problems with Vista logging on just can not get seven to log on.  Thought it may have something to do with Nortons but have tryed altering setting there with no luck. Does anybody have any other ideas for this problem.
    Friday, November 27, 2009 8:52 PM
  • I finally solved it.

    not sure which step did it. but i double checed and corrected the date and time of the windows 2000 server and windows 7 to be exactly the same within a minute.

    and i changed the settings to accept older style encryption, allowed for shares  under advanced network settings.

    then it allowed me to log in.

    if it's the date that was the problem i think it's really annoying it gives no clue to that being the issue.

    Friday, November 27, 2009 8:56 PM
  • Mine is working now too, it was the time not the network setting. How stupit is that, thanks would never have figured that one out.
    Friday, November 27, 2009 9:12 PM
  • Sweet! You solved my problem and saved me many more hours of experimentation. Thanks for your post...much appreicated!
    Tuesday, December 08, 2009 1:19 AM
  • It was the time! This is usually only enforced on a domain. WTF. That was a stupid move MS. At least give us a real error!
    I don't know everything, but I do know people who do!
    Wednesday, December 30, 2009 4:38 PM
  • Many Thanks to you timesters!  I had the same problem and was frustrated rotten.  Had reinstalled W2K because of general severely degraded performance and completely missed that default time zone was PST.  Changed it to EST and login problem disappeared.
    Friday, January 22, 2010 5:46 PM
  • Just ran into this problem.  Windows2k Server and 7 Home Premium Client.  The thing that tipped me off was that Daylight Savings just kicked in.  It was not the time that was the issue as the time on both machines was set within 20 seconds of each other, it was the Time Zone setting that was the issue.  Because the server thought that Standard time was still in effect.  I changed the Time Zone on the server to Eastern (GMT-5) and was able to access the shares.  I'm sure I will have to change when the old Daylight savings time occurs.

    Thanks for the insight...don't think I would have figured this one out on my own.

    Wednesday, March 17, 2010 10:21 PM
  • Thanks ever so much for this fix; it worked like a charm  As a result i saved some money by not having to purchase a new server. Starbucks on me for everyone!


    Friday, June 11, 2010 5:06 PM
  • Just had the same problem - Win7 Pro couldn't log onto network with a Win2k Server.

    Different solution that worked.

    Having installed a new Win2k server (mirrored backup server), Win7 Pro couldn't log on with any current or new account details. It turns out that Win7 had used the old server mac address as part of the security / addressing information for the old server and just couldn't / wouldn't seem to refresh.

    Try creating a new windows user profile. Log into the new profile and try connecting to the server using the existing uname and pword. This will cause Win7 to load a new desktop & network profile for the new user - this also cause Win7 to refresh existing network details on the current un-connectable Win7 profile.

    Once you have connected, log out of new user, log back in with old / current user, see if it works.

    This problem was with 4 Win7 PC's and a Win2k server. Reducing security encription standards in Win7 to 40 & 54 bit didn't make a difference. Nor did reducing the NTMLCompat value. Time zones were all consistent.

    New server machine only (mirroed servers with identical hardware config), same server name, same domain name, same IP, different NIC mac address only - refused to connect from Win7. WinXP machines re-connected without issue.

    Created new windows user profile on each Win7 machine - logged into new profile - connected to Win2k server - logged out of new Win7 user and back into old user account on Win7 machine - connected to Win2k server without further issue.


    Wednesday, June 16, 2010 8:48 PM
  • Thank you SO MUCH. I NEVER would have figured that out. Spent 2 days on this already with no luck. I never would have guessed about synching the clocks, but sure enough that was it. Our server said it was 2 hours different than my PC. Changed it, and bang - worked like nothing was ever at issue.

    Thank you again!

    Tuesday, August 17, 2010 6:10 PM
  • Also make sure that the Windows 2000 Server is updated to SP4.



    Thursday, November 11, 2010 2:12 AM
  • Hi,

    Thanks a lot for your input. I had same issue. i changed the time zone on the server. It worked now :-) :-)


    Once again thanks a ton.




    Friday, December 10, 2010 6:30 AM
  • Hi, excellent! Thank you. Once I set the correct time I was in like Flynn. My one last Win2000 system and now my Win7 system can access!

    -qb white

    Saturday, January 08, 2011 6:23 PM
  • I'm running into this same issue.  2x Windows 7 Pro machines on a workgroup network cannot authenticate with a win2k server to get to file shares.  This also occurred the day after a Daylight Savings Time change. 

    However, simply changing up the date/time on the server to match the workstaion does not seem to fix it for me.  The time zone and daylight savings time adjustment have matching settings on the server and workstation, and the time is now matching to the minute, after I adjusted it.  Does the server usually need a restart after adjusting the date/time?

    Tuesday, March 15, 2011 4:16 PM
  • Nevermind, I found my issue:  I had to turn off "automatically adjust for daylight savings time" on the Windows 7 workstations.  That then adjusted the clock by an hour, which I manually adjusted to match the server's time.  Now they can be networked.


    Note that my server already had this setting turned on and still does, yet I had to turn it off on the windows 7 machine for it to work.

    Tuesday, March 15, 2011 6:16 PM
  • Hi All!!

    I just tested your recommendation settings/Policies(from Robinson ZhangMicrosoft), but the problem is still there.

    I can access the Windows 2000 Computer from a machine with Windows Xp, but no with computers with Windows 7.

    Date and Time are the same and correct.

    I also tried this:

    Any help or guide would be really appreciate it.


    Monday, March 28, 2011 5:47 PM
  • I had the same probleme last month but with win 2003 server.

    I misconfigure the DNS on the server, What I needed to do is to put the router IP adress in the DNS serveur and tell the server to let the router do the DNS job.

    Let me know...

    Friday, April 01, 2011 10:54 AM
  • Do you have some news ?
    Friday, April 08, 2011 11:04 AM
  • Similar problem, except windows 7 'sees' the windows 2000 machine, but upon trying to connect i get "Windows cannot access \\compaq" where compaq is the computer name.  The message box also provides error code 0x80070035 "the network path was not found"

    All the other computers are XP machines and they communicate properly with win2k and win7.  The win2k can even read files on windows 7, but I don't even get the opportunity to log in to win2k from Win7, though the icon is displayed on the win7 network window.  I don't understand how the 'network path cannot be found" when the icon for the PC is displayed!

    Time clocks are synched, same time zone, NTLM 2 didn't work, registry fix didn't work.  Same user name and password on all machines.

    (There are other issues with the machine such as inability to run a scheduled task if the 'Run whether user is logged on or not' regardless of which checkboxes are set but it will run when 'run only when user is logged on.  don't think this should be related but who knows).

    Hoping that someone has a solution for me, as Microsoft support said they don't support windows 2000 anymore and wouldn't look at the issue, even though it is a windows 7 problem which I didn't have until I bought this machine!


    Tuesday, April 26, 2011 5:54 PM
  • I've had the exact same problem with the time settings on the windows 2000 machine. thanks for pointing out the time issue.
    Wednesday, August 07, 2013 4:02 PM
  • I had the same problem and I wasted 2 hours on it before I researched the problem and found this thread. I found The Madz solution and it worked for me! Can't thank you enough. 

    Chronicle of my issue where I thank The Madz...

    Tuesday, January 14, 2014 2:20 PM
  • You have solved the problem of the year for me with this crazy but AWESOME solution. Thank you so much
    Thursday, April 24, 2014 6:57 PM
  • I can't believe that something so insignificant can cause such a headache. Thanks for sharing this with us as this problem was driving me bats! Some Win7 machines would log in and others would not. I kept tinkering with the different protocols stopping & starting services, and just could not figure this issue out, till I saw your post on this. Thanks again.
    Saturday, November 01, 2014 4:43 AM