none
Win 7 64 bit not recognizing esata drive

    Question

  • Many people in various forums are reporting problems with Win7 recognizing esata/USB drives. I am running Win 7 64 bit, with an Gigabyte GA-MA790X-UD4P motherboard, a Rosewill RX358 esata drive enclosure and a Maxtor hd. Win 7 will not recognize the esata connected drive when the enclosure is powered up (USB works ok). I was able to get it to recognize the hd if I reboot with the drive on, at least at first-now that has vanished. If I reboot into my old XP installation, it all works fine. When I go back to Win7, nothing. So it certainly appears to be a Win 7 driver issue. I have updated the chipset drivers from the Gigabyte website, but it does not help.
    Saturday, December 05, 2009 8:57 PM

All replies

  • In bios, change the port that you have the esata cable in to ACHI mode.  Then in windows delete the sata driver from device manager. 

    Reboot and it should detect the achi sata port and then it should work.
    • Proposed as answer by DrX69 Saturday, December 05, 2009 10:36 PM
    Saturday, December 05, 2009 10:36 PM
  • You cant once you install if you do change to ACHI if you were in ATA mode when you installed your system may no longer boot.  You must set the bios before install.  I think it only works with RAID/ACHI most boards also have ATA mode.  I thinks its alright if your controller does ATA / SCSI but that only worked when I updated the driver in windows.  Changing to ACHI from ATA could cause the system to boot normal then crash BSOD or enter a mode of infinite Reboots as it fails to load windows.
    Sunday, December 06, 2009 3:29 AM
  • Just a thought, are you able to view it under disk management?
    Sunday, December 06, 2009 4:27 AM
    Answerer
  • No. I can see it only if I boot the computer with the drive on. ( I said above that that didn't work-but it does now).
    Sunday, December 06, 2009 5:53 AM
  • It always works better with booting plugged in because then the AHCI driver causes the device to be showed as plugged in with the option to safely remove it without halting the system.  Some motherboards have a switch option in the BIOS which enables the ESATA port if it is part of  the motherboard.  There are two types.  1 type the port is on the back and is integrated and may have to be turned on.  The second type is AHCI enabled with a cable that hooks to the boards sata port and the other end uses an open pci slot that has ESATA so its like sata to ESATA.  Important not BIOS has to be write think about it.  Normal SATA requires separe power supply.  Enabling ESATA port and AHCI allows power to travel down the bus to the drive so no separte power source is needed.  You probably might not see the drive because unless the drive is powered it does nothing to interact with the bus telling Windows a device has been plugged.  Simple test of this would be to take your multimeter and probe the the ESATA port for voltage signal if none is present then its not switch on in the bios.  This is just my thought I haven't confirmed this theory in any way.
    Sunday, December 06, 2009 5:08 PM
  • uhhh.. if the drive was not visiable then he is not booting from it.  As long as your c drive is not on it, you can do whatever you want.
    Sunday, December 06, 2009 5:36 PM
  • Correct. This is just your standard external back up type drive; not booting from it. It works fine if I reboot, so that in essence, the system thinks its just another internal sata drive, I believe. The problem exists when you want to turn it on while the system is already powered up, as one would normally do with an external drive. I did not install AHCI drivers when I installed Win 7-perhaps that is the issue; not sure. I am reading that there are many issues in installing those drivers after the OS is installed. Simply changing the sata mode from IDE to AHCI in the bios did nothing; I tried that early on, and then chickened out when it came to messing with the drivers and went back to IDE mode. Maybe I will be just be relegated to USB until this issue gets better clarified.
    Sunday, December 06, 2009 5:56 PM
  • Just one other thought...I didn't need any kind of AHCI drivers or anything else while running XP-it still works fine if I reboot and choose the old XP installation-that works like a charm, recognizing the drive when turned on while XP is running. It has to be some kind of Win 7 issue.
    Sunday, December 06, 2009 6:05 PM
  • Yeah Windows 7 recognizes the AHCI with drivers included in the installation files.  However it has been my experience that the driver is generic.  If you open device manager you can check to confirm.  You can get AHCI drivers by installing the Intel or whatever chipset you haves drivers from the site.  The ones in Windows 7 are generic.  I have extracted drivers from Asus I update the present AHCI driver in the device manager with the .inf I have extracted and it asks me to reboot.  It immidiately said installing drivers before it asked me to reboot.  When I check after the reboot I have the Intel ICH9 drivers installed.
    Sunday, December 06, 2009 11:47 PM
  •  I am embarassed to say that this was a dunderhead mistake on my part, and not Windows 7. The Gigabyte GA-MA790X-UD4P motherboard has two sata controllers, one in the chipset for 6 sata ports and one seperate Gigabyte controller for two more. I knew that, but thought that I had installed the drivers for both from the Gigabyte website. The Gigabyte download for "Chipset and Sata Drivers" only had the AMD drivers for both. The drivers for the Gigabyte controller was a seperate download under "Sata Raid" that I missed. So the OS naturally loaded the generic windows drivers for both controllers, which did not work for the Gigabyte JMicron controller. As soon as I installed the specific Gigabyte drivers for that controller, everything worked fine. Mea culpa.
    Thursday, December 10, 2009 2:01 AM
  • I'm not an expert but what I do is put my laptop to sleep, turn on my eSATA drive (give it a minute to boot up) and wake up my computer. It woorks since my USB and eSATA ports are shut down when my computer sleeps.
    • Proposed as answer by m flood Monday, May 28, 2012 5:52 PM
    • Unproposed as answer by m flood Monday, May 28, 2012 5:52 PM
    Friday, May 07, 2010 1:22 PM