none
Windows 7 cannot access shared folders

    Question

  • Recently my windows 7 cannot access shared folders by ip \\192.168.128.11\shares
    Last night I was able to connect and access files no problem.
    I get an error code 0x80004005 unspecified error.

    My tests are as follows:
    I can ping the IP address.
    I can RDP into the computer.
    At the same time I have vmware on my windows 7 with windows xp as a guest os.
    From windows xp I can connect and access the files.

    After I use System Restore to the previous day my windows 7 can access the files.
    I don't make any changes and turn off the computer for the next day or two.
    When I power back on, windows 7 cannot access the share again.
    I did the same tests as previously stated with the same results

    I've been doing research for the last week and had to keep using the System Restore every day in order to access my share files.

    Any advice would be much appreciated.

    Thanks in advance,
    Friday, January 8, 2010 1:31 PM

All replies

  • Ensure the comp that you're trying to access are power on. Instead of mapping it's IP, try mapping the username instead as in follow \\BKUO-PC (example) Make sure the following feature is turn on, if is running win 7 1)network discovery 2)file and printer sharing 3)public folder sharing except 4)password protecting is turn off  5)home group connection=allow windows to managed home group connection

    Lastly ensure there's no third party firewall on both comp
    • Proposed as answer by vohungvi Monday, March 21, 2016 3:46 AM
    • Unproposed as answer by vohungvi Monday, March 21, 2016 3:46 AM
    Friday, January 8, 2010 2:54 PM
    Answerer
  • Well I tried the suggested changes but windows 7 explorer still could not show the windows xp shares.
    I have a nas as well that too cannot be viewed from windows 7.

    I have a secured network so I do not have third party firewall installed.
    Monday, January 11, 2010 11:36 AM
  •  

     

    Hi,

     

    Are the Windows 7 machine and the target machine in a domain?

     

    At this stage, I suggest you temporarily turn off firewall on Windows 7 machine and the target machine for a test. If the issue persists, please try following steps.

     

    1: Clear the Hosts file

    --------------------------------------

    a. Click the Start Button, type "%SystemRoot%\system32\drivers\etc" (without quotation marks) and press Enter.

    b. Right-click on the file "Hosts" (without quotations) and choose Delete.

    c. Click Continue to confirm the deletion and verify the administrator permission.

     

    2: Clean up the Domain Name Resolution (DNS) cache

    --------------------------------------

    a. Click the Start Button, type "cmd" (without quotation marks), in the search result list, right click on Cmd.exe and select Run as administrator.

    b. Click Continue button to verify the administrator permission.

    c. In the popup window, type: "ipconfig /flushdns" (without quotation marks) and press Enter.

     

    If the network folder still cannot be accessed, please collect the following log file when the symptom occurs.

     

    Collect the Netmon trace

    =========================

    a. Download NetMon3.3 from the following website and install it on the computer

     

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=983b941d-06cb-4658-b7f6-3088333d062f

     

    b. Launch NetMon3.3.

    c. In the Microsoft Network Monitor 3.3 window, click Create a new capture tab …

    d. In the new tab, select all the Network Adapters in the Select Networks window.

    e. Then, switch to Network Monitor, press F5 to start NetMon.

    f. Try to download the large file. When it failed, go to step 7.

    g. Go back to the NetMon window and press F7 to stop the NetMon.

    h. Press Ctrl+S to save the Netmon file named test.

    i. Then, please upload it

     

    Thanks,

    Novak

     

    Wednesday, January 13, 2010 2:10 AM
  • http://cid-d938941bf24b9cc7.skydrive.live.com/self.aspx/Capture/test.cap

    I've look at the file too.
    I can see the ipv4 patches from 192.168.128.69 to 192.168.128.10.
    It's sort of Greek to me.
    Friday, January 15, 2010 4:49 AM
  • I also capture the one to 192.168.128.11
     
    http://cid-d938941bf24b9cc7.skydrive.live.com/self.aspx/Capture/testb.cap

    Ping and tried to browse through windows explorer.
    Friday, January 15, 2010 5:01 AM
  • I've captuerd from one of my guest vm computer, that's on the windows 7 computer that has the problem.  I was able to connect with no problem.

    http://cid-d938941bf24b9cc7.skydrive.live.com/self.aspx/Capture/test%5E_good.cap
    Friday, January 15, 2010 5:49 AM
  • Hi,

     

    After analyzing the log file, I suggest you perform a Clean Boot to check the result.

     

    Thanks,

    Novak

    Friday, January 15, 2010 8:07 AM
  • Clean boot also has the same problem, only the Microsoft service was enabled.  This time the error message came back a lot faster.  I've tried to diagnose from cmd and at least try to ping, and I couldn't ping "unable to contact IP driver"  .   I'll tried to stop all services and try to see if one service is having the problem.
    Sunday, January 17, 2010 4:12 AM
  • Ok, I gave up and used the windows 7 dvd and upgrade/re-installed.  It kept all my existing programs and now getting to my share on the network works.  For sanity check I've capture my network traffic.

    http://cid-d938941bf24b9cc7.skydrive.live.com/self.aspx/Capture/test%5E_20100117.cap

    I see the big difference where the SMB is now in the packets captured.  Is there a way to replace/repair the SMB service if it fails?

    Thanks,
    Bkuo
    Sunday, January 17, 2010 3:55 PM
  • Makes sure IIS_WPG has permissions to the content files and folders.
    http://support.microsoft.com/kb/812614
    • Proposed as answer by Steven GJ Thursday, July 15, 2010 11:19 AM
    Wednesday, July 14, 2010 10:07 PM
  • Ok, I gave up and used the windows 7 dvd and upgrade/re-installed.  It kept all my existing programs and now getting to my share on the network works.  For sanity check I've capture my network traffic.

    http://cid-d938941bf24b9cc7.skydrive.live.com/self.aspx/Capture/test%5E_20100117.cap

    I see the big difference where the SMB is now in the packets captured.  Is there a way to replace/repair the SMB service if it fails?

    Thanks,
    Bkuo

    Hi everybody,

    I have the same problem today and I think the issue is related with SMB over TCP. I'm looking for some information about how to restore SMB or how to fix this problem, but i didn't find something to help.

    I captured the network connections using NetMon and there are not SMBoverTCP instances in my Win7. So, anyone could help me to restore the smb service?

    PS: My win7 is x64 and all others machines in my network are win7 x86, and only the win7 x64 had this problem (two times) - Are there any related information about this issue with x64? The first time that it happens, I re-installed everything, but now I want really fix it.

    thanks in advance

     


    Guilherme Rattes
    Friday, July 23, 2010 9:28 PM
  • Welcome to the club.  I'm having the same problem and have been researching it all day.  Try this out:  create a folder called "test" on your C drive and share it.  You'll find out you can't access it by using \\computername\test

    There is definitely an OS issue at work here.

    Wednesday, January 19, 2011 11:58 PM
  • Nothing?  No help at all?  HELLOOOOOOOOOOO Microsoft?!??!
    Thursday, February 10, 2011 11:10 PM
  • I have the same issue, it was working fine for the last month now it won't let me access the Windows server at all, keeps telling me "wrong username or password"  I do a system restore to the day before and it works fine for a while then the problem returns.  Thought maybe a Windows automatic update was to blame so I did another system restore to the prior day and disabled automatic updates and I had access again.  Then an hour later same issue.  Come on Microsoft what is the deal!!! We need a fix for this.
    Tuesday, March 15, 2011 3:35 PM
  • I hade the same issue. On my Host system (Windows XP) the real time clock was lost as result of on old battery. After setup the current time on the host system the problem was fixed. Probabely this helps.
    • Proposed as answer by Antoine271167 Tuesday, September 6, 2011 9:45 PM
    Wednesday, April 13, 2011 7:49 AM
  • I am having the same problem with some Vista Business machines too.

    I see there is no solution to this other than rebuilding/reinstalling windows.

    There is also no solution in other forums.

    I wonder if Microsoft knows about this. There is no report or article on this in Microsoft web site too.

    I have raised another question thread on this with Vista in the title to highlight that this is not just happening to Windows 7.

     

    Regards,

    ltkhoo

    Friday, May 6, 2011 6:27 AM
  • I am having the same problem with some Vista Business machines too.

    I see there is no solution to this other than rebuilding/reinstalling windows.

    There is also no solution in other forums.

    I wonder if Microsoft knows about this. There is no report or article on this in Microsoft web site too.

    I have raised another question thread on this with Vista in the title to highlight that this is not just happening to Windows 7.

     

    Regards,

    ltkhoo


    Hi

    I've answer your queries at vista section, you might wanna take a look at your thread.

    Friday, May 6, 2011 7:18 AM
    Answerer
  • Hello,

    I believe I am having the same issue. can you please post a link to the fix in the vista forums?

    Thanks!

    Thursday, June 23, 2011 6:31 PM
  • Ok, this did the trick for me. I had to do some software debugging and testing with different dates and changed it a couple of times manually. Suddenly I could not access network drives anymore. After I changed it back to the current date, the problem was solved. I really don't understand what the data has to do with validating if your password is correct or not but I am happy it's working again.
    Tuesday, September 6, 2011 9:49 PM
  • I've had the same problem for a long time... tried everything... blamed win7 x64, because i have a laptop running win7 x32 ultimate and no problems accesing shared network folders on that... but... i have eset smart security, maybe i dindt configured the network correctly when i first accesed the wifi with the x64 computer... it was the firewall!!! dahh.. seemed so obvious once i had it working.... disabled firewall on eset and it worked, later i realized what was wrong, enterd advanced setup, went to firewall and fixed to trust my wifi network, that was it!
    it will work, try it on your antivirus, or windows firewall... i've disables windows firewall and only have eset's firewall on... if you allowd sharing when you first added your wifi, you're set, no problems there... the problem starts when adding the wifi to the computer, if you selected "do not allow" sharing and when windwos pop's up asking if its a home/work/public network, you select public, your're screwed... for trusted networks, select both on antivirus firewall and windows network: trusted/home, allow/home, or whatever term your antivirus uses... cheers!
    Tuesday, January 3, 2012 8:52 AM
  • Hi Microsoft,

    What is the solution for this ? please help us to resolve this

     

    Regards

    Veeresh

    Thursday, January 19, 2012 1:21 PM
  • Ever figure out a solution to this issue? I am having a similar problem, and I'm still searching for a solution.
    dmatranga
    • Proposed as answer by SSVEERESH Wednesday, February 8, 2012 10:44 AM
    • Unproposed as answer by SSVEERESH Wednesday, February 8, 2012 10:44 AM
    Monday, January 23, 2012 9:23 PM
  • Hi All Finaly  we found the solution here

    1. Start Registry Editor. To do this, click Start

    Collapse this imageExpand this image

    , type Regedit in the Search programs and files box, and then press ENTER.

    2. Locate and then click following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA

    3. Locate the LmCompatibilityLevel registry value.

    If the registry value is not present, follow these steps to create it:

    1. Select the registry subkey that is listed in step 2.
    2. On the Edit menu, point to New, and then click DWORD Value.
    3. Type LmCompatibilityLevel, and then press ENTER.

    1. Set the DWORD value to 1. To do this, click Modify on the Edit menu, type 1 in the Value data box, and then click OK.

    2. Exit Registry Editor and restart the computer.

    • Proposed as answer by SSVEERESH Wednesday, February 8, 2012 10:44 AM
    Wednesday, February 8, 2012 10:44 AM
  • Thanks SSVEERESH, I tried that previously, and the problem still exists. Here's some more info that I found on my problem:

    1. If I try to ping the server from the CMD from a client computer by host name, e.g. SERVER-PC, it fails.
    2. I then ping the server by IP address, it works.
    3. I then try to ping the server by Hostname, SERVER-PC, and it works.

    Any ideas?


    dmatranga

    Wednesday, February 15, 2012 6:01 PM
  • I had a similar problem like this Dan.  Are you using Hyper-V or VMware by any chance? Because that's what caused the issue for me - Hyper-V created a virtual network connection which messed up the physical NIC local area connection.

    Thursday, February 16, 2012 10:01 AM
  • Actually, I do have a LogMeIn installation on the server computer so that I can access it remotely. Could that be creating some issues you think? And can I not have the best of both worlds, i.e. LAN access and Remote Access? If not, let me know what you did to remove the virtual network.

    Thanks,
    Dan


    dmatranga

    Thursday, February 16, 2012 3:30 PM
  • I've seen this problem in 10 machines, and after testing every suggestion I find, the problem is NEVER solved. I always end up reimaging the laptops because people need them back.

    This has to be some sort of bug in the OS. Hasn't anyone opened a support case @ MS so they can do some low level debugging?

    I'm amazed how this hasn't been solved yet.

    ------------ EDIT -----------------

    I managed to solve this on the machine I was working on. In a last ditch attempt before formatting the machine, I went to device manager - SHOW HIDDEN DEVICES - and uninstalled everything from under "Network Adapters".

    After a reboot I can see every machine on the network and I can connect to UNC shares...

    Monday, February 20, 2012 5:14 PM
  • Thank you Diogo, your edit resolved the issue for me.
    Monday, February 20, 2012 6:03 PM
  • Tried this on another machine and it works for the first few times, but after a while it just doesn't solve the problem anymore.

    I don't understand this, there is no pattern or apparent cause. The only "clue" I have is that this has never happened to sales people, which leads me to believe it might be something the technical guys use (vpn clients?).

    Now I'm going to have to reinstall yet another machine because of this problem.

    • Proposed as answer by DS World Thursday, May 3, 2012 1:18 PM
    • Unproposed as answer by DS World Thursday, May 3, 2012 1:19 PM
    Thursday, April 12, 2012 9:21 AM
  • Lol it's been two years !!

    I have a client on a boat who has the same problem, by phone it did tell him to flush dns/static IP/discover ON/IPV6 On/Host file Clean/Ping fonctional/all network services needed ON/Connected to network YES/

    Still no way to connect to shared on the same network, all other computers (3) on the network can acces shared and have the same configuration ( wim image.... )

    Any ideas ??? I cannot connect to this remote computer has the boat doesn't have internet...

    Thursday, May 3, 2012 1:26 PM
  • Hello,

    have encountered the same problem - none of the proposed fixes in the www work.

    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/6c5069d3-826e-4b56-b78a-4a51239abf81

    My IP Network works fine, but accessing shares of other computers does not work anymore. Before asking for user/password the unspecified error 0x80004005 appears.

    Maybe someone can tell how to re-install all network protocols from LanmanWorkstation and all the rights handling instances above. Any help welcome.

    Monday, May 21, 2012 3:45 PM
  • I have a Windows 7 ultimate that cannot access any file shares on my network, either by name or IP address.  This was working and I have followed all the suggestions from the NTLM, to removing ALL my networking components and reinstalling, to disabling Windows Firewall to removing my antivirus, and I am unable to system restore back to when it was working. 

    Please Microsoft, this seems to be a fairly widespread issue, please help us!!!

    Wednesday, May 23, 2012 2:18 PM
  • It got resolved after installing Client for Microsoft network which was not present in the network settings.
    Friday, July 13, 2012 6:24 AM
  • I had the same issue between two Windows 7 Ultimate computers, with advanced sharing enabled.
    I disabled IPV6 on the sharing PC, and can now access the shares form the other one.

    BR,
    B


    BalintN

    It was only a temporary success: after restarting the sharing box, I can't access it again, I get an Access denied error.

    :-(

    • Proposed as answer by BalintN Friday, September 7, 2012 8:06 AM
    • Edited by BalintN Thursday, September 13, 2012 10:38 AM
    Thursday, September 6, 2012 8:52 AM
  • Check Credentials on Windows 7 machine.  I found the credentials were for local machine.  I edited to Domain\User with the user password for the domain and this worked.  A reboot will be required.  You can access credentials in control panel.
    Tuesday, October 9, 2012 6:42 PM
  • Hi All Finaly  we found the solution here

    1. Start Registry Editor. To do this, click Start

    Collapse this imageExpand this image

    , type Regedit in the Search programs and files box, and then press ENTER.

    2. Locate and then click following registry subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA

    3. Locate the LmCompatibilityLevel registry value.

    If the registry value is not present, follow these steps to create it:

    1. Select the registry subkey that is listed in step 2.
    2. On the Edit menu, point to New, and then click DWORD Value.
    3. Type LmCompatibilityLevel, and then press ENTER.

    1. Set the DWORD value to 1. To do this, click Modify on the Edit menu, type 1 in the Value data box, and then click OK.

    2. Exit Registry Editor and restart the computer.

    Was is same boat as most users here, had tried everything, repeatedly, except the quoted. This worked! After applying the registry edit, I rebooted. It didn't work straight away. I ran an elevated CMD.exe and rebuilt the mapped drive as follows.

    net use \\[server]\[share] /user:[username] [password] /P:Yes

    and that was that, it worked.

    Running Vista Home Premium SP2

    This has been infuriating for me, can I ask exactly what that registry change did? I was in the same boat, where from the vista client I could see all shares on the server, but could not access any despite EVERYTHING being setup correctly on both ends. Every other client could access the shares with the same credentials. The Vista client could access shares on every other client correctly, just not the server.

    Also had a virtual enviroment setup on client pc with virtualpc and also a logmein user.

    • Proposed as answer by N1c0S Tuesday, January 22, 2013 4:01 PM
    Sunday, November 18, 2012 4:59 PM
  • i'm facing the same problem..actually there is no home group..all are in LAN the computer which is next to me from that i can access my PC but from conference room i'm not able to access the same...

    1) ping is there.

    2) no home group.

    3)from other PC i can access min also from conference room i can access several PCs but not mine..

    Thursday, April 18, 2013 10:41 AM
  • Hi everyone,

      Here is how to fix this issue:

       
    1. Click Start >  Run , type secpol.msc in the box, and click OK .
    2. Click Local Policies .
    3. Click User Rights Assignment .
    4. Click Access this computer from the network and make sure that the Everyone group is included.
    5. Click Deny access to this computer from the network and make sure that the Everyone group is NOT included.

     As I can tell, if a network is specified as public, the guest account is added to the 'Deny Access to this computer from the network' Security Policy.  If you remove the guest account (the same account which is used for authentication-less access to shares), you'll find your sharing works!

    Monday, June 17, 2013 8:01 PM
  • So I followed all the advices and voodoo tricks on the thread that did not lead anywhere and found another one that finally fixed it.

    My specs and situation: Windows 7 Home Premium cannot access the shared folders on any computer on my home network (same workgroup) especially not the ones off my NAS. Tried sync'ing the clocks, disabling IPv6, removing the 4to6 network adaptors (I had none), messing with secpol.msc (not available on W7 Home), the firewall is off, sharing is allowed and so on...

    Finally what fixed it was re-enabling the "Client for Microsoft Networks" in the network adapter settings:

    - go to Network Connections, right click the one you use -> "Properties"
    - "Install" -> "Client" -> "Add"

    click "Microsoft", click OK, reboot and my shared folders appeared!!

    • Proposed as answer by Wimber Thursday, April 17, 2014 5:55 PM
    Saturday, June 29, 2013 12:37 PM
  • Thanks, it was the date, for some reason the date has to be exactly correct, I would have never figured this out, thanks a bunch!!!!
    Friday, August 9, 2013 7:10 PM
  • i tried these steps but still no luck, could someone take this high priority and provide the solution.
    Monday, October 28, 2013 4:11 AM
  • Hi! This happened to me, and I finally SOLVED it!

    Log on as administrator to the computer you want to access shared folder.

    Go to Control Panel > User Accounts and Family Safety > User Accounts and click Configure Advanced User profile properties (it takes time to load so wait) on User profile check the name of your computer.

    Mine was:

    W7SUCKS\admi and this supposed to be W7SUCKS\admin, when I try to connect to this computer again I put the user admi and my password then it connect!

    Friday, February 7, 2014 3:51 AM
  • Hey Guys,

    I read through all of this.  I had enabled sharing at the drive and folder level and this worked on and off.  There is also a computer and network level sharing radio button under control panel.  After I enabled sharing at the computer level it fixed my problem and I was able to map and access my shared folders without issues.

    Here is where I went:

    Control panel / Network and Internet / Choose homegroup and sharing options / Change advanced sharing settings

    then on this next screen there are three categores of networks [ Home or Work, Public, Domain (current profile) ]

    Under EACH of these network categories there is a section "Network Discovery".  Select the radio button for "Turn On Network Discovery".

    Under EACH of these network categories there is a section "File and Printer Sharing".  Select the radio button for "Turn on file and printer sharing".

    Once network discovery and file and printer sharing were enabled at the computer level, this fixed my problem.

    Monday, March 31, 2014 10:17 PM
  • THanks Stephanbozzo!! You solved my problem.

    Problem appeared after installing vmware player...

    Thursday, April 17, 2014 5:55 PM
  • Thats correct my friend!!  It Works!
    Monday, May 26, 2014 1:21 PM
  • I tried many solutions but just this answer of Stephanbozzo can actually help me!

    Thanks a lot!


    Saturday, July 12, 2014 5:50 AM
  • Hi, one of the posters (whom I upvoted) asked about vSphere - which I had recently installed - and when I disabled the two "VMware Virtual Ethernet Adaptor for VMnet1" and VMnet8, I could immediately connect to the shares that I needed, once more - fantastic. Good call.
    Monday, March 23, 2015 1:43 PM
  • Thanks a lot Stephan, It worked for me.
    Wednesday, May 6, 2015 12:45 PM
  • Hi Veeresh, the post is perfectly working for me, Thanks a lot.
    Thursday, June 8, 2017 5:20 PM
  • We have tried it and worked, Thanks.
    Thursday, June 8, 2017 5:21 PM
  • Working great.

    Thursday, June 8, 2017 5:21 PM
  • worked 100% for me
    Saturday, November 11, 2017 12:18 PM
  • After many hours searching and trying, the tip from Stephanbozzo pointed in the right direction. Uninstalled Client for Microsoft Networks, reboot, install Client for Microsoft Networks, reboot. Now I can access my NAS again trough a share.
    • Proposed as answer by Jaap Reitsma Thursday, October 11, 2018 2:56 PM
    • Unproposed as answer by Jaap Reitsma Thursday, October 11, 2018 2:57 PM
    Thursday, October 11, 2018 2:56 PM