Vista failed to boot ntkrnlpa.exe 0xc0000428


  • I have been recieveing this error when I try start my pc


    File: \Windows\system32\ntkrnlpa.exe
    Status: 0xc0000428
    Info: Windows cannot verify the digital signature of this file


    This started after I plugged in a Kodak easy share printer which I have used many times before with vista and on the same pc. I have tried every thing from safe boot to booting from the dvd and using the repair tool. I have tried these things several times, nothing works. I have seen this on the thread before


    even though the original poster said that the DVD repair doesn’t work RichardWu
    didn't seem to care and said "Using the Vista DVD to boot and choosing the Repair option is a helpful solution. Let close this thread now." clearly this is not true. So what’s up Microsoft are you trying to cover something up? Also please don't post telling me something corrupted the file because if this is true your basically saying use pc accessories like printers, mouse, keyboards, and anything else at your own risk, what kind of operating system is it if you can't use any accessories.

    Wednesday, June 27, 2007 10:12 PM

All replies

  • First of all, the solution of using Vista DVD to boot and repair is a Offical solution from MS for solving bootup problem. Many peoples get their problem solved by this method. The ORGINAL message poster of that post did not give a reply after a whole month. So, I assume his problem was solved.

    I understand the solution may not be applicable to you. In you case, did you try recovery install? You can also try to copy that file from another Vista PC to your computer, see whether it can solve the problem.(You can do that by going to the command prompt)


    This posting is provided AS IS with no warranties and confers no rights.

    (Please note: We are not work for MS, our reply is not a offical answer.)

    Tuesday, July 03, 2007 6:23 PM
  • i have seen that issue twice, my suggestion is back your information and reinstall because the ntkrnlpa.exe does not seem to take on a the problemed computer. as well usal this error is led by the to bootmgr.exe is missing or corrupt. the only odd thing is this was caused by a camera. ive seen it caused by uninstalling sec soft and doing a system restiore but nothing like this.
    Friday, July 06, 2007 3:57 AM
  • Which means it's a 3rd party software problem again...
    Sunday, July 22, 2007 1:05 PM
  • Yeh well, for me it was a restore point or whatever it's called that killed my vista. I only got a recovery disk with my computer and that starts to load and hangs up on the vista loading bar for hours on end till it seems to go in sleep mode. Also I cannot start vista in any way anymore, please advise...

    TY in advance for any helpfull information
    Monday, October 13, 2008 3:50 PM



    I never did solve my problem; I ended up going back to XP Pro until Sp1 was released for Vista. Of course since going back to Vista I have not tried to plug in the Kodak Printer. I have to say though since SP1 for Vista many of the problems with Vista seem to be gone. My only suggestion to you is to reinstall Vista; hopefully you have kept good backups of you data.

    Monday, October 13, 2008 4:09 PM
  • I had SP1 when it happened. also I cannot reinstall vista, nor XP for that matter. No clue as to the problem but after initial loading my computer just stops doing anything usefull. can't describe it better than that.
    Monday, October 13, 2008 7:25 PM