none
Visio Office 2007 SP2 crashes on Windows 7

    Question

  • I was able to install Visio 2007 with no problems on Windows 7. I am able to open Visio and create a document. If I attempt to launch Visio by opening a saved Visio document from my Desktop, Visio crashes. If I launch Visio on its own say via the Start menu, then attempt to open the same document, it still crashes. I checked that the file was not corrupt on a Vista machine running the same Visio version.

    The solution to stop the crash was to run Visio as Administrator. I was able to open files with no issues then.

    I have not tried differnt combinations of file locations, to see if opening files from a different location (i.e. other than Desktop) had the same effect.
    Monday, June 22, 2009 6:09 PM

Answers

  • Hello ccarpinteri,

    This is a wierd case of bad permissions or compatibility,  at any rate if when you run as administrator you get no problems then you could just set Visio to always run as administrator until an update or the RTM has a chance to resolve this.
    -Scott
    • Marked as answer by axfelix Thursday, June 25, 2009 7:46 PM
    Thursday, June 25, 2009 7:21 PM

All replies

  • ccarpinteri,

    Do try that, and report back with your results. I'm glad you've found a workaround meanwhile.
    -Alex
    Monday, June 22, 2009 7:27 PM
  • OK I turned "run as an administrator off", and repeated the tests from a different folder location, in this case "C:\Temp". The result was the same, crashes if not ran as administrator. I also started Visio through Start menu, created a sample drawing, saved and closed, then attempted to reopen and it still crashes.

    Hope this helps.
    Monday, June 22, 2009 7:41 PM
  • Hello ccarpinteri,

    This is a wierd case of bad permissions or compatibility,  at any rate if when you run as administrator you get no problems then you could just set Visio to always run as administrator until an update or the RTM has a chance to resolve this.
    -Scott
    • Marked as answer by axfelix Thursday, June 25, 2009 7:46 PM
    Thursday, June 25, 2009 7:21 PM
  • Yes I have done that already, although I wanted to report this bug as this is obviously not ideal.

    Charlie
    Thursday, June 25, 2009 7:51 PM
  • Hello ccarpinteri,

    Well you could think of this forum as one giant bug report ,  but if you wanted to make specific mention go to Start>run and type rundll32.exe FeedbackTool.dll,ShowWizard.
    -Scott
    Thursday, June 25, 2009 8:08 PM
  • This may being caused by the "Send to Bluetooth" add-in.  Works like a charm after disabling it.

     

    You may thank: http://knightfoo.wordpress.com/2010/06/14/visio-2007-and-2010-crashing/
    To disable the bluetooth addin
    open visio as administrator
    click tools -> trust center
    click add-ins on the menu bar on the left
    – you should see the bluetooth add-in near the top
    In the manage drop down select “COM Add-ins” and click GO
    You can now deselect or remove the bluetooth add-in
    Click OK

    • Proposed as answer by Harmony Steve Monday, April 18, 2011 1:48 PM
    Friday, January 21, 2011 1:50 PM
  • Boomerific, 

    I have admin rights on my Windows 7 laptop however when I log on to Visio it does not allow me to deselect the bluetooth add-in. Any pointers for me?

    ______________________________________________________________________________________________________________________________

    Never mind, it appears as if it didn't deselect but when I opened and closed it a few times it became disabled.... sigh...

    Wednesday, January 26, 2011 3:43 PM
  • Thank you thank you thank you thank you!  My Visio has been crashing very weirdly ever since upgrading to Windows 7 months ago.  I've tried re-installing, and repairing, etc, and then resorted to just using Visio on my other XP machine where it was always working correctly.  Out of the blue I decided to google "visio crashes" and whallah, it leads me to this solution.  I disabled the Send to Bluetooth add-on and it's WORKING again!  THANK YOU!
    Thursday, April 21, 2011 8:31 PM
  • This may being caused by the "Send to Bluetooth" add-in.  Works like a charm after disabling it.

     

    You may thank: http://knightfoo.wordpress.com/2010/06/14/visio-2007-and-2010-crashing/
    To disable the bluetooth addin
    open visio as administrator
    click tools -> trust center
    click add-ins on the menu bar on the left
    – you should see the bluetooth add-in near the top
    In the manage drop down select “COM Add-ins” and click GO
    You can now deselect or remove the bluetooth add-in
    Click OK


    This totally fixed the issue for me - THANKS!!!
    Monday, April 25, 2011 4:21 PM
  • a BIG THANKYOU for this solution.

    I owe you a beer if we meet someday :)

    Tuesday, May 24, 2011 1:51 PM
  • THANK YOU. Works like a charm.

     

    If anyone have a problem running Visio as administrator.

    1) Go to "Program Files" or "Program Files (x86)" if you have x64 windows 7 then Microsoft Office\Office12 (office 2007) Microsoft Office\Office14 (office 2010)

    2) locate visio.exe, right cleck, click "Run As Administrator"

    3) Follow the instructions to disable "Send to Bluetooth"

    4) Enjoy :)

    Tuesday, May 24, 2011 2:44 PM
  • Problem solved. Visio crashed all the time with me, when trying to save, when copy pasting things. Disabled the bluetooth add-in, no more problems.

    Thank you very much!

    Monday, December 26, 2011 2:07 PM
  • Wow, it works. Thank you. I have tried to work as administrator, did not help. But disabling this feature everything works.

    I am still wandering about Microsoft, what they do making those bugs? There is no normal reason to have bluetooth affecting operation, and why this option is not disabled by default. Today is Jan.09.2012, 9 months expired, I have all upgrades and bug is still present. I lost half day of my job, who is going to pay for this. Microsoft obviously does not care. Strange, because Visio 2007 and Windows 7 are both Microsoft programs. Windows 7 is just nightmare, wasting time software. Microsoft will keep busy people enabling and disabling ridiculous options, with no logical path. Just try to disable visual effects for desktop letters. XP was much, much better and easier to accept. Step forward again, nothing learned with Vista, or company does not care for customers. 

    Monday, January 09, 2012 4:15 PM