locked
Windows 7 Pro shuts down improperly when I put it to Sleep. RRS feed

  • Question

  • When I place my Windows 7 SP1 Pro machine into sleep mode or if it goes into sleep mode after 30 minutes of inactivity then it causes the machine to shut down.  No Blue Screen, No Error, just shuts down.  When you start up you get the screen that says, Windows was shut down improperly how would you like to start windows.  etc. This started happening recently as my computer would go to sleep normally and I was able to wake it up, now it is impossible. My BIOS is up to date and my power management settings doesn't allow hibernating.

    Any suggestions or fixes so that I'm able to put my machine to sleep again? Thank you!

     

    Tuesday, May 10, 2011 2:41 PM

Answers

  • Hi,

     

    According to your description, this issue did not occur before; I suggest you try system restore to get back to a previous time point to check if this issue persists.

     

    Meanwhile, you could update the latest chipset driver for test.

     

    In addition, you could try to install the following hotfix to check how it works:

     

    Sleep and hibernation do not work or a crash memory dump file is not created after you install Service Pack 1 for Windows 7 or Windows Server 2008 R2

     

    You cannot make a computer that is running Windows 7 shut down or sleep

     

    Hope it helps.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Cloud_TS Wednesday, May 25, 2011 5:31 AM
    Thursday, May 12, 2011 9:31 AM


  • Microsoft has released the http://support.microsoft.com/default.aspx?scid=kb;en-us;977307&sd=rss&spid=14481 download and test the issue

    follow this  
    Click Start Orb > type cmd in the search box > right-click cmd in results above > 
    click Run as administrator         - At the prompt type powercfg -devicequery ( wake up from any key) > press enter, 
    it tells you what devices may cause problems with sleep mode

    Also, update all the device drivers including chipset driver, mouse driver and display card driver. 
    Please run Windows Update and keep the system update to date. 
    Besides, if there is any security (anti-virus, anti-spyware) software installed, 
    temporary disable or turn them off to check the result.

    if the issue persists
    you can also perform Clean Boot test
    How to perform Clean Boot:  
    1. Click Start, type MSCONFIG in the Search Bar and Press Enter to start the System Configuration Utility.  
    Please click Continue if the "User Account Control" window pops up.  
    2. Click the Services tab, check the "Hide All Microsoft Services" box and click Disable All (if it is not gray).  

    3. Click the Startup tab, click Disable All and click OK.  
    4. Restart the computer and test the issue.  


    ==> Clean Boot is a troubleshooting step. 
    If some programs have been disabled during the troubleshooting,
    we can enable them later. If there appears System Configuration Utility , 
    check the box of "Don't show this message" and then click OK


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Cloud_TS Wednesday, May 25, 2011 5:32 AM
    Friday, May 13, 2011 11:08 PM

All replies

  • Using Windows 7 Ultimate SP1 (can't install SP2 - installation fails.  Every.time.I.try) and I have the same problem.

    Replaced the fan because it was bad - thought this was part of the problem.  Still happening.

    If I leave laptop running, it runs normally until I resume use.  If I hibernate, it hibernates properly.  If I put it to sleep, it shuts down improperly.

    No help, but thought I'd echo that I am having the same problem.

    Wednesday, May 11, 2011 1:07 AM
  • Hi,

     

    According to your description, this issue did not occur before; I suggest you try system restore to get back to a previous time point to check if this issue persists.

     

    Meanwhile, you could update the latest chipset driver for test.

     

    In addition, you could try to install the following hotfix to check how it works:

     

    Sleep and hibernation do not work or a crash memory dump file is not created after you install Service Pack 1 for Windows 7 or Windows Server 2008 R2

     

    You cannot make a computer that is running Windows 7 shut down or sleep

     

    Hope it helps.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Cloud_TS Wednesday, May 25, 2011 5:31 AM
    Thursday, May 12, 2011 9:31 AM


  • Microsoft has released the http://support.microsoft.com/default.aspx?scid=kb;en-us;977307&sd=rss&spid=14481 download and test the issue

    follow this  
    Click Start Orb > type cmd in the search box > right-click cmd in results above > 
    click Run as administrator         - At the prompt type powercfg -devicequery ( wake up from any key) > press enter, 
    it tells you what devices may cause problems with sleep mode

    Also, update all the device drivers including chipset driver, mouse driver and display card driver. 
    Please run Windows Update and keep the system update to date. 
    Besides, if there is any security (anti-virus, anti-spyware) software installed, 
    temporary disable or turn them off to check the result.

    if the issue persists
    you can also perform Clean Boot test
    How to perform Clean Boot:  
    1. Click Start, type MSCONFIG in the Search Bar and Press Enter to start the System Configuration Utility.  
    Please click Continue if the "User Account Control" window pops up.  
    2. Click the Services tab, check the "Hide All Microsoft Services" box and click Disable All (if it is not gray).  

    3. Click the Startup tab, click Disable All and click OK.  
    4. Restart the computer and test the issue.  


    ==> Clean Boot is a troubleshooting step. 
    If some programs have been disabled during the troubleshooting,
    we can enable them later. If there appears System Configuration Utility , 
    check the box of "Don't show this message" and then click OK


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Cloud_TS Wednesday, May 25, 2011 5:32 AM
    Friday, May 13, 2011 11:08 PM