none
How to make Changes in C:\Windows\System32\drivers\etc\hosts file in Windows 7

    Question

  • Hi,

    i want to add some thing in C:\Windows\System32\drivers\etc\hosts file, how i can add, i login in as admin but its not allowing me to add, 

    can any one please tell me how i can make changes in this file.

    Thanks

    Saturday, July 17, 2010 4:51 AM

Answers

  • it still now allows it gives message you not have permission, contact your administrator to make changes, i am already logged in as admin, and file is read only then also i am not able to  make any change, can some one first test it and then please tell me.

     

    i need this to be done urgently but not seems some one is telling this.


    Since you don't have the option "Run as Administrator", please check the following KB article and see if it helps:

    http://support.microsoft.com/kb/922708


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, July 19, 2010 8:41 AM
    Moderator
  • For the method to start notepad with adminrights works fine. Make sure, that you select "Run as administrator", now go to the folder, click open, select the host file, edit it and save it. This works!

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Sunday, July 18, 2010 8:36 PM

All replies

  • The file is almost certainly read only, so right-click it > Properties and remove the check mark. Make a backup copy of it, then using Notepad change its contents and save it (not as a .txt file, i.e. it has no extension).
    Saturday, July 17, 2010 1:57 PM
  • Run notepad with admin rights (right click on notepad.exe and select "Run as administrator"), open the host file, modifiy it and save the changes.

    André

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Saturday, July 17, 2010 3:45 PM
  • Hi,

    i tried both option but it not worked in windows 7, option of run notepad as run as administrator option was not available, even i was logged in as admin, 

     

    any more option, i already removed read only from entire windows direcctory then also it not worked.

     

    please let me know how i can make changes.

     

    Thanks

    Sunday, July 18, 2010 3:51 AM
  • Right click on file and open with , then chose notepad or click on it and if box come up chose notepad, it will as you permission and click yes.
    Sunday, July 18, 2010 7:19 AM
  • it still now allows it gives message you not have permission, contact your administrator to make changes, i am already logged in as admin, and file is read only then also i am not able to  make any change, can some one first test it and then please tell me.

     

    i need this to be done urgently but not seems some one is telling this.

    Sunday, July 18, 2010 6:12 PM
  • when i checked security option of etc folder it shows i have special permission,
    Sunday, July 18, 2010 6:14 PM
  • For the method to start notepad with adminrights works fine. Make sure, that you select "Run as administrator", now go to the folder, click open, select the host file, edit it and save it. This works!

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Sunday, July 18, 2010 8:36 PM
  • it still now allows it gives message you not have permission, contact your administrator to make changes, i am already logged in as admin, and file is read only then also i am not able to  make any change, can some one first test it and then please tell me.

     

    i need this to be done urgently but not seems some one is telling this.


    Since you don't have the option "Run as Administrator", please check the following KB article and see if it helps:

    http://support.microsoft.com/kb/922708


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, July 19, 2010 8:41 AM
    Moderator
  • If you still couldn't find the answer.


    http://support.microsoft.com/kb/923947

     

    Tuesday, March 15, 2011 9:33 AM
  • I have found a better answer to all of the supports here, I am using avira and it seems that I disable my anti virus and it worked, try disabling your anti virus for a mean time and you will be able to edit this, the anti virus prevent it from being edited. :)
    Friday, June 28, 2013 12:42 PM