MS KB977074 Update Problem


  • I ust installed this update and my system hangs/freeze at the windows bootup screen.

    So, I use the system restore to resolve the problem.

    Anyone else have this issue? and how to fix this

    My Spec Dell studio xps 1645 Intel i7 q720 1.6ghz 4gb windows 7 professional 64 bit
    Wednesday, January 27, 2010 6:30 PM

All replies

  • Yepp. Same issue. Had to hide the update.

    I also get random bluescreens. One of them blamed tcpip.sys.

    I have a home built with Asus P5Q Turbo motherboard, Sapphire Radeon 4850, Corsair SSD, W7 Ultimate 32-bit.
    Wednesday, January 27, 2010 11:50 PM
  • Very strange, there are other threads about problems with this update, too. I don't believe it's a hardware issue, as the quoted specs - at a first look - are too different for this. Do you have any detailed error messages (event log, reliability monitor...) that could help to narrow down the cause?
    (In my case, just to offer a complete alternative, this update was installed without any of the problems you are reporting.)
    Mobile AMD64 3000+, VIA Apollo K8T800 chipset, 1 G RAM, ATIRadeonMobility 9700, 20x DVDRW, C:XPSP3 (50G),D:WIN7 (30G),F:DATA (250G)
    Thursday, January 28, 2010 12:05 AM
  • Hi Super Sarge,


    You may update the BIOS and the hardware drivers first.


    After that, I would like to suggest you disable the antivirus program and try to install the update KB977074 in Clean Boot manually again.


    Here are the download links for the update KB977074:


    Update KB977074 for Windows 7 32-bit:


    Update KB977074 for Windows 7 64-bit:


    Does it work?



    Arthur Li - MSFT
    Friday, January 29, 2010 6:47 AM
  • I had the same issue on my brand new laptop. It worked fine until the auto update kicked in and installed an update. Started hanging and freezing after that. I tried to wipe the drive and reinstall a fresh OS but it kept hanging on the opening screen. Keep in mind, this is a top of the line Maingear laptop with a quad processor and 4GB of Crucial RAM and a Crucial SSD. I was baffled till I read something about SATA conflicts with Windows 7 64 bit. So I pulled out the extra SATA carriage, removed the battery, and plugged in and wiped the drive again and reinstalled. It worked! After that I was able to replace the extra SATA cage and boot up normally. That was a month ago and I have not had any freezes since but I have been afraid to try any Microsoft updates. I dont know if 7 really does have a SATA issue but I am still plagued with constant "not responding" delays in almost every program from Word to Photoshop and I am not sure if it is due to 7's logic regarding RAM or SATA or if it is isolated to 64 bit or does 32 have the same problems. One thing is for sure, many people have the same issue.
    Friday, January 29, 2010 9:03 PM
  • I too am experiencing the same problem. Windows Update installs the KB977074 update but after rebooting my system hangs. To be more specifical, the computer boots up and begins to start Win7...I then get a message to say that "Windows is installing updates...Do not turn off your computer...0 (zero) %"

    Unfortunately it just stays on "0%" and the system seems to hang here. The only way to get around this is by cold reboot and system restore to before the update.

    Im dual-booting Win7 on my 2009 Macbook pro 2.6Ghz (Unibody model). 4GB ram/320Gb sata.

    My system is configured to receive automatic updates and this is the first problem I have experienced since installing Win7. There are a few other threads posted around the net concerning this problem so it seems Im not alone.  For now I will just disable this update.
    Saturday, January 30, 2010 5:37 AM
  • Hi,


    Since there are thousands of the different hardware and software configurations, it is hard for Microsoft to test the updates on all the different hardware and software configurations. However, please be assumed that our developers are improving the products.


    For the people who installed cannot start the computer normally, it is better to wait for the next stability and reliability update.




    Arthur Li - MSFT
    Monday, February 01, 2010 4:12 AM
  • Thank you for all the answer

    hide the update at the moment
    Monday, February 01, 2010 10:11 AM
  • Hi, I also have the same problem on my IMac C2D (2006 Gen). After install it auto reboot then hang after I key in the password and try to load the windows7. Beside to wait for the solution, is there any way I can do in safemode? I tried to restore in Safemode but useless.

    I need to hang in my project in word format but now I just can do nothing.
    Monday, February 01, 2010 1:27 PM
  • When will KB977074 be fixed?

    I also removed KB977074 which, fixed my problems. 

    At shutdown the PC often hangs with a message that a program is still running.  Forcing program end does not work.  The PC hangs for minutes until I press the PC’s power button.

    During one startup, a message came up indicating I needed to validate Windows 7.  Therefore the PC lost the validation information.  The revalidate succeeded.

    Shutdown problems consistently occur after running media center.

    Also have problems with recorded TV programs.  Intermittently can’t burn a recorded TV program to disc.  After this failure occurs, a subsequent shutdown produces a hang 100% of the time.

    My System
    OS Name Microsoft Windows 7 Professional
    Version 6.1.7600 Build 7600
    Motherboard: Gigabyte GA-MA790GP-UD4H
    Processor AMD Phenom(tm) II X2 550 Processor, 3100 Mhz, 2 Core(s),
    BIOS Version/Date Award Software International, Inc. F3, 6/24/2009
    SMBIOS Version 2.4
    Installed Physical Memory (RAM) 4.00 GB
    Hauppauge 950 USB Tuner

    Monday, February 01, 2010 5:40 PM
  • Same problem here. Blue screen.
    Best solution for me was to hide update.
    Andrea Antonangeli - Milano (Italy)
    Friday, February 05, 2010 10:58 PM
  • Hi,

    I have similar problems, however in my case the laptop (Acer Aspire 1690) doesn't resume from sleep mode. The laptop switches on and I get the logon screen, but after entering the password, the machine hangs on 'Resuming'. I can only hard reset the machine and restart Windows 7 in normal boot modus.

    Mark (Netherlands)
    Sunday, February 07, 2010 12:01 AM
  • Hi,

    I have similar problems, however in my case the laptop (Acer Aspire 1690) doesn't resume from sleep mode. The laptop switches on and I get the logon screen, but after entering the password, the machine hangs on 'Resuming'. I can only hard reset the machine and restart Windows 7 in normal boot modus.

    Mark (Netherlands)

    Does reverting to an earlier restore point solve the issue?
    Sunday, February 07, 2010 1:01 AM
  • I'm getting the same problem. When I installed the update the log in time increased from 1-2 seconds to 20-30 seconds. Computer does nothing during that time no Hard drive activity. I have a dell XPS 420. The problem however went away for me after i ran a scf /scannow and rebooted. Running Win 7 Ult 64x Clean

    Sunday, February 07, 2010 1:38 AM
  • My system froze on startup as well after installing this....but I got some error on reaching the desktop that "windows cannot enable something" and my theme changed to classic with no aero.....My system did not shutdown or restart..

    after a bit of searching the error on google I was able to resolve it by restarting the netsh......

    I restarted my computer and it works now as normal...and this update is listed as update succeeded..

    try reseting the netsh might work for you..

    Monday, February 08, 2010 12:29 AM
  • For me it messed up 3 different computers running win7 64. Had to system restore etc. There is no excuse for this.
    Monday, February 08, 2010 7:48 PM
  • I found out about this problem through ArsTechnica. I installed all the important updates through Windows Update until now (only after checking on a forum for issues), I even installed this one too. I will check once I am home. I didn't notice any problems, other than the ____ game (the one from 2002) crashing after I letf it running in the background and switched back to it; I only blamed it on the game, being so old. I am using Win7 Ultimate 64 bit. I read on ArsTechnica that 64 bit systems do not seem to as affected as the 32 bit version. It is not a big deal that this appeared, this was bound to happen anyway :) Let's just hope that there a fix is released soon :)
    Tuesday, February 09, 2010 1:17 PM
  • I have had this same problem with one of my Win 7 64 bit machines.  For the past two weeks, the only way to start my system was to use F8 and "last known good configuartion".  It gets all the way up to just prior to showing the account log-in screen, shows the mouse cursor and just sits there with the hard disk repeating the same patern of activity indefinately.  I have let my system sit for an hour waiting for it to finish the install but it never does.

    I have even reinstalled Win 7.  It works until this update gets installed and then it hangs at the same spot all over again.  I was about to give up on Win 7 and "upgrade" back to Vista 64 when I found this thread.  I'll attempt some of the fixes described here to fix the issue.
    Wednesday, February 10, 2010 6:12 PM
  • @SactoDoug:
    I wouldn't care so much of this issue. First, you can hide this update if it causes problems. So, the next time it will not be re-installed automatically. Second, the update itself isn't THAT important. It solves some problems you probably never had (see the corresponding KB article). Third, it seems that the issue only appears in some hardware/software configurations that are difficult to reproduce. So far, I doubt that a general solution will be found quickly. Better wait for the next reliability update that (like twice in the past) will include previous improvements and hopefully not repeat this current problem.
    "I think there is a world market for maybe five computers.” (Thomas J. Watson, Sr.)
    Wednesday, February 10, 2010 11:35 PM
  • Agreed with Sanmartin. Just restore, hide the update and get on with life. It's no big deal.
    Thursday, February 11, 2010 2:38 AM
  • Hi All,


    This issue has been reported. We are trying to analyze the log files and narrow down the causes.


    Would you please send me the following information for analyzing.






    For your convenience, I have created a new workspace for you. You can upload the information files to the following link. (Please choose "Send Files to Microsoft")


    Workspace URL:

    Password: ulgpzl-]#G


    Note: Due to differences in text formatting with various email clients, the workspace link above may appear to be broken.  Please be sure to include all text between '(' and ')' when typing or copying the workspace link into your browser. Meanwhile, please note that files uploaded for more than 72 hours will be deleted automatically. Please ensure to notify me timely after you have uploaded the files. Thank you for your understanding.



    Arthur Li - MSFT
    Thursday, February 11, 2010 10:09 AM
  • Thanks for your reply.  I have narrowed my particular issues down further and it turns out to not be directly related to this update.  My problem which is identicle to the original poster's problem, is caused by my Hauppauge TV tuner card HVR-2250 drivers.  When I disable the drivers, my system starts up fine.

    I will be contacting Hauppauge with this issue.
    Thursday, February 11, 2010 6:36 PM
  • Ok I've updated. Not unexpectedly, Firefox doesn't work. ;)
    Friday, February 12, 2010 5:06 AM
  • Same issue experienced here with a Dell Inspiron 1420 running Windows 7 Home Premium. After the updates were applied, the system would hang during startup and try to do a system repair. This ran for a very long time and then said it was unable to perform a repair. It did have a detailed error message and one of the indications was bad driver. I was able to do a System Restore from an image prior to the updates and get the computer operational again. I then hid all February Tuesday updates and all is well. After seeing this thread and some others it does appear that the KB977074 update is the culprit. (I plan to unhide all the other updates and leave this one hidden). Oddly enough, my EEE 1000HE PC running Windows 7 Ultimate has not experienced any issues after applying all of the February Tuesday patch updates.
    Friday, February 12, 2010 2:19 PM
  • yup BSODs all the time here too most pointing to dxgmms1.sys others not pointing at anything ie: nothing stated as the cause in the bsod screen, I'll try the uninstall the update and see how it goes 
    Sunday, March 07, 2010 4:04 PM
  • I just wanted to give an update.  I found the cause of my particular problem.  It was not the update after all.  It was my video card.  I have replaced the video card and now my system has run rock solid for the last two weeks.
    Sunday, March 07, 2010 6:33 PM
  • That comment would be much more useful if you told us what video card you had.
    Sunday, March 07, 2010 11:32 PM
  • It was a defective HIS Radeon 4850.  I replaced it with a BFG Nforce 9800GT.
    Monday, March 08, 2010 5:25 AM
  • Interesting. I also have a Radeon 4850, from Sapphire.
    Monday, March 08, 2010 7:47 AM
  • heres the system spacs :

    Asus M3A32MVP-Delux (non wifi) 790FX + SB600

    AMD Athlon x2 7750BE @ 2700MHz 1.25v (stock)

    2 sets of Corsair Dominator Twin2x2048-8500C5D DDR2-1066 5-5-5-15 CR2 2.10v

    2x WD2500AAJS Raid0 boot, 3x Samsung HD502IJ storage

    1x pioneer DVR212s 18x DVDRW, 1x Lite-ON 1693 SOHW 16x DVDRW

    On-board Sound  Analog Devices AD1988B SoundMax

    HIS HD5770Fan 1GB 850/1200 1.2v stock Volt and clocks

    all drivers are upto date as of last week

    directX Feb 2010 redist, Catalyst 10.3, removed KB977074 marked hide and still I'm having an problem with dxgmms1.sys crashing my system whilst playing games that push my system ( doesn't crash at all with MS built in games or playing video/sound ) but does with the likes of FarCry 2 v1.03 and NFS Undercover from anywhere between 5mins play to 2hrs


    I've had multiple BSOD's with varying exceptions but all pointing to dxgmms1.sys as the cause

    I do wish that MS would hurry up and get this sorted

    Thursday, March 11, 2010 12:23 PM
  • Has the workspace been taken down?

    Did they found a solution, other than 'not install'?

    Sunday, May 02, 2010 1:51 AM
  • This may or may not be the same problem I had if it hangs at the 'enter setup' screen then try this, go into setup and disable 'legacy support'. This worked for me. Hope it does for you.
    Monday, January 30, 2012 10:06 PM