none
Windows 7 "Always wait for the network at computer startup and logon" group policy

    Question

  • Hey guys searching searching searching but didnt found the asnwer.

    The problem we have alot of users and since 2 months we have 40 pc running windows 7.

    Most of them work perfect (after alot of coding) but we run into some problems.

    Some pc`s dont run the computer startupscript, we made a policy to run the computer script but on some computers it doenst work.

    All the pc are the same, have the same security groups.

    We have another policy "Always wait for the network at computer startup and logon" and we have the policy " Run startup scripts synchronously" 

    So again everything works on most computers but some just don`t wait for the network, they skip the policy because the network isn`t ready yet?

    Whats happening here?

    Update: ok so i figured out that if i add a reg setting (or policy) that it works but i have to wait for 60 sec before the network/pc is ready, were all on the same network some people have no problems some do.

    regsetting: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon "GpNetworkStartTimeoutPolicyValue"=dword:00000019
    regsetting: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters "DisableDHCPMediaSense"=dword:00000001

    Its 60seconds right nog if i put it to 24 sec the startup computerscript isnt triggered! at 60  seconds it works!
    So its odd that some pc have no problem and some have to wait for 60 seconds before everything works.....

    Is there a retry option in AD before it tries to push the policy again after it failed the first time?

    • Edited by bassie2009 Tuesday, January 25, 2011 2:47 PM update
    Tuesday, January 25, 2011 1:16 PM

All replies

  • As I know there is no such setting. Because the computer cannot adjust if the script is run properly. You may consider add the tasks via Task Scheduler.
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, January 27, 2011 8:59 AM
    Moderator
  • If i use the two reg settings:

    regsetting: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon "GpNetworkStartTimeoutPolicyValue"=dword:00000019
    regsetting: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters "DisableDHCPMediaSense"=dword:00000001

     

    Everything works so the network is ready when the computerscript starts but the users have to wait 60 seconds before the network is ready.

    If we disable the regsetting no computerscript and no logonscript (user)

    We all have 1gb network lan, iam guessing this is the problem but i cant find a solution anywhere......

     

    Are we the only one having this problem?

    • Proposed as answer by russjr08 Wednesday, October 19, 2011 3:52 PM
    Thursday, February 03, 2011 8:11 AM
  • If i use the two reg settings:

    regsetting: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon "GpNetworkStartTimeoutPolicyValue"=dword:00000019
    regsetting: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters "DisableDHCPMediaSense"=dword:00000001

     

    Everything works so the network is ready when the computerscript starts but the users have to wait 60 seconds before the network is ready.

    If we disable the regsetting no computerscript and no logonscript (user)

    We all have 1gb network lan, iam guessing this is the problem but i cant find a solution anywhere......

     

    Are we the only one having this problem?

    I know its kind of an old thread, but no, you are not the only one having this problem.

    I'm using the "Wait for Network Connection" policy, and without those registry keys you provided, none of the Computer Policies are applied. Real quick I see Preparing Network Connections, but then it goes to the "Press Ctrl + Alt + Delete" and I had to first log onto a local account, because it wasn't connected to a domain. Then after that I could login as a Domain User (or in my case a Domain Admin). I even tried doing multiple gpupdate commands. I tried

    gpupdate
    gpupdate /force
    gpupdate /force /boot
    gpupdate /force /boot /Sync << This must be run as an Admin


    And those didn't even do anything from what it seemed like. Although it was showing the message we have set after the Ctrl + Alt + Delete which meant we was getting closer.

     

    Now after the Registry Tweaks you provided, when the computer starts, it finally applies the policies and you can see "Applying Computer Settings" which wasn't there before.

     

    Thanks :)

    Wednesday, October 19, 2011 3:58 PM
  • Glad it helped you, it solves a lot of problems BUT i think its wrong from MS thats it needs this as a fix...

    We also changed our switches (spanning tree fast protocol) which also helps alot :)

    • Edited by bassie2009 Wednesday, November 23, 2011 2:58 PM
    Wednesday, November 23, 2011 2:47 PM
  • It sounds crazy, but I found a solution to this for my problem of the same variety after a LONG time: disable IPv6

    I went through lots of things before I found this, so perhaps if it's not the same issue, some of the steps I took might help:

    • Update the network drivers
    • Turn on UserEnviroment Logging and check the log for problems
    • Check the event log for any failures
    • Check the computers are in the right OU's and that the policies are applied
    • Create a shortcut on the desktop to the script that is meant to run and run it immediately after login to see if this works.
    • put the script into the the login script section under the user profile and/or group policy to see if this works.

    The computers I was looking at were having issues resolving names, and as such not running scripts (or whole scripts). Don't know if it might be related, but give it a go?

    Wednesday, October 30, 2013 12:27 PM