system cannot find secpol.msc


  • I just bought a new PC with Vista Home Premium.  In trying to load a new software app, Vista will not allow me to install as it requires "elevation".  In checking Vista help, it told me to go to programs, accessories, run then type in "secpol.msc".  At that point Vista comes back with "secpol.msc" not found.  Is this the new Microsoft qaulity?
    Wednesday, February 21, 2007 4:43 AM



    Secpol.msc does not exist in the home versions of Vista. But basically secpol.msc is just another GUI for registry settings. All settings regarding UAC can be found in the registry at HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System.
    Thursday, August 23, 2007 12:46 PM

All replies

  • I'm having essentially the same problem. There are one or two commercial programs on my VISTA laptop that always generate the "Do you really want to run this" dialogue box. This is apparently generated by User Control in VISTA. All I wanted was for User Control to shut up about this particular program. If I have double-clicked it, it means that I want it to run and the Windows message was irritating to say the least. I got instructions from a Microsoft Website about how to disable the message, but it requires running secpol.msc. I got the same error message that you received. Translation, there was no way to get User Control to shut up, so I did the next best thing and turned off User Control completely. I ran XP without User Control for years without ill effect, so I don't see this feature of VISTA as overly important, regardless of how loudly the operating system squawked about "security" once I had disabled User Control.

    Once Microsoft gets its act together and provides me with the missing file, then I will think about allowing User Control to operate again, but minus the irritating prompts.

    Friday, February 23, 2007 5:08 PM
  • yes I have this problem too but only on my laptop. On my main compute that I installed Vista on it is there but the new laptop with Vista already on, windows will not find it
    Saturday, February 24, 2007 4:13 PM
  • so we are just stuck wit it asking over and over again.  nice.
    Tuesday, February 27, 2007 9:17 PM
  • ok..I think I have figured it out...and if I am right it is simple and wonder why microsoft does not explain. in in Vista office and ultimate but not in Vista Home
    Tuesday, February 27, 2007 9:30 PM
  • To stop the UAC you can go into your Control Panel, then Administrative Tools --> System Configuration --> Tools Tab --> Down to Disable UAC.

    Peace and Mahalo,
    Friday, March 16, 2007 5:56 PM
  • Bless you Scott.  It has been so hard getting anything done with the UAC activated.  I couldn't even find Run for the longest time...



    Tuesday, August 21, 2007 3:19 PM

    Secpol.msc does not exist in the home versions of Vista. But basically secpol.msc is just another GUI for registry settings. All settings regarding UAC can be found in the registry at HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System.
    Thursday, August 23, 2007 12:46 PM
  • Did as you suggested and it did not work and I still need the secpol.msc. I welcome any more input.


    Wednesday, September 5, 2007 12:26 AM
  • Exactly what setting do you want to change and to what option using secpol.msc? As I said almost 100% af oll settings are registry based, you just have to locate the right keys or create them yourself! Smile

    Wednesday, September 5, 2007 5:19 AM
  • I would like to log off the Admin account and log on as a standard user called "Doug".

    The "Doug" account doesn't need a password and I don't want users to be able to set one.




    Saturday, September 15, 2007 11:55 PM
  • As far as I'm aware you can only deny changing the password for accounts in a domain, not on a local computer. What is the name of the policy setting in secpol.msc that you want to configure?
    Sunday, September 16, 2007 9:24 AM
  • Hi I have problems loggin in to my D-Link DNS323 network NAS storage. The solution from D-LINK is to use Secpol.msc and change the Local LAN policies. Vista only uses NTLMv2 and D-link device only suopports LM & NTLM.


    They tell me to change the "Network Security: LAN manager authentification level" to "Send LM & NTLM"


    Can this be done in the regestry?


    // Lars

    Friday, September 21, 2007 1:37 PM
  • hit the start > run > regedit:HKEY_LOCAL\MACHINE SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon > at this point > look for and/or create/select the key 'SpecialAccounts'  > then < Highlight your new key 'SpecialAccounts' and create the key(if not there already) 'UserList'.   -- on both keys listed leave out the ' marks, they were placed to single out Wink.



    now right click in the HKEY_LOCAL\MACHINE SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserList window on the right and create a new DWORD (32-bit) Value and enter the accounts name you want hidden as the value.


    however, what you've come to find out if you do this is, that you will only receive the full security logon on home by doing this if you have every account hidden, and on that notion by default vista home will un-hide the last user logged on but leave unknown square boxes you can click on for the enter name and pw logon prompts.




    Thursday, January 17, 2008 4:20 AM
  • Only three things that make ultimate my next OS purchase anyday now, UAC option menu/GPEditors/and...

    nothing beats hiding all your administrator user accounts while UAC is still on then making a User account before restarting.  UAC pops up with the user but the to enter password administrator field you cannot enter and no name appears which forces complete seclusion unless you restore to earlier date or re-install with factory settings.  which I believe to not be intentional because why would a option where a entry of data field mini menu and security screen be in use if the field part and dbase are missing, truly the actual third real reason for ultimate for me is being able to join a domain.


    UAC needs LocalUAC or rather the adv fw is like the spartan's shield link defense.


    outbound firewall is non-negotiable by far the ultimate

    Thursday, January 17, 2008 11:17 AM
  • Just installed a critical update, and UAC got turned back on. (Sigh)


    Saturday, May 31, 2008 7:57 PM
  • Stenhall:  sounds like you know whats up- question- if you want to change the logn screen to where is asks for user name and a password and just not a password can you do that with vista home prem? b/c there is no secpol.msc for prem.  You help and knowledge is well recieved.


    email me back at



    Tuesday, June 10, 2008 12:10 AM
  • Sorry - in current version  \Policies\System not existant! (Windows Vista Home Premium)

    Tuesday, June 17, 2008 6:08 AM

  • I have a similar problem. I need to run secpol.msc in order to changed LAN authentication levels so that I can access password protected files on an older wireless external harddrive. According to the harddrive manufacturer it's a necessary step when you use Vista (my desktop is still XP, but my new laptop is Vista). It worked fine, once I changed the settings. However, then my laptop OS crashed and the reload disks Lenovo sent me contained Visto Home Basic vice Business!!! Thanks to these posts, I now know why I can't get at all the work I've save on my external hardrive, though I still can't get any work done and have another reaosn to be pissed at Lenovo.

    Does anyone have a short-term solution for me?

    Wednesday, September 10, 2008 2:22 PM
  • Amen Scott, Amen
    Sunday, March 22, 2009 2:33 AM
  • Easiest way to make the proper(and same) setting as in secpol.msc for Vista Home premium:


    Set this value to 1( is default on 3) "send LM and NTLM "
    See knowledgebase Q823659
    Wednesday, April 8, 2009 4:57 PM
  • Here is a solution to your problem click start and right click on the my computer icon click properties click the advanced tab the settings, There should be a data execution tab click it and check the one that says turn on DEP for all programs and services except for those i select. Then, go to user accounts. At the bottom it should say turn user account control on or off turn it off. That should solve your problem. If you still have an issue repost the issue.

                                                                                                 Chad Griffith
                                                                                           Windows Client Tech Center
    Wednesday, August 12, 2009 7:25 PM
  • Hey hayo_vista

    Are you sure this "tweak" will work ? I don't want to take any risks with my machine. Also, can you please specify that if we do this, what exactly will happen ? Will be able to run "secpol.msc" ?

    My intentions are to change the UAC policies in teh Security policies option. There are several I also want to have a look at.

    Thanks a lot and eager for your reply.
    Sunday, February 14, 2010 3:52 AM
  • Hey Chad

    Don't you think this is like a "turn off security" kind of feature. Is there a way I can review my local security policy ?

    Thank you

    Sunday, February 14, 2010 3:53 AM
  • Glad I found this thread.  Andreas I know you posted this two years ago, but can you or anyone tell me what to do once I reach


    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System ?


    My problem is this:


    The Diagnostic Policy Service, and everything that carries it as a dependability is failing to start.  This is a personally owned PC, I'm on the administrator account and should have the admin token.  When attempting to start - Error 5, Access Denied.  Hence Vista is unable to communicate with any of the four different types of internet access I have available (Wireless Router, a 4G network, direct DSL connection, and a Verizon Anywhere stick).


    I've gone through tons of registry keys and enabled full control permissions for every user, every service.  I've gone in and added profile permissions for NT SERVICE\mpssvc and NT SERVICE\dhcp where needed.  I've tried running strings of services under Local System, Local Service, The Admin User Name, everything.


    I'm banging my head against the table here.  Where do I give this thing permission to exist, and how?


    Thanks to anyone who can help.

    Sunday, April 18, 2010 7:18 AM