none
Cannot Open Volume for Direct Access

    Question

  • Whenever my system boots up, it runs the CHKDSK function and encounters the error "Cannot Open Volume for Direct Acess" it dircts me to go to my control panel and use the system restore. However I am unable to system restore as the following error message shows up "Windows has detected file system corruption on Local Disk (C:). You must check the disk for errors before it can be restored."

    A few things to keep in mind before you respond:

    -I am pretty sure it is not an issue with any Anti-Virus program I have installed or Spyware Doctor

    -Do not refer me to install XP SP3, as I am on a Windows 7 System

    -Do not refer the chkdsk or chkntfs functions in command prompt, as they have not worked.

    -Do not refer me to using the Windows Boot CD

    -Find me a solution that will allow me to use system restore, whether it be overriding the "unable to system restore..." or disabling the chkdsk utility on boot.

     

    So keeping those things in mind, does anyone have any solutions?

    Sunday, April 11, 2010 2:01 AM

Answers

  • Hi,

     

    I would like to suggest you try to run the hard disk diagnostic tool from the official website of your hard disk manufacturer. You may also run HD Tune to scan the hard drive.

     

    Note: The third-party product discussed here is manufactured by a company that is independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's performance or reliability.

     

    If you want to disable checking disk when starting, you may run the following command with the elevated administrator privilege:

     

    chkntfs /x c:

     

    Note: If you have 2 drive, C and D, you can disable chkdsk with the command below.

     

    chkntfs /x c: d:

     

    Regards,


    Arthur Li - MSFT
    Monday, April 12, 2010 7:43 AM
    Moderator

All replies

  • Hi....

    Firstly I am no tech wiz or anything of that sort. I had the exact same problem so I came across your post through google.

    I'll just tell you how mine occured. My laptop boot time was pretty slow so like a pro I tried to alter system configs of boot and startup. I ended up getting the black screed. But other than that the machine worked perfect....though I din realize any difference in boot time!!

     

    Ok this is what worked for me......

     

    I think there are 2 ways that you could handle this....

    1. Go to safe mode and do a system restore.......should work.

    2. Go to msconfig and under boot click safe boot and restart. It will do a disk check (which didn't work previously) and automatically correct it.

     

    Dude there might be better ways of doing this but this definitely worked for me.

     

    gud luck

    • Proposed as answer by KimieTech Tuesday, November 13, 2012 5:14 PM
    Sunday, April 11, 2010 6:19 PM
  • Hi,

     

    I would like to suggest you try to run the hard disk diagnostic tool from the official website of your hard disk manufacturer. You may also run HD Tune to scan the hard drive.

     

    Note: The third-party product discussed here is manufactured by a company that is independent of Microsoft. We make no warranty, implied or otherwise, regarding this product's performance or reliability.

     

    If you want to disable checking disk when starting, you may run the following command with the elevated administrator privilege:

     

    chkntfs /x c:

     

    Note: If you have 2 drive, C and D, you can disable chkdsk with the command below.

     

    chkntfs /x c: d:

     

    Regards,


    Arthur Li - MSFT
    Monday, April 12, 2010 7:43 AM
    Moderator
  • Was looking for answers and found this!  Awesome!  Safe Boot worked for me!!  Thanks!

    Wednesday, April 28, 2010 3:35 AM
  • Savan, you may not be a "tech wiz"... But you ARE my new best friend... I can confirm that solution #2 works, perfectly... Thank You Sir...
    Saturday, November 10, 2012 3:52 AM