none
Microsoft Print to PDF fails RRS feed

  • Question

  • Windows 10 Pro x64 (1903)

    I am trying to create a PDF file from a print window. I get configuration  error 0x8000ffff. This is happening after I upgraded to 1903.

    8000ffff says a .NET 3.5 issue. So I re-installed .NET 3.5. I then unchecked in windows feature the Microsoft to PDf function, rebooted and tried to add it back. I now get error 0x899F0922.

     Did Microsoft print to PDF die in the new build? What can I do to get this working?


    John Lenz

    Friday, November 8, 2019 6:23 PM

Answers

  • I can enable/disable this feature without a reboot being required.

    You could try updating to 1909, maybe that fixes the problem.

    • Marked as answer by JohnLenz Thursday, November 28, 2019 7:47 PM
    Saturday, November 16, 2019 7:03 AM

All replies

  • The error codes you are getting are related to  .NET issues.

    Kindly go through:

    Microsoft .NET Framework Repair Tool

    Manually fix Microsoft .NET Framework errors


    S.Sengupta,Microsoft MVP Windows and Devices for IT, Windows Insider MVP

    • Proposed as answer by Kapil.AryaMVP Saturday, November 9, 2019 9:06 AM
    Saturday, November 9, 2019 1:13 AM
  • 0x8000ffff (E_UNEXPECTED) is not a .NET framework specific error!
    COR_E_XXX Exceptions start with 0x8013 (FACILITY_URT).
    So I wonder why you think this would have anything to do with .NET?
    If an old framework were really required for "Microsoft Print to PDF" , it would have been selected by default.
    On the 1903 system I tested, "Microsoft Print to PDF" works and .NET 3.5 is not enabled.

    as this might be document specific: from what program did you print what?
    did you try the test page printing from the printer properties


    • Edited by EckiS Saturday, November 9, 2019 10:06 AM
    Saturday, November 9, 2019 9:53 AM
  • on the system I use most often, I removed the print to PDF and now cannot re-install it. In "turn windows feature on or off", When I select print to PDF it goes through an installation and aborts with 0x800F0922.

    On another win10 1903 system, When I go to properties of the Microsoft print to PDF object, I get a message that the printer driver is not installed. It asks if I want to install it (BTW, all these systems used print to PDF on the prior win 10 build). I say "yes" and choose print to PDF version 10.0.17763.1. The error message is unable to install Microsoft Print to Pdf Type 4 - User Mode x64 driver; Element not found.

     I have used this feature on several of the Win10 system I have in the prior build with no problem.

    What di I do to get this back functioning?


    John Lenz

    Saturday, November 9, 2019 4:29 PM
  • Ran the  tool, fixed 2 issues but Microsoft print to PDF object still fails to install, 0x800F0922

    John Lenz

    Saturday, November 9, 2019 4:34 PM
  • I tested disabling / reenabling the feature on Windows 10 1903 build 18362.449.
    There was no error, and Print to PDF still works. So its no general problem with 1903.

    0x800F0922 seems to be a generic Windows installer error: 
    "CBS_E_INSTALLERS_FAILED Processing advanced installers and generic commands failed"
    so you could try:
    DISM /Online /Cleanup-Image /RestoreHealth
    Saturday, November 9, 2019 7:01 PM
  • You could try to use the -All parameter that may also install any required parent packages:

    Enable-WindowsOptionalFeature -online -FeatureName Printing-PrintToPDFServices-Features -All

    You have to extract the following from Windows 10 IS0:

    Enable-WindowsOptionalFeature -online -FeatureName Printing-PrintToPDFServices-Features -All -Source "C:\SourceISO\sxs"

    Another option reinstall Windows 10.


    S.Sengupta,Microsoft MVP Windows and Devices for IT, Windows Insider MVP

    Sunday, November 10, 2019 3:11 PM
  • Tried DISM,. still failed.

     I did find one on my win101903 systems where Print to PDF worked. A stop gap unitl I can fix this.


    John Lenz

    Sunday, November 10, 2019 7:07 PM
  • I tried both approaches

    Both failed

    I have worked in this arena for decades. This one is a hair puller. What is stopping iy?


    John Lenz

    Tuesday, November 12, 2019 11:50 PM
  • What was the error you received with:
    Dism /online /Enable-Feature /FeatureName:Microsoft-Windows-Printing-PrintToPDFServices-Package /All /Source:C:\SourceISO\sxs 

    Wednesday, November 13, 2019 1:58 AM
  • Ran it; said feature name not recognized

    Here is the log file: https://1drv.ms/u/s!AmoQ3UGkAIVBhcY8hqx4W8rsqiXlRg?e=fg1pgC 

    I tried get-features like it said in the window but that Get-Features option is unknown error.


    John Lenz

    Wednesday, November 13, 2019 7:04 PM
  • Is the sources/sxs that you are using the one that comes with 1903? 1903 is pretty picky and does not seem to work with other Windows 10 Sources/sxs versions. 
    • Edited by Sam Gartner Thursday, November 14, 2019 1:08 AM
    Thursday, November 14, 2019 1:08 AM
  • All my systems migrated from Win 8 & Win 7. I went to media creation tool (current) and selected create an ISO. I burned it to a DVD disc and am using this. It should be 1903 form media creation tool. However, I have ISO of server images and the file type is .ISO. The disk I burned is an install with files and setup. Do I have the correct win10 disc?

    John Lenz

    Thursday, November 14, 2019 2:57 PM
  • to get the features:
    dism /online /Get-Features
    and the correct featurename is "Printing-PrintToPDFServices-Features"
    so the correct command is:
    Dism /online /Enable-Feature /FeatureName:Printing-PrintToPDFServices-Features

    Thursday, November 14, 2019 7:29 PM
  • Well, this is very strange.

     I ran an elevated CMD and copied your Dism. It ran , said feature installed and needed re-boot.

    Upon re-boot, I got the "wait while we install..." then Could not install feature... restoring windows.

    What is happening. Remember, I used the print to PDF a lot in build 1809 on this system


    John Lenz

    Friday, November 15, 2019 8:46 PM
  • I can enable/disable this feature without a reboot being required.

    You could try updating to 1909, maybe that fixes the problem.

    • Marked as answer by JohnLenz Thursday, November 28, 2019 7:47 PM
    Saturday, November 16, 2019 7:03 AM
  • OK,

    Is 1909 available in media creation tool?

    Or, what is the process to revers an upgrade. I can go back to 1809


    John Lenz

    Sunday, November 17, 2019 6:33 PM
  • Hi John, 

    According to my know, Windows 10 1909 is available to download through the link below. 

    https://www.microsoft.com/en-au/software-download/windows10

    For rolling back to previous system, we should roll back in 10 days after upgrade. If you want to go back, please go to Settings > Update & Security > Recovery and then selecting Get started under Go back to the previous version of Windows 10.

    Bests,


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, November 21, 2019 9:47 AM
    Moderator