none
Disable Sleep when IE Open: Powercfg -REQUESTSOVERRIDE doesn't work

    Question

  • I'm trying to disable sleep/turn-off-monitor when IE is open:  I tried  POWERCFG -REQUESTSOVERRIDE PROCESS iexplore.exe Display System

    However, that didn't work.  Any ideas?

    Friday, May 25, 2012 8:00 PM

Answers

All replies

  • Hi,

    Please use Powercfg -requests to check the application and driver power requests.

    You also need to block requests made by the audio driver to block system sleep.


    Juke Chou

    TechNet Community Support

    Tuesday, May 29, 2012 9:21 AM
    Moderator
  • So I should use -requests as opposed to requestsoverride?  Or am I merely using requests to see if I have the Audio Driver overridden?

    Tuesday, May 29, 2012 2:15 PM
  • Hi,

    -requests switch can list the applications and Audio drivers that block System sleep. You may check this list before using -REQUESTSOVERRIDE switch. Typically, if you want to prevent IE from blocking system sleep, try the command below.

    powercfg -requestoverride driver "the driver listed in -requests " system


    Juke Chou

    TechNet Community Support

    Wednesday, May 30, 2012 7:02 AM
    Moderator
  • Typically, if you want to prevent IE from blocking system sleep, try the command below.

    powercfg -requestoverride driver "the driver listed in -requests " system

    I'd like to do the opposite of this:  I'd like Internet Explorer AND/OR the audio driver to not allow sleep if open.  Unless that is what you meant?

    Wednesday, May 30, 2012 5:01 PM
  • Hi,

    Sorry, if you play Video in IE, it will block System Sleep by default. You may check this by running -requests switch.


    Juke Chou

    TechNet Community Support

    Thursday, May 31, 2012 7:17 AM
    Moderator
  • Unfortunately, it is not blocking sleep nor (more importantly) screen timeout.

    When I try to stream Netflix the screen goes dark after the screen timeout powersaving setting.  It's not recognizing the Audio Driver nor Silverlight nor IE as active. 

    Any ideas on how to keep the screen from turning off while watching netflix (a conglomeration of Audio Driver, Silverlight and IE)?

    Thanks,
    JOe K.

    Thursday, May 31, 2012 4:34 PM
  • Hi,

    When playing Video in IE, it can prevent system sleep but turning of monitor. You can prevent this happening in Windows Media Player. 

    http://windows.microsoft.com/en-us/windows7/Turn-off-your-screen-saver-when-playing-video

    Please change Turning off the Display timeout to Never when watching Video in IE.


    Juke Chou

    TechNet Community Support


    Friday, June 01, 2012 6:37 AM
    Moderator
  • Does this include videos not being run through (embedded) in windows media player.

    It's Netflix; therefore, it's being run through Silverlight and IE not IE and WMP.

    Friday, June 01, 2012 3:16 PM
  • Hi,

    No, you need to change turning off the display timeout to Never to prevent Monitor from turning off.


    Juke Chou

    TechNet Community Support

    Monday, June 04, 2012 2:40 AM
    Moderator
  • Hi,

    No, you need to change turning off the display timeout to Never to prevent Monitor from turning off.



    I have the same problem on the Windows Server 2012 R2 EN x64.

    You wrote:
    «if you play Video in IE, it will block System Sleep by default. You may check this by running -requests switch.»
    But it is not!

    When I'm running the HTML5 video in IE (for example YouTube video), it does not turn off the sleep function.
    During playing video in IE, "powercfg /requests" command show nothing in DISPLAY and SYSTEM sections.
    But during playing video in Windows Media Player, "powercfg /requests" command show WMP process in DISPLAY and SYSTEM sections!

    So, if 2 minutes display off set in power settings, in IE after 2 minutes display go to sleep.
    And if WMP playing video, sleep function for display are turning off, and display stay on.

    How to resolve this problem with IE? May be there is some options in registry/settings/policies?
    Sunday, September 21, 2014 7:53 AM