Snipping Tool will not save


  • I've read another thread with the same problem of "no save" but the solution there doesn't apply here.

    Until last week, I could use the snipping tool and save the results.  I use this a lot - it's a brilliant feature.  
    Now, when I click on "Save As", nothing happens.   If I click "Close" I am asked if I want to save the snip first.  I click "Yes", the application closes.

    What I can do is to click "Copy" in snipping tool, and then open Paint Shop Pro and paste into that.   That is an awfully long way round, and I'd prefer to save direct, as I have been doing since I started using the Beta of Win 7 early this year.

    Less important:  if I ask snipping tool to "send" the snip, it insists on opening MS Outlook, which I don't use.   Is there a way to persuade it to use Thunderbird, my mail client?

    Windows 7 Home Premium, IBM ThinkPad T43 laptop, nothing unusual.
    Friday, December 11, 2009 6:38 PM


  • I finally managed it. The problem occurs if you don't have My Pictures folder in the place pointed in registry:
     "HKEY_CURRENT-USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders"

    I've deleted that folder - I don't need it so that's why save stopped working.
    • Marked as answer by KeithjUK Monday, January 25, 2010 3:34 PM
    Monday, January 25, 2010 10:29 AM

All replies

  • Re-installing the Snipping Tool
    • Open Control Panel, click the Classic View in the Tasks pane. Double click 'Programs and Features'.
    • Select 'Turn Windows features on or off' in the Tasks Pane.
    • Remove the check mark from the 'Tablet PC Optional Components' and press OK.
    • Exit and reboot the computer. This will remove the Snipping Tool component.
    • After the computer restarts, go back into Control Panel and repeat the same procedure
    • Add the check mark to the 'Tablet PC Optional Components'
    • Reboot the computer again.

    Possible quick fixes are

    On HP: Disabling QuickPlay through MSconfig.
    On DELL: Uninstall QuickSet
    Miscellaneous startups - In this case try running the Snipping Tool in Safe Mode, to confirm it's not the tool
    Turn off Tablet PC Optional Components from Windows features and then turned it back on.
    Run Office 2007 Diagnostics

    Friday, December 11, 2009 11:24 PM
  • Thanks, but there is no "Tablet PC Optional Components" there.   This is Windows 7 Home Premium.

    It has "Tablet PC Components" which was all turned off already - stuff like handwriting recognition and Windows Journal.  I let it install those, but Snipping Tool still doesn't save its results.   I'll turn those off again, since I'll never need them.

    It's an IBM ThinkPad, so HP and Dell stuff isn't likely to help.  I don't use Office 2007 - I prefer (and use) Office 2003.

    I'll try Safe Mode when it restarts, to see if that proves anything, but there have been no error messages and there's nothing in the Event Viewer about it.
    Sunday, December 13, 2009 1:49 AM
  • It didn't like that at all!   When I restarted after turning the Tablet PC Components off, it went through a long sycle of removing stuff, restarting, removing stuff again, restarting, then reporting start errors.  It wanted to go back to an earlier installation, which I didn't want to let it do because there's a lot of work I've done over the last 36 hours that isn't backed up - this is my laptop, and I'm not at home.

    Anyway, it eventually restarted OK, the Tablet stuff is gone, and Snipping Tool still doesn't save stuff.

    In the past couple of weeks, it's installed KB976098 (Update for Microsoft Windows) and KB976325 (Security Update for Microsoft Windows).  The security update coincides with the loss of snipping tool saving, so maybe snipping is now deemed an insecure process.

    It looks as if I'm into pasting snips into Paint Shop Pro from now on.  

    I'm not going to risk messing around in Safe Mode.  I did try running it as administrator, but that made no difference.

    Sunday, December 13, 2009 2:11 AM
  • Hi KeithjUK,


    I would like to suggest you run a System Restore to check the issue.


    If it does not work, you may also try to test the issue in Clean Boot.


    If it reoccurs in Clean Boot, I also would like to suggest you create a new user account to check the issue.


    If you want Snipping Tool to send to another email program, you may refer to Control Panel\All Control Panel Items\Default Programs\Set Default Programs, highlight the email program you need, click Set this program as default and OK.


    Good luck!

    Arthur Li - MSFT
    Tuesday, December 15, 2009 2:31 AM
  • I also experiencing this problem - no save. I have Win 7 ultimate. Tablet PC was an option for Vista - but in Win 7 it is system itegrated feature not Tablet PC one. I tried a lot of things and still cannot get this save popup work.
    Tuesday, December 15, 2009 12:08 PM
  • I finally managed it. The problem occurs if you don't have My Pictures folder in the place pointed in registry:
     "HKEY_CURRENT-USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders"

    I've deleted that folder - I don't need it so that's why save stopped working.
    • Marked as answer by KeithjUK Monday, January 25, 2010 3:34 PM
    Monday, January 25, 2010 10:29 AM
  • Hi Arthur ,

    I'm just catching up after an exciting few weeks!

    I don't think a System Restore is viable.  There's too much stuff that I've loaded in the meantime.  Snipping is very useful, but copy-and-paste to Paint Shop Pro is a lot less fuss than having to spend a couple of days reinstalling all kinds of software.

    Zefir - thanks:  that sounds very plausible, because I did tidy up my machine and put stuff where I keep it rather than where Mr Microsoft thinks I should.  I'll follow that lead and report back.
    Monday, January 25, 2010 3:20 PM
  • Zefir , you sir are a genius!

    I changed that registry setting to the correct location of my Pictures folder, and the snipping tool works properly again.

    I saw some other folders listed in that registry location with addresses starting %usersomethingorother% which are also wrong!
    You'd think that Microsoft would set up Windows Explorer to update the registry if the user moves the default folders from their deep hiding place in the bowels of drive C to a more logical location, but apparently not.   I don't keep my "data" on drive C at all - that's for the operating system.  Everything else is on drives D to Q.

    Job done.
    Monday, January 25, 2010 3:34 PM
  • I finally managed it. The problem occurs if you don't have My Pictures folder in the place pointed in registry:
     "HKEY_CURRENT-USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders"

    I've deleted that folder - I don't need it so that's why save stopped working.

    Well done Zefir for posting this, This has cleared up several isues I have had.

    I had relocated all my Liberarys to a diferent drive and had problems saving files in several Apps. I found that most of Reg enteries were like " %USERPROFILE%\Music" They should have been like this "E:\Users\Anthony\Music".

    Thank you for your post.


    Tuesday, April 13, 2010 2:46 PM
  • This worked for me on Window 7.  NO clue why my snipping tool would suddenly not save, but it's fixed.- thanks cdobbs! 
    • Edited by DevenF Tuesday, September 13, 2011 11:21 PM
    Tuesday, September 13, 2011 11:20 PM
  • I used your registry solution as the fix to my problem. I found that the : "%USERPROFILE%\Pictures" directory was missing (I must've deleted it as I don't use the whole Microsoft "My xxx" folder schema for my documents).

    Put in the "%USERPROFILE%\Pictures" folder and now Snipping Tool will let me save the picture anywhere I want.

    Before this permanent fix I went back to old-school Microsoft Paint and PrintScreen to save screen-shots.

    Kudos Zefir.

    Peter A. Berger Jr.
    Tuesday, December 20, 2011 3:17 PM
  • Just voted as helpful: the ansawer is 100% correct and the fix works. Thanks.

    Just to utter my annoyance with microsoft: how on earth is it possible that a simple tool depends for its functioning on a directory being there, or not? And with no error message either. While saving the picture is one of the first things you would do.

    Tuesday, April 10, 2012 12:45 PM
  • Thanks very very much Zefir !  Well done
    Monday, October 08, 2012 12:42 PM
  • Thanks Zefir, you're the man!  I've had this problem a few times before but couldn't fix it.  Perfect fix.
    Tuesday, November 13, 2012 4:31 PM
  • Thanks. I used your tip to solve my "Snip It not saving" problem. In my case I found that the file wasn't missing but the "HKEY_CURRENT-USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders" had the My Pictures folder on a drive partition I deleted when I installed Winodws 8! I am running Winodws 7 Pro on the machine as I have since the release of Windows 7. The tool quit working in 7 when I installed 8 (dual boot system) but until your tip I didn't connect the dots! Thanks! 
    Monday, December 10, 2012 8:31 PM
  • Had the same problem,now solved.You are a ninja-thanks!
    Wednesday, February 06, 2013 10:23 AM
  • Just thought you might want to mention that once you get to that part of the registry you right click on My Pictures, click modify, and then enter the path in in the value data field. 

    Stupid windows!  :)

    Thursday, February 07, 2013 1:13 AM
  • Thanks a million, Zerif!  Works like a charm. to help me with Java problems?  I've installed ver 7 yet Oracle's test page says Java is not installed.  I've tried several times installing, testing, uninstalling.  Still not being recognized.

    Monday, June 10, 2013 7:03 PM
  • my registry was pointing to (d:) and I recently moved everything over to larger drive (e:) by just simple edit it fixed the tool and now I can use all functions.


    Monday, July 15, 2013 6:12 AM
  • I have a question... are you deleting the entire "user shell folder" or the folders inside that or the %userprofile%\my pictures folder itself?  Im not having any luck with any of this.  We are using dell and windows 7. 
    Monday, September 16, 2013 6:56 PM
  • fixes same problem in windows 8.  Must be pointed at a "My Pictures" folder in whatever drive you choose
    Saturday, October 05, 2013 4:57 PM
  • Thanks for this tip!  I've been using Win7 for a couple of years now, and the "Libraries" thing just doesn't fit my style at all so I deleted all of them (the library folders, not the registry entries).  However I didn't realize that those paths were stored deep in the registry, which explains why various apps keep trying to save to them.  (Not to mention, sometimes Library folders would reappear after being deleted!)  

    It makes no sense to me that there's a path variable named (e.g.) "My Pictures" that points to a folder/library named "Pictures".  Why not call them both "My Pictures"?  Or call the library folder "Pictures Library"?  

    Ah well, I have fixed the paths now, and not only does Snipping Tool work again, but I have hopes that I am finally free of Libraries in Win7 forever.  Thanks so much!!

    Wednesday, December 25, 2013 9:49 PM
  • I am really struggling with this - Using Windows 7 - I opened 'Control Panel' cannot see 'task pane' Or see whether or not it is in Classic View or not - I have not got beyond that.

    The snipping tool did work fine - but I am now getting 'Location Not available' - something to do with Drive C - I have no idea how to fix it and am on point of giving up.
    Wednesday, January 01, 2014 10:55 AM
  • Following this suggestion, I simply created another My Pictures folder in my User folder and it (Snipping Tool) worked

    after that. Thank you.

    Sunday, March 16, 2014 9:51 PM
  • changed my registry entry to D:/pictures and snipping tool save now works.
    Tuesday, June 24, 2014 4:00 PM
  • resolved , thanx a lot man


    Thursday, June 26, 2014 10:50 AM
  • Mine is the exact same it was working perfectly whilst i was making a music video for my fave game and it stopped letting me save my images for it so after id placed some i deleted some to make some space 'cos i though that was the problem but it wasnt and thanks for the tips on how else to do it 
    Saturday, July 26, 2014 6:23 PM
  • This solution has worked for me. Thank you.
    (FYI in my case this bug happened because I deleted the folder to which I saved the image from the Snipping Tool last time. I tried to restore the folder where I last saved the image and then change to an existing folder and save the image there but when I deleted that previous one, it did not work again.)

    • Edited by hhgygy Saturday, February 14, 2015 9:59 AM
    Saturday, February 14, 2015 9:55 AM
  • Well i found out my folder is still in space so i checked the my pcitures folder properties and figured out it is set as read only marked so i removed its tick .

    now snipping tool save/save as works as it is used to be.

    Saturday, April 25, 2015 7:41 PM
  • I finally managed it. The problem occurs if you don't have My Pictures folder in the place pointed in registry:
     "HKEY_CURRENT-USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders"

    I've deleted that folder - I don't need it so that's why save stopped working.

    Thanks !! 5 years after your original post it helped me to solve the same problem. I accidentally MOVED my documents and settings to X:\Backups which is a network drive. Windows suddenly decided that all my default locations also moved to X:\Backups so all folder settings where changed. Now I reset those settings and all works again.

    Thanks !


    Thursday, July 23, 2015 7:36 AM
  • I am not enough computer savy that i understand how to fix. Is there a step by step process. I need this tool back.

    Friday, August 21, 2015 8:29 PM
  • Easy way to go:

    Open Windows Explorer

    Right Click on LIBRARIES



    The default location should be your DESKTOP

    If you don't like that location, change to your preferred one AND SAVE the SNIP

    The preferred location should be the default thereafter.

    • Proposed as answer by jurassical Tuesday, September 15, 2015 7:48 PM
    • Edited by jurassical Tuesday, September 15, 2015 8:34 PM
    Tuesday, September 15, 2015 7:31 PM
  • I already got that folder but problem still persists..

    Any suggestions?

    Thursday, December 31, 2015 3:14 AM
  • Above Fix: No need to edit the Registry. Press WinKey or click Start button. Click on your username. Create new folder Pictures.
    Alternative: In Windows Explorer, navigate to C:\users\YourName\ and create the deleted folder Pictures.

    Sunday, January 17, 2016 7:42 PM
  • THANK YOU.....this post saved me
    Saturday, September 24, 2016 2:33 AM
  • This registry setting pointed to the default "%USERPROFILE%\Pictures" and I tried to copy that into my file explorer, and it navigated to the right place, so this is a valid location.

    I tried to set the registry setting to a different path, and then the save function worked. I set the registry back to it's original place (because this is the location I want it to be), and the save still works, but it remembered the last location I saved the previous one. This makes me think that it remembered a location that I have later deleted, and that this was the problem.

    • Edited by awe Tuesday, December 13, 2016 9:31 AM
    Tuesday, December 13, 2016 9:30 AM