none
RDP to Windows 2003 Server - problems with keyboard RRS feed

  • Question

  • Hello!

    I've been struggling with a strange problem with RDP and keyboards. OS is Windows 7 Pro 32-bit on a HP 3500 MT. When connecting to a Win 2003 Server (both standard and R2) over RDP on our intranet, SHIFT-key gets "stuck". This happens totally at random or I have completely failed to trace the cause for this. Only solution so far is to disconnect the session and log back in again or use win+L to lock the RDP session and unlock it again. This will also happen if you just connect to the server and leave it so, doing nothing at all. There's no specific time this takes to happen - it could be anything from 1 minute to 4 hours. My clients basically work only on our terminal servers, so this is starting to be a real issue.

    So far I've tried to disable all keyboard filters and ease of access-tools. I have also tried multiple types of keyboards using different drivers - nothing seems to work. I've tweaked the mstsc.exe to all the different keyboard settings, all do the same. This problem does not occur using Win 7. I've searched hours for a solution to this and tried every single solution provided.

    Any help will be greatly appreciated! I've just finished a massive rollout of new computers and certainly don't feel like doing it all again because of some freaky hardware issue that "cannot be solved"... To my mind anything can be solved - the difference is how hard it's gonna be... :-)

    Best regards,

    Tero Korhonen

    IT admin

    Wednesday, July 24, 2013 5:12 AM

Answers

  • Hi,
     
    Regarding your post, I know that Shift key got stuck during use Windows server 2003 via RDP. You have tried several steps like disabling StickyKeys and FilterKeys. Also, you tried to press the shift key repeatedly to clear this issue as workaround.
     
    It seems a common issue. Because when the Apply Windows key combinations setting is set to On the remote computer, the RDP client hooks into the keyboard at a lower level and this doesn’t appear to interact properly with the Presentation Server’s Unicode keyboard support.
     
    We can try this workaround to see the results:
    1. Click Show Options in the Remote Desktop Connection User Interface.
    2. Select the Local Resources tab.
    3. Under Keyboard,  select On this computer in Apply Windows key combinations list.
     
    Hope this can be helpful.

    Best Regards, StarSprite

    Thursday, July 25, 2013 2:48 PM

All replies

  • I've seen the same thing with some of our servers. I our case the resolve has been to turn off sticky keys within the accessibility options, though I note you say you've already done that. When you disabled the option did you simply uncheck "Use StickyKeys" and "Use FilterKeys" within accessibility options, or did you also go into each of them and disable the options within their respective settings? If you don't also go into the settings for each and turn off the shortcut option then it can still turn on again.

    Where I've seen it I've found one work around is to simply keep pressing SHIFT several times which clears the issue, though in my case it also happens with some other keys, for instance CTRL. Note also, I believe the settings are per profile, so while you can change the default for new users in the general tab, all existing users would need (assuming this resolves it) make the same change in their profiles as well.

    Wednesday, July 24, 2013 6:35 AM
  • Thanks for a quick answer!

    Indeed, I disabled StickyKeys and FilterKeys including all their options under them. Sidenote, this problem cannot be reproduced with a 64-bit 7 Pro, 4530S Probook. So it seems that

    And yes, you are correct, repeadetly pressing the shift key also clears this, I forgot to mention it in the previous post. If there's no permanent fix for this, I'll just create a manual on how to go around this issue for our staff.

    Hoping that one day, Microsoft will provide a permanent fix for this and explain the reasons. We migrated from XP to 7 just this year and ofc this frustrates our staff - "Why won't work properly now like it worked with XP".

    Ofc, this all comes down to me working in the lowest level of the foodchain (I'm in charge of end-user IT support for our coporation). Guess there won't be no special treatments for me on the day after tomorrow (Sysadmins day)... :-)

    Wednesday, July 24, 2013 7:42 AM
  • Hi,
     
    Regarding your post, I know that Shift key got stuck during use Windows server 2003 via RDP. You have tried several steps like disabling StickyKeys and FilterKeys. Also, you tried to press the shift key repeatedly to clear this issue as workaround.
     
    It seems a common issue. Because when the Apply Windows key combinations setting is set to On the remote computer, the RDP client hooks into the keyboard at a lower level and this doesn’t appear to interact properly with the Presentation Server’s Unicode keyboard support.
     
    We can try this workaround to see the results:
    1. Click Show Options in the Remote Desktop Connection User Interface.
    2. Select the Local Resources tab.
    3. Under Keyboard,  select On this computer in Apply Windows key combinations list.
     
    Hope this can be helpful.

    Best Regards, StarSprite

    Thursday, July 25, 2013 2:48 PM