none
Backup fails with error code 0x80070002 - SOLVED RRS feed

  • Question

  • I had the problem with file backup my Windows 7 (64). I can do system backup, but not file backup. Many people have the same problem ("Backup fails with only 0x80070002 and no further information" and a lot of message when you will do search by using Google).  I did not find resolution not in Microsoft KB, not in MS forums. I found resolution step by step. And it is very simple and stupid resolution. You must assign drive letter to the small system-reserved partition (containing bcd)! And it is standard configuration of Windows 7 :-(

    The same solution you can find on this forum - http://social.technet.microsoft.com/Forums/en-US/windowsbackup/thread/53b7a2c4-33c3-4c0f-a6fd-715abe36f1f9

    My suggestion:

    1) MS Backup have bad design - backup should work in any conditions. I do not understand why backup need information about BCD for FILE backup (but all is OK with system backup).

    2) MS Backup have bad error reporting. There aren't any clear information about error. Error log does not help me to resolve problem at all.

    3) MS Backup was not tested on STANDARD windows 7 configuration with hidden system partition. I did think that it is possible in MS :-(

    4) MS support did not recognize this problem. Clear description and resolution this problem was a year ago - - http://social.technet.microsoft.com/Forums/en-US/windowsbackup/thread/53b7a2c4-33c3-4c0f-a6fd-715abe36f1f9

     

    Best regards

    Sergey Voropaev


    • Edited by Serg-V Thursday, September 15, 2011 9:15 AM
    Thursday, September 15, 2011 9:09 AM

Answers

  • In reply to Jeff Ren

    Hi,

    You receipt is not related to my problem. I have done a lot of recommendation and this too. Please read my message and message of "M. from L.". The problem is in hidden system partition. I and "M. from L." solved this problem without your support and it is bad. I want to help another people with this problem and I want that information about this solution was added to KB. It will be nice to add testing of this situation to test case of windows backup too.
    Best regards

    Sergey Voropaev



    • Marked as answer by Jeff RenModerator Tuesday, September 20, 2011 6:54 AM
    • Edited by Serg-V Tuesday, September 20, 2011 7:07 AM
    Tuesday, September 20, 2011 6:40 AM

All replies

  • Hi, 

     

    According to the description, the issue seems to be related to Windows 7. As we mainly focus on the windows server backup questions about Windows Server system and here is not the best support resource for Windows 7, it is recommend you to get further support in the corresponding community so that you can get the most qualified pool of respondents. Thanks for your understanding.

     

    For your convenience, I have list the related link as followed.

     

    Windows 7 IT Pro

    http://social.microsoft.com/Forums/en-US/category/windowshomeserver/

     

     

    Best Regards,

    Jeff Ren


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, September 16, 2011 5:05 AM
    Moderator
  • Hi, 

     

    According to the description, the issue seems to be related to Windows 7. As we mainly focus on the windows server backup questions about Windows Server system and here is not the best support resource for Windows 7, it is recommend you to get further support in the corresponding community so that you can get the most qualified pool of respondents. Thanks for your understanding.

     

    For your convenience, I have list the related link as followed.

     

    Windows 7 IT Pro

    http://social.microsoft.com/Forums/en-US/category/windowshomeserver/

     

     

    Best Regards,

    Jeff Ren


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    Yes, but:

    1) Description this forum - "This forum supports questions for the default backup utility in Windows Vista, Server 2008 and beyond. For questions on NTBackup or Windows Server 2003/XP, please use the “File services and storage" forum."

    2) As I understand Backup in Windows 7 and Server 2008 is a same. So this problem exists in any version of OS.

    3) I do not think, that forum about WHS is better then this forum. It will helpfull if you give link to forum about Backup on Windows 7

    Best regards

    Sergey Voropaev

    Friday, September 16, 2011 6:37 AM
  • Hi,

     

    This problem is due to one or more profiles under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows

    NT\CurrentVersion\ProfileList with missing ProfileImagePath.

     

    To check whether you have missing profiles:

    1.       Open regedit, navigate to the above registry key. (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList). Expand the list

     

    2.       Click on each of the profiles listed. The first 3 profiles should have ProfileImagePath value of

    %SystemRoot%\System32\Config\SystemProfile,

    %SystemRoot%\ServiceProfiles\LocalService, and

    %SystemRoot%\ServiceProfiles\NetworkService

    respectively.

     

    3.       Starting from the 4<sup>th</sup> profile, the ProfileImagePath should contain path to the user profiles on your machine, such as C:\users\Christine

     

    4.       If one or more of the profile has no profile image, then you have missing profiles.

     

    To work around this, delete the profile in question (Caution: The registry contains critical settings that are necessary for your system to function properly. Take extra caution while making changes)

     

    1.       First, export the ProfileList key for safekeeping. (Right click on the key, choose “Export”, and save it to the desktop.)

    2.       Right click on the profile in question, choose delete.

    3.       Try backup again.

    For more details ,please refer to:

    http://blogs.technet.com/b/filecab/archive/2008/03/12/common-causes-and-solutions-to-backup-system-restore-and-complete-pc-backup-problems-updated.aspx

     

    Best regards,

    Jeff Ren


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    • Edited by Jeff RenModerator Monday, September 19, 2011 8:27 AM
    • Proposed as answer by Jeff RenModerator Monday, September 19, 2011 8:27 AM
    • Unproposed as answer by Jeff RenModerator Monday, September 19, 2011 8:27 AM
    • Proposed as answer by Jeff RenModerator Monday, September 19, 2011 8:36 AM
    • Unproposed as answer by Serg-V Tuesday, September 20, 2011 6:47 AM
    • Proposed as answer by Going4it Tuesday, January 19, 2016 10:48 PM
    Friday, September 16, 2011 6:50 AM
    Moderator
  • In reply to Jeff Ren

    Hi,

    You receipt is not related to my problem. I have done a lot of recommendation and this too. Please read my message and message of "M. from L.". The problem is in hidden system partition. I and "M. from L." solved this problem without your support and it is bad. I want to help another people with this problem and I want that information about this solution was added to KB. It will be nice to add testing of this situation to test case of windows backup too.
    Best regards

    Sergey Voropaev



    • Marked as answer by Jeff RenModerator Tuesday, September 20, 2011 6:54 AM
    • Edited by Serg-V Tuesday, September 20, 2011 7:07 AM
    Tuesday, September 20, 2011 6:40 AM
  • hi,

    do you want to give some suggestions to microsoft to add your solution to KB?i will have a try.

    thanks for your sharing.

    beast regards,

    Jeff


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, September 20, 2011 6:51 AM
    Moderator
  • hi,

    thanks for your sharing.

     

    best regards,

    Jeff


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, September 20, 2011 6:56 AM
    Moderator
  • hi,

    do you want to give some suggestions to microsoft to add your solution to KB?i will have a try.


    Thank you.

    Yes, fixed KB will be nice. But:

    1) MS should fix this bug in Backup too.

    2) Error reporting in MS Backup should be improved too

    Tuesday, September 20, 2011 7:14 AM