locked
deploying from network share RRS feed

  • Question

  • hi.
    i am going to deploy the image of refrence computer (my pc) that installed on win7  on networkshare  in order to apply the image on destination computer (my laptop that installed on winxp) but every time i do this command( net use y: \\network_share\ images       copy d:\myimage.wim y: )

     the following error occurs:

    The syntax of this command is:
    NET USE
    [devicename | *] [\\computername\sharename[\volume] [password | *]]
            [/USER:[domainname\]username]
            [/USER:[dotted domain name\]username]
            [/USER:[username@dotted domain name]
            [/SMARTCARD]
            [/SAVECRED]
            [[/DELETE] | [/PERSISTENT:{YES | NO}]]

    NET USE {devicename | *} [password | *] /HOME

    NET USE [/PERSISTENT:{YES | NO}]

    is it necessary to creat network connection between my pc & laptop during deploying from network share?
    plz help me .thanks

    Friday, February 12, 2010 7:46 AM

Answers

  • OK Sam,
    here is your problem.

    Computer1 is configured to use
    Static IP Address. . . . . . . . . . . . : 192.168.0.51

    your other computer "PC", (when it runs normal Windows, not WinPE) is is configured to use
    Static IPv4 Address. . . . . . . . . . . : 192.168.0.19

    Since the two computers are in the same subnet
    (Subnet Mask . . . . . . . . . . . : 255.255.255.0),
    they communicate without a problem.

    However, when you boot a second computer with WinPE, the WinPE is configured to obtain IP address automatically. Since you don't have DHCP service on the network, the WinPE computer gets an IP address from the Automatic Private IP Address range (APIPA):
    (Autoconfiguration IPv4 Address. . : 169.254.235.11)

    Since the two computers are now in different subnets, and APIPA does not assign default gateway, the two computers cannot communicate.

    The quick fix.

    1. Forget what I said about adding driver, the network card is detected correctly.

    2. When you boot from WinPE, issue command:
    netsh int ip set address local static 192.168.0.42 255.255.255.0

    This will set a static IP address to your network card.

    3. Continue with net use command we discussed earlier.

    Good luck, and if I may suggest you study some basic networking (like A+ or Network+).

    Regards,
    Les


    • Marked as answer by sam_mh_85 Wednesday, February 17, 2010 4:08 AM
    Monday, February 15, 2010 11:40 PM
  • I'm using WinPE and connecting to a network share on my laptop all the time, so let's try to solve it.

    Computer1     Computer2
    (LAPTOP)  <--   (PC) booted into WinPE
    "Server"          "Client"
    192.168.0.51   192.168.0.42

    Computer2 wants to connect to Computer1.

    1. On your LAPTOP computer.
    Create a folder D:\Images
    Move your .wim file to D:\Images
    Share folder D:\Images as "Images".
    This folder is now accessible from the network as
    \\LAPTOP\Images
    You did create user Bob as I asked before, didn't you?
    You did make Bob a member of Administrators on your LAPTOP as I asked before, didn't you?
    You did assign Bob's password a value Pa$$w0rd (or whatever), didn't you?

    2. Go to Computer2 (PC)
    Boot into WinPE
    a) Run command
    netsh int ip set address local static 192.168.0.42 255.255.255.0

    wait 1 minute

    b) Run command
    net use u: \\LAPTOP\Images
     
    You should be prompted for username and password
    Username: LAPTOP\Bob
    Password: Passw0rd (or whatever)

    Your wim image should now be accessible as U:\MyImage.wim

    You can apply this image to 'PC' using ImageX command, for example

    ImageX /apply U:\MyImage.wim 1 C:\

    Another advice (sorry if I'm nagging you)

    In my town where I live, we have tens of Wireless clubs. We basically share our wireless equipment, we hang on rooftops and teraces, we share Internet access and play games ("Call of Duty" is very popular). You can find many bright people in these clubs willing to share their knowledge about networking. It's a great hobby for technology enthusiasts.

    • Marked as answer by sam_mh_85 Wednesday, February 17, 2010 4:06 AM
    Tuesday, February 16, 2010 12:46 PM

All replies

  • Hi Sam,

    Are you trying to issue two commands from one line?
    The way you wrote it, it seems so.
    So, you've got two commands

    net use y: \\network_share\ images

    I can see an extra space here:
    \ images

    The correct command should be
    net use y: \\network_share\images

    The other command looks OK 
    copy d:\myimage.wim y:


    If you want to issue both commands at once, you can write them in a .cmd file.
    Open notepad, paste the following two lines inside and save as MyImageCopy.cmd (ensure that under Folder Options/View, the option "Hide extensions for known file types" is cleared). You can then simply run command MyImageCopy from the command Prompt.

    net use y: \\network_share\images
    copy d:\myimage.wim y:



    Friday, February 12, 2010 11:18 AM
  • hi
    i do what you say,but i have the problem again,and sometime the following error occurs:
    system error 53 has occurred.
    the network path was not found,


    my pc is a refrence computer that running win7,i created a refrence image of my pc ,then i want to apply this image to mp laptop( destination computer) so that install win7 on my laptop.

     it is necessary to make workgroup or domain connection between my laptop and pc  befor  i am going to use these instruction:

    net use y: \\network_share\images
    copy d:\myimage.wim y:

    there is no connection between my laptop and pc during enter above commands,
    Friday, February 12, 2010 3:37 PM
  • Another option would be using the Microsoft Deployment Toolkit 2010 to deploy your image from the Network to the client PCs in your environment.
    http://deploywindows7.wordpress.com/
    Friday, February 12, 2010 9:11 PM
  • Sam,

    The error message indicates that you name resolution is not working, meaning that computer cannot resolve IP address from the name.
    In order to fix it you need,
    a) on the client computer set network sharing and discovery. Share something on client
    b) on the server, setup WINS server.
    c) on the client computer(s), adjust IPv4 properties to use your WINS Server.
    d) check firewall settings.

    If it sounds complicated, try to connect to the server using IP address instead o the name.
    You may also tryto use fully quallified domain name (FQDN) if you are using DNS on your private network (if you are using domain, then you are using DNS).
    Friday, February 12, 2010 11:29 PM
  • Sam,

    The error message indicates that you name resolution is not working, meaning that computer cannot resolve IP address from the name.
    In order to fix it you need,
    a) on the client computer set network sharing and discovery. Share something on client
    b) on the server, setup WINS server.
    c) on the client computer(s), adjust IPv4 properties to use your WINS Server.
    d) check firewall settings.

    If it sounds complicated, try to connect to the server using IP address instead o the name.
    You may also tryto use fully quallified domain name (FQDN) if you are using DNS on your private network (if you are using domain, then you are using DNS).

    thanks for your help,but i havn't server,i used workgroup connection between laptop and pc.when i insert winPE media in DVD-R the command-prompt windows open then i coldn't access the workgruop network that before created ,and  error the network path was not found, occurred.
    i said i have only  2computer one of them is refrence and the other one is destination.
    Saturday, February 13, 2010 7:09 AM
  • 1. You need to turn on file sharing and network discovery on your computer where your image resides, let's call it a "server".
    2. Your two computers must be able to communicate with each other.
      a) on both computers go to command prompt and issue command
          ipconfig /all
          If your both computers have the address from the range 169.254.y.z, you are using APIPA. This is OK. You may need to wait a while to establish connection (retry after 1 minute).
          Your computers can also have address from some other range like 10.w.y.z, 172.w.y.z or 192.168.y.z but it is important that the first two or three dotted numbers are the same. It may be helpfull to post the output of Ipconfig on both computers here.
      b) From your WinPE computer, try to ping IP address of your "server" computer obtained in a) above. If you get reply, you have the connection.
      c) Try to disable (temporarily) firewall in your "server" computer.

    3. Sometimes there may be problems with blank passwords
    a) on your "server" computer create a user "Bob" with password Pa$$w0rd.
    b) try to turn "Advanced Sharing" on your shared folder and add user Bob with full control permissions.
    c) from your WinPE computer try to access network share on your "server" computer, let's say it's name is "RIO". Use the command
      net use t: \\RIO\SharedFolder /User:RIO\Bob
      You should then be prompted for a password.
      etc.
    Saturday, February 13, 2010 3:20 PM
  • 1. You need to turn on file sharing and network discovery on your computer where your image resides, let's call it a "server".
    2. Your two computers must be able to communicate with each other.
      a) on both computers go to command prompt and issue command
          ipconfig /all
          If your both computers have the address from the range 169.254.y.z, you are using APIPA. This is OK. You may need to wait a while to establish connection (retry after 1 minute).
          Your computers can also have address from some other range like 10.w.y.z, 172.w.y.z or 192.168.y.z but it is important that the first two or three dotted numbers are the same. It may be helpfull to post the output of Ipconfig on both computers here.
      b) From your WinPE computer, try to ping IP address of your "server" computer obtained in a) above. If you get reply, you have the connection.
      c) Try to disable (temporarily) firewall in your "server" computer.

    3. Sometimes there may be problems with blank passwords
    a) on your "server" computer create a user "Bob" with password Pa$$w0rd.
    b) try to turn "Advanced Sharing" on your shared folder and add user Bob with full control permissions.
    c) from your WinPE computer try to access network share on your "server" computer, let's say it's name is "RIO". Use the command
      net use t: \\RIO\SharedFolder /User:RIO\Bob
      You should then be prompted for a password.
      etc.
    hi,
    I performed all of the instructions that you said,i connected two computers together then  they communicated with each other ,and got reply,then ener the command (
    net use t: \\RIO\SharedFolder /User:RIO\Bob ) on the computer that called "server" and meesage occured :the command completed successfully.

    then i inserted WinPE Media on "server" computer and restart computer then windows PE starts and open  a command-prompt  window
    and type the below command:
    net use t: \\RIO\SharedFolder /User:RIO\Bob
    then the error again occured :
    system errors 53 has occured,the network path was not found. :(

    then exit of  winPE command-prompt  window and return to serevr computer ,then retype the below commands:
    net use t: \\RIO\SharedFolder /User:RIO\Bob ,
    and the message occured:
     the command completed successfully.

    everytime i insert the winpe media on the server computer and restart and open winpe command-prompt  and retypre the commands the error occure and couldn't find the network path
    Sunday, February 14, 2010 9:30 AM
  • Sam Why do you not use the IP address of the system??
    It will not need to figureout where the box is that way.
    Sunday, February 14, 2010 10:03 AM
  • 1. You need to turn on file sharing and network discovery on your computer where your image resides, let's call it a "server".
    2. Your two computers must be able to communicate with each other.
      a) on both computers go to command prompt and issue command
          ipconfig /all
          If your both computers have the address from the range 169.254.y.z, you are using APIPA. This is OK. You may need to wait a while to establish connection (retry after 1 minute).
          Your computers can also have address from some other range like 10.w.y.z, 172.w.y.z or 192.168.y.z but it is important that the first two or three dotted numbers are the same. It may be helpfull to post the output of Ipconfig on both computers here.
      b) From your WinPE computer, try to ping IP address of your "server" computer obtained in a) above. If you get reply, you have the connection.
      c) Try to disable (temporarily) firewall in your "server" computer.

    3. Sometimes there may be problems with blank passwords
    a) on your "server" computer create a user "Bob" with password Pa$$w0rd.
    b) try to turn "Advanced Sharing" on your shared folder and add user Bob with full control permissions.
    c) from your WinPE computer try to access network share on your "server" computer, let's say it's name is "RIO". Use the command
      net use t: \\RIO\SharedFolder /User:RIO\Bob
      You should then be prompted for a password.
      etc.

    Dear les52,

    i write for you the following instruction that exist on 70-680 configuring win7 trainingkit book page 86,i think  found the problem that i come across with....

    1.

     

     

    log on to the canberra computer  using the kim_AKERS  account.

    2.

     

     

    On the canberra computer, insert the Windows PE medium and restart the computer.

    3. Windows PE starts and opens a command-prompt window.

    4.

     

     

    To capture an image of the reference installation by using the ImageX tool located

    on your Windows PE medium, enter

     

    e:\imagex.exe /capture c: d:\images\

    myimage.wim “Canberra Win7 Install” /compress fast /verify

     

    .
     This command uses ImageX on the CD/DVD-ROM drive E: to capture the image of the system disk C: to the folder images on the second hard disk D:

     

     


    5.
    Enter exit and remove your Windows PE boot disk. The computer boots into Windows 7.

    6.

     

     

    Check that the file Myimage.wim exists on the D: drive (or wherever you chose to put it).

    7.

     

     

    Optionally, if you want to share the image across a network, create a network share,

    (for example, \\Canberra\Images) and map it to a network drive (such as Y:) and then

    copy the WIM file to this share.



    i dont perform step 5 and don't exit of winPE command-prompt

    ,after  the step4 that  created  the  image file of win7 ,i don't type "exit" in  winPE command-prompt window and don't remove winpe media ,and stayed in the winPE command-prompt  and type  the following instruction:

    net use  t:  \\RIO\images   /User:RIO\Bob    then the  error "the network path couldn't not found " occurred.


    do you think this is the main cause of my problem in this section that after step4   i don't  exit of  the  winpe command-prompt  or not ?

    Sunday, February 14, 2010 1:38 PM
  • Sam,

    are you learning for the exam 70-680?

    Which training kit are you refering to (full title and publisher please)?

    Do you really have two computers?

    Are they physical or virtual?

    At the moment you are really stuck with the basic networking.

    On first computer, no matter if it's running a server or client operating system, you need to share a folder that contains your wim images.

    On second computer which is booted to Win PE, you need to connect to this shared folder on first computer. That's what net use command does

    From the description of your exercise, I didn't get the impression that you are working with two computers.

    When you are studying it is best to create two virtual machines, one with server and one with client operating system. Windows 7 has a free Windows Virtual PC download. However, this requires hardware virtualization to be present on the CPU and BIOS. Some other alternatives also exist, some are free, some are commercial. From Microsoft download site, you can also download ready built virtual machines.

    Some usefull web sites:
    Windows Virtual PC:
    http://www.microsoft.com/windows/virtual-pc/

    Windows 7 vhd
    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=606ae07e-b7db-405b-974b-dd61fc41add4

    Windows Server 2003 R2 vhd
    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=77f24c9d-b4b8-4f73-99e3-c66f80e415b6

    In fact, it is best to go to Microsoft download site and type vhd into Bing search box and click "Search all Download Center".

    Good luck with your study.
    Les


    Sunday, February 14, 2010 6:08 PM
  • Sam,

    are you learning for the exam 70-680?

    Which training kit are you refering to (full title and publisher please)?

    Do you really have two computers?

    Are they physical or virtual?

    At the moment you are really stuck with the basic networking.

    On first computer, no matter if it's running a server or client operating system, you need to share a folder that contains your wim images.

    On second computer which is booted to Win PE, you need to connect to this shared folder on first computer. That's what net use command does

    From the description of your exercise, I didn't get the impression that you are working with two computers.

    When you are studying it is best to create two virtual machines, one with server and one with client operating system. Windows 7 has a free Windows Virtual PC download. However, this requires hardware virtualization to be present on the CPU and BIOS. Some other alternatives also exist, some are free, some are commercial. From Microsoft download site, you can also download ready built virtual machines.

    Some usefull web sites:
    Windows Virtual PC:
    http://www.microsoft.com/windows/virtual-pc/

    Windows 7 vhd
    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=606ae07e-b7db-405b-974b-dd61fc41add4

    Windows Server 2003 R2 vhd
    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=77f24c9d-b4b8-4f73-99e3-c66f80e415b6

    In fact, it is best to go to Microsoft download site and type vhd into Bing search box and click "Search all Download Center".

    Good luck with your study.
    Les


    i am learning for the exam 70-680.
    my refrence for reading is MCTS exam 70-680,configuring windows7,self-paced training kit (PUBLISHED BY Microsoft Press  A Division of Microsoft Corporation

    One Microsoft Way Redmond, Washington 98052-6399)

    ,yes i  really have two physical computer(pc and laptop)..
    you said:On second computer which is booted to Win PE, you need to connect to this shared folder on first computer. That's what net use command does
    this is my problem,on second computer (pc) could't connect to this shared folder on first computer in winpe command-prompt,
    but before the pc booted to winpe command-prompt, two computer(pc and laptop) connect together ..


    Monday, February 15, 2010 6:15 AM
  • On the first computer that hosts the shared folder, please go to command prompt.
    Issue command
    ipconfig /all > Computer1.txt
    Open Computer1.txt in Notepad. Copy and paste the file content here.

    On the second computer (WinPE), from the command prompt, please issue command
    ipconfig /all
    and show us results here. 

    Hint
    You can insert UFD (let's say it' drive letter is F:).
    You can then isuue command
    ipconfig /all > F:\WinPEIpconfig.txt
    Open WinPEIpconfig.txt in Notepad. Copy and paste the file content here.

    I have a hunch that your WinPE does not contain driver for your network card.
    If that is the case you can address the problem in two ways.

    1. You can add a driver directly from the WinPE session using command
    drvload.exe inf_path
    inf_path is a path to the INF file of your driver.

    2. You can add a driver to the WinPE image. This means recreating your boot WinPE media
    You can use DISM command to perform this task. 

    More info is here
    http://technet.microsoft.com/en-us/library/dd744371(WS.10).aspx

    Another hint(s)
    1. If you are using physical computers, you may find it more flexible to use UFD boot media instead of CD/DVD.

    2. During learning, you may find it beneficial to use virtualized environment.
    Monday, February 15, 2010 9:04 AM
  • On the first computer that hosts the shared folder, please go to command prompt.
    Issue command
    ipconfig /all > Computer1.txt
    Open Computer1.txt in Notepad. Copy and paste the file content here.

    On the second computer (WinPE), from the command prompt, please issue command
    ipconfig /all
    and show us results here. 

    Hint
    You can insert UFD (let's say it' drive letter is F:).
    You can then isuue command
    ipconfig /all > F:\WinPEIpconfig.txt
    Open WinPEIpconfig.txt in Notepad. Copy and paste the file content here.

    I have a hunch that your WinPE does not contain driver for your network card.
    If that is the case you can address the problem in two ways.

    1. You can add a driver directly from the WinPE session using command
    drvload.exe inf_path
    inf_path is a path to the INF file of your driver.

    2. You can add a driver to the WinPE image. This means recreating your boot WinPE media
    You can use DISM command to perform this task. 

    More info is here
    http://technet.microsoft.com/en-us/library/dd744371(WS.10).aspx

    Another hint(s)
    1. If you are using physical computers, you may find it more flexible to use UFD boot media instead of CD/DVD.

    2. During learning, you may find it beneficial to use virtualized environment.

    hi les,

    computer1.txt

     

    Windows IP Configuration

            Host Name . . . . . . . . . . . . : LAPTOP

            Primary Dns Suffix  . . . . . . . :

            Node Type . . . . . . . . . . . . : Unknown

            IP Routing Enabled. . . . . . . . : No

            WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Wireless Network Connection:

            Media State . . . . . . . . . . . : Media disconnected

            Description . . . . . . . . . . . : Atheros AR5007EG Wireless Network Adapter

            Physical Address. . . . . . . . . : 00-22-5F-79-F6-67

    Ethernet adapter Bluetooth Network Connection:

            Media State . . . . . . . . . . . : Media disconnected

            Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)

            Physical Address. . . . . . . . . : 00-0D-F0-60-7F-19

    Ethernet adapter Local Area Connection:

            Connection-specific DNS Suffix  . :

            Description . . . . . . . . . . . : Realtek RTL8168C(P)/8111C(P) PCI-E Gigabit Ethernet NIC

            Physical Address. . . . . . . . . : 00-1F-16-1B-0D-6C

            Dhcp Enabled. . . . . . . . . . . : No

            IP Address. . . . . . . . . . . . : 192.168.0.51

            Subnet Mask . . . . . . . . . . . : 255.255.255.0

            Default Gateway . . . . . . . . . :

    WinPEIpconfig.txt :


    Windows IP Configuration

       Host Name . . . . . . . . . . . . : minint-qjut1j4
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : NVIDIA nForce Networking Controller
       Physical Address. . . . . . . . . : 00-1C-25-35-7E-BC
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::3c5a:7d04:af5d:eb0b%2(Preferred)
       Autoconfiguration IPv4 Address. . : 169.254.235.11(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Default Gateway . . . . . . . . . :
       DHCPv6 IAID . . . . . . . . . . . : 33561637
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-13-0B-D0-F6-00-1C-25-35-7E-BC
       DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                           fec0:0:0:ffff::2%1
                                           fec0:0:0:ffff::3%1
       NetBIOS over Tcpip. . . . . . . . : Enabled


     as you said, i also add a driver directly from the WinPE session using the following command:
    1: drvload.exe  nvenetfd.inf
    drvload: succesfully loaded nvenetfd.inf
    2. drvload.exe  nvnetbus.inf
    drvload:unable to load nvnetbus.inf <error 0x80070103>


    i also creat a txt file of second computer before insert winpe media on DVD-ROM AND RESTART SECOND COMPUTER TO OPEN WINPE COMMAND-PROMPT:


    Windows IP Configuration

       Host Name . . . . . . . . . . . . : PC
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

    Ethernet adapter Local Area Connection 2:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : NVIDIA nForce Networking Controller #2
       Physical Address. . . . . . . . . : 00-1C-25-35-7E-BC
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::c8cd:df8c:a661:2138%16(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.0.19(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . :
       DHCPv6 IAID . . . . . . . . . . . : 268442661
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-13-09-06-A5-00-1C-25-35-7E-BC
       DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                           fec0:0:0:ffff::2%1
                                           fec0:0:0:ffff::3%1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{9E5F4801-3078-4B1F-846E-B7D7C6C9D704}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter 6TO4 Adapter:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft 6to4 Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Monday, February 15, 2010 4:55 PM
  • OK Sam,
    here is your problem.

    Computer1 is configured to use
    Static IP Address. . . . . . . . . . . . : 192.168.0.51

    your other computer "PC", (when it runs normal Windows, not WinPE) is is configured to use
    Static IPv4 Address. . . . . . . . . . . : 192.168.0.19

    Since the two computers are in the same subnet
    (Subnet Mask . . . . . . . . . . . : 255.255.255.0),
    they communicate without a problem.

    However, when you boot a second computer with WinPE, the WinPE is configured to obtain IP address automatically. Since you don't have DHCP service on the network, the WinPE computer gets an IP address from the Automatic Private IP Address range (APIPA):
    (Autoconfiguration IPv4 Address. . : 169.254.235.11)

    Since the two computers are now in different subnets, and APIPA does not assign default gateway, the two computers cannot communicate.

    The quick fix.

    1. Forget what I said about adding driver, the network card is detected correctly.

    2. When you boot from WinPE, issue command:
    netsh int ip set address local static 192.168.0.42 255.255.255.0

    This will set a static IP address to your network card.

    3. Continue with net use command we discussed earlier.

    Good luck, and if I may suggest you study some basic networking (like A+ or Network+).

    Regards,
    Les


    • Marked as answer by sam_mh_85 Wednesday, February 17, 2010 4:08 AM
    Monday, February 15, 2010 11:40 PM
  • OK Sam,
    here is your problem.

    Computer1 is configured to use
    Static IP Address. . . . . . . . . . . . : 192.168.0.51

    your other computer "PC", (when it runs normal Windows, not WinPE) is is configured to use
    Static IPv4 Address. . . . . . . . . . . : 192.168.0.19

    Since the two computers are in the same subnet
    (Subnet Mask . . . . . . . . . . . : 255.255.255.0),
    they communicate without a problem.

    However, when you boot a second computer with WinPE, the WinPE is configured to obtain IP address automatically. Since you don't have DHCP service on the network, the WinPE computer gets an IP address from the Automatic Private IP Address range (APIPA):
    (Autoconfiguration IPv4 Address. . : 169.254.235.11)

    Since the two computers are now in different subnets, and APIPA does not assign default gateway, the two computers cannot communicate.

    The quick fix.

    1. Forget what I said about adding driver, the network card is detected correctly.

    2. When you boot from WinPE, issue command:
    netsh int ip set address local static 192.168.0.42 255.255.255.0

    This will set a static IP address to your network card.

    3. Continue with net use command we discussed earlier.

    Good luck, and if I may suggest you study some basic networking (like A+ or Network+).

    Regards,
    Les



    hi les,

    i am really sorry to make you tired
    .

    i set the second computer 's  ip address as you said in winpe:
    netsh int ip set address local static 192.168.0.42 255.255.255.0

    then issue the command on winpe (second computer):  ping 192.168.0.51 (the fisrt computer 's ip adress)
    and get: reply from 192.168.0.51 :bytes=32 .....
                  reply from 192.168.0.51 :bytes=32 .....

    ..

    then issue the command on first computer for more times :
    ping 192.168.0.42
    but the error occured:
    the requset time out
    the requset time out
    ..
    the first computer could't make connection with second com .unlike the first computer the second computer  get reply ...

    ----

    then
    i enter the following commands on winpe command-prompt:
     net  use  y:    \\192.168.0.42\d    (d is my shared drive)
    error:system error 53 has occured,the network path not found.

    i think  the winpe could'nt find the networkshared or shared folder (such as d in the above command )

    then i try to issue the command so that the winpe command-prompt find the network_shared:
    net share d=D:

    error: the service name is invalid
    more help is available by typing NET HELPMSG 2185.

    i think the net share doesn't work in winpe .
    then issue the command in winpe:
    net use  u:   \\192.168.0.51\d   PaaSWWORD  (PaaSWWORD , is THE password of first computer)
    the error:system error 5 has  occurred.
    access is denied.

    i think my problem resolved by the net share command if this command  work correctly in winpe.

    but i am sure that it is impossible for me to use winpe,and networkshare....
    Tuesday, February 16, 2010 11:21 AM
  • I'm using WinPE and connecting to a network share on my laptop all the time, so let's try to solve it.

    Computer1     Computer2
    (LAPTOP)  <--   (PC) booted into WinPE
    "Server"          "Client"
    192.168.0.51   192.168.0.42

    Computer2 wants to connect to Computer1.

    1. On your LAPTOP computer.
    Create a folder D:\Images
    Move your .wim file to D:\Images
    Share folder D:\Images as "Images".
    This folder is now accessible from the network as
    \\LAPTOP\Images
    You did create user Bob as I asked before, didn't you?
    You did make Bob a member of Administrators on your LAPTOP as I asked before, didn't you?
    You did assign Bob's password a value Pa$$w0rd (or whatever), didn't you?

    2. Go to Computer2 (PC)
    Boot into WinPE
    a) Run command
    netsh int ip set address local static 192.168.0.42 255.255.255.0

    wait 1 minute

    b) Run command
    net use u: \\LAPTOP\Images
     
    You should be prompted for username and password
    Username: LAPTOP\Bob
    Password: Passw0rd (or whatever)

    Your wim image should now be accessible as U:\MyImage.wim

    You can apply this image to 'PC' using ImageX command, for example

    ImageX /apply U:\MyImage.wim 1 C:\

    Another advice (sorry if I'm nagging you)

    In my town where I live, we have tens of Wireless clubs. We basically share our wireless equipment, we hang on rooftops and teraces, we share Internet access and play games ("Call of Duty" is very popular). You can find many bright people in these clubs willing to share their knowledge about networking. It's a great hobby for technology enthusiasts.

    • Marked as answer by sam_mh_85 Wednesday, February 17, 2010 4:06 AM
    Tuesday, February 16, 2010 12:46 PM
  • I'm using WinPE and connecting to a network share on my laptop all the time, so let's try to solve it.

    Computer1     Computer2
    (LAPTOP)  <--   (PC) booted into WinPE
    "Server"          "Client"
    192.168.0.51   192.168.0.42

    Computer2 wants to connect to Computer1.

    1. On your LAPTOP computer.
    Create a folder D:\Images
    Move your .wim file to D:\Images
    Share folder D:\Images as "Images".
    This folder is now accessible from the network as
    \\LAPTOP\Images
    You did create user Bob as I asked before, didn't you?
    You did make Bob a member of Administrators on your LAPTOP as I asked before, didn't you?
    You did assign Bob's password a value Pa$$w0rd (or whatever), didn't you?

    2. Go to Computer2 (PC)
    Boot into WinPE
    a) Run command
    netsh int ip set address local static 192.168.0.42 255.255.255.0

    wait 1 minute

    b) Run command
    net use u: \\LAPTOP\Images
     
    You should be prompted for username and password
    Username: LAPTOP\Bob
    Password: Passw0rd (or whatever)

    Your wim image should now be accessible as U:\MyImage.wim

    You can apply this image to 'PC' using ImageX command, for example

    ImageX /apply U:\MyImage.wim 1 C:\

    Another advice (sorry if I'm nagging you)

    In my town where I live, we have tens of Wireless clubs. We basically share our wireless equipment, we hang on rooftops and teraces, we share Internet access and play games ("Call of Duty" is very popular). You can find many bright people in these clubs willing to share their knowledge about networking. It's a great hobby for technology enthusiasts.


    hi les,
    it worked correctly ,i am suprrised. i used the BOb account,and share folder on second computer not first computer so want to access the share folder via winpe on second computer,this is my fault.
    before my problem was resolved i am so depress but now i am sooo happy.
    all commands work correctly,it was extremely extremely kind of you to help me, you are vary helpful person,you are a professional  expert on any things especially on WINDOWS 7
    thanks soooo much
    thanks for every things,
    thanks again for your patience during all of this.
    sorry for my English during this.
    have a graet weekend,take care.
    • Marked as answer by sam_mh_85 Tuesday, February 16, 2010 5:57 PM
    • Unmarked as answer by sam_mh_85 Wednesday, February 17, 2010 4:06 AM
    Tuesday, February 16, 2010 5:57 PM