none
Mirror drivers don't support Aero effects

    Question

  • I cannot enable windows Aero in Windows 7 beta. It worked on friday, and now on Monday I cannot enable it. My windows experience index is 5.9. I have a remote desktop client running, LogMeIn Pro, but I do not believe that is the problem since I have been running that remote client since I started using Windows 7 and have never had an issue with it.  I tried the so called "registry hack" that enables Aero on PC's with a WEI of less than 3 but to no avail. Any ideas?

    Aero
    Publisher details
    Issues found
    Not fixed
    Not Fixed
    Close programs using mirror drivers
    Informational
    Potential issues that were checked
    Issue not present
     

    Issues found
    Detection details
    6
    Mirror drivers don't support Aero effects
    Not fixed
    Not Fixed
    A running program uses a mirror driver (a type of display driver) which is not compatible with the Aero desktop experience.
    Close programs using mirror drivers
    Informational
    To allow Aero effects to be displayed, close any programs that use mirror drivers (a type of display driver), such as Windows Remote Assistance and Windows Live Mesh.
    Potential issues that were checked
    Detection details
      Aero effects not supported on this Windows edition
    Issue not present
     
    Some Aero features such as transparency are not included on certain Windows editions.
    Detection details
    Expand
    Collection information
    Computer Name: HOLTEN-OFFICE
    Windows Version:
    6.1
    Architecture:
    amd64
    Time:
    Monday, September 28, 2009 11:01:51 AM
    Publisher details
    Expand
    Aero
    Display Aero effects such as transparency.
    Package Version:
    1.0
    Publisher:
    Microsoft Windows
    Aero
    Display Aero effects such as transparency.
    Package Version:
    1.0
    Publisher:
    Microsoft Corporation
    Monday, September 28, 2009 4:08 PM

Answers

  • I managed to fix the problem: in the end it was the remote desktop client. I guess the new version of the client uses a mirror driver. I eventually looked at my Display Adapers in Device Manager and saw that a Mirror Driver was listed. I just uninstalled it and rebooted. All problems are solved. Previous versions of the remote desktop client did not intsall this mirror driver.
    • Marked as answer by holt8137 Thursday, October 1, 2009 2:39 PM
    Thursday, October 1, 2009 2:39 PM

All replies

  • here's a list of running processes:

    Image Name                     PID Session Name        Session#    Mem Usage
    ========================= ======== ================ =========== ============
    System Idle Process              0 Services                   0         24 K
    System                           4 Services                   0     14,784 K
    smss.exe                       272 Services                   0      1,108 K
    csrss.exe                      368 Services                   0      4,252 K
    wininit.exe                    452 Services                   0      4,692 K
    csrss.exe                      472 Console                    1     28,124 K
    services.exe                   508 Services                   0     11,508 K
    lsass.exe                      524 Services                   0     11,780 K
    lsm.exe                        532 Services                   0      4,096 K
    winlogon.exe                   636 Console                    1      7,164 K
    svchost.exe                    696 Services                   0     11,708 K
    nvvsvc.exe                     760 Services                   0      3,864 K
    svchost.exe                    800 Services                   0     11,728 K
    svchost.exe                    892 Services                   0     18,712 K
    svchost.exe                    932 Services                   0    108,268 K
    svchost.exe                    980 Services                   0     41,416 K
    svchost.exe                    600 Services                   0     11,616 K
    nvvsvc.exe                    1080 Console                    1      8,060 K
    svchost.exe                   1172 Services                   0     30,652 K
    spoolsv.exe                   1320 Services                   0     17,624 K
    svchost.exe                   1348 Services                   0     16,196 K
    svchost.exe                   1448 Services                   0      9,016 K
    svchost.exe                   1580 Services                   0      3,828 K
    svchost.exe                   1632 Services                   0      3,536 K
    PSIService.exe                1656 Services                   0      4,040 K
    QBCFMonitorService.exe        1708 Services                   0     13,372 K
    svchost.exe                   1744 Services                   0      7,884 K
    nSvcAppFlt.exe                1796 Services                   0      7,300 K
    nSvcIp.exe                    1856 Services                   0      7,696 K
    taskhost.exe                  2600 Console                    1      9,316 K
    explorer.exe                  2716 Console                    1     77,324 K
    Core Temp.exe                 3000 Console                    1      6,712 K
    qbupdate.exe                  3044 Console                    1     16,524 K
    acrotray.exe                  2120 Console                    1      4,604 K
    jusched.exe                   2240 Console                    1      4,432 K
    svchost.exe                   2508 Services                   0      6,548 K
    SearchIndexer.exe             2056 Services                   0     33,520 K
    wmpnetwk.exe                  2188 Services                   0      3,608 K
    OUTLOOK.EXE                   2552 Console                    1     65,452 K
    svchost.exe                    864 Services                   0     24,808 K
    dwm.exe                       1328 Console                    1      5,644 K
    iexplore.exe                  1736 Console                    1     30,048 K
    iexplore.exe                  1500 Console                    1     67,916 K
    infocard.exe                  3092 Services                   0     22,136 K
    SSPro.exe                     2984 Console                    1     36,580 K
    audiodg.exe                   3632 Services                   0     15,544 K
    GPU-Z.0.3.4.exe                956 Console                    1     16,164 K
    iexplore.exe                  1476 Console                    1     77,816 K
    SearchProtocolHost.exe        1864 Console                    1      7,212 K
    SearchFilterHost.exe          4064 Services                   0      4,976 K
    cmd.exe                       3580 Console                    1      2,908 K
    conhost.exe                   1912 Console                    1      5,516 K
    WmiPrvSE.exe                  1908 Services                   0      6,652 K
    tasklist.exe                  3616 Console                    1      5,452 K
    Monday, September 28, 2009 4:25 PM
  • I suggest that you roll back the video adapter driver.

    How to Roll Back a Device Driver

    If the issue persists, please open Control Panel\Program and Features, remove the video driver from there. Then run Windows Update to reinstall the driver.


    Arthur Xie - MSFT
    Wednesday, September 30, 2009 10:05 AM
    Moderator
  • I managed to fix the problem: in the end it was the remote desktop client. I guess the new version of the client uses a mirror driver. I eventually looked at my Display Adapers in Device Manager and saw that a Mirror Driver was listed. I just uninstalled it and rebooted. All problems are solved. Previous versions of the remote desktop client did not intsall this mirror driver.
    • Marked as answer by holt8137 Thursday, October 1, 2009 2:39 PM
    Thursday, October 1, 2009 2:39 PM
  • I just ran into this issue and the LogMeIn Mirror Driver for LogMeIn v4.0.0.982 will definitely kill Aero on Vista SP2 w/ an nVidia Quadro FX 570...

    Going into Device Manager and disabling the "LogMeIn Mirror Driver" under "Display adapters" and a reboot brings Aero right back.

    Hope this saves some peeps a little time.
    • Proposed as answer by booragal Thursday, September 8, 2011 1:01 AM
    Tuesday, December 1, 2009 4:05 PM
  • awesome!!! ive spent hours reading for solutions and trying pretty much all i found and nothing worked until you said to check the device manager and display display adapters, i uninstalled a program that i didnt even know i had installed, rebooted and done! thanks!! (Windows 7 64-bit) START -RIGHT CLICK ON MY COPMPUTER -MANAGE -DEVICE MANAGER -DISPLAY ADAPTERS -MIRROR SOFTWARE I HAD INSTALLED <---- THAT'S WHAT I UNINSTALLED (RIGHT CLICK, UNINSTALL, REBOOT, ALL DONE!) -MOBILE INTEL(R) 4 SERIES EXPRESS CHIPSET FAMILY
    • Proposed as answer by Lil Hasnah Tuesday, March 5, 2013 3:20 AM
    • Unproposed as answer by Lil Hasnah Tuesday, March 5, 2013 3:20 AM
    • Proposed as answer by Lil Hasnah Tuesday, March 5, 2013 3:20 AM
    • Unproposed as answer by Lil Hasnah Tuesday, March 5, 2013 3:21 AM
    Saturday, December 19, 2009 5:55 AM
  • I went to device managermdisplay adapters and there was no mirror driver just some Mirage Driver and my graphich card,my aero theme crashed when i runed some pgoram utipu(screen recording program)i presed record and aero theme dissapered,i thought it will come back as soon as i stop recording,well i stoped it nothing thme frezzed i uninstall utipu nothing,those troubleshooting problems say Mirror Deivers cant aupport Aero effect or someting like that,and i cant find a solution,can someone please inform me if he knows bcs my theme now sucks and i cant put any theme... :(
    Friday, April 2, 2010 8:00 AM
  • the same thing happened to me. I installed utipu (tipcam) screen recording software and when i ran the program the aero theme dissapered and i got a message saying that "the windows color scheme has changed to basic". i tried restoring the system but it was of no use.  the device manager display adapters show only my ati graphic card and something called mirage driver. there is no mirror driver listed there. tried force enabling windows aero using some registry tweak but that too dint work... any help would be greatly appreciated.... ty.
    Wednesday, April 28, 2010 4:40 PM
  • I went to device managermdisplay adapters and there was no mirror driver just some Mirage Driver and my graphich card,my aero theme crashed when i runed some pgoram utipu(screen recording program)i presed record and aero theme dissapered,i thought it will come back as soon as i stop recording,well i stoped it nothing thme frezzed i uninstall utipu nothing,those troubleshooting problems say Mirror Deivers cant aupport Aero effect or someting like that,and i cant find a solution,can someone please inform me if he knows bcs my theme now sucks and i cant put any theme... :(

    I just found a solution to the problem.... Do exactly the same as u did earlier i.e. go to control panel then to device manager and then to display adapters. under display adapters you said your graphic card and Mirage driver are listed. Right click on Mirage driver and uninstall it.  reboot the system and there you go... the windows 7 aero effect will be back. hope this has helped..

    ::earlier posts say that we need to uninstall mirror drivers. for me there were no mirror drivers listed under display adapters.  but some how uninstalling mirage drivers worked. probably both of them must be same or similar.

    Wednesday, April 28, 2010 10:48 PM
  • Oh my God, I was dying with that TipCam of this utipu company and I need it back... I love Microsoft! Thanks!
    Thursday, June 3, 2010 11:45 AM
  • Hum... Who knows how I change this wallpaper?

     

    Thursday, June 3, 2010 11:50 AM
  • Do I need to check the box so I can have Aero back?

     

    Thursday, June 3, 2010 11:54 AM
  • Thx!

    Done

     

    Aero back!

    Friday, July 2, 2010 9:42 PM
  • It was helpful...i got my aero back....mirror drive is same as mirage drive...just uninstall and reboot

    now your aero will be back..

    Sunday, July 4, 2010 5:06 AM
  • Thank you very much. It worked for me too!
    Saturday, January 15, 2011 10:09 PM
  • Hi,

    If you use LogmeIn, Here's another popular fix for "Mirror drivers don't support Aero effects" from imakalic at

    http://community.logmeinrescue.com/t5/Free/Aero-is-deactivated-after-installing-logmein/td-p/26193/page/2

    "The simplest solution is to open logmein and remotely control your own computer. Let it load, then simply click the disconnect button. Everything will be restored."

    Instant joy for LogMeIn. The LogMeIn mirror driver remains installed (as you can see in Device Manager | Display Drivers) and nothing gets broke either.

    Regards,

    Brcobrem



    • Proposed as answer by Brcobrem Friday, March 25, 2011 2:21 AM
    Friday, March 25, 2011 2:20 AM
  • After I used Remote Tools from the SCCM Configuration Manager Console (running on a Windows XP machine) to take over a Windows 7 machine, Aero effects seemed to be disabled after I closed the session. Windows 7 reported "Mirror drivers don't support Aero effects" and I was unable to use Aero effects on the machine. I solved the issue by going to Device Manager -> Display adapters -> select the display adapter in use (in my case it was an Intel on board display adapter) -> right click and 'Disable". After the device was disabled I enabled it again (right click and "Enable"). Immediately after Aero effects started working again, no reboot required.
    Tuesday, May 17, 2011 8:31 AM
  • If the disabling the display driver did not work(Incase of dameware Development Mirror Driver) follow the steps to uninstall:

    1. Click on start button, type devmgmt.msc and press enter.
    2. Now in the device manager expand Display adapters, under this you should be able to see Mirror Driver (DameWare Development Mirror Driver).
    3. Right-click on it and select properties.
    4. In the properties window, under Driver tab, click on Uninstall button.
    5. After the uninstalling the drivers restart the computer (or it might restart automatically). The system will pickup and will install proper drivers for it. Once the system is back the Aero effects will be there.

    Mirror Drivers are mostly used by vpn (Virtual private network)/remote desktop tools/Windows Live Mesh. Removing this driver may resolve such issues.

    Regards,

    ~Kishore Kumar.


    Monday, June 4, 2012 2:34 PM
  • awesome!!! ive spent hours reading for solutions and trying pretty much all i found and nothing worked until you said to check the device manager and display display adapters, i uninstalled a program that i didnt even know i had installed, rebooted and done! thanks!! (Windows 7 64-bit) START -RIGHT CLICK ON MY COPMPUTER -MANAGE -DEVICE MANAGER -DISPLAY ADAPTERS -MIRROR SOFTWARE I HAD INSTALLED <---- THAT'S WHAT I UNINSTALLED (RIGHT CLICK, UNINSTALL, REBOOT, ALL DONE!) -MOBILE INTEL(R) 4 SERIES EXPRESS CHIPSET FAMILY
    yesss, it work! thank you very much :)
    Tuesday, March 5, 2013 3:20 AM
  • Dude, thanks a lot I had the same problem and your advice was just perfect!!!

    It worked.

    Thanks man!!!

    Tuesday, July 16, 2013 4:54 AM
  • I had this too. The mirror driver which was affecting it was the "Bomgar Display Driver" for me (a part of the Bomgar Representative console). All I did was disable this, rebooted Windows - which is a necessary part of disabling it and re-enabled it.

    No need to uninstall it and risk breaking any installed dependent software.

    Thursday, May 29, 2014 10:21 AM