none
Windows 7 Freezes when Resumed from Idle due to Screen Blanking

    General discussion

  • I have observed this behavior on several builds using X64 versions of Ultimate and Home Premium; have not observed with X32 versions or with Professional, although I have little experience with these versions.

    The symptoms are that the system is left at idle for a period of minutes to hours, during which the screen(s) are turned off by the power management software.  There appears to be the need for a process to be operating in the background, such as a disk defragmenter, antivirus scanner, whatever, be it a MS service or a third party application.  If a service is active in the background when the user returns to the computer, after the monitor(s) have been blanked, moving the mouse appears to "turn the system back on," with the monitor(s) coming back on and the mouse being (initially) responsive, e.g. you can move the mouse cursor around the screen(s).  After anywhere from a few seconds to perhaps as much as 20 seconds, the mouse becomes frozen and won't move anymore.  At no time from when the system was "woken up" by the mouse, can you do anything with the mouse or keyboard, e.g. any attempts to click on an icon on the desktop, to start an application, even during the short period when the mouse will move, has no effect.

    After 10-20 seconds, when the system freezes, nothing the user can do will have any impact other than a hard reboot of the system.  If the user is willing to wait, the system will ultimate become responsive once again after varying periods, from as little as 5 seconds to (much more typically) several minutes up to half an hour later.  Once the system revives itself, it will function normally.  Reviewing system logs will reveal exactly ZERO, other than if one did a hard reboot one will see the signs of that, or, one can find that some service or application was working in the background at about the time when the user tried to resume using the system from idle.

    The bug clearly seems related to screen blanking ("turn off display" in power options), not to hibernation or "sleeping."  In wading through many hundreds of posts I found through web searching, one person stated that the only fix he had found was to turn off screen blanking and to turn his monitors off with the power buttons, manually, and that this had solved the problem for him.  I'm currently testing this out myself.  I believe that his observation is correct; the triggering factor is screen blanking when the machine has been left at idle, something related to the code used to implement that function, probably combined with any of a large number of possible applications or services working in the background at a time when the screen(s) have already been blanked and when the user then comes back to "revive" the machine.
    • Changed type champignon Wednesday, January 27, 2010 7:31 AM Clearly a Bug
    Wednesday, January 27, 2010 7:29 AM

All replies

  • There is a new Windows Critical update out: http://support.microsoft.com/?kbid=977074

    Specifically it fixes the issue of:
    • On a computer that is running Windows 7, you configure the Screen Saver Settings to display the logon screen on resume. Additionally, you configure the computer to go to sleep. However, the computer may not go to sleep after the screen saver starts. Instead, a black screen is displayed. This problem causes the operating system to stop responding. You must restart the computer by holding down the power button.
    • Edited by passionfly1 Wednesday, January 27, 2010 9:02 PM
    Wednesday, January 27, 2010 8:18 AM
  • Hi,

    This update has already been installed on my system.  I can't tell from the linked page when this update was released, although the current build I have on my machine was put back on the disk (from an old image from December) yesterday so the update shows as having been installed yesterday, when I did a "Windows Update" right after putting the image back on the system disk.  I was having the issue up until yesterday, shortly before I made my post, when I disabled the ability of Windows 7 to turn off the monitors on the system.

    The description of the problem on the linked page does not match what I am observing; for one thing, I have the screen saver disabled, and I never got or get a black screen.  Rather, my normal desktop (on both monitors) becomes "frozen" e.g. unresponsive, for varying periods of time, and ultimately resolves itself if left to sit.

    I have only observed this behavior on one system, but have observed it with 3 different "builds" I've done with this machine, with X64 Home Premium on one "build," and with two different builds of Ultimate X64.  I have initially left the power settings at default, as installed by the Win 7 install disk, although have also played around with them once the problem presented itself to try to see if any changes in these settings would resolve it.  The problem does not seem to occur, or at least is not anywhere as common or annoying (due to length of "freezing period") when the only software installed has been Office and Win 7 itself.  Once I start to install additional programs such as Antivirus (AVG Free most of the times) or a disk defragmenter (Perfect Disk 10), the problems begin and become progressively worse.  The common thread is that these are applications that work in the background when the system is at "idle."  Sometimes the system freezes up altogether, with a stuck cursor, and occasionally one ends up with the round "cursor in a circle," equally unresponsive however the cursor will continue to be able to be moved around the screen when "round" as opposed to being totally frozen in place when it is not "round."  Most of the times I've had simply a frozen cursor, not the round version.  I have tried disabling various services through task manager, and this does seem to work, but then of course it results in a crippled system.  The MS native service I've seen that can also "cause" this behavior is the disk defragmenter service, another "background service."

    The common observation is that this only happens after the system has blanked the screens after being at "idle" for at least 10 minutes, which is the time at which the default install power options blank the screens.  Resuming from idle with the screens blanked, the screens come back on but the system is unresponsive other than for a few seconds of possible movement of the mouse cursor, and nothing else.  The period of unresponsiveness varies from several seconds to many minutes.  No errors are noted in the various windows or other "event" logs, although one generally can see that some application or service was active in the background just before the mouse was moved to "reawaken" the system.

    Details of this system are that it is a Lenovo ThinkCentre K230 desktop with an Intel Q8200 quad core processor, 8 gb of DDR2 RAM in 2 banks with 2 matched sticks (different types in each of the 2 banks however the same in each bank, all 6400 downclocked by the bios to the next speed down (would have to go into the Bios to look at this again, I forget for the moment what that is).  Memtest 86+ has been run on this setup through about 8 passes with no errors whatsoever.  Have tried moving the RAM around with no changes.  Had the same problem when the system had 6gb as suppled by the Mfr., and now with 8gb.  Swapped out one of the 3 original sticks so that I'd have 2 matched banks of 2 identical sticks each.  Slow video card, EGA dual headed 1gb Nvidia 9400.  No problems whatever in device manager on any of the hardware in this system.  And, as I've indicated before, I don't get blue screens and exhaustive review of system logs reveals nothing (including looking at services for ALL users).

    In reading through a gazillion posts on many web searches addressing system "Freezes" with Windows 7, it is obvious that most of what is being described as system freezes is not what I am/have been experiencing with this sytem.  I did however find several other posts in various threads from people who seemed to be having exactly the same problem I'm reporting here.  The only suggestion I have read that has worked, at least so far, was to turn off the ability of the system to blank the screens after a preset period of system idling.  By turning this function off in the power manager service, and turning off the screens myself, manually, when I leave the system for a period of time, the problem seems not to occur.
    Wednesday, January 27, 2010 4:18 PM
  • this caught my eye "different types in each of the 2 banks however the same in each bank". Do you have this problem if u ran the computer with only 1 stick inserted and the other one out for troubleshooting purposes. I understand this is not how you want to run it but does this error happen with only 1 stick?

    If the memory sticks are of different brands or same brand but different timings, they will work ideally with, some motherboards may be very very picky which timing is optimal for the pair and cause harrowing havoc on your system.

    Let us know...
    Wednesday, January 27, 2010 9:07 PM
  • this caught my eye "different types in each of the 2 banks however the same in each bank". Do you have this problem if u ran the computer with only 1 stick inserted and the other one out for troubleshooting purposes. I understand this is not how you want to run it but does this error happen with only 1 stick?

    If the memory sticks are of different brands or same brand but different timings, they will work ideally with, some motherboards may be very very picky which timing is optimal for the pair and cause harrowing havoc on your system.

    Let us know...

    Hi,

    Thanks for your response.  As I said before, I had this same problem with 3 identical sticks (2gb each; as sold by the mfr as the system was sold with 6gb of RAM from the factory) occupying 3 of the 4 slots.  When I added the additional (4th) stick, I elected to remove one of the 3 so as to have a bank of 2 sticks vacant, which I then replaced with 2 new, identical sticks.

    I have also moved the sticks around so that the pair that was in a bank of two is now in the other bank of two.  I have run Memtest86+ multiple passes on the original 6gb, and each of the 2 sets of 2 in place by themselves, as well as all 4 sticks in place in the two alternate banks, each.  There has never been a single error reported by the current version of Memtest86+

    The RAM is being run, under control of the bios (stock limitation of the Lenovo bios, not something I can set myself) at 633mHz rather than the 800mHz at which it is rated.  For some reason this mobo with this bios will only run 3 sticks of 2gb each (total 6gb) at the faster speed, and defaults backwards when 8gb are in place.

    I've had a fair amount of experience with bad RAM over the years, and it is generally fairly obvious.  The problem I am reporting is extremely specific, one type of fault, with no errors reported in the Windows Event Logs, with never a BSOD.  Given how much I have already moved stuff around on the Mobo, including the memory, I am extremely reluctant to remove RAM sticks yet again for testing that to me appears to have about a 0.00000001% chance of showing anything, given that every time you muck around with physical components there is a small but finite risk of damaging something through ESD or other causes.

    To use your term, nothing is causing "havoc" on my system; it just freezes when coming out of an idle state when the system has blanked the screens.  The problem has not recurred after I turned off screen blanking in power options as suggested by another user with an identical problem on a different system.  This is way way way way way too specific and repeatable of a problem to be due to the RAM, and suggests some sort of software incompatibility either among different pieces of code or possibly between the OS code controlling power usage and some specific sets of hardware components.

    • Edited by champignon Wednesday, January 27, 2010 9:27 PM typos
    Wednesday, January 27, 2010 9:20 PM
  • This isn't a memory issue per se its my hunt to find a commonality in terms of hardware devices that can be attributed to all ppl having this same sort of issue. This is definitely a Windows 7 OS issue NOT memory.

    Join our crusade for an answer here instead. Its a more livelier discussion:

    Windows 7 crash and reboot automatically kernel-power error

    Thursday, January 28, 2010 10:56 AM
  • This isn't a memory issue per se its my hunt to find a commonality in terms of hardware devices that can be attributed to all ppl having this same sort of issue. This is definitely a Windows 7 OS issue NOT memory.

    Join our crusade for an answer here instead. Its a more livelier discussion:

    Windows 7 crash and reboot automatically kernel-power error


    I'll have a look in on the other thread that you referenced. I did skim it before I made my own post, however it doesn't seem to be referencing the same set of "symptoms" that I have observed, even if the cause in the code may be the same.  I have a natural tendency to continually open up computer cases and to move stuff around and to change components.  This behavior has done a lot of damage to my systems over the years, and I am trying to avoid opening up the case when there is no real likelihood of benefit.  So, I'm sorry to not have participated in the search for a common cause, but at least I still have a working system:-)

    On the plus side, I have not had a single freeze from Idle since I changed the power settings to never turn off the monitors.  The monitors are still, however, getting blanked when the desktop puts itself to "sleep" after 30 minutes (even though I have turned them off physically beforehand).  When the machine reawakens due to a mouse movement, I am now getting prompted to put in my password, something that often did not happen even though the system was set up to do that.  This leads me to believe that the patch from yesterday, #977074, has solved both problems, the freezing problem I was having and also problems with not asking for the PW on reawakening.  It could well be that changing my power options to never blank the screen has done nothing at all and simply been a coincidence with release of this patch.
    Thursday, January 28, 2010 3:25 PM
  • I spoke too soon.  The patch #977074  has not corrected this bug.   I changed the power management settings to again allow the monitors to be turned off, and the freezing has resumed.  And as before, the freezing ultimate stops without user intervention if one is patient enough (the most recent episode lasted for more than 20 minutes, after which I went out for lunch and returned to a system that was once again working).

    I'm not at all sure that the bug I am reporting here is related to other "freezing" issues with this OS (64 bit Windows 7).  The symptoms are certainly different.
    Friday, January 29, 2010 7:23 PM
  • I am writing simply to say that I am running W7 x64 w/two monitors and you (Champignon) have described the issue verbatim.  Patch 977074 was installed on 1/26 to no effect.  I have nothing to add because you've described the issue perfectly.  I'll be following this thread for a resolution.
    Friday, February 05, 2010 3:40 PM
  • I spoke too soon.  The patch #977074  has not corrected this bug.   I changed the power management settings to again allow the monitors to be turned off, and the freezing has resumed.  And as before, the freezing ultimate stops without user intervention if one is patient enough (the most recent episode lasted for more than 20 minutes, after which I went out for lunch and returned to a system that was once again working).

    I'm not at all sure that the bug I am reporting here is related to other "freezing" issues with this OS (64 bit Windows 7).  The symptoms are certainly different.

    Yeah I am starting to think your issue is different form the Kernal-Power issue/bug. I would narrow your cause down to it being purely OS or your memory chips and how they relate to the OS. These are the 2 possible causes I can see. One of em may be the correct avenue. I can only help you extensively in the hardware side of thing as this is my forte. OS issues I can give clues to but Microsoft, knowing its own code, has to do the brunt of that technical work.

    Its also not so much that you have bad ram. Far from it. How the timings are set and then represented by the OS can be quite staggeringly different. If the timings of your memory chips are off in their actuality under load then from what they are set to (in the BIOS) this could cause sluggishness and lockups and reboots. Its not whether Memtest86+ fails at the tests that's important but to see what memory timings its showing they are running at while performing these tests that's important. If your timings are set in the BIOS and Memtest shows them testing identically then you are good. If not, time to call your Mobo maker/Laptop manufacturer and ask them why the timings are changing or off when under load. A BIOS patch should correct this sort of discrepancy.

    Setting timings of 5-5-5-15 2T in the BIOS for instance and having Memtest running the tests at 5-5-5-18 2T would be an example of a timing discrepancy. This could cause huge consequences if the actual memory starts running at speeds over 800mhz. The faster the memory runs the more catastrophic the system error will be. Running into a wall at 2mph won't be as fatal as say 70mph, for example.

    But again I ask, have you had this problem with only ONE memory stick inside your computer for troubleshooting purposes? I did not see this in your last post. You just mentioned you ran 2 out of 3 of the chips not specifically 1 out of 3 only .
    Friday, February 05, 2010 4:21 PM
  • I think I might have the same issues... I do use multiple users, and it seems to happen only if one users was logged in. Either black screen, or login screen, but turning black and staying black as you try to login. I had this behavior before and after applying patch 977074. I replaced all my RAM with different RAM, all of it from DELL, and ran plenty of tests, so I am pretty confident in my RAM (but could have timing issues Dell is not aware of)

    Two days ago I uninstalled Norton Internet Security and Genie Backup Manager, which made my machine stable, potentially because there are fewer backup jobs running now. No freezes since then. But it's been only 2 days, and I want both backup and virus protection running.

    I'll look at my power settings. Maybe if I no longer let windows turn off monitors, that will help.


    Saturday, February 06, 2010 10:05 PM
  • I don't know for sure if multiple monitors are necessary to have this problem, however my effected system has 2 monitors.  I can say that after turning off screen blanking in the power settings that the problem has disappeared.  Even though Win 7 x64 has been instructed not to turn off the monitors, they still get turned off, perhaps because the sleep function has not been disabled.  After the system has been left on a while, typically a day or two or 3, the system will cease blanking the monitors even though it was not "told" to blank them in the first place.  If the monitors do get turned off, then a password prompt appears when I resume using the system.  After the system has been booted up for a while (a day or 2 or 3) and it has ceased screen blanking or asking for a password on being resumed, it still does not have the freezing problem I reported earlier.

    I am not the first person to document this behavior.  As I reported in my first post, I found a couple of posts on other forums documenting this behavior which they described as "freezing" in the same situations as I have described it.

    To Passionfly1, I am not insensitive to your request but I am very uninterested in reopening my computer case for the umpteemth time to remove Ram to follow up on your theory.  For one thing, I am using this system in various ways and distractions like that I don't need.  For another, it would take some time to document whether or not the problems had resumed and if they did it would be a bit PITA for me to deal with in a system that is now working, albeit with the screen blanking function turned off in the power settings   I agree that this is a bug, as I said in my initial posts.  This is not the first MS bug I have had to deal with in my life, and I'd rather have them inconvenienced by this than me!
    Sunday, February 07, 2010 6:48 AM
  • I have the same problem with Win7 x64 Ultimate with only a single monitor; sleep/hibernation is off, but the monitor is set to turn off after idling for awhile. I really doubt that it's a memory issue since this is the only instability/freezing issue that I have at all in Windows 7, and my memory timings are consistent (though I haven't memtested the sticks yet). For now, I'm just leaving on the monitor continuously and setting the screensaver to blank.
    Monday, February 08, 2010 8:22 PM
  • Hi,

    I too am having the exact same symptoms as this. I have a HTPC with an AMD Athlon II 250, Gigabyte MB and 4GB of DDRII 1066 Ram. The only problem I seem to have with my setup is this freezing issue once I move my mouse to bring my screen back after it's been blanked.

    I'd love to know the solution but for now I guess I'll use the work around of disabling screen blanking, just use the screen saver, screen blanking is of no use to me on this particular PC as my LCD TV doesn't turn off, just sits there with "No Signal" flashing across the screen.
    Monday, February 08, 2010 9:22 PM
  • After 10+ days, I've had zero system "freezes" by turning off the monitor blanking function in the power settings.  As I noted earlier, the system still blanks the screens, at least for a couple or 3 days after having been rebooted, in most instances, apparently when the system is due to go into "sleep" mode due to inactivity, and a password prompt screen comes up when I resume the system.  Occasionally the screens are not blanked, but usually they are.

    I can't explain this behavior but it is really obvious that it is a bug, that may be hardware dependent, and something that MS has yet to address with any patches.  Perhaps it only effects a small percentage of Win 7 x64 users, and as I indicated, is hardware dependent.

    I can live with this current fix, but it would be better if MS would fix it once and for all.
    Tuesday, February 09, 2010 4:36 AM
  • After 10+ days, I've had zero system "freezes" by turning off the monitor blanking function in the power settings.  As I noted earlier, the system still blanks the screens, at least for a couple or 3 days after having been rebooted, in most instances, apparently when the system is due to go into "sleep" mode due to inactivity, and a password prompt screen comes up when I resume the system.  Occasionally the screens are not blanked, but usually they are.

    I can't explain this behavior but it is really obvious that it is a bug, that may be hardware dependent, and something that MS has yet to address with any patches.  Perhaps it only effects a small percentage of Win 7 x64 users, and as I indicated, is hardware dependent.

    I can live with this current fix, but it would be better if MS would fix it once and for all.

    Please describe with specificity what you mean by "turning off the monitor blanking function in the power settings". What steps did you do to get this done? I do not see this setting there.
    Tuesday, February 09, 2010 8:46 AM

  • Please describe with specificity what you mean by "turning off the monitor blanking function in the power settings". What steps did you do to get this done? I do not see this setting there.
    It's simple.

    Go to control panel, select "power options," choose the power plan which is selected, by default it is "balanced," on the top.  Click on "change plan settings."  There are two things that will appear under the basic options, which are the interval to have the computer go to "sleep," which is irrelevant, and the other is when to turn off the monitor.  Select "NEVER" for when to turn off the monitor, then save your settings and exit out of the dialogs and control panel.

    That's it.
    Tuesday, February 09, 2010 3:23 PM
  • Hi champignon et al,

    I've had exactly the same problem on my HP notebook (AMD, ATI graphic card, 3GB RAM, no external display) since installing W7 x64 Ultimate. I didn't notice such behavior under Vista x64 I had run earlier. I tried several things, different VGA drivers and settings, disabling bluetooth - first I was suspecting BT mouse to cause the problem since I usually "wake up" display by moving a mouse... nothing helped.

    The only "solution" is what you already use, disabling system to power off display.

    I will be monitoring this thread in case sbd finds a solution. However I agree that this smells like Windows bug and should probably be addressed by MS.

    btw. what kind of graphic card are you using? I know ATI has some special power management features that I haven't investigated yet. It's a long shot but it may help if we find common denominator to all reported cases.
    Tuesday, February 09, 2010 3:51 PM
  • Hi champignon et al,

    I've had exactly the same problem on my HP notebook (AMD, ATI graphic card, 3GB RAM, no external display) since installing W7 x64 Ultimate. I didn't notice such behavior under Vista x64 I had run earlier. I tried several things, different VGA drivers and settings, disabling bluetooth - first I was suspecting BT mouse to cause the problem since I usually "wake up" display by moving a mouse... nothing helped.

    The only "solution" is what you already use, disabling system to power off display.

    I will be monitoring this thread in case sbd finds a solution. However I agree that this smells like Windows bug and should probably be addressed by MS.

    btw. what kind of graphic card are you using? I know ATI has some special power management features that I haven't investigated yet. It's a long shot but it may help if we find common denominator to all reported cases.
    I have  an EVGA (?) Geforce 9400 dual headed DVI PCI-E x16 card.  This is a fairly slow, low power draw video card that is not used in high performance systems.  In any event this is an NVidia card, not an ATI chipset card.
    Tuesday, February 09, 2010 10:50 PM
  • I have video "wake-up" problems on two Win7 32-bit systems.  In my case, I find that on resume, the display never wakes up, but the system does.  I can access file shares on it through the network even while the display is "dead".  I have not tried using an RDP client to get a remote screen, but I suspect that would work even with the console not working. This is definitely not a screen saver issue, and the computer is definitely not in full sleep or hibernation mode.

    On my systems, no mouse or common keyboard action will wake up the video, but typing a single CTRL-ALT-DEL will bring the video back to life.  Apparently the keyboard controller portion of the chipset will generate an appropriate interrupt when it gets a request for such a 3-finger salute.  After the screen wakes up I hit ESC to back out of the shutdown/logoff prompt.

    In my case my motherboards both have embedded on-board graphics (AMD 790GX chipset with ATI HD 3300 embedded graphics).  They share RAM with the CPU, and they also have a small amount of "side-port" RAM dedicated to video buffering.  I'm wondering if it's the RAM that is not waking up.

    As others have noted, I have set my power settings to a very long display shutdown timeout, then when it happens I use CTRL-ALT-DEL to wake it back up.
    Friday, February 12, 2010 12:00 AM
  • Try locking your computer before you leave.
    Sunday, February 14, 2010 8:46 AM
  • same problem and i tried everything and this seems to work for me so far...2 weeks.
    set screen saver to "blank" at "x" amount of minutes.  then set power down monitor 5 minutes after you have set the "blank" screensaver. for example mine is set for blank screensaver 5 minutes...power down monitor 10 minutes and powerdown system at 3 hours. i'm probably wrong but it seems to be a process that powers down the monitor.
    Monday, February 15, 2010 2:51 PM
  • I have the exact same problem as the OP. After I leave my laptop, brand new HP DM3-1130us, long enough so that the screen saver and turn off monitor power options kick off. My systems appears to come back to life. But just seconds after I move my mouse either touchpad or external mouse, it will freeze. Eventually the OS will become responsive. It could take a few minutes to 30 minutes to come back to normal. What is weird though, it seems the longer the computer is inactive, the longer I have to wait for it to become responsive. I checked event viewer and I don't see anything out of the ordinary. I saw in another forum someone mentioned to set the minimum processor state in power options to 100%. They also said what the OP suspected, something with the background tasks running. I am going to try disabling the screen saver and let the monitor shut off. I will let you know how that works out. If anyone else comes up with something please post.
    Tuesday, February 16, 2010 6:20 AM
  • Disabling the screen saver did not fix the problem. I just changed my power settings to disable monitor shut off. It sucks though because I am on a laptop so the screen saver is just going to run the whole time if I can't remember to shut the lid. I will let everyone know if that fixes my issue.
    Tuesday, February 16, 2010 3:48 PM
  • After more internet searching I found that this is quite a popular problem. The problem may stem from the auto hide feature of the task bar. I had it set to auto hide. After disabling the auto hide feature it hasn't froze after idle. I will continue to monitor the problem. So for those out there with this problem, try disabling auto hide if you have it enabled.
    Tuesday, February 16, 2010 5:16 PM
  • I have seemed to find a workaround. If I disable the autohide feature it does not lockup, freeze or become unresponsive. I opened a case with MS to hopefully find an actual fix for the problem.
    Tuesday, February 16, 2010 10:55 PM
  • I have seemed to find a workaround. If I disable the autohide feature it does not lockup, freeze or become unresponsive. I opened a case with MS to hopefully find an actual fix for the problem.
    Thanks for reporting on this and for contacting MS about it.  I really like the autohide feature and would prefer to leave my system as is, without automatic screen blanking rather than lose autohide.

    I should say, however, that I have never found the screen blanking function to be reliable in any recent version of Windows (XP, Vista, or 7).  Quite often when I expected it to work, I would come back to my computer hours later and find the monitors still on.  So, it has become a habit of mine to turn my monitors off manually anyway, most of the time.
    Thursday, February 18, 2010 6:20 PM
  • I'm getting the same issue. I do NOT have auto-hide enabled. However, Dell's diagnostic (desktop) lights 3 & 4 I believe are lit each time this happens and their manuals state some sort of memory issue. However the system works fine throughout the day - it's *only* when I leave it overnight. Any idea?
    Thursday, February 18, 2010 10:01 PM
  • I have a second system that has now exhibited this problem.  It is a micro ATX system with a dual core Intel Atom 330 processor in it, being used as a media center box.  The only software installed on it (other than a few small utilities) is Windows 7 Home Premium X64.  There is a PCI-E x16 video slot on the board, and an integrated Nvidia Ion video with HDMI, DVI, and VGA ports.  There were no issues using the onboard video.

    I put a Radeon card (I think it is a 3650 chipset but I'd need to look at it to verify this) into the vacant video card slot.  After doing so I have had some instability issues with the system and ultimately removed the card, reverting to using the onboard video.  I did check the Bios to be sure it was set to use the discrete video card and there was nothing else I could change at a bios level that would have made any difference.

    When the Radeon card was in the system, I had the freezing issue, as described in my initial post.  I have since removed the card, as above, and so far, the freezing issue hasn't returned.

    I don't think this problem has anything to do, per se, with ATI Radeon video chipsets.  In fact, my main system is using a discrete Nvidia card.  But both systems have integrated video which (at least when exhibiting this behavior) was over ridden by a separate discrete PCI-E video card.

    Most likely this is only one of a number of hardware or software configurations that can lead to this problem, but the similarity vis a vis the video in the two effected systems caused me to post this update.

    My main desktop has no problems at all as long as I leave the screen blanking turned off in the power settings, as above.
    Friday, February 26, 2010 3:56 PM
  • Good news!  In my case the problem went away on two of my systems.  Your "wake up" problem may be different than mine.  For me, both motherboards are ASUS M4A78T-E's using AMD Phenom II 965BE's with AMD 790GX chipsets.  The 790GX has embedded ATI HD 3300 video.  I just updated the ATI drivers from Catalyst 10.1 to 10.2.  I also installed the optional Catalyst 10.2 Southbridge Driver and Catalyst 10.2 AHCI Driver.  One of those did the trick.  I have now gone throught several sleep/wakeup cycles on both systems and the wakeup has been fast and flawless.

    The ATI Catalyst 10.2 docs make this comment:

    Resolved Issues for the Windows 7 Operating System

    This section provides information on resolved issues

    - Resuming video playback after sleep/hibernation no longer causes black checkered video corruption or the system to stop responding

    - Display will now enter power save mode properly

    Saturday, February 27, 2010 8:06 PM
  • Good news!  In my case the problem went away on two of my systems.  Your "wake up" problem may be different than mine.  For me, both motherboards are ASUS M4A78T-E's using AMD Phenom II 965BE's with AMD 790GX chipsets.  The 790GX has embedded ATI HD 3300 video.  I just updated the ATI drivers from Catalyst 10.1 to 10.2.  I also installed the optional Catalyst 10.2 Southbridge Driver and Catalyst 10.2 AHCI Driver.  One of those did the trick.  I have now gone throught several sleep/wakeup cycles on both systems and the wakeup has been fast and flawless.

    The ATI Catalyst 10.2 docs make this comment:

    Resolved Issues for the Windows 7 Operating System

    This section provides information on resolved issues

    - Resuming video playback after sleep/hibernation no longer causes black checkered video corruption or the system to stop responding

    - Display will now enter power save mode properly

    This would imply this Chipset or Display driver issue, Either way this sound like the problem I have had on 2 systems now, All tho I never tried disabling  turn off monitor feature which I have now done to see if it stops  this problem, Cause I been told it my RAM or HD and same Ram and HD work fine in XP for years and even the NEW PC with NEW RAM but same HD does this and when I original test WIN7 RC build I did it on  different HD and only thing in common with this problem is

    64bit OS

    1. Monitor turning off  feature  used
    2. AutoHide Taskbar used

    If Disabling either of these 2 fixs this problem then this serously flaw that MS failed to fix cause it been around since the RC build they made public,   on side note this feature worked fine for me in XP for years, IF this the case and that the cause, where would i go to open an case or  report this bug to MS cause like said I first noticed this in the RC build of Win 7
    Monday, March 01, 2010 5:26 PM
  • Now I'm seeing this issue on two different computers.  I've had Win7x64 installed on my Mac Pro for about 4 months now, and this issue just appeared last week.  At first I thought maybe my RAM was going bad until I researched it and saw how many other people were having the identical problem.

    The other computer is a Dell Studio Hybrid that I just installed Win7x86 on this week.  It had previously been running a pre-release version with no problems, but as soon as I installed the RTM Pro version I started getting the freezing.  The most annoying thing is that even though I have changed the power settings to NOT turn the display off, I still come back to my desk and find it turned off.  Then have to wait 5 minutes for Windows to unfreeze itself.

    Two wildly different platforms, different versions of the OS, installed at different times--this is not a hardware issue.
    Friday, March 05, 2010 3:52 PM
  • Good news!  In my case the problem went away on two of my systems.  Your "wake up" problem may be different than mine.  For me, both motherboards are ASUS M4A78T-E's using AMD Phenom II 965BE's with AMD 790GX chipsets.  The 790GX has embedded ATI HD 3300 video.  I just updated the ATI drivers from Catalyst 10.1 to 10.2.  I also installed the optional Catalyst 10.2 Southbridge Driver and Catalyst 10.2 AHCI Driver.  One of those did the trick.  I have now gone throught several sleep/wakeup cycles on both systems and the wakeup has been fast and flawless.

    The ATI Catalyst 10.2 docs make this comment:

    Resolved Issues for the Windows 7 Operating System

    This section provides information on resolved issues

    - Resuming video playback after sleep/hibernation no longer causes black checkered video corruption or the system to stop responding

    - Display will now enter power save mode properly

    Both of my effected systems at this time have Nvidia graphics subsystems.
    Saturday, March 06, 2010 3:18 AM
  • Nvidia here too
    Monday, March 08, 2010 7:49 PM
  • I have the same freeze issue after the display turns off due to power options.  I have Windows 7 x64, with an Asus motherboard, and a nVidia 285 graphics card.  I do use the auto-hide toolbar.

    Sometimes the system will come back again after about 1 minute of freeze.  Other times it requires a hard reset.  I hope this bug gets fixed soon.
    Thursday, March 11, 2010 2:13 AM
  • I had the same random freezing problem for more than a month after installing W7. Tried many solutions - updated drivers, tweaked screen savers, etc. I finally found what I believe is the solution regardless of your video card or system. Mine has been running now for three weeks without freezing after making this change:

    1. Open the System Configuration window (Start Button > type in "System Configuration")
    2. Click on the "Boot" tab, then click on "Advanecd Options".
    3. Check both boxes at the top ("Number of processors" and "Maximum memory"). Do not change the default values that appear.
    5. Click "OK" twice to exit, and reboot.

    I'm not sure why this works, but it has for me.
    Monday, March 15, 2010 4:42 PM
  • I just purchased a HP Pavilion notebook model #WA7790UA with an Intel HD Graphics card and I am experiencing the same lock up problem as Champignon after the system is idle or sleep.  At first you can move the mouse but after a click or two, the mouse freezes and a hard boot is necessary.  I do not get a black screen.  However, I have got the black screen a couple of times when I switched users.  A hard boot was necssary for this second problem.  Since I purchased my computer from Staples with 14 days ago, I am returning it today.  Sounds like they are going to swap it out with a new one rather than try to fix it.  Let's see if the problem is consistant with the machine.  I'll keep you posted. 
    Tuesday, March 16, 2010 4:38 PM
  • Update:  I returned my HP notebook to Staples and they provided me with a new one.  However, the new one has exactly the same problems as the first.  The model number is actually DV6-2150US and the product number is #WA7790UA.  I tried all the solutions on this post, included the Boot/Advanced Options idea from Axis7 and nothing works to correct the sleep problem.  I even found the following fix on HP's website and it didn't resolve the problem.  The notebook is going back to Staples for a second time and I think I'll switch to another model or manufacturer.  I do believe, however, that the problem is Window 7 related and not the hardware because it is such a common problem on so many machines. 

    http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01912228&tmp_track_link=ot_faqs/top_issues/en_us/c01912228/loc:3&lc=en&dlc=en&cc=us&lang=en&product=4121143#

    Troubleshooting a high-definition audio device
    A high-definition audio device on a notebook PC may no longer work after restarting Windows 7 or resuming from hibernation/sleep. The device may be a sound device or a modem. You also may see an "X" character appear on the speaker icon in the notification area.
    To resolve this issue, re-scan the device in Device Manager by performing the following:
    • Click Start , enter device into the search field, and then select Device Manager from the list when it becomes available.
    • Highlight and right-click Sound, video and game controllers .
    • Choose Scan for hardware changes .
    The high-definition audio device will detect hardware changes and the "X" character should no longer appear on the speaker icon.
    Thursday, March 18, 2010 4:01 PM
  • I too have the occasional problem of a black screen after my password has been entered after a wake-up from the screen-saver or sleep.

    I just changed fron Nvidia to ATI and tested anew. It still happens randomly. I am using auto-hide.

    My temporary work-around is to no longer request a password upon wakeup of the screen saver or monitor sleep.

    I am running Win 7 with all patches installed.

    I do think that it is a combination of some background jobs running while the mintor is in screen-saver mode or power-save mode. Then upon wake-up the problem will occur. Whih background jobs cause the problem to occur, I do not know as yet.


    Seymour
    Friday, March 19, 2010 12:08 PM
  • I'm really glad I've found this posting. I've started to notice similar behaviour to the original poster.

    If I leave the PC for around 10 minutes, when I get back I've either got a frozen screen or the screen is black (and frozen) due to my 5 minute "Turn off the display" power setting. I changed all the advanced settings for power saving to disabled and I'm still seeing the same behaviour. I can actually get myself out of this freeze by hitting the power button as if to trigger a shutdown, I then get a screen popup telling me that certain programs are still running and would I like to end them or cancel, I select cancel and I'm back at the desktop again and all is fine!

    I can't see anything else with regards to power saving that I can change, I don't have a screen saver set, just the screen blanking after 5 minutes. This is my work machine running windows 7 x64 Enterprise, the hardware is a Dell Precision 380, with a GeForce Quadro 1400 gfx card and 8gb of ram.

    My home machine is running windows 7 x64 home premium, exactly the same power settings and screen blanking, GeForce gtx295, 4gb of ram and I never see this problem.

    I am starting to have a niggling feeling that it COULD be our latest version of McAfee Antivirus Enterprise that we run here at work, at about the time this started to happen we had an ePO-agent update and version 8.7.0i of the client. Other windows 7 machines that this has been installed on don't seem to be showing the same signs though so I'm still trying other things.

    Tuesday, March 23, 2010 3:48 PM
  • I have never had Mcafee and I see the reaction.
    Seymour
    Tuesday, March 23, 2010 6:50 PM
  • I never had Mcaffee.  I don't have Nvidia or ATI either.   And I experience the same problem (frozen screen) on my HP Paviliion notebook.  I ended up keeping the replacement from Staples and set it to shut down when the lid is closed.  This has stopped the problem completely.  It's not the ideal situation but it's better than the alternative.  I still think is a MS problem because that is the only common thread between everyone's machines.  Or, it could be in the BIOS.  One of these days someone will find the answer.  It sure is taking a long time.  I've seen this same subject on other posts and they are dated back to early 2009!!

    Thursday, March 25, 2010 3:42 PM
  • I'd sort of ruled out McAfee quite quickly too :(.

     

    I've actually seen this talked about as far back as vista, not just windows 7. I had a brilliant version of it happen today, when the screen froze this time it actually told me that my video driver had stopped responding!

    Thursday, March 25, 2010 6:26 PM
  • THANK YOU!!! I can't tell you how long this has bothered me!  I have an HP Dm3-1030US (with Win7 x64).  Occaisionally, if the computer "idles" to sleep or close to sleep?!?!) it freezes temporarily after waking up...sometimes it even freezes permanently.  In fact, it just did it which is why i went looking for a solution AGAIN...i have looked before, but never found this until now!

    I am glad you have reported this to Microsoft, I will do the same as I am now convinced after reading this that it is not HP that is actually to blame for this annoying problem!

    Friday, March 26, 2010 4:00 AM
  • I have never had Mcafee and I see the reaction.
    Seymour

    Initially I blamed a background defragmentation program, Perfectdisk, but it became clear after a while that the bug is with the Windows OS itself and the way that it handles power saving activity when a machine is left idle.

     

    There is no other explanation for this behavior given the number of people who are obviously experiencing this, and the hugely variable hardware and software platforms they are running.

     

    ADDENDUM:  I have now observed this behavior on both X32 and X64 Windows 7 machines.  I no longer believe that the problem is limited to the X64 code.

    Friday, March 26, 2010 4:49 AM
  • ADDENDUM:  I have now observed this behavior on both X32 and X64 Windows 7 machines.  I no longer believe that the problem is limited to the X64 code.

    With the amount of reporting that is available via Google etc, it is very evident that it is not limited to X64 code. Also this has been reported with Vista also. It is definitely an MS-induced problem 
    Seymour
    Friday, March 26, 2010 12:42 PM
  • When you have encountered this problem, did you have the taskbar set to auto-hide?  I had my taskbar set to auto-hide, and i think i read something in this forum which implied that might be involved.
    Saturday, March 27, 2010 10:50 PM
  • When you have encountered this problem, did you have the taskbar set to auto-hide?  I had my taskbar set to auto-hide, and i think i read something in this forum which implied that might be involved.

    Yes, but I have used Autohide since at least Windows XP (did it exist for Win 2000?  If so, then I used it there also.  I have never had this particular problem with versions of Windows before Windows 7, even though I have used Autohide for many years.
    Sunday, March 28, 2010 2:53 AM
  • I am also having the same problem. I am working with an Asus G60V Laptop running Centrino 2 Duo processors and 4GB Ram, an NVidia 1GB Geoforce GTX260M Video card, and 64Bit Windows 7. The issue only occurs when I let my PC idle into screen off mode. I have set the screen off to 15 minutes and the screen saver to 10 minutes. The issue only happens when I allow the system to go into screen off mode. One post suggested going to start>Configuration>Boot>advanced> and selecting the top two boxes - available ram and number of processors. This fix does not work. In my case It causes the computer to respond faster at first, until the cursor eventually freezes completely.


    The only fix I have found to work is the one posted by champignon - turning off the "display off" setting in the power options menu. I have tested this method over the past few days and this works - even in conjunction with the use of a screen saver. Next I will test this theory in with the "blank" screen saver. Essentially this should be the same as having the display power off....properly.

    Sunday, March 28, 2010 3:07 AM
  • I have experienced this problem using the Windows 7 beta, also using the RC, and now in the RTM also (as of 03/28/2010 with all updates current). I did not experience the lockups using Vista. The fact that this bug has not yet been addressed is surprising considering it has been detailed in forums since at least RC 7100!

    I'm using an ASUS F81SE laptop with a Core 2 Duo P8600 processor and 4GB RAM, and a Radeon Mobility HD 4570 GPU. The suggestion to use the advanced boot options dialog is ridiculous and has no bearing whatsoever on this bug. The only workaround at this time is to set the "turn off the display" drop-boxes to "never" in the Power Options > Edit Plan Settings dialog, as mentioned by 'champignon.' I have not explored the taskbar auto-hide connection yet, but I need auto-hide for the screen space savings, so I'm happy to just not have the display turn off for now.

    Considering that this bug affects such a wide cross-section of systems, I really do hope that Microsoft investigates this bug ASAP.

    Sunday, March 28, 2010 5:29 AM
  • I have experienced this problem using the Windows 7 beta, also using the RC, and now in the RTM also (as of 03/28/2010 with all updates current). I did not experience the lockups using Vista. The fact that this bug has not yet been addressed is surprising considering it has been detailed in forums since at least RC 7100!

    I'm using an ASUS F81SE laptop with a Core 2 Duo P8600 processor and 4GB RAM, and a Radeon Mobility HD 4570 GPU. The suggestion to use the advanced boot options dialog is ridiculous and has no bearing whatsoever on this bug. The only workaround at this time is to set the "turn off the display" drop-boxes to "never" in the Power Options > Edit Plan Settings dialog, as mentioned by 'champignon.' I have not explored the taskbar auto-hide connection yet, but I need auto-hide for the screen space savings, so I'm happy to just not have the display turn off for now.

    Considering that this bug affects such a wide cross-section of systems, I really do hope that Microsoft investigates this bug ASAP.

    That would be great, if MS would fix this!!!
    Monday, March 29, 2010 2:38 PM
  • One of my first attempts at fixing this problem was turning off auto-hide.  It didn't work.  :(
    Monday, March 29, 2010 4:45 PM
  • My work-around is as follows:

    I kept auto-hide on.
    I removed the requirement for the screen saver to prompt for password.
    I have changed my power-save to never for the monitor.
    I turn the monitor off overnight or if I plan on being away for a length of time.


    Seymour
    Monday, March 29, 2010 5:32 PM
  • That does work, however I wish I could replicate it again on my home machine which doesn't show the same problem. The only difference being that my work machine runs Windows 7 Enterprise and my home machine Windows 7 Home Premium, both 64bit and both a typical installation.
    Thursday, April 01, 2010 11:50 AM
  • I turned off auto-hide, and so far my computer has not frozen...i'll keep watching it.

    Friday, April 09, 2010 8:27 PM
  • For those with ATI cards try uninstalling the Catalyst software from ATI I found the best thing for this problem if you have an ATI card is to jsut load the Windows drivers. Sad, if you like the features the ATI software gives you, but it seemed to work for me.

    Plus Windows 7 would always have a dll problem with the Catalyst and close the program anyway.

    I am hoping the issue gets figured out. I have a fairly identical system with an Nvidia card and it has never been an issue.

    Tuesday, April 13, 2010 8:00 PM
  • I have also had this same problem since I bought my Windows 7 laptop back in November.  My whole computer freezes after resuming from the monitor being turned off by Windows.  I am able to move the mouse for a few seconds (but cannot click on anything) and then it just freezes completely for 2-30 minutes, unless I hard-reboot the machine.  I am also using windows 7 64 bit; I have an Acer Aspire 5517 laptop with ATI graphics.  So far the only way I have found to get around this is to disable screen blanking, which as this is a laptop I hate to do because I can't just flick the power on the LCD.  I even reformatted the PC and disconnected all accessories.

    After reading this thread I have turned off the auto-hide that seems to have fixed the problem, kind of a pain but for me its better than having to disable screen blanking, so thanks to the people who submitted this work-around.

    So I guess its just a Windows 7 x64 bug, I'll submit a ticket also, does this seem to happen on ALL windows 7 x64 PC's with Auto-hide on?

    Monday, April 19, 2010 6:22 PM
  • I had the same random freezing problem for more than a month after installing W7. Tried many solutions - updated drivers, tweaked screen savers, etc. I finally found what I believe is the solution regardless of your video card or system. Mine has been running now for three weeks without freezing after making this change:

    1. Open the System Configuration window (Start Button > type in "System Configuration")
    2. Click on the "Boot" tab, then click on "Advanecd Options".
    3. Check both boxes at the top ("Number of processors" and "Maximum memory"). Do not change the default values that appear.
    5. Click "OK" twice to exit, and reboot.

    I'm not sure why this works, but it has for me.

    be sure to check out my thread on the specifics of getting an upgraded core processor to show up correctly. This has been verified as a good fix for this specific (although rare) problem by Microsoft here that I posted on a different thread. It is a very rare bug if all the criteria are correct for it to happen so don't panic. Just a little aside to this fine thread.
    Tuesday, April 20, 2010 5:48 AM
  • Update:  I returned my HP notebook to Staples and they provided me with a new one.  However, the new one has exactly the same problems as the first.  The model number is actually DV6-2150US and the product number is #WA7790UA.  I tried all the solutions on this post, included the Boot/Advanced Options idea from Axis7 and nothing works to correct the sleep problem.  I even found the following fix on HP's website and it didn't resolve the problem.  The notebook is going back to Staples for a second time and I think I'll switch to another model or manufacturer.  I do believe, however, that the problem is Window 7 related and not the hardware because it is such a common problem on so many machines. 

    http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01912228&tmp_track_link=ot_faqs/top_issues/en_us/c01912228/loc:3&lc=en&dlc=en&cc=us&lang=en&product=4121143#

    Troubleshooting a high-definition audio device
    A high-definition audio device on a notebook PC may no longer work after restarting Windows 7 or resuming from hibernation/sleep. The device may be a sound device or a modem. You also may see an "X" character appear on the speaker icon in the notification area.
    To resolve this issue, re-scan the device in Device Manager by performing the following:
    • Click Start , enter device into the search field, and then select Device Manager from the list when it becomes available.
    • Highlight and right-click Sound, video and game controllers .
    • Choose Scan for hardware changes .
    The high-definition audio device will detect hardware changes and the "X" character should no longer appear on the speaker icon.

    Thank you for this info. I can also add that in addition to doing a Scan for hardware changes I have actually disabled the playing sound source in the Sound Control Panel and renabled it to allow the sound to instantly work again. But your tip is also very helpful. I never would have though of doing it that way!
    Tuesday, April 20, 2010 5:58 AM
  • For those with ATI cards try uninstalling the Catalyst software from ATI I found the best thing for this problem if you have an ATI card is to jsut load the Windows drivers. Sad, if you like the features the ATI software gives you, but it seemed to work for me.

    Plus Windows 7 would always have a dll problem with the Catalyst and close the program anyway.

    I am hoping the issue gets figured out. I have a fairly identical system with an Nvidia card and it has never been an issue.


    Yeah I have had this problem with the earlier CCC (Catalyst Control Center) around the time that Win7 came out (versions 9.7-9.9 , I think). The recent ATI Catalyst drivers as of 10.1 seem to have made the CCC (if actually installed) very stable and not crash (or make the CCC icon in the taskbar just plain vanish) like the old versions used to. I think this was more of an ATI software issue then Microsoft but who knows with the complexity of software nowadays =/ Anywho I have had less and less even remote issues of the CCC even budging, crashing or plain acting weird since 10.1 came out in the beginning of this year. The current version is 10.3 as of this writing.
    Tuesday, April 20, 2010 6:03 AM
  • For those with ATI cards try uninstalling the Catalyst software from ATI I found the best thing for this problem if you have an ATI card is to jsut load the Windows drivers. Sad, if you like the features the ATI software gives you, but it seemed to work for me.

    Plus Windows 7 would always have a dll problem with the Catalyst and close the program anyway.

    I am hoping the issue gets figured out. I have a fairly identical system with an Nvidia card and it has never been an issue.


    I would revisit the post 10.1 Catalyst drivers that have been out since Jan/Feb time frame. They are very stable unlike the 9.7/9.9 versions around the time when Win7 was released and shortly thereafter in October. It seems ATI is back in stride in squashing any bugs that may creep up with a very new OS. ATI rocks! I have not had a single ATI Catalyst issue since February when I installed the 10.1 and the current version is 10.3 (recently released) as of this writing.

    Update: the current ATI Catalyst drivers are now at 10.4 and do require a reboot upon installation on Windows 7. This is a first.
    Tuesday, April 20, 2010 6:09 AM
  • Hey all,

    Also having the same issue. Windows 7 64-bit, ATI 5870m in a Sager NP8760. Catalyst 10.3.

    Following someone's suggestion somewhere, I ran CMD and typed "powercfg -energy"
    The report contains 13 errors, 11 warnings. Seems pretty high, should I post them here? Are the values returned by this report relevant to this issue, or important somehow?

    Wednesday, April 28, 2010 7:59 AM
  • What would really be nice would be for Microsoft to acknowledge the existence of this problem and to design a patch to fix it.  All of the speculation about video cards and whatever else is irrelevant.  This is a problem that has effected a lot of people on different hardware and the only apparent thing in common (and I can't even be sure of that ) is that it effects 64 bit Windows 7 systems regardless of version (e.g. home, pro, ultimate).
    Wednesday, April 28, 2010 12:45 PM
  • I'm glad I found this thread because it describes my situation exactly.  I never experienced this problem until I enabled auto-hiding the taskbar.  I am running Windows 7 Home Premium 32-bit, so the problem is not specific to x86 or x64.  Now I have to decide whether to disable auto-hiding the taskbar or stop Windows from powering down the display.  Either option is bothersome, and I would appreciate it if Microsoft engineers to look into this issue.
    Saturday, May 01, 2010 6:47 PM
  • Don't hold your breath waiting for Microsoft. This problem has been going on since Vista Beta version.

    Re original post, I had this problem for a long time but it is cleared now.

    On my system it was both mouse AND keyboard that locked up. after a video driver update, the problem with the mouse was fixed (for me). But the keyboard still comes back disabled. This makes Sleep unuseable, instead I use Hibernate. Return from Hibernate on Windows 7 Retail is very fast.

    Microsoft's priority seems to be getting the system to boot fast when the desktop background is a solid color (for which the fix just came out.) If you've been watching these threads you know how long ago that one was reported.

    Saturday, May 01, 2010 10:01 PM
  • Don't hold your breath waiting for Microsoft. This problem has been going on since Vista Beta version.

    Re original post, I had this problem for a long time but it is cleared now.

    On my system it was both mouse AND keyboard that locked up. after a video driver update, the problem with the mouse was fixed (for me). But the keyboard still comes back disabled. This makes Sleep unuseable, instead I use Hibernate. Return from Hibernate on Windows 7 Retail is very fast.

    Microsoft's priority seems to be getting the system to boot fast when the desktop background is a solid color (for which the fix just came out.) If you've been watching these threads you know how long ago that one was reported.

    yeah its up to us to help each other as Microsoft has all but washed their hands of ppl's problems once the 3 month free support for Windows 7 expires and we are forced to do their bug testing for them while paying for the support. I wish some company like Google perhaps will unveil  a new OS that run's on PC's so we can once and for all purge Microsoft juggernaut from our computers =P
    Sunday, May 02, 2010 12:55 AM
  • and it would be *great* for those whose problems are cured through ati catalyst updates to start another thread as your issue seems to differ from the issue detailed in this thread (this thread focuses on an issue that affects Windows 7 systems regardless of video driver -- I'm using Catalyst 10.4 drivers and the problem remains -- and other hardware differences). otherwise it all gets too confusing and might suggest to microsoft that the problem is driver related!
    Sunday, May 02, 2010 10:42 AM
  • I use WIn 7 x86 and I noticed the same problem of freezing when auto-hide the taskbar is enabled.

    In fact, I noticed exactly the same problem, once the system turn the monitor off.

    Once I move the mouse to turn the display on, the system freeze from few seconds to few minutes.

    If I put the auto-hide the taskbar on disabled, then the problem disappear.

    So this problem need a fix, because the auto-hide taskbar is unusable.

    Set-up : Win 7 x86, Motherboard ASUS P5W DH, C2D 2.4GHz, 4Go RAM, ATI  Radeon X800 Graphic card.

    Monday, May 10, 2010 2:04 PM
  • Exact same problem here, this issue is really starting to annoy me, i have actually had this problem with both 64x an 86x OS and i cant see any similarities in something that may be causing this (example everyone has a nvidia geforce card or most people have the same third part software witch may cause this freez up) This problem  definitely does not discriminate as this page has a number of different pc's, graphic cards ram so on witch have the same problem, thinking it must be a bug in win7 os any way for the record I am running on asrock N68PV-GS with a 7 series nvidia geforce 7600 gs 3 gigs of ram not sure of the maker but both ram chips are set to the same speed witch they are both compatible with, processor is amd athlon 64 x2 dual core 6000+ 3.10 ghz. hope MS get this fixed soon.
    Tuesday, May 11, 2010 1:23 AM
  • One thing i do find interesting is my misses has the exact same os installed on here laptop i don't no the specks and cant get them yet as she is not home but one thing i do know is her laptop has 1 gig of ram on the one chip and the processor is not dual core and she has no problems like this at all none to be exact
    Tuesday, May 11, 2010 1:35 AM
  • One thing i do find interesting is my misses has the exact same os installed on here laptop i don't no the specks and cant get them yet as she is not home but one thing i do know is her laptop has 1 gig of ram on the one chip and the processor is not dual core and she has no problems like this at all none to be exact


    I have many computers (at least 10), all with dual core.  Only a couple have been afflicted.  Some of this however will be related to how the computer is used.  If it isn't left on for long periods of time at idle, whatever is happening that results in the freezing won't happen because the screen never gets blanked and/or the system never goes into standby or idle.

    In any event, the huge majority of systems being sold nowadays are dual core.

    Tuesday, May 11, 2010 2:21 PM
  • One thing i do find interesting is my misses has the exact same os installed on here laptop i don't no the specks and cant get them yet as she is not home but one thing i do know is her laptop has 1 gig of ram on the one chip and the processor is not dual core and she has no problems like this at all none to be exact
    Thank you for this information. I think this is a very crucial criteria for this freezing that included in the whole results in the freezing aspect of Windows 7. You need to have a dual core processor (or multi-core) AND memory that runs @ faster then 800mhz AND memory chips of 2 or more different slots (single memory chip systems tend to not exhibit this dilemma) AND the computer going into a sleep mode. If the criteria above is all met and true then the end result is the OS completely freezing and requiring a hard reboot with the on/off button. Other symptoms I have also noticed is blue screens or garbled video as the underlying hardware dominoes collapses like a deck of cards underneath itself.

    If any of the above is NOT met then the freezing or crashing does not occur. I have been running my system @ 800 mhz now for over 6 months with no symptoms showing. Even though my premium memory is fully capable in running @ 1066 mhz. I have to basically dumb down my system to accommodate this bullsh it OS into behaving itself or I get crashes and freezes or worse the same day I bump my memory up.

    MICROSOFT YOU FREAKING SUCK!!!
    Wednesday, May 12, 2010 11:40 AM
  • Now if you put two memory cards in and it fails but works with one memory card, how can you blame Microsoft for this?

    It sounds like your Motherboard is not compatible with the memory you are using at the high speed. If it works at low speed, again how can you blame Microsoft for this?

    Be glad your investment in hardware, software, time etc is not all for naught since you have found a working configuration, rather than cursing Microsoft.

    Wednesday, May 12, 2010 12:46 PM
  • i've had this same problem since beta. this sounds incredible, but i recently purchased two new monitors to replace my previous dual monitor setup. the new monitors came with their own monitor drivers and the problem disappeared. i was using generic win 7 monitor drivers, and now run the latest from viewsonic with no problems for 3 weeks.

     trust me, its worth trying.

    Wednesday, May 12, 2010 12:59 PM
  • read both my posts carefully as i stated both my ram chips are set to the same speed and vaults witch the maker specifies as compatible, and as for cursing microsoft well i don't think i swore but can you blame me for being annoyed i just payed over $300 for my os and i just want it running stable but man, i dont mean to whinge i just want it resolved, and i would like to state xp, vista, me, 2000 run fine with this hardware. I am a os junkie and like to try things out ill even try 95 for a blast from the past if i get a copy
    Wednesday, May 12, 2010 1:27 PM
  • I have the latest graphics card driver and monitor driver plus i have rolled back to older drivers with no luck, i am glad you mentioned dual monitors because when i have 2 monitors running (different sizes both lcd) i do not have this freez up issue
    Wednesday, May 12, 2010 1:38 PM
  • Also i don't think you understood it was 2 different pc's one had a single ram chip the other had 2, the pc witch i am having issues with works fine with any other os but thanks for commenting.
    Wednesday, May 12, 2010 1:54 PM
  • Now if you put two memory cards in and it fails but works with one memory card, how can you blame Microsoft for this?

    It sounds like your Motherboard is not compatible with the memory you are using at the high speed. If it works at low speed, again how can you blame Microsoft for this?

    Be glad your investment in hardware, software, time etc is not all for naught since you have found a working configuration, rather than cursing Microsoft.


    It would be Microsoft's problem if you contact the manufacturers of the memory, processor and motherboard and even Microsoft and they all say its compatible and capable to be used together and some manufacturers even go through the length of testing identical setup such as Motherboard with Memory and Windows 7 64-bit. Then yes it is a Microsoft problem if something is different in the OS and the hardware is identical in the manufacturers testing labs. I have spent an inexorbirant amount of time combating this issue. Its the OS, I am 110% sure of it.
    Wednesday, May 12, 2010 1:56 PM
  • I have the latest graphics card driver and monitor driver plus i have rolled back to older drivers with no luck, i am glad you mentioned dual monitors because when i have 2 monitors running (different sizes both lcd) i do not have this freez up issue

    interesting, very interesting!
    Wednesday, May 12, 2010 2:03 PM
  • Dam sorry people I am new to these threads and have just noticed i have been replying when I should have quoted and when I received an email from this thread i thought it was a quote, so just ignore my comments if they seem not to make sence.
    Wednesday, May 12, 2010 2:11 PM
  • For the record I don't agree with the statement that this problem is related to the memory type or speed used; that it needs to be running faster than 800mhz, for example.

    Both of the effected systems that I have, and especially the one on my desk which is the one that motivated me to write the original post in this thread, are not running memory faster than 800mhz.  In fact, my desktop has 4 sticks of 800mhz memory however the Mobo runs it at 667.

    I believe there are conclusions or generalizations being made in this thread that are simply not supported by any facts.  The simple freezing problem from idle that I described originally, which quite obviously has been experienced by quite a few others posting on this thread, has no known cause that I am aware of.  It does have a couple of easy solutions, apparently, including turning off screen blanking in the power settings, and possibly also disabling auto-hide (I have not tried the latter).

    Other problems with freezing like symptoms have been described on other threads, however it would be best to treat each problem individually.  The one I described here does not appear to be related to specific hardware such as the type of video card or the memory being used on the mobo.

    Wednesday, May 12, 2010 4:25 PM
  • For the record I don't agree with the statement that this problem is related to the memory type or speed used; that it needs to be running faster than 800mhz, for example.

    Both of the effected systems that I have, and especially the one on my desk which is the one that motivated me to write the original post in this thread, are not running memory faster than 800mhz.  In fact, my desktop has 4 sticks of 800mhz memory however the Mobo runs it at 667.

    I believe there are conclusions or generalizations being made in this thread that are simply not supported by any facts.  The simple freezing problem from idle that I described originally, which quite obviously has been experienced by quite a few others posting on this thread, has no known cause that I am aware of.  It does have a couple of easy solutions, apparently, including turning off screen blanking in the power settings, and possibly also disabling auto-hide (I have not tried the latter).

    Other problems with freezing like symptoms have been described on other threads, however it would be best to treat each problem individually.  The one I described here does not appear to be related to specific hardware such as the type of video card or the memory being used on the mobo.


    Everything you are saying is completely true and I agree. It my case I can empiracally prove once I bump up the memory to 1066mhz all the slew of problems starts within 1 hour of it running like this and continues until the memory speed is bumped down. Microsoft said the hardware I have should run @ 1066 memory speed, so has Corsair (memory), so has Gigabyte (motherboard), so has AMD (processor), so has ATI (video). Gigabyte went so far as to build an identical system as I had running 3 flavors of Windows on it. Only Windows 7 64-bit started to show some anomolies they were not able to pinpoint as the cause. Then again a technical support lab in no way can duplicate an actual users day to day functions as accurately. They do burn-in tests and users don't to replicate their problems. They use their computers in ways no burn-in test can accommodate entirely. It this respect I have to say, and based on equal user experience from multiple users on various threads dealing with Windows 7 crashing, freezing, locking, garbled video, sleep mode issue it is the OPERATING system that is the root cause that ties all this together. Specific hardware when running in a specific pattern like higher memory speeds compounds the problem and makes it evident much faster. This is what I noted in my last post.

    I have tried my best to come with some sort of commonalty by reading almost every post I can on this issue and similar in the many threads in these forums and that was the best commonality I could glean from them all. I have also empirical proof of users abolishing these problems once their memory speed was dumbed down to 800mhz all their problems went away like mine, identically. Various hardware, same OS, memory bumped to 800mhz, problem is solved. This leads to believe I am on to something. That something is the OS and not the hardware. If it was the hardware then why does XP or Vista not show these same results, only Windows 7 (especially 64-bit) create so much headaches.

    If anyone can share some sort of better commonality on this issue I am sure we are all willing to learn from it.

    Thursday, May 13, 2010 9:45 AM
  • Does anyone from Microsoft even read these posts? 
    Friday, May 14, 2010 4:27 PM
  • Does anyone from Microsoft even read these posts? 
    It's been about 4 months since I made the original post; perhaps it will take a while longer, but hope springs eternal :-)
    Saturday, May 15, 2010 3:25 PM
  • I too get this problem. I have tried everything to fix this by reading other threads with no success. I just turned off power down for the display. Hopefully this works. Getting ral tired of hard booting everytime I sit back down at my desk. I will keep you informed if this works for me.

    Hopefully Microsoft will fix this problem.

    Tuesday, May 25, 2010 10:47 PM
  • I got some ideas from other uses in this thread and put it to use, i turned my screen saver to blank then to power down 10 minutes after that, it sleeps after 2 hours, i also turned off auto hide task bar and i have not had a problem for weeks now witch is great because i had the freez up problem just about every time the pc went to sleep, screen saver came on, powered off screen. this is only a quick fix but it has worked for me and i also get screen protection and use of sleep, i think for me anyway this might be caused by the task bar auto hiding and conflicting with screen resume and task bar not being able to pop up and causing a nasty hang and i say hang because half of the time i can recover my pc by clicking ctrl/alt/delete and waiting for a short period then clicking start task manager then just closing it when i am back on the desktop.
    Wednesday, May 26, 2010 12:01 AM
  • I also have this issue running Ulimate on a 32bit version.  Will follow discussions to see if a resolution is forthcoming
    Friday, May 28, 2010 3:00 AM
  • Having disabled all hard disk etc. sleep options Windows 7 would still freeze for varying periods shortly after resuming from a screen power down. Turning off the task bar auto hide function has however fixed the problem for me. Somewhat annoying as I like using auto hide but not as annoying as waiting for unspecified periods for Windows to recover itself. Clearly this is a Windows 7 issue and it would be good if Microsoft could come up with a fix.
    Friday, May 28, 2010 2:28 PM
  • Having disabled all hard disk etc. sleep options Windows 7 would still freeze for varying periods shortly after resuming from a screen power down. Turning off the task bar auto hide function has however fixed the problem for me. Somewhat annoying as I like using auto hide but not as annoying as waiting for unspecified periods for Windows to recover itself. Clearly this is a Windows 7 issue and it would be good if Microsoft could come up with a fix.

    I am hoping that Microsoft will fix this taskbar issue in any forthcoming service pack they are creating for Windows 7. There are many people who have had similar problems with this taskbar and once the first Service Pack is released eventually this problem will be addressed. Just make sure you post this problem with Microsoft to let them know the problem and what you did to fix it. Thank you for posting this problem to all of our attention.
    Friday, May 28, 2010 7:52 PM
  • I tried it again.  I disabled the task bar autohide and set my system to sleep after 10 minutes and to sleep when lid is closed. (I previously had it set to "never" sleep.)  I still experienced the lock up where the system is unresponsive to any mouse activity.  No black screen though.  I had to force a shut down by pressing the on/off button which of course during restart brings up the black and white screen asking if you want to open in safe mode or normal mode.  So autohide is not the culprit on my machine.  I wonder if hybernate would have been any different???
    Thursday, June 03, 2010 4:01 PM
  • I tried it again.  I disabled the task bar autohide and set my system to sleep after 10 minutes and to sleep when lid is closed. (I previously had it set to "never" sleep.)  I still experienced the lock up where the system is unresponsive to any mouse activity.  No black screen though.  I had to force a shut down by pressing the on/off button which of course during restart brings up the black and white screen asking if you want to open in safe mode or normal mode.  So autohide is not the culprit on my machine.  I wonder if hybernate would have been any different???
    I have heard that hibernate solves this issue by a few ppl who have tried it instead of sleep.
    Friday, June 04, 2010 7:50 PM
  • Hello All, My first post here ,

    and Thanks to everyone for taking the time to help others .

    I run Windows-7 Ultimate , although I'm not yet terribly proud of that fact . 

    Although I will say that it has it's plus points , in general , my old XP setup was far more straight forward , and the new Windows Explorer stinks .

    Over the Past 30 years I have become more proficient at Windows than your average teenager , but this problem is really tweaking my behind .

    I have tried everything in this thread , and more , with the exception of turning off  "Auto-Hide" .........  

    I must have "Auto-Hide" , it's mandatory as far as I'm concerned  .

    I have had one instance of another oddity.......  with High Performance selected , and the monitors manually switched off over night ,

    I awoke to a computer that was  OFF   , I can't explain this one ,

    I run a 1000 watt UPS that has never failed me , and , no other people in the house , no flashing clocks , bios set to "Last State" for power loss .

     

    I use 3 shortcuts on the desktop to quickly switch between  "Power Plans" .

    Low Power is used to shut-down the monitors after one minute , never sleep or hibernate , never turn off disks , NIC , or USB  .

    Memory Passes with flying colors , I never overclock anything , alphabetical defrag , registry cleaned with JV-16 Power Tools registry cleaner .

    This is a brand spankin new box I built myself , my eighth custom build , all drivers current , including latest bios upgrade , and all Windows Updates .

    My normal configuration is to leave my computer on 24/7 with the "Microsoft required" re-boot every morning at 6-am ,

    but quite early into the new OS learning curve , I noticed that I kept coming back to a

    dead keyboard , dead desktop , a mouse that would freeze after about 30 seconds , and a dead power button ,

    requiring a 4 second hold for a hard re-boot .  I thought it might have been all my registry tweaking , but that's not it .

    Is anyone here experienced enough to know if it's possible to swap in some older Vista , or maybe even XP files , that might alleviate this aggravation ? 

    It seems that after 5 months of this thread , someone from MS would have cared enough to duplicate , verify , and/or report this problem .

    I mean , what is it ?, pride or something ?, preventing them from saying something like ......

    "Swap in this Vista DLL , here's a link to download it , a Windows Update will have a proper fix in a month or two" .

    Seems like they're trying to operate like the US government , just deny it ever existed !

    In the mean time , I guess I'll just have to see if some sharp tweaker out there can do Microsoft's job for them , I'm sorry , but I can't afford the time .

     

                       Jim

     


    Asus M4A785TD-V EVO , Phenom II X4 945 3Ghz , 4G Corsair Mem , 2X - Raid-0 HD Pairs , 2X 750G Back-up HDs 2X ViewSonic 24" Monitors , Radeon 4650 GPU , ~75 Reg Tweaks , Bad to the Bone, except for one prob.....
    Wednesday, June 16, 2010 1:10 AM
  • Unfortunately im not really technically minded so i cant give much information other than i too have this freezing issue after idle. my os is windows 7, 32 bit so again the issue is not just relevant to 64 bit users. my desktop ran absolutely fine on xp with no issues at all and the upgrade advisor told me my desktop was fine apart from a few drivers that needed upgrading. What i found however when i installed windows 7 was my graphics card was no longer working and ati had no upgrade drivers stating the card was no longer supported (just 2 years old) my creative soundblaster live 5.1 card was no longer working and again no software support available and my creative web cam was also unsupported, anyway £200 later for ne w hardware and the pc seems to be a touch better than xp but not good enough to warrant the expense but whats most annoying is this re start issue. ive now switched off the monitor idle in power settings to see if this works and will report back. 
    Monday, June 21, 2010 8:00 AM
  • People winged about vista and i thought they were being silly although i never realy used it i stuck with xp, then win 7 was released and after searching the internet and seeing the problems that people are having  and the problems i have been having (other then the freeze after resume) windows 7 should still be a beta and i want my $300 dollars back, just look at the updates lately how is windows 7 not a beta and why is people paying so much money for something that has to be constantly updated and im not talking about security updates i mean compatibility updates, something that needs so many updates over a short period of time and wich has so many problems should not be sold but should be offered to download as a beta. I paid $300 just to send error reports, update and have a unreliable os Microsoft i want my money back, windows 7 nice idea but it failed
    Thursday, June 24, 2010 3:40 PM
  • My second reply .....

    One new development ,
    I just ran a small freeware program called  "MonitorInfoView.exe" , the results surprised me .

    It seems that I have 10 monitors listed in the registry under various extremely long numbers .
    ( I actually have only 2 )
    This may be totally normal , I really don't know , but the Read-Me that came with the
    program said that there should be one listing per monitor ,
    but it did not comment on what multiple registry listings might indicate .

    Seems like having multiple listings could very easily cause a problem .
    Does anyone here know if this is a significant discovery ?

    Could this be caused by re-installation of Video Card Drivers ?   ( which I've done 4 or 5 times now )

    Another note.....
    I have repeatedly gone through all the advanced Power Plan settings trying
    different combinations with no joy .
    But I seem to remember seeing a check box that is no longer there ,
    it was called hybrid-(something) , (maybe sleep??) , it just isn't there anymore .

    Here is a partial list returned by  "MonitorInfoView.exe"   :

                                              Standby Suspend  Lo-Power   Default
    Monitor Name  ProductID        Mode   Mode    Mode       GTF            Registry Key
    VX2262wm    30753 (0x7821)    No      No          Yes          No      VSC7821\5&3607f973&0&UID259   
    VX2262wm    30753 (0x7821)    No      No          Yes          No      VSC7821\5&3607f973&0&UID260   
    VX2262wm    30753 (0x7821)    No      No          Yes          No      VSC7821\5&3607f973&0&UID268435459   
    VX2262wm    30753 (0x7821)    No      No          Yes          No      VSC7821\5&3607f973&0&UID268435460   
    VX2433wm    14370 (0x3822)    No      No          Yes          No      VSC3822\5&3607f973&0&UID259   
    VX2433wm    14370 (0x3822)    No      No          Yes          No      VSC3822\5&3607f973&0&UID260   
    VX2433wm    14370 (0x3822)    No      No          Yes          No      VSC3822\5&3607f973&0&UID268435459   
    VX2433wm    14370 (0x3822)    No      No          Yes          No      VSC3822\5&3607f973&0&UID268435460   
    VX2433wm    14370 (0x3822)    No      No          Yes          No      VSC3822\5&5c59ef5&0&12345678&01&05   
    VX2433wm    14370 (0x3822)    No      No          Yes          No      VSC3822\5&5c59ef5&0&UID257 

                                    Jim  



    Asus M4A785TD-V EVO , Phenom II X4 945 3Ghz , 4G Corsair Mem , 2X - Raid-0 HD Pairs , 2X 750G Back-up HDs 2X ViewSonic 24" Monitors , Radeon 4650 GPU , ~75 Reg Tweaks , Bad to the Bone, except for one prob.....
    • Edited by LowQCab Friday, June 25, 2010 3:22 AM Re-Format Text
    Friday, June 25, 2010 3:15 AM

  • I HAVE A SOLUTION    (finally)

    My third post here .

    After some serious investigation and lots of new brain numbing acronyms  (3 or 4 letter abbreviations ) ,

    I have discovered that behind the scenes in the computer world ,
    where only true geeks are brave enough to tread ,
    the  "power control scheme"  wars are raging .

    What this is referring to is the format, and types of commands
    that the operating system uses to communicate with the BIOS / Motherboard / Hardware ,
    in order to either turn-off or slow-down certain hardware functions .

    Of course , everyone wants to retain "Legacy" functionality ,
    although it's starting to become a losing battle ,
    at some point your operating system , motherboard, processor, memory,
    and all the rest of the  "old"  hardware will become defunct .

    Anyway , here's what I found.....

    My brand new  ( designed ~1 year ago )  motherboard and it's latest BIOS up-grade came with
    certain default settings that are not completely compatible with Windows-7,
    and Win-7's programs for controlling the booting and power throttling of various pieces of hardware .
    OR......  Win-7 is not following the newest protocol and sending a notification to
    the BIOS that the BIOS should use  "S3"  mode  for Suspend Commands .

    So....  Here is the exact setting that solved my problems :

    In my BIOS , under "Power" there are several different settings that control
    how the BIOS will communicate with the OS,
    Here are my options ,  ( yours may vary from mine of course ) ,

    Under  "POWER"............

    I tried disabling :  ACPI 2.0 Support   , result = boot to black monitors , no OS .

    I tried disabling :  ACPI  APIC Support , same result , boot to black monitors , no OS .

    Then I tried changing :  SUSPEND MODE ,  the default is  "AUTO" ,
    the options are :
    S1 (POS) only
    S3  only
    AUTO


    After I changed this setting to  "S3 only" .....  No more problems  :D  .

    This would indicate to me that Windows is NOT sending the pertinent info to the BIOS so that
    the BIOS knows which language or mode the OS wants to use to
    issue  "Suspend Mode Commands"  to the Motherboard .
    An older OS that does not know how to speak in  "S3"  language , would , of course,
    NOT send any info to the BIOS saying to use  "S3" ,
    so if the BIOS gets no notification to use S3 ,
    it defaults to using  "S1 (POS) only"  mode, when it is set to  "AUTO" , which it is by default  .

    Other settings in my BIOS are :
    APM CONFIG
    Options are :
    Restore on AC Power Loss                =  "Last State"
    Power On from S5 by PME#              =  disabled
    Power On from S5 by Ring                =  disabled
    Power On from S5 by PS/2 KB/MS     =  disabled    (This is in case you are using a PS/2 Keyboard or mouse)
    Power On from S5 by RTC Alarm       =  disabled 

    I hope this helps out somebody , if you have a new Asus MoBo it probably will be the solution .


                               Jim
    Asus M4A785TD-V EVO , Phenom II X4 945 3Ghz , 4G Corsair Mem , 2X - Raid-0 HD Pairs , 2X 750G Back-up HDs 2X ViewSonic 24" Monitors , Radeon 4650 GPU , ~75 Reg Tweaks , Bad to the Bone, except for one prob.....
    Thursday, July 01, 2010 12:29 AM
  • Hoping to help grab Microsoft's attention.  I also confirm the same symptoms.

    Win 7 Pro, i5 750, 4 GB Corsair, nVidia GT 240, etc.

    Have about 13 instances of PC freezing over the last 60 days.  The last few days it has become a guaranteed recurrence each time I restart.

    Planning to adjust power settings first and see what happens.

    Thanks for the scouting work.

    Monday, July 05, 2010 8:14 PM
  • I have the same problem on two different systems, and its very annoying.

    Hope that Microsoft looks into this soon and can't understand why they haven't yet...

    Tuesday, July 06, 2010 6:48 PM
  • I also have this problem.  It seems to me that something needs to be corrected.  I've been trying for 3 months to get my PC to stop freezing up after going idle.  Just today i've finally decided that I'm going to try to set my monitors to never turn off, which I think is a lame solution if it does work. 


    Without fail every single day if I leave my pc for more than an hour and my monitors turn off, it just freezes and I can move the mouse around, and sometimes it will eventually "Catch Up" and return to being usable. 

    I have seen solutions that reference updating your power settings in the bios, but i've updated to the most recent bios on the ASROCK X58 Extreme, and there is no option to mess with power suspend settings. 

    I feel like I have read thousands of complaints on this exact issue, so i'm not sure why Microsoft is not able to figure out how to fix it.  If it is incompatability with certain motherboards or hardware, then I believe it is Microsofts duty to figure it out and make it work. 


    This has gone on too long.

    Friday, August 13, 2010 10:51 PM
  • I had the exact problem as described above.  When I disabled the monitor sleep function, the issue went away.

    Thanks for your post.

    Saturday, August 14, 2010 5:00 AM
  • Same here. Waking up the screen after "Turn of display after ... " stalls the computer for an unpredictable time.

    Win 7 64 bit, Asus P6T SE, Intel Core i7 920, ATI Radeon HD 4800 series.

    C'mon Microsoft !

     

    Paul.

    Wednesday, August 18, 2010 4:34 PM
  • Looks like MS has no effect what we saY - All MS people sing one same song !! Regardless all the different H/w in the world - it is not their problem but Hardware vendors.

    Endless people and same problem esp the one with freezing and black screen

    http://social.msdn.microsoft.com/Forums/en/windowssearch/thread/17e1a927-7552-45d8-bfd2-503cc89dd1c7

    Hope someone can look into it seriously even MS PHONE SUPPORT ends the case by saying it is hardware issue on the brand new HP machines !!! Very interesting !!

     

    Wednesday, August 18, 2010 9:11 PM
  • if this  bug is still here then obviously MS dont care, And they wonder why people  like to pirate there OS's
    Wednesday, August 25, 2010 3:45 AM
  • I have two Dell XPS desktops, just got the second yesterday, and they both have the same problem.  Running Win7 Ultimate 64 on both.  Reinstalled (in a clean install) the Win7 OS in the older (one year old) desktop, problem continued.  I have tons of RAM and someone at MS once time told me that it's the large amount of RAM that seems to hang up the system.  By the way, I tried to upgrade my ATI Catalyst drivers, and just ended up with the desktop icons becoming huge....don't know what the problem is....ended up uninstalling the CCC.
    Monday, August 30, 2010 1:50 PM
  • I case someone from MS or a techie who knows this stuff is reading this, let me describe the symptoms in some detail:

    1. The screen saver is set to cycle through "My Photos" after 5 minutes of inactivity; then to require the logon password upon return.

    2. The Power Management is set to "never" turn off the screen or the hard drive

    3. If the computer is inactive for a short time (one or or so), and I move the mouse, the screen saver disappears, login screen appears, I log in and get the desk top in quick order, like it should be.

    4. If the computer is inactive for 2 plus hours, but less than overnight, and I move the mouse, the screen saver disappears, I can log in, but then there is a black screen for a while until the desktop finally appears.  The duration of the black screen is directly proportional to the time period during which the computer was inactive, ranging from one to five minutes.

    5. If the computer is inactive for overnight or longer, when i move the mouse the screen saver freezes.  Again, the duration of the frozen screen saver is directly proportional to the length of the inactivity - anywhere from two minutes to ten minutes or more.  Ultimately, the logon screen appears, and then after I log on, I go directly to the desktop (no black screen).

    6. I have two high performance Intel i7 processor desktops (one with 12 and one with 18GB DDR RAM), Dell Studio XPS 435 and 9100.  Both exhibit the same signs.

    Monday, August 30, 2010 9:04 PM
  • I am starting to see this issue crop up on more and more machines. I am also seeing black screen issues in the office after people rdp in from home. These black screen issues are really getting old.
    Friday, September 03, 2010 7:47 PM
  • this issue is not a microsoft problem it definitely is a hardware issue.

    In all the research and bug finding i have dune I have come to the conclusion that windows 7 is sound and this is not a bug in win 7 but more likely a  compatible issue with hardware witch who is to blame microsoft or the hardware manufactures, I think we should be more winging to hardware manufactures for a driver fix update.

    I have not found out which hardware is causing this but i have suspicions on power, getting the right amps ect to graphics card, ram processor on resume,

    People with home made pc's will suffer i think, there is just to much of a combination of hardware but if you have  purchased a pc pre installed with windows 7 then you should be hitting up the place you got it from and make them fix it.

    also find out if your main board is supported because i had a new main board asrock such and such which a got in 2009 new sorry i can't remember exactly what board it was but apparently windows 7 did not support the chipset of that board even though asrock had a bios update exlosively for windows 7. which maby micosoft should have had a warning or something stating that such and such chipset would not be support and may not work so then i would not have got it.

    Sunday, September 05, 2010 1:39 PM
  • this issue is not a microsoft problem it definitely is a hardware issue.

    In all the research and bug finding i have dune I have come to the conclusion that windows 7 is sound and this is not a bug in win 7 but more likely a  compatible issue with hardware witch who is to blame microsoft or the hardware manufactures, I think we should be more winging to hardware manufactures for a driver fix update.

    I have not found out which hardware is causing this but i have suspicions on power, getting the right amps ect to graphics card, ram processor on resume,

    People with home made pc's will suffer i think, there is just to much of a combination of hardware but if you have  purchased a pc pre installed with windows 7 then you should be hitting up the place you got it from and make them fix it.

    also find out if your main board is supported because i had a new main board asrock such and such which a got in 2009 new sorry i can't remember exactly what board it was but apparently windows 7 did not support the chipset of that board even though asrock had a bios update exlosively for windows 7. which maby micosoft should have had a warning or something stating that such and such chipset would not be support and may not work so then i would not have got it.

    And how exactly did you come to this conclusion?  I've had this problem on 4 different machines at this point, only one of which was built from components, and whose processor (an Atom, soldered into the mobo) did not even exist until long after Windows 7 was released (so if was not "compatible with Windows 7, what exactly was Zotac making that board to run???).

    I've also had the issue on manufactured Lenovo and HP systems, to which I did exactly zero in the way of hardware mods, and which were shipped with Windows 7 installed.

    Sunday, September 05, 2010 7:06 PM
  • Sorry 'mikekell',

    I've experienced this problem not only on my new ASUS laptop and my old Dell laptop, but on 2 other computers that don't belong to me - all with no unifying threads in terms of hardware between them. How could so many disparent systems be exhibiting the exact same symptoms - symptoms that respond to the exact same workarounds (disabling taskbar autohide or just preventing W7 from turning off the display, internal or external)? This is a Windows 7 problem pure and simple and Microsoft needs to do something about it.

     

    _sP_

    Tuesday, September 07, 2010 7:00 AM
  • this issue is not a microsoft problem it definitely is a hardware issue.

    In all the research and bug finding i have dune I have come to the conclusion that windows 7 is sound and this is not a bug in win 7 but more likely a  compatible issue with hardware witch who is to blame microsoft or the hardware manufactures, I think we should be more winging to hardware manufactures for a driver fix update.

    I have not found out which hardware is causing this but i have suspicions on power, getting the right amps ect to graphics card, ram processor on resume,

    People with home made pc's will suffer i think, there is just to much of a combination of hardware but if you have  purchased a pc pre installed with windows 7 then you should be hitting up the place you got it from and make them fix it.

    also find out if your main board is supported because i had a new main board asrock such and such which a got in 2009 new sorry i can't remember exactly what board it was but apparently windows 7 did not support the chipset of that board even though asrock had a bios update exclusively for windows 7. which mayby Microsoft should have had a warning or something stating that such and such chipset would not be support and may not work so then i would not have got it.


    ok, I would tend to agree with you EXCEPT if Vista or XP is loaded onto the exact same system it does NOT have these freezing/black screen issues only with Windows 7 so its only logical that Windows 7 has some extremely problematic bugs it experiences with the way the BIOS handles memory voltage and/or speed.

    It IS a Windows 7 software problem and IS Microsoft's fault to release this heinous buggy OS without resolving this issue by now with a hotfix that fixes it finally and forever.

    This OS is now approaching 1 year since retail release and still no hotfix or service pack to fix this extremely problematic problem.

    Windows 7 outside of this extremely volatile and data corrupting issue is a wonderful OS but this problem is a SERIOUS deal breaker if you experience it enough once u upgrade to 7 and start loosing data due to freezes and forced to hard reboot.

    This problem can be contained if you run the memory speeds @ 800mhz or lower in either DDR3 or DDR2 flavors. Which I have done and have had no problem at running the OS stably since February of this year (2010). We should not have to dumb down our hardware to accommodate software that is poorly coded however. It IS Microsoft's fault here not the hardware systems which come preinstalled with Windows 7 and are experiencing this issue never mind the Do-It-Yourselfers like myself.

    Monday, September 13, 2010 5:08 PM
  • After three full days of reading threads and forums and trying various solutions I have solved this problem for me but I'm afraid the cure will not help everyone.  I now believe there are many causes for this problem and more than one solution.  I had held out the most hope for Champignon's solution of shutting off the power saver for the monitor but that did not work for me.  I had already checked my BIOS and all my drivers and all were up to date.  I tried every combination of power settings there were and none helped.  I ran every fix it and trouble shooter I could find and none found any problem.  I tried safe boot and while I could not recreate the problem in safe boot it really didn't help me other than to eliminate some things it could of been.

    I should state I'm running Windows 7 on a Dell Inspiron 530S, 64-bit operating system with 4 gigs RAM.

    What resolved this problem for me was simply to remove Microsoft Silverlight.   There may be a bigger underlying problem yet to be resolved but at least by removing Microsoft Silverlight I have my computer back and can now use my power settings without locking up explorer and/or the entire machine.  If anyone has yet to fix this problem give this a try. I know it won't help everyone but if it doesn't help it is easy to reload.


    This is the first report I have read where turning off screen blanking did not work.  I can't be sure, but I wonder if you really understood the proposed "fix," and if you actually executed it as intended.  I don't say "as I intended," because as I have indicated previously, I did not find this fix, someone else did, and all I have done in this thread is to increase awareness of it.

    In order to execute the proposed "screen blanking" fix, what you need to do is to go into CONTROL PANEL, click on POWER OPTIONS, on the left side panel click on "CHOOSE WHEN TO TURN OFF THE DISPLAY," then select "NEVER" for "TURN OFF THE DISPLAY."  You will have both  "BATTERY" and "PLUGGED IN" options if what you are configuring is a portable/laptop computer, and you should select "NEVER" for both in that situation.  Then, click on "SAVE CHANGES" below.

    Perhaps I am wrong, however this fix appears to have worked for a whole lot of different computers running very different hardware, so you might have one where it does not work, but I sort of doubt it.

    As to Silverlight, I only have that installed on a couple of computers, and I have had either 2 or 3 computers that had this "freezing" problem without having had Silverlight installed.

    Wednesday, September 15, 2010 4:09 PM
  • I'm an old man and I do frequently have memory lapses but I an sure I followed your instructions to a "T" and it didn't work for me.  The only power settings that I left changed from the default was Hybred Sleep is turned off as is the Power saving setting for the network adapter. I left those off, both of which other individuals swore would fix the problem, only because I never turned them back on after trying and getting no results.  I did turn the Display power saving back on only because I wanted the monitor off when not using.

    As I stated I don't really think Silverlight was "THE" problem, I think it may be a combination of things, but removing it seems to have helped me at least for now.  If the problem does return for me the first thing I will try again is your Display Never power saving.

    Wednesday, September 15, 2010 5:06 PM
  • I deleted my prior post on what I thought was a possible problem resolution because the problem is back.  Sorry.  I did test it for almost 24 hours prior to posting, letting it sleep several times for over an hour and was able to bring it back up with no problem but now the problem has returned.  I wonder if the problem only persists during a certain period of  sleep time?  Anyway I did try turning the display power setting to never but I'm afraid that did not help me either.

    Where I'm at: The desk top screen does come back from sleep but I am unable to get back into explorer.  No message, no nothing.  So I try to power off, everything shuts down but the screen hangs on the final "Logging Off" screen and I can only shut down by using the power button.  Back to the drawing board.

    Wednesday, September 15, 2010 6:37 PM
  • In addition to turning the power saver (screen) to never, I also changed my screen saver to go blank and NOT require a password upon re-awakening. The problem has never returned.

    I never tried disabling the hiding of the taskbar because I want that facility.

    But I still want the problem solved.


    Seymour
    Wednesday, September 15, 2010 6:54 PM
  • I have the same problem and could have wrote the above post. No screen blanking and no problem.
    Thursday, September 16, 2010 11:11 PM
  • Ok, tested for two full weeks this time and my problem is solved.  Solved by going back and deleting one at a time all updates that had taken place in the 30 days prior to the power problems/ explorer freeze starting.  In my case it was a Webroot Essentials update, actually an upgrade, that was causing the problem.  Webroot could not solve and was not allowed to go back to prior version so I switched to Norton and all problems resolved.  All my power settings are back to default and working as they should. During this same time frame had also been having problems with the new Carbonite update and that added confusion to the problem, have now switched to Mozy.  Good luck to all.
    Wednesday, September 29, 2010 3:45 PM
  • Ok, tested for two full weeks this time and my problem is solved.  Solved by going back and deleting one at a time all updates that had taken place in the 30 days prior to the power problems/ explorer freeze starting.  In my case it was a Webroot Essentials update, actually an upgrade, that was causing the problem.  Webroot could not solve and was not allowed to go back to prior version so I switched to Norton and all problems resolved.  All my power settings are back to default and working as they should. During this same time frame had also been having problems with the new Carbonite update and that added confusion to the problem, have now switched to Mozy.  Good luck to all.


    Not every machine exhibits this "freezing" problem with Windows 7, and not every machine that has this freezing problem has the problem for the reasons that are the gist of this thread.  Windows 7 can presumably freeze for a variety of reasons and in your case it may well have been due to some ancillary software installed.  If this is the case, than you have not had the exact same problem we have been discussing in this thread, rather your machine has experienced something else.

     

    Good luck.

    Saturday, October 02, 2010 2:49 AM
  • I'm also having this problem on a X64 Intel 920 Win7, Nvidia GeForce 295GTX with all the latest updates and drivers.

    My problem began happening after I installed Civilization V, Steam, and its associated drivers.  I went back and re-updated the NVidia drivers but am still having the problem.

    I noticed that it indeed does happen when my copy of Norton kicks in with a background scan during the system idle/display sleep and I return from that sleep.

    A concurrent problem that arose at the same time is that very occasionally, the system display will go black (losing its signal) seemingly randomly - if I wait long enough, the display comes back and Windows informs me that the Nvidia driver crashed and has been restarted.

    Going with your disabling monitor sleep solution for now, thanks champignon for verifying I'm not insane and preventing me from cracking my case and checking every hardware connection.

    I'm not convinced this is a Windows solution - perhaps its an ATI/NVidia driver solution?

    Sunday, October 17, 2010 11:53 PM
  • Is the following related?

    http://support.microsoft.com/kb/976427

     


    Seymour
    Monday, October 18, 2010 12:06 AM
  • What i think is none of you have a dam clue why this happens.

     

    So i know im going against what im saying but someone has to.

     

    If you dont know how to fix this problem, then dont chat shite about registry keys and all the rest of it.

    If you had spare time over the weekend do some gardening insted of trying to impress people on here. please only post if you have a genuine fix, not some magic fix..

    Wednesday, October 20, 2010 1:17 AM
  • What i think is none of you have a dam clue why this happens.

     

    So i know im going against what im saying but someone has to.

     

    If you dont know how to fix this problem, then dont chat shite about registry keys and all the rest of it.

    If you had spare time over the weekend do some gardening insted of trying to impress people on here. please only post if you have a genuine fix, not some magic fix..

    Wednesday, October 20, 2010 1:17 AM
  • Wow, I honestly had no idea the problem has been going on this long, however I am kind of thankful because I thought it was something I changed in my system.

    Long story short, I've had my setup as it stands right now for almost a year with no problems at all:
    ATI 5750
    Core 2 Duo
    4gigs of G.Skill DDR2-800
    Windows 7 x64 Ultimate
    2 monitor setup

    The ONLY thing I changed was replacing my main drive and reinstalling Windows 7. I went from a WD Caviar black 640gig to a WD Caviar blue 1tb (I don't recommend Caviar Blue for a main drive btw lol). Once I made the new drive my main OS drive is when I started noticing this problem.

    I'm sorry to say I don't have a fix, but unless its my new hard drive causing the problem (i doubt it), than all I can think of is that I had something installed before that somehow prevented this. Even though my monitors would blank after an hour before (and come back with ease mind you), I'm wondering if my IM service (program constantly running/updating in the background) or, i've noticed some other people mention this, my taskbar program DisplayFusion was keeping my taskbar open on my second monitor and auto-hidden on my first, are all what kept my computer from doing what its doing now. As it stands right now i'm coming from a very fresh OS install, so other than my antivirus, I don't have ANYTHING in this computer.

    I'll see if I can report back once I install my IM service and DisplayFusion and see if i still experience the problem. Mind you these aren't fixes, but it at least give credence to the idea that its Microsoft's problem and not anyone else's.

    Unless you're all using Caviar Blue 1TB drives that is...

    Saturday, November 13, 2010 11:49 PM
  • just curious, was this ever resolved?  The only thing I have done was set my "Turn My Display Off" to never and so far it hasnt frozen up.  I have my screen saver (Bubbles) come on after 5 minutes.  Just to note, I replaced my Hard drive, changed from Win 7 Pro to Win Ultimate, went through various Dell diagnostics, ran CCleaner, Analyzed HDD, Defragged, antivirus, etc and it would still lock up after the screen turned off after inactivity.  I've also installed the most up to date drivers, updates.
    Wednesday, November 17, 2010 10:35 PM
  • Same issue here. Trying several different configurations to fix. I don't really want to leave my monitor on all day. 
    Friday, November 26, 2010 3:16 PM
  • Same issue here. Trying several different configurations to fix. I don't really want to leave my monitor on all day. 
    It seems one workaround (other than disabling turn off display) is to NOT have the task-bar auto-hide or use the clock gadget with the second hand.
    Sunday, November 28, 2010 4:30 PM
  • I think I have the same issue on my Win 7Pro x64. It just occurred again today. I have "turn off monitor after" and "go to sleep after" both set to 'never'. When I leave my computer for more than ten minutes I usually turn off my LCD manually, when I come back and turn it on again I have the screen, the mouse moves for a couple of seconds -can't do anything else- then it locks up completely. I'm not a 100% sure, but I vaguely remember as sometimes this bug occurs even if i don't turn off the screen, jut leave my rig alone for a while without user interaction.

    I never head my taskbar set to auto-hide.

    I have a Gigabyte GA-MA790FX-DS5 mobo, with several cpus (ahtlon4400, phenom9650, phenomII945), vgas (Sapphire 4850 Toxic, 5770 Vapor-X) ram modules (Geil 4*1GBs, Geil 4*2GBs) and hard drives over the years. The problem always remained.

    I have no other issue with my set-up. And I only have this issue when the computer is 'user-interaction free' for a while.

    I have windows updates set to manually, I have no scheduled task set up, I disabled search caching, prefetching, disk defragmentation... basically every process that I know of that would be ran by Windows on idle. I also noticed that rarely I still _hear_ the HDD reading/writing dispite all this on idle (my system runs from an SSD now). I suspect there are some hidden system/maintenance processes still present, maybe on of them is causing this bug

     

    Friday, January 21, 2011 5:43 PM
  • I too am experiencing the problem described in the lead post on this thread. It has been with me since I first observed it in Win 7RC. While there may be similar problems this one seems to be a function of returning from a screen blanking with auto-hide enabled on the task-bar. Reading the posts, I'd conclude that it is independent of cpu vendor, GPU vendor, and probably memory. I'm reminded of a sign which hung in a research lab, "Hundreds of experiments have conclusively proven that the beating of tom-toms causes the sun to come back after an eclipse." It's obvious to me that MR Softee (MSFT) never reads these threads, and denies the existence of this "feature". Thanks to this thread, I've turned off auto-hide. Where I used to freeze 2-5 times per day, I've now been failure free for 7 days. Thanks for telling me which tom-tom to beat upon.
    donw19
    Sunday, January 23, 2011 6:33 PM
  • It seems that not all users are helped by disabling auto-hide-taskbar and/or disabling screen blank after x minutes.

    Also: gpu type, memory type, have been cancelled out.

    Could it be that the harddisk type causes the delay? My disks are 5400rpm sata which is uncommon.

    Also: I use an adapter for DVI to DSUB VGA. Maybe this causes wrong communication between the monitor and system when returning from screen blank.

     

    Can other victims confirm either using 5400rpm disks or using an adapter between the system and monitor?

    Thursday, February 03, 2011 8:31 AM
  • Just thought I would wade in with another example of same problem, when screen has blanked and go back to use the machine, will freeze, (well actually run soooooo slow, that if I move the mouse of press caps lock, can take a minute or more to see any kind of movement, if at all) and end up just rebooting about half the time with a power button press.

    Machine is an Acer FO200 netbook, amd athlon x2 L310, ATI HD3200 vid and windows 7 x64. Three gig of ram installed. This issue is really starting to become a major problem. 

     

    Thursday, February 03, 2011 9:17 AM
  • Sorry, I have a 64GB Kingston SSD, and a direct DVI-DVI connection between my Ati VGA and Dell (2009wfp) monitor. See more at my previous comment @Friday, January 21, 2011 5:43 PM.
    Thursday, February 03, 2011 9:28 AM
  • Sorry, I have a 64GB Kingston SSD, and a direct DVI-DVI connection between my Ati VGA and Dell (2009wfp) monitor. See more at my previous comment @Friday, January 21, 2011 5:43 PM.

    Thanks, that eliminates my suggestions for HDD type and VGA adapter causes.

    Someone noted McAfee as a possible culprit. I am using Avast's latest free edition. Maybe any similarities in that corner?

    Thursday, February 03, 2011 10:05 AM
  • Nope - recently swtiched to security essentials after ditching avg

     

    Thursday, February 03, 2011 11:15 AM
  • The following fixed the problem for me.

    http://support.microsoft.com/kb/2300639


    Seymour
    Thursday, February 03, 2011 1:00 PM
  • Regarding the choice of disk drive -- I had the problem with a MAXSTOR drive at 7200 RPM under W7 RC.  And also with a WD drive at 7200 RPM.  I Never got into the WD "Green drives" at 5400 or 5900 RPM until well after W7 was released.

    As for Anti-virus:  I ran without any antivirus software for the last 3 years.  I installed Microsoft Security Essentials in September of 2010,  but the problem was with me since the RC in Summer of 2009.

    Since turning off Auto-Hide, I've run trouble free for two weeks, and my baseline is about 2-3 freezes per day of use.

    I'll try the fix in kb 2300639 next, and if it is benign, I'll re-enable the auto-hide functionality.

     


    donw19
    Thursday, February 03, 2011 9:51 PM
  • Just to let you all know, Have applied the same hotfix, KB2300639. Will report back and let you know if this has resolved my issue. The description of the symptoms seems to match my experience so will see. FTR - Acer FO200 netbook with (now) 4gb of ram and X64 installed. 

    Friday, February 04, 2011 7:09 AM
  • I had the same problem. I think that it was indeed enabling the Auto Hide that started it. Turning off the monitor blanking function in the power settings seems to have fixed the issue for me - an easy workaround that I am surprised is not on the linked hotfix page.
    Wednesday, February 09, 2011 5:31 PM
  • The following fixed the problem for me.

    http://support.microsoft.com/kb/2300639


    Seymour

    Why not try the hotfix described above? I have kept auto-hide ON and have had no problems in the last 10 days.
    Seymour
    Wednesday, February 09, 2011 6:04 PM
  • I've had this problem on our two hp dv8t pc's running Win7 Ultimate x64 since we got them in Sep 2010.  I got nowhere with any warranty or vendor help.  After a couple of weeks of this hell, I tried putting a gadget clock on the desktop.  This actually works!  One big problem with this solution is that there also is a severe memory leak in sidebar.exe, and if the second hand is selected you can kiss about 1 GB RAM up per day.

    I just saw your posting to see http://support.microsoft.com/kb/2300639 .

    That exactly describes my problem, and I applied the fix on the 2 pc's.  So far, OK.

     

    Thanks.

    Lester

    Monday, February 14, 2011 12:05 AM
  • I just saw your posting to see http://support.microsoft.com/kb/2300639 .

    That exactly describes my problem, and I applied the fix on the 2 pc's.  So far, OK.

    I now consider the problem eliminated  Since I applied the hotfix, everything is back to normal for me.


    Seymour
    Monday, February 14, 2011 12:11 AM
  • I just installed sp1 the other day.  I am unable to apply the hotfix kb2300639... I'm assuming since it is included in sp1.  I still have freezes, despite any combination of things I try to do.  Technical support from HP insists I have a "unique" case but the examples described in this thread are similar to or the same as what I am currently experience.  Given that I've followed this thread for the last couple weeks with no true success of my own than say a delayed freeze here and there, if anyone is able to find a true resolution to this problem please post it. I'm really more frustrated than ever with this.

    Friday, February 25, 2011 1:19 AM
  • I am soooo glad I am not the only person with this issue. My issue couldn't be described more perfectly than what Champignon initially described as they are the EXACT same. I have read all the posts from everyone. Here is my two cents. I have the same issue on a desktop but am doing the base troubleshooting on a laptop. System specs: Dell D630, Win 7 Pro SP1 x86, nVidia video card, (origionally) 1GB DDR2 PC5300 (667MHz) RAM, using laptop monitor only, all sleep/hibernate/disk options disabled, USB selective suspending disabled, I did use the "turn monitor off after 20 mins" option, Trend Micro Officescan corporate AV. I have a lot of laptops with this configuration some with XP and others with Win7 Enterprise/Pro. No screensaver in use. All drivers up-to-date from Dell site. Auto-hide not used. No Silverlight installed. Same as other report that the longer the idle the longer the recovery tim (5mins - 30 mins). The issue is not present on all D630's with Win7 x86 installed. In fact I have seven D630 Win7 laptops (x86) with either Pro or Enterprise installed, each with only 1GB RAM, and this is the only laptop with any issues. The other can be turned on for weeks and run nice and smooth.

    Initially, I though 1GB was just not enough memory even though other laptops work fine; so I pulled the 1GB stick and added (new) 2 x 2GB (PC5300 DDR2 @ 667MHz) sticks (as well as updated the system BIOS to the latest revision A17... issue still there. Removed 2GB leaving the other 2GB stick in place... issue still there. Swapped the 2GB stick with the other 2GB stick... issue still there. Definately NOT a memory issue. Attempted applying the hotfix described in the thread but got the message "update not applicable" because I'm on SP1. Used the "turn monitors off = disabled" and the system has been working perfect for a week and I just close the lid at night. Turned off the same feature on desktop and issue is gone away there too; desktop has an ATI video card so it's definately not limited to nVidia. Changing the "Turn monitors off" setting to "Never" seems like the only workaround for now.

    One person on another blog had an interesting suspicion as to the root of the problem. It was regarding power management of the video card itself (which there is no manual control over, all OS managed) when the monitor is automatically turned off. They suspected that the video card itself for whatever reason wasn't receiving the proper wake-up commands from Win7 upon resume, therefore causing the freeze. Not a solution but an interesting suspicion as to the problem. I mention this to highlight it not being a hardware specific issue and a software one as the other 6 laptops have the exact same hardware specs (with less RAM) and they work perfectly.

    Friday, March 11, 2011 5:20 PM
  • Well, it now been six days since I change the "turn monitors off" feature to disabled and the computer hasn't so much as stuttered since. Solid, stable, no reboots since and she's working perfectly. I hope MS fixes this so I can re-enable the feature.
    Thursday, March 17, 2011 2:01 PM
  • is your system able to do recovery discs of so try to reimage  then flash the bios chipset drivers video audio are you running virtual if not go into bios and disable it at this time down load the sp1 for seven
    Sunday, March 20, 2011 9:42 PM
  • I just had the issue re-occur again. I did not turn the feature "Turn monitors off after xx minutes" on again but what I did do was lock the computer for the night. I was able to repeat the problem by locking again and leaving it for roughly two hours. I hadn't locked it previously during my tests but am going to try not locking it again for the next few days. Not a solution, just another piece of the puzzle.
    Thursday, March 24, 2011 9:36 PM
  • go into your bios settings advanced and disable your virtual machine  as the video will corrupt on sleep and hybernate causes grief on seven ultimate i trust you have a 64 bit  machine also i see you updaqted the bios i have to question your antvir? if norton its bloated soft ware griefs the drive  what is the make of your pc please tell me its not acer or hp or gate way if so get rid of the back door in bios will clean up alot of your issues
    Saturday, March 26, 2011 5:29 AM
  • ????Possibly Resolved???

    So, I may have resolved the issue by accident when resolving a different issue altogether. I was getting some "Service Control Manager | 7011" errors in the system log. Some were to do with "brwoser service" timeouts, some were regarding "wuauserv" serivce timeouts... long story shorm there were a lot of SCM | 7011 errors regarding a lot of services. Then I flipped over to the application log and I found a lot of warnings regarding Windows search, indexing of offline files. The timing of these errors were loosely corresponding to the times of the system freezes. So I went on to tackle getting rid of these warnings.

    One article I read said that these errors could have to do with indexing of .xml and .xlxml file types and therefore recommended removing these from being indexed. In hindsight I should have made only this change and checked to see if the warnings continued... however I did proceed without testing as the warnings also listed the affected SID's it was throwing warnings about. Reverse enginerring the SID'd identified them to be for test users that haven't logged into the system for a lon time; additionally there profiles had also been deleted too; C:\Users\%username%. So I searched the registry and deleted EVERYTHING associated with those SID's (users) particulary those located under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList. Then I went into SyncCenter and purged the cache to rebuild on next logon. All the Windows Search AND Service Control Manager warning/errors then ceased after I rebooted and purged (and haven't come back since).

    Then, just for giggles, I re-enabled the "Turn monitor off after 20 minutes" feature just to see what would happen. My computer has now been up for 7 days, 20 hours, 30 minutes without even a hiccup. TOTALLY RESPONSIVE ALWAYS!

    I am now going to re-enable the indexing of the xml and xlxml files to see if the issue returns. Keeping my fingers crossed on this one! I'll report what happens soon if the issue re-occurs or in a week or so if it doesn't!

    Tuesday, April 12, 2011 4:59 PM
  • Here is a website that has lots of information on this problem. Certainly worth a read. Resume from idle freezes


    MyPcHealth ------ Some Free Tools
    Wednesday, April 13, 2011 9:55 AM
  • Hi Chunks_

    Unfortunately I looked through all of those before grasping at additional straws before coming to my conlucions and fixes. Good news is though that my Win7 system has now been up for 10.5 days with all power features enabled (minus hibernate/sleep) and haven't had a single reoccurance of the issue. Still keeping my fingers crossed but am getting very hopeful that this was "the fix" needed. Previously I had tried patches, driver updates, hotfixes, BIOS updates, increasing RAM, removing various software to strip it down to bare bones and nothing had helped. But he steps I mentioned in my "Possibly Resolved" comment have been utmost fruitful so far:)

    Thursday, April 14, 2011 8:47 PM
  • Up for your consideration:

    2 machines with exactly the same hardware same applications, programs and drivers. Both running same version of Zone Alarm with tight security settings.

    Machine #1 running an older version of Windows 7 Ultimate  64bit, with sleep and display-off DISABLED totally, and automatic updates DISABLED. Machine #1 never freezes.

    Machine #2 running a newer version of Windows 7 Enterprise 64bit, with sleep and display-off DISABLED totally, and automatic updates ENABLED.  Machine # 2 freezes after 2 hours of non-use.

    Machine #2 also shows heavy hard-drive accessing and network accessing even when idle.

    Obviously a Microsoft issue.

     


    Tuesday, April 19, 2011 3:47 AM
  • Woo hoo! It's been a number of weeks now and I haven't had the issue re-occur since. Anyone else with this problem please try my suggested fixes.
    Friday, May 13, 2011 4:49 PM
  • Hi LoserDave,

    Please try my suggestions with the Windows Search trying to index orphaned profiles that's local profiles no longer exist on C: and then cleaning them out of the registry too as well as re-initializing your offline cache through sync center. I had the exact same symptoms as you with huge amounts of HDD activity even when idle. I cleaned the issue up on 2 systems that were experiencing the problem of six total systems that had Win7 (Pro & Enterprise mix) installed on identical hardware where 4 of the systems didn't have the issue.

    Friday, May 13, 2011 5:09 PM
  • I gave up trying these possible fixes months ago, did not help any of them. Yet the problem disappeared "on its own" a few weeks ago for me, too. I'm fairly sure one stability update fixed it, maybe one that's part of SP1.
    Friday, May 13, 2011 8:24 PM
  • The following fixed the problem for me.

    http://support.microsoft.com/kb/2300639 and is included in SP1.


    Seymour
    Friday, May 13, 2011 8:45 PM
  • Just a note that I had the problem both pre and post SP1 installation.
    Wednesday, May 18, 2011 4:29 PM
  •   Hi Ben. Can you explain your fix more clearly? MY english is not so good. In my users folder I have 3 folders. My profile, default and common folder. (its name can be "public", dont know what is in english)

    Which folder should I delete?

    In registry under profilelist folder, I have 4 key and 4 sub folders.

    And please describe how to clear your cache in synccenter.

    I have freeze problem since I install windows 7. I turned off power settings, and monitor settings but nothing worked. Problem was occuring when I left my computer idle for 2-3 hours, but today windows freezed when I use it. Not after being idle or inactivity. Now I am looking for a serious fix...

     

     Do you have any freeze problem after your "possibly resolved" message since  April 12 ?

    Thanks , and sorry for english.

    Monday, May 23, 2011 3:21 PM
  • Hi Caksoy,

         I'll have to do up a detailed explanantion as to the exact steps for you that I took to resolve the problem. This will take a couple days so patience please :)

         I haven't had a single freeze since my last reboot of my computer 25 days ago after installing some regular windows updates. It had been quite a number of days prior to that too since I had any issues as well. On another system that was experiencing the same issues I ran the same fixes on that one an it ceased to be problematic as well.

         Hold tight and I'll get a detailed description for you of exactly my process.

    Cheers,
    Ben

    Tuesday, May 31, 2011 8:44 PM
  • Hi Caksoy,

         So here's hwta I did to resolve the problem.

    1. Went through the event log, at first I wasn't getting any significant errors but hen I started receiving System Log\Service Control Manager\7011 errors on pretty much every service there is. There were also some 7000 errors regarding the browsing service.
    2. Then I flipped over to the application log and I found a lot of warnings regarding Windows search service and the indexing of offline files. Two user account SID's were consistently brought up. Looking up the two SID's I found that those were both SID's for user accounts that were a) both Active Directory user accounts used for testing, and b) accounts that I had deleted the local user profile folder (C:\Windows\Users\%username%) but hadn't removed the corresponding key from HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList.
    3. One article I read said that these errors could have to do with indexing of .xml and .xlxml file types in and therefore recommended removing these from being indexed (the one setting if for all local files as well as offline files cached. In hindsight I should have made only this change and checked to see if the warnings continued... however I did proceed without testing as the warnings also listed the affected SID's that the application log was throwing warnings about.
    4. Basically, I copied and pasted the SID's into notepad and then performed a search through the registry and deleted ALL corresponding keys to the referenced SID's.
    5. Then, bacause I use folder redirection fo rhte My Documents folder,  I rebuilt the offline cache from SyncCenter: Control Panel /  Sync Center / Manage Offline Files / View Offline Files / Opened the offline files for the (now) ghost users that corresponded to the SID's / Clicked to highlight each of the following folders; My Documents, My Music, My Pictures, My Videos; then right-clicked on each of the folders and selected "Delete offline copy".

      Alternatively, to just delete and rebuild the complete offline cache for all users en-mass for the machine you can open the regoistry and navigate to:

      HKLM\System\CurrentControlSet\Services\CSC\Parameters\
      Create DWORD Value: FormatDatabase
      Set DWORD Value FormatDatabase to 1
      Reboot
      to make the magi happen

      This setting can also be automated by running the following command
      REG ADD "HKLM\System\CurrentControlSet\Services\CSC\Parameters" /v FormatDatabase /t REG_DWORD /d 1 /f
      Reboot
      to make the magi happen
    6. I rebooted the systems
    7. I then re-enabled the indexing of the .xml and .xlxml files. I don't think it was necessary to disbale this setting in the end as it is now working perfectly with the actual users that DO log into the machine.

    Hope this helps!

    Ben

    Monday, June 06, 2011 5:02 PM
  • Hi Caksoy,

         So here's hwta I did to resolve the problem.


    1. Alternatively, to just delete and rebuild the complete offline cache for all users en-mass for the machine you can open the regoistry and navigate to:

      HKLM\System\CurrentControlSet\Services\CSC\Parameters\
      Create DWORD Value: FormatDatabase
      Set DWORD Value FormatDatabase to 1
      Reboot
      to make the magi happen

    Ben, I have exactly the same problem as stated above, which only started occurring few weeks ago.
    Blank screen when going into stanby/sleep mode after certain time or pressing the power button.

    I wasn't sure about step 1 to 5. Main problem for me is identifying the SID from the log and which item exactly to delete. Don't want to mess the registry up. Any chance you could explain it in slightly more detail please?

    Anyway, I thought I could skip these steps and do the quoted txt above.

    I did, and it gave me a blue screen when I rebooted and had to rebuild the start up files as it has been corrupted.

    Any clue why that happened?


    When I tried doing it in CMD, it gave: Error: Access is denied.

    Please help! =(
    The problem is still persisting.
    Do you mind if I can contact you through other means please?

    Wednesday, September 14, 2011 11:20 PM
  • Hi Josh,

         Sorry for the delay in response. I don't seems to be receiving notifications on replies to this post.

         Steps 1 - 5 were my order of operations in finding the cause.

         I don't have a copy if the logs handy anymore so you may have to bare with me as I work from memory. To identify the correct SID, locate the csc (Client Side Caching) error in your event log. Contained in the error, first line if I remember correctly, it will show a path in the format of csc://xxxxx-xxxxxx-xxxx. Where the "x's" are will be the identifying SID. Copy the SID to your clipboard and then perform a search through the registry for that specific SID. It may be a local user account or a domain account where the C:\Users\%username% profile folder has been deleted from the file system but the registry entries are still present telling the CSC to index that location which no longer exists. Remove the registry entries and you remove the issue (at least in my case). My system can now run for 45+ days without any issues at all :)

         I would be surprised if formatting the CSC database would cause a BSOD as it's just the offline cache of files... but, you never know.

         If you're getting an Access Denied message from the command prompt I would suggest opening the key in regedit, verifying the permissions (adjusting if necessary to give you Full Control), change the DWORD value manually and rebooting.

         If you have an email address you could post for me I can contact you outside of the forum as well if desired.

    Wednesday, September 28, 2011 7:11 PM
  • Hi Ben,

    Thanks for your reply!

    Would you be able to drop me an email to (josh(.)yap(at)gmail(.)com) (without brackets) please.

    Thank you!

     

    Monday, October 10, 2011 8:26 AM
  • Yep, me too, I'm on SP1 and so far the only solution I have is the workaround of not turning off the screen.

    This and the amount of CPU time that Win7 uses to run the OS makes this the least eco friendly OS available.

    Thursday, October 20, 2011 11:43 AM
  • Hi There Champignon

    I am having the same problem but found if my task bar is in hide mode, I leave the mouse on it so it is always up and it eliminates this problem.

     

    gregoryd

    Saturday, October 22, 2011 5:46 PM
  • Hi Josh,

         Message sent last week. Sorry for the delay as I don't seems to be getting notifications on replies to my messages.

    Cheers,
    Ben

    Monday, October 24, 2011 9:29 PM
  • I was having this same issue on my Samsung laptop, running Win7 Home Premium 64-bit, and I had tried all the solutions that I found posted on multiple forums - disabling the USB suspend setting, disabling my monitor from going to sleep, or dimming, and none of those options had worked for me.  I started to notice when I was having the freezing issue with my mouse, and it happened when I was using the internet.  I use FireFox as my preferred browser and I was on version 8, so I uninstalled FireFox, restarted my laptop, then downloaded the latest version, which is 9 now, and so far that seems to have fixed the freezing issue.  In my case it seems the problem was with the software I was using and not the Win7 OS itself, but time will tell...
    Thursday, December 22, 2011 11:44 PM
  • I'm no technie, but people seem to be replying to two separate issues here. The original post was about the video freezing up on resume, but many posts have been about the computer freezing up. The video issue just happened to me, on a bog-standard dell laptop. I think it's irrelevant to describe the specs, as computers with every spec under the sun have been included, although many refer to the computer freeze rather than video freeze - or maybe posters are just using the times interchangeably, which they shouldn't, they are different issues. My computer froze, I'm sure for an unrelated issue, during shutdown, and was finally shut down down using the power switch. That meant, given teh video issue I couldn't access the computer because although it was restarting in resume, both resume and startup require a password, and there was no screen to type the password into. Of course I didn't know the computer had actually started, it just seemed totally frozen. Fortunately a post above alerted me to the fact that the computer had actually started, it was just the screen. This is why differentiating between computer freeze and video freeze is important in this thread. Knowing that, and being fortunate to have a fingerprint reader, I could enter a "password" without seeing a screen. I then used control-alt-delete to shut down, then restarted. As hoped for, the computer restarted on the black screen with a message about their being an issue with prior restarts from Resume, and I switched to restart from boot. Computer started with no problems, with video. The computer used the same hardware and settings but different start programs - this is also the case in the posts above - yet can have different, and consistently different, results. This doesn't suggest any sort of hardware problem. However, it could be that the more complicated the start-up, or shut-down - screensavers, auto-hide, different video controls for discrete and on-board video etc, the more likely that an idiopathic logjam might occur, and so changing or simplifying this process may resolve the issue, regardless of the specific change.
    • Edited by pemburung Tuesday, February 14, 2012 7:22 PM
    Tuesday, February 14, 2012 7:18 PM
  • I've had this problem since day 1 (win32, enterprise) with my laptop. I have a few different issues, but generally it's just failure to offer the login screen after the computer has been 'locked' (sometimes I just see "locking your computer" and in this case a hard reboot is necessary).

    I don't have the problem on same machine (hp elitebook 8530p) with 64bit prof.

    None of the fixes here resolve the issue (screen saver, turn off screen etc). 

    I have reverted to a (insecure) work-around to prevent loss of work out of frustration:

    copy cmd.exe sethc.exe (you need to do this as administrator, in fact I did it booted via USB into linux, backup your old one first:)

    when it locks up, 99% of the time if you hit the shift key 5 times (now executes cmd.exe instead of sethc.exe, and you can BTW also change a forgotton password here:) you will get a DOS prompt, then type:

    c:\windows\system32> taskkill /im logonui.exe /f

    The login screen is now presented and you can login.

    Seems to me that the logonui.exe is the issue, it crashes/gets into some sort of state. hth some people.

    Wednesday, February 15, 2012 3:49 AM
  • Hi,

    I too am having the exact same symptoms as this. I have a HTPC with an AMD Athlon II 250, Gigabyte MB and 4GB of DDRII 1066 Ram. The only problem I seem to have with my setup is this freezing issue once I move my mouse to bring my screen back after it's been blanked.

    I'd love to know the solution but for now I guess I'll use the work around of disabling screen blanking, just use the screen saver, screen blanking is of no use to me on this particular PC as my LCD TV doesn't turn off, just sits there with "No Signal" flashing across the screen.
    So i also have this issue with Win 7 enterprise 64, but my issue just started yesterday when i replaced one of my two 22 inch displays with a new 32 inch lcd tv, this issue has never occurred before this, and i have had the same build for 2 years now, only difference is the new lcd tv as a display. 
    Wednesday, April 18, 2012 11:03 AM
  • Similar problem to Champignon, ie after 20-30m of idle, mouse initially responsive & then freezes, "e.g. you can move the mouse cursor around the screen(s).  After anywhere from a few seconds to perhaps as much as 20 seconds, the mouse becomes frozen and won't move anymore.  At no time from when the system was "woken up" by the mouse, can you do anything with the mouse or keyboard, e.g. any attempts to click on an icon on the desktop, to start an application, even during the short period when the mouse will move, has no effect".

    Tried many of the recommended fixes, but none worked.

    What worked for me was turning off System Protection.

    Right click on "Computer" select "Properties" select "System Protection"select "Configure" select "Turn off system protection".

    WARNING; ALL YOUR SYSTEM RESTORE POINTS WILL BE DELETED

    Since turning off System Protection, I have had no more freeze ups.

    Thursday, May 24, 2012 12:34 AM
  • Hi everybody,

    I had the same problem of video freezing after resume. Just a few weeks ago everything was ok but suddenly it started after a few modifications and software upgrades. I knew that it was not related to any of drivers or hardware issues because my laptop (HP Pavilion DV6) was working smoothly with no problem. After searching tons of blogs and forum sites with no success I decided to use system restore to roll back to very last good situation, and I did it many times cycling through every restore point but nothing changed! At last I tried to uninstall every program I recently modified or upgraded and at last I found the guilty one. BABYLON 9 !!!

    Exiting from Babylon, (not uninstalling!) solves my problem. Every time I use it I have the same problem of freezing after resume or blank screen. May be useful for somebody J .


    Thursday, May 31, 2012 2:46 PM
  • I'm simply astonished how many people are having this issue, and yet so many different variables as to what could be causing the problem.  I posted on another thread relating to this issue, and I figured I'd post here too.

    Originally I thought I had my issue of freezing after screens go blank by simply removing that setting.  It seemed to of fixed the problem for a whopping two weeks or so, and the issue has returned.  But the problem seems to have gotten worse being that I'm getting freezes during use on the computer and not just when the screens go blank.

    I feel for everybody that is experiencing this issue.  Has anybody else come across a valid solution or an idea as to what is really causing the problem?

    Cheers,

    Thursday, June 28, 2012 5:31 PM
  • Have we all given up on this issue? *sigh*
    Tuesday, July 03, 2012 5:35 PM
  • Thank you for this answer. I,ve been looking for this answer for awhile. It works....lol
    Monday, October 29, 2012 12:57 PM