none
Always Ask Before Opening This Type of File RRS feed

  • Question

  • This is the message most users get when they double-click an attachment in Outlook. In our case, Outlook 2019 (x64) on Windows 10 (1809). And although I'm most of the time logged in as a regular user, I don't get this message opening attachments. Weird. Some colleagues like to get rid of this message, which I thought would be easy - a check mark somewhere in Outlooks Options. Not so. It turns out a Windows thing. Now disabling this message in Outlook is pretty easy, although kinda weird. Start Outlook as Admin, double click attachment and then clear the check box.

    Now for the opposite - I want to switch it ON again. I managed to turn it back on for some file types, like PDF. This involves setting / changing a registry key (see http://www.slipstick.com/problems/disable-always-ask-before-opening-dialog/). We use Foxit Reader and in that case have to change HKEY_CLASSES_ROOT\FoxitReader.Document Reg-Dword EdiFlags to 0. And that does the trick - Outlook again pops up the 'Always Ask Before Opening This Type of File' window.

    Not so for Word documents, whether they are .doc or .docx. Changing the registry value for EditFlags doesn't change anything. For newer versions of Word, this value is listed in several locations, so I set all of them to the same value. But nope, doesn't make a difference.

    There are also posts suggesting removing 'HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\AttachmentExecute' will do the trick, but it doesn't.

    So how do I get this prompt back on for Office documents?


    Simon Weel



    • Edited by Simon Weel Thursday, June 18, 2020 2:21 PM
    Thursday, June 18, 2020 2:20 PM

All replies