none
Remote Desktop Connection Mouse Slow with Windows 2012

    Question

  • Hello:

    I am connecting to a customer site with Citrix and using Citrix's Remote Desktop. I know this may be a Citrix issue but not sure. Customer isn't helping so thought I would check here.

    I have two connections to computers in their network with Remote Desktop. One is to a Windows 2003 Server which works fine. When I connect to Windows 2012 the mouse is slow. I tried adjusting the mouse settings but it doesn't help.

    Has anyone else experienced this? Is it an issue specific to Citrix or to Remote Desktop in general?

    Thanks,

    Wednesday, January 29, 2014 7:26 AM

Answers

  • I'll answer my own question here. I turned off the mouse pointer shadow in the mouse settings in control panel on the remote server. Mouse is working normal now. It seems the mouse pointer shadow behaves differently in Remote Desktop than when using normally. When I search the internet it seems that turning off the pointer shadow has been a recommendation for years with Remote Desktop--I don't remember running to that issue though.

    Tim/Dharmesh: Fair comment. I was just trying to say that there is a difference between me saying "this may be a Citrix issue" to someone on Microsoft staff making a definitive statement that this was "mostly" a Citrix issue. I was curious how Dharmesh came to that conclusion.

    • Marked as answer by urbanmojo Friday, January 31, 2014 4:51 AM
    Friday, January 31, 2014 4:51 AM

All replies

  • check out this blog, it's for virtual PC though but also using RDP.

    just try it out whether it helps or not

    http://mattrefghi.com/blog/solutions/virtual-pc/slow-mouse-when-controlling-a-virtual-pc-through-remote-desktop/

    Slow Mouse When Controlling a Virtual PC Through Remote Desktop

    1. Right-click the Desktop, and select Properties.
    2. Move to the Settings tab in the Display Properties dialog.
    3. Click the Advanced button.
    4. Move to the Troubleshoot tab in the Monitor Properties dialog.
    5. Move the Hardware acceleration slider all the way to the right, so it is right next to Full.
    6. Click OK in the Monitor Properties dialog.
    7. Click OK in the Display Properties dialog.


    Every second counts..make use of it. Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.


    • Edited by cguan Wednesday, January 29, 2014 9:00 AM edit
    Wednesday, January 29, 2014 8:57 AM
  • Hi,

    As this issue represent mostly for Citrix side, you can contact to Citrix Support for help. In addition, for you suggest to try with latest Citrix receiver if it resolve your issue.

    Hope it helps!

    Thanks,
    Dharmesh

    Thursday, January 30, 2014 2:40 AM
    Moderator
  • Dharmesh...can you provide proof that this is a Citrix issue? And if it is "mostly" a Citrix issue, that means it is "partly" a Microsoft issue. Any idea what I can look at in Windows?
    Thursday, January 30, 2014 2:49 AM
  • "can you provide proof that this is a Citrix issue?"

    Urbanmojo, even you open with the statement "I know this may be a Citrix issue but not sure", therefore, it only makes sense to also check with Citrix.

    I use Microsoft's remote desktop connection to manage all my Windows Server 2012 installations, and I have never experienced the problem you are describing.  Does that mean that it is not a Microsoft issue?  No, but since there are few reports in this or other forums of anything like what you report, it tends to minimize the possibility.  Cguan did provide something for you to try which worked for a different but similar sounding problem.

    To pursue the Microsoft problem investigation (while you simultaneously pursue a similar line with Citrix), it would be helpful if you were to give a description of your environment and the actual versions of programs, including the Citrix Remote Desktop, that you are using.


    .:|:.:|:. tim

    Thursday, January 30, 2014 2:31 PM
  • I'll answer my own question here. I turned off the mouse pointer shadow in the mouse settings in control panel on the remote server. Mouse is working normal now. It seems the mouse pointer shadow behaves differently in Remote Desktop than when using normally. When I search the internet it seems that turning off the pointer shadow has been a recommendation for years with Remote Desktop--I don't remember running to that issue though.

    Tim/Dharmesh: Fair comment. I was just trying to say that there is a difference between me saying "this may be a Citrix issue" to someone on Microsoft staff making a definitive statement that this was "mostly" a Citrix issue. I was curious how Dharmesh came to that conclusion.

    • Marked as answer by urbanmojo Friday, January 31, 2014 4:51 AM
    Friday, January 31, 2014 4:51 AM
  • Dude, you nailed it!  Turning off the mouse shadow in an "RDP over ICA" session to a 2012 server resolves the slow/jittery mouse issue.  Glad I found your post.

    Nice job!

    Jacques.

    Thursday, March 20, 2014 6:04 PM
  • Thanks, this has been bugging me too for quite a while. Problem solved, you saved my day :-)

    Wednesday, March 26, 2014 11:12 AM
  • Please try this options > changing the Windows Aero (System Scheme) to Windows Standard (large) in mouse pointer settings . Thank you.
    Wednesday, June 11, 2014 3:30 AM
  • Thanks so much! Ive been dealing with a laggy mouse pointer on RDS connections to Server 2012 for ages and your tip has finally fixed it for me. I don't know why I never heard of this before.
    Friday, March 27, 2015 2:18 PM
  • This worked like a charm on remote connection. Have a normal fast moving mouse.

    SOLUTION:

    In Windows Search (Start button) type

    CHANGE MOUSE SETTINGS--> POINTERS tab ---> SCHEME dropdown ---> Select Windows Standard (large) (System Scheme)

    CLICK APPLY

    Done :) !!!!

    THank you

    • Proposed as answer by Pranee Jonna Sunday, April 26, 2015 3:29 PM
    Sunday, April 26, 2015 3:29 PM
  • thanks for the solution. Now mouse works fine on windows 2012 server.

    We do not have citrix in our environment. But we would see this issue of pointer being painfully slow when we mstsc into windows 2012. So i think it is a windows issue.


    Tuesday, July 14, 2015 4:29 PM
  • Awesome, this been driving us crazy :) thanks for the tip!
    Tuesday, October 27, 2015 7:40 AM
  • Thanks for the help, it worked !!

    Tuesday, December 01, 2015 6:34 AM
  • I'll answer my own question here. I turned off the mouse pointer shadow in the mouse settings in control panel on the remote server. Mouse is working normal now. It seems the mouse pointer shadow behaves differently in Remote Desktop than when using normally. When I search the internet it seems that turning off the pointer shadow has been a recommendation for years with Remote Desktop--I don't remember running to that issue though.

    Tim/Dharmesh: Fair comment. I was just trying to say that there is a difference between me saying "this may be a Citrix issue" to someone on Microsoft staff making a definitive statement that this was "mostly" a Citrix issue. I was curious how Dharmesh came to that conclusion.

    Thank you!!! you helped me a lot, have a great day sir :)
    Monday, January 23, 2017 2:21 PM
  • Thank you!

    This was affecting me when connecting to Windows Server 2012 R2 through VMWare Horizon. So I don't think it is specifically a Citrix issue. I don't have the problem when I connect to other 2012 R2 Servers on the LAN or through VPN though. I honestly don't understand why this works but it magically fixed the problem.

    Wednesday, April 12, 2017 12:52 AM