locked
Virtual Machine Wizard RRS feed

  • Question

  • I am currently running Windows Virtual PC with XP Mode all is working great. I am trying to add or upgrade my other vhds and I cannot find the create virtual machine wizard or add virtual machine. When I follow these instruction :
    To create your own virtual machine
    1. Open the Virtual Machines folder. From the Start menu, click Windows Virtual PC. If the menu item is not visible, click All Programs, click the Windows Virtual PC folder, and then click Windows Virtual PC.

    2. The Virtual Machines folder opens in Windows Explorer. From the menu bar, click Create virtual machine.

      "Create Virtual Machine" is not there, what am I doing wrong or what steps have I missed?

    • Edited by Scott Keller Thursday, February 11, 2010 3:40 PM
    Thursday, February 11, 2010 2:39 PM

Answers

  • Try this:
    http://smudj.wordpress.com/2009/12/29/missing-create-virtual-machine-in-usernamevirtual-machines-folder/

    Below is the fix for the virtual machines folder for WinVPC when the folder here “%username%virtual machines” is missing the “Create Virtual Machine” option.

    The fix is pretty simple (thanks to Vinod Atal from MSFT when I first hit the problem back in May), copy and paste the following lines into notepad and save to a *.reg file, then double-click to run it (you shouldn’t need to reboot for the fix to take effect, close and re-open the window:

    Windows Registry Editor Version 5.00
    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\BagMRU]
    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags]
    [-HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\BagMRU]
    [-HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\Bags]
    [-HKEY_CURRENT_USER\Software\Classes\Local
    Settings\Software\Microsoft\Windows\Shell\BagMRU]
    [-HKEY_CURRENT_USER\Software\Classes\Local
    Settings\Software\Microsoft\Windows\Shell\Bags]
    • Marked as answer by Scott Keller Thursday, February 11, 2010 8:02 PM
    Thursday, February 11, 2010 6:12 PM

All replies

  • Did you install Windows 7 Virtual PC or Virtual PC 2007 SP1?

    Complete screen captures of what to do are found here: http://www.sevenforums.com/tutorials/8254-windows-virtual-pc-create-virtual-machine.html

    If you don't see Create virtual machine in the menu bar as shown in the screen capture of Windows Explorer, then we need to figure out why not.
    Thursday, February 11, 2010 2:49 PM
  • My start button folder says "Windows Virtual PC" and I do not see "Create Virtual Machine" button in explorer. Could it be because I did not install VPC correctly or I have the wrong version?
    Thursday, February 11, 2010 3:26 PM
  • Try this:
    http://smudj.wordpress.com/2009/12/29/missing-create-virtual-machine-in-usernamevirtual-machines-folder/

    Below is the fix for the virtual machines folder for WinVPC when the folder here “%username%virtual machines” is missing the “Create Virtual Machine” option.

    The fix is pretty simple (thanks to Vinod Atal from MSFT when I first hit the problem back in May), copy and paste the following lines into notepad and save to a *.reg file, then double-click to run it (you shouldn’t need to reboot for the fix to take effect, close and re-open the window:

    Windows Registry Editor Version 5.00
    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\BagMRU]
    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags]
    [-HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\BagMRU]
    [-HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\Bags]
    [-HKEY_CURRENT_USER\Software\Classes\Local
    Settings\Software\Microsoft\Windows\Shell\BagMRU]
    [-HKEY_CURRENT_USER\Software\Classes\Local
    Settings\Software\Microsoft\Windows\Shell\Bags]
    • Marked as answer by Scott Keller Thursday, February 11, 2010 8:02 PM
    Thursday, February 11, 2010 6:12 PM
  • Thanks for the fix it was easy and worked perfectly.
    Thursday, February 11, 2010 8:03 PM