none
DHCP not working on a wireless connection

    Question

  • Hi there,

    at SonicWALL we are getting many people complaining that their wireless clients running Vista are unable to obtain an IP address via DHCP from SonicWALL firewalls. 

    We are unable to reproduce the problem.  Is this a known issues. Is this fixed or will be fixed?

    There seems to be similar issues...
    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=863519&SiteID=17

    CASE 1:

    WEP, no WEP... I can connect no problem, but cannot get an ip address handed out. Vista seems to see it as an unidentified network and will not connect to it. The same laptop running XP, no issues whatsoever. I have fresh installed Vista a second time with no avail.

    Any other non Vista machine has no issues connecting to wireless.

    I can see successful authentication, and DHCP shows nothing has been issued.

    FWIW, Vista indicates that it cannot identify the network...

    Any suggestions? Anyone else having this issue?

    I'm stumped.


    I actually have since brought two other laptops online of different makes with Windows Vista with the same results.

    SONICWALL - HELP?! :)


    CASE 2:

    I am glad to see you have the same problem. My HP nc6140 exhibits the same thing you see. IT works fine with XP, but no joy with Vista on a Sonicwall TZ170W.

    My suspicions are it's a MS problem in the IP stack. As a MS partner, I have used Vista betas since way back - some work, some don't in this regard. I got the OS to work in RC1 and 2 by loading the original XP system and then upgrading it. It doesn't seem to work if you do a fresh install.

    It seems to connect but doesn't pull a DHCP address. When you hardcode the proper address it still gives a 169.X.X.X address on the wireless adaptor and then tells me there is a IP address conflict on the network - which is nonsense.

    Bennett


    CASE 3:

    I have the same problem. I can joined my vista to 5 other wieless networks but cannot connect to my own home network with my TZ-170w. I have had it connect a few times then drop for no reason. It is very very strange.


    CASE 4:

    My Dell 620 is unable to connect to the internet through the SonicWall. Did you have to do anything special with the configuration of the SonicWall??

    VLan is not listed under advanced tab. Using an Intel prowireless 3945abg adapter. Event log in Vista show that there is ip address conflict and assigns the 269.154.. Ip. Event log states it did receive 172.31.16.. address and then a conflict. Sonicwall show the mac address as associated but DHCP doesn't show that it has given and IP address. Very weird issue, but all my clients have sonicwalls and i cannot connect via wireless.

    CASE 5:

    The issue I saw was with the Intel 2915 ABG card.

    It would try and get an address from the Sonicwall and I saw in the DHCP table where the Sonicwall would keep giving multiple addresses until all were exhausted.

    I don’t have it installed anymore and this was with RC2 Beta.

    Event log in Vista show that there is ip address conflict and assigns the 269.154.. Ip


    Any help and explenation of the issue is appreciated. 

    Thanks,


    Jean-Marc
    SonicWALL
    Friday, December 15, 2006 6:16 AM

All replies

  • ::..Hi guys

    I have exactly the same problems as mentioned in the previous post. Wired connection works fine, but wireless won't work and it keeps reverting to the 169.x.x.x IP. It simply cycles through the whole DHCP range always comming back with an indication of an IP address conflict. Hardcoding the IP address doesn't help either.

    The client is running Vista Enterprise v6.0.6000 with as updated drivers as possible for the Intel 3945abg card. The Sonicwall is a tz150 with, to my knowledge, the latest firmware. I have been messing around with all kinds of settings on the sonicwall including the security stuff. None of the changes made it work.

    Connection to the same Sonicwall from the same PC, just using WinXP works like a charm...

    Any help on this issue would be highly appriciated :-)

    Cheers

    ..::HazelTWA

    Thursday, January 04, 2007 11:06 PM
  • I am also having the exact same problem. I'm using the released version of Vista with a SonicWall TZ150. Can connect to the network, but I can never get a DHCP address. Setting a static doesn't work either. Anyone found any work arounds?
    Monday, January 22, 2007 5:21 AM
  • This is the exact problem I've been having.  I frequently go to Panera Bread between client visits to get some work done on the wireless, and I've been having this problem with not being able to get a DHCP address.  I talked with the manager at length about it today, and he tells me that (1) they use Sonicwall firewalls and (2) I'm the only person that's complained so far about any connection problems on his network (this is a new store).  I told him that I presumed it was probably some incompatibility between Vista and Sonicwall, because nothing else makes any sense.  I hope they get a fix soon.
    Tuesday, January 23, 2007 2:22 AM
  • I actually submitted a support case to SonicWall (we use them in our company) and got the following response:

    -Hi Josh. -Thank you for contacting SonicWall Technical Support. -I am Raj and I have taken ownership of this case. -As per the issue description, I understand that you are having issue with the Vista. -I would like to update you that as of now Vista is not compatible to SonicWALL. -This is the known issue here and our Engineering Department is working on this issue. -We are hoping to fix it soon. -As soon it will fix we will update you with the same. -I would be moving the status of this case to, “Pending Closed”. The case would remain open for the next five days and automatically close on the sixth day. -Kindly update the case or give us a call on 1-888-777-1476 for any further assistance or queries. -NCB. Regards, Raj, SonicWall Technical Support.

    So, apparently they know about it and are working on it, but no details. Even if they do fix it, it will probably be some sort of firmware update to the SonicWall. Who knows if places using them for access points will know to update them. Very interesting.

    Tuesday, January 23, 2007 4:27 PM
  • I followed these directions I found on SonicWalls webiste:

    I am using a Dell Latitude D620 with Vista Enterprise Edition - I can now get a valid IP address from DHCP - give it a try and see if it works for you.

    David

    The issue is caused by a lack of a correct association on the SonicWALL between the computer running Windows Vista and its assigned IP address. Follow these steps to work around the issue by editing the System Registry:

    1. Click the Start button.
    2. Select All Programs > Accessories.
    3. Right click Command Prompt and click Run as administrator.
    4. Type regedit.exe and press enter.
    5. Go to the following location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
    6. Right click this entry and select New Dword.
    7. Rename the new entry ArpRetryCount (leave it set to 0 by default).
    8. Restart the computer.
    9. Reassociate with the SonicWALL. You should notice a successful connection.
    See the Microsoft article entitled Registry management strategies for IT Pros for additional information on editing the System Registry in Windows Vista.

    Important Note: This information is provided for guidance purposes only and does not represent a configuration officially supported by SonicWALL.

    • Proposed as answer by Josh Erquiaga Tuesday, May 05, 2009 6:43 PM
    Tuesday, January 23, 2007 5:22 PM
  • Hi David,

    Do you have the original page that this solution came from on the SonicWall website? I did extensive searches there and was just wondering where you were actually able to find it.

    Tuesday, January 23, 2007 5:41 PM
  • Josh,

    Here it is...what I did was do a knowledge base search for Vista and it came back with three choices...i picked the third one.

    http://www.nohold.net/noHoldCust22/Prod_3/KnowledgePortal/KPScripts/frameskp.asp?sid=671221&ds=nh5.nohold.net

    David

    Tuesday, January 23, 2007 6:19 PM
  • Thanks! That's crazy, that it would be that easy and obvious. You always miss those things. Thanks! I'm going to try this a little later today, when I can get to my other site.
    Tuesday, January 23, 2007 6:46 PM
  • The steps seem to have worked for mine. I did have one instance where I got a connection for a few hours and then it dropped out again, so I'll update if that happens again, but for now I've got my fingers crossed!
    Wednesday, January 24, 2007 12:06 AM
  • Glad to hear you got it working as well.  It still seems to be going good.  I think its weird that SonicWall tech support did not pass this on to you intead of just saying its a bug and we are working on it.

    David

    Wednesday, January 24, 2007 5:08 PM
  • Day 1: figured out that it was an ARP problem.

    Day 2: laboriously determined that none of the usual ways to disable ARP solved the problem (reg entry IPAutoconfigurationEnabled does nothing).

    Day 3: figured out that it might be ArpRetryCount and found this page as a result of searching for that term.

    POOF! Problem solved.

    The only remaining problem is that my chair is now surrounded by clumps of my hair, pulled out whilst pursuing this brain twister.  How exactly do I reattach the clumps to my scalp? I can't afford to lose any more of my dwindling supply of head-fur.

    Thanks for the info in this thread. It was exactly what I needed... I just wish I could have found it earlier!

    PS to future readers: this thread is focused on configurations that use DHCP but it applies, too, to people like me who are setting up a network behind a SonicWall and are using static IPs.  In that case, your NIC will be configured to not use DHCP but you will find that the static IP you provided is magically (and annoyingly) being trumped by an IP being assigned by ARP.  You can do a "ipconfig /all" in a DOS window to see this is the case (look at the IP you are using, the so-called preferred IP and notice that it is in the ARP range of IPs).  Also you'll see that "ipconfig /all" indicates that it is using autoconfiguration, despite the fact that you don't want it, and that you can't turn this off with the usual registry setting of IPAutoconfigurationEnabled. However, the simple solution offered in this thead (setting ArpRetryCount to 0) does work and allows the static IP to be used just as it has always been in prior versions of Windows.

    Wednesday, January 31, 2007 12:16 AM
  • I have a prebuilt system with the Asus P5AD2 Motherboard with integrated wireless connecting to a Linksys 4 Port Wireless G Router.  After upgrading from XP Pro SP2 to the Vista Ultimate I was unable to obtain an IP address from my router.  It loaded the drivers fine and it also stated that I was connected via the wireless, however I was getting the APIPA address instead of a valid IP address.

    I followed your suggestion above about editing the registry and it didn't work for me.  After doing more research, I found out that there are many people having troubles using the WPA authentication along with AES or TKIP encryption.  So I changed the router to WEP and as soon as I did that, my wireless was up and running.  I tried both WPA and WPA2 with AES and TKIP combinations and nothing worked other than the WEP.

    Cheers!

    Thursday, February 01, 2007 6:31 PM
  • This solution worked for me as well. The user had Vista Business on a HP laptop. We use a Sonicwall TZ 170 Wireless firewall. After implementing the registry addition the connection worked perfectly!
    Wednesday, July 25, 2007 1:05 AM
  • Good Evening,

     

    I am having the same problem.  I can get the PC to connect if I use a static IP but no luck with DHCP.

     

    Did you find a solution to this problem?

     

    David J.

    Monday, May 26, 2008 9:02 AM
  • I was also having this problem, ("Unknown Network" and "Windows has detected an IP address conflict") but only on my wired LAN connection with a Netgear RP614 router.   I tried this: http://support.microsoft.com/kb/928233 but to no avail.

    The ArpRetryCount setting as suggested by davidhall.dc seems to have solved it.

    Why hasn't Microsoft incorporated this issue in an update? Can't they make registry changes through automatic update?

    --------------------------
    Dell Inspiron 1420
    VISTA Home Premium

    Tuesday, July 08, 2008 5:33 PM
  • Thanks David

    I did what I saw on your scrap and my Vista worked finally after a week of  troubleshooting!

    God Bless You and your brain!!!
    Saturday, October 03, 2009 2:11 AM
  • Problem

    When multiple computers are connected to the SonicWall wireless network, the wireless network goes down every 15 minutes.

    Synopsis

    The problem has been confirmed resolved by updating the firmware and disable the Intrusion Detection on the wireless.

    Solutions

    Update the SonicWall firmware to the most recent version. Disable the Intrusion Detection on the wireless network.

     

    Shawn Zernik
    http://www.internetworkconsulting.net

     

    Tuesday, September 27, 2011 2:57 PM
  • Thank you David, It works. Wow i am grateful.
    Saturday, December 31, 2016 6:32 AM
  • I found same problem in Dlink DIR 600 (AP mode).
    After apply register entries above.
    Sucessfull connection.

    PS: My SO Client on Windows 10 Professional
    Wednesday, February 15, 2017 5:36 PM