Windows 7 Spooler Hangs on boot


  • I've seen several people start threads on this subject but none of them have a solution.


    I have several Windows 7 32-bit Professional machines that are printing to a Ricoh Aficio MP C2050 across the network.  I had them printing through a server, but now have them printing directly to the printer itself.  Here is what happens:


    On boot, the user brings up Outlook 2k7 and then Word 2k7.  Word never makes it past it's splash screen.  Going into Devices and Printers the window hangs.  I can't stop the Printer Spooler service.  I have to do 'taskkill /im spoolsv.exe /f' then start the service.  Everything is fine after that until the machine is rebooted.

    I have disable bidirectional communication on the TCP port.  I have tried setting the port to RAW.  This seems to work, except print jobs take hours to print.  Putting it on LPR the print jobs come out at normal speed but this problem persists.  I have reloaded the drivers.  Cleared out the spool folder.  No luck.

    Please, please, please if someone knows how to fix this, let me know.  I can't believe MS would see all these posts for this exact problem on their forums and remain so silent about it.

    Friday, May 13, 2011 4:44 PM

All replies

  • We are experiencing the exact same error on most of our win7 64bit sp1 workstations, all using office 2010. it is not consistent though, sometimes they do boot with out error, makes trouble shooting even more of a mission.

    We have tried the same steps as you describe, as well as updating the printer drivers, removing pdf writers that we thought were causing the issue and removing unwated drivers in print server properties. no errors in event viewer.

    The spooler service claims to be running, but if we try to restart it, it fails to restart and actually just stops. Then we start it and all is well... until the next reboot

    All our W/S use the same print server with the same share and driver. it has not always been a problem, but has definitely increased in the last month. We now have a spooler rush every morning to get all staff up and running... very frustrating.

    Wednesday, May 25, 2011 6:27 AM
  • After looking at another W/S, there is an error in event viewer system log:

    A timeout (30000 milliseconds) was reached while waiting for a transaction response from the Spooler service.

    Event ID: 7011

    Wednesday, May 25, 2011 6:47 AM
  • We will try the driver isolation test. The spooler does not "hang" when printing, only at login. After login, we kill the spooler service, start it and all is fine until the next reboot.

    We are using the latest driver for all our printers and the 64bit drivers have been installed in the manner described above.

    Friday, May 27, 2011 8:36 AM

    I do not think it is printer driver related... We have tried to isolate drivers and have also gone as far as removing all printers and deleting drivers, and the problem persists.

    Tuesday, June 21, 2011 1:35 PM
  • We have had same issue with a number of Acer laptops runnning W7 pro and W7 Ultiimate.

    Seemed to start after Windows updates around time of SP1 though have not been able to identify which, update is responsible. removing and reinstalling selective updates was not conclusive. restore to previous condition  only sometimes fixed the issue but my laptop today can either reboot with or without the issue, and I have ONCE seen it in my home PC with Win 7 Ultimate.


    Other symptoms are :-

    on shutdown , pc insistes that outlook is still running and needs to force closure, as outlook was closed it can't do this so hangs in shutdown.

    Word cant start , as it cant scan for printers. but word editor in outlook is OK.

    Remote web workspace can't scan for credentials, so can't open connection to other PCs from web workspace, (remote desktop still able to find credentials and connect). Other web workspace functions Email and Intranet are OK.  This problem continues when print spooler is restarted.

    I have noted that when the print spooler service it stopped normally although it warns the action could not be completed the service does actually stop and the dialog box Stop legend greys out, so using start will work and the print service is then OK after.


    Re the remote web space use of RPC  and As Print spooler has dependancies which include RPC and the fairly random occurance of this issue in my laptop is there a startup sequence problem  ??

    Come on Microsoft this IS an issue!


    Saturday, August 20, 2011 1:02 PM
  • We have the same issues at our company and there is still no solution.

    It appears on all our computers but very irregularly.

    If someone knows a fix for this (except restarting the spooler service everytime) please let me know.

    Thursday, September 15, 2011 12:58 PM
  • To analyze what the problem may be, I went to the properties of the Print Spooler service and clicked on the Dependencies tab.

    I saw that this service depends on:

    • HTTP component
    • DCOM Server Process Launcher service AND
    • RPC Endpoint Mapper service

    It may be possible that on startup these services/components are not starting immediately and causing Print Spooler service from becoming unresponsive. Ensure the above service have startup type Automatic. Also try to configure the Print Spooler service to startup type Automatic (Delayed Start) and see if this fixes the problem.

    Please revert back here if this does not resolve the issue. Hope it helps!

    Kunal D Mehta - a Windows Server Enthusiast | My first TechNet Wiki Article
    • Edited by Server Baba Saturday, September 17, 2011 1:37 PM
    Saturday, September 17, 2011 1:35 PM
  • We did try the delayed print spooler startup, but it appears as though it is not supported? We get the following error when doing so:

    The delayed auto-start flag could not be set.

    Error 87: The parameter is incorrect.

    Wednesday, September 21, 2011 9:00 AM
  • We have got a new error relating to the same fault, it seems as though this is a side effect of spooler.exe not starting correctly:

      A problem caused this program to stop interacting with Windows.

    Problem signature:
      Problem Event Name:    AppHangXProcB1
      Application Name:    explorer.exe
      Application Version:    6.1.7601.17567
      Application Timestamp:    4d672ee4
      Hang Signature:    1bca
      Hang Type:    129
      Waiting on Application Name:    spoolsv.exe:spoolss
      Waiting on Application Version:
      OS Version:    6.1.7601.
      Locale ID:    7177
      Additional Hang Signature 1:    1bcae400f12c6eada131d14f3c9ea58f
      Additional Hang Signature 2:    5d52
      Additional Hang Signature 3:    5d529e35c2aecc0e2df9150e4f232dc7
      Additional Hang Signature 4:    5162
      Additional Hang Signature 5:    5162ce924ca5aba47303b80e4821ac88
      Additional Hang Signature 6:    5503
      Additional Hang Signature 7:    5503511f9683f508e3c249a0bff23e69

    Read our privacy statement online:

    If the online privacy statement is not available, please read our privacy statement offline:

    Tuesday, September 27, 2011 5:53 AM
  • We have the same issue at our company...just killing me. I upgraded our drafting department to Win 7 - 64 and they not get this issue randomly, if anything it is getting worse and I am no closer to a resolution...


    I was thinking it was our HP plotter, but not 100% sure yet.

    • Proposed as answer by Matt Roush Thursday, March 08, 2012 7:09 PM
    • Unproposed as answer by Matt Roush Thursday, March 08, 2012 7:09 PM
    Friday, September 30, 2011 5:07 PM
  • We have the same issue and also have an HP plotter. Thinking back, it is possible that this problem began occurring around the time the plotter was introduced.
    Wednesday, October 05, 2011 12:17 AM
  • We have exact the same issue. Is there anyone has solution? We don't have HP plotter. We have HP LaterJet 4350. I just asked my user not reboot computer.
    Wednesday, October 05, 2011 1:49 AM
  • We also experience this problem on Windows 7-64Bits. Our printers are:

    -       HP Designjet T7710ps

    -       Xerox Phaser 7760

    The problem appears randomly. It can disappear during several days and come back. The only workaround for now is:

    -       Killing “spoolsv” process

    -       Restart spooler service

    Sometimes everything works fine after a reboot. Changing the default printer has no effect.

    Hope that someone will find a solution or that the problem will solve itself after a future WindowsUpdate.

    Thursday, October 06, 2011 9:18 AM
  • One of my clients is having exactly the same issue.  In our case, the only "printers" present are MS FAX and a Quicken PDF printer.  We did have an HP printer as well as the standard MS XPS Writer but I removed both of those.

    Symptoms include Word hanging on startup (never gets beyond splash screen), and Control Panel / Devices and Printers hanging.  Stopping the spooler service will free either of these up.  Stopping the spooler is not always possible.

    As many of the other respondents on this thread have mentioned, this is an incredibly frustrating problem.  Any new input from Microsoft --- please?

    ...Forgot to add that the system is Win 7 x64 on an HP Pavilion Entertainment laptop with 4 GB RAM, using Office Pro 2007.
    Monday, October 17, 2011 7:03 PM
  • How many of the people who are having this spooler issue that have posted in this thread are using Autodesk Revit? It sounds like a long shot, but we have noticed a pattern with users who are syncing a local file to a central model. Some times the spooler actually fails during the sync or after a reboot after syncing. User who are not working on shared models do not have the spooler "crash".

    User who are not using Revit, never have the spooler failer at boot or any other time.


    Wednesday, October 19, 2011 2:28 PM
  • Our organisation does use Revit, but the spooler issue occurs on both the systems with Revit installed and the systems without Revit installed. However, all our systems without Revit do have AutoCAD LT installed though, so all the PCs in the organisation do have some type of Autodesk products installed...

    Both the 32 bit and 64 bit Windows 7 clients exhibit the intermittent frozen spooler at startup issue, but the XP clients don't.

    Friday, October 21, 2011 8:49 AM
  • hi!

    same here. I have the same problems as described here. I use Windows 7 Enterprise SP1, both 32 and 64 bit.

    We have Lexmark, Canon and Brother Printers (Drivers are up to date) which are connected to a Windows 2008 Server.

    I'm googling for days now and tried almost everything (including autostart the rpc-locator service and changing the printer settings to not use the spooler, i.e. send the printing jobs to the printers directly), but nothing worked.

    I don't have Revit or AutoCAD in use, so I don't think the problem is related to that. Perhaps it's not a printer driver issue but related to some program that is istalled. I'm not sure, but I think everything worked before I installed alle the programs (each with the most recent version):

    MS Office 2007
    McAfee VirusScan Enterprise 8.8
    Flash Player 11 Plugin and ActiveX
    Java JRE
    MS Visio Viewer 2007
    Open Office
    iTunes (with Application Support, Application Update, QuickTime)
    VLC Player
    FileZilla FTP Client
    Adobe Reader X
    KeePass 2

    That's all :) Perhaps we can find the troublesome program together. I suspect McAfee and PDFCreator but didn't have time to test it, yet. I hope we can find the source of the problem soon, because that currenty prevents me from deploying Windows 7 (~50 Workstations still running WinXP)



    Monday, October 31, 2011 9:30 AM
  • Thomas,

    The only common programs we have with you are as follows:

    MS Office 2007 (and 2010)
    Flash Player 11 Plugin and ActiveX
    Java JRE
    Adobe Reader X

    Wednesday, November 09, 2011 4:35 AM
  • Common apps on our end are:

    Flash Player 11 Plugin and ActiveX
    Java JRE
    iTunes (with Application Support, Application Update, QuickTime)
    VLC Player
    FileZilla FTP Client
    Adobe Reader X

    We have also suspected PDFCreator and even Java and flash updates that kick off after login.

    Wednesday, November 09, 2011 2:02 PM
  • We have this same issue on random machines.

    We are all Windows 7 x64, Office 2010 Pro.

    We have Java JRE, Flash 11, and Adobe Reader X in common with the apps you guys have.

    Our printers are all printing through a Windows 2008 R2 print server, with the printers assigned by GPO.

    This problem has been getting slowly worse. 

    We've got Xerox and HP printers - and I see that this happens to people with other brands.  So it appears to not be printer dependent. 

    What about print driver isolation?  Ours are a mix of shared and none, right now.

    Wednesday, November 09, 2011 3:06 PM
  • Same Issues here. Office full of windows 7 x32. But only 2 machines are doing the following.

    We dont use any HP Products so I am thinking it is not a HP issue. I removed the XPS printer and rebooted 10 times and so far no error. Keeping fingers crossed.

    I am looking into to actually dumping the Windows\system32\spool\drivers files so we have almost zero printer drivers on the machine itself.

    If that all goes well for a bit I will load one printer at a time a fly that way until or of the problem reoccurs.



    Friday, November 11, 2011 2:51 PM
  • Ok, this may be a solution.  given that the problem doesn't happen every time on boot, it is very hard to tell when the issue is actually solved.


    On the machines in my office that have been having this issue I have noticed a couple of things:

    When I look in the registry here:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider\Servers\YOUR_PRINT_SERVER_NAME_HERE\Monitors\Client Side Port

    I see many registry keys pointing to printers that do not exist any more (have been replaced, or renamed, or moved).

    So, I want to clear this cruft out:

    1)  Stop the Print Spooler service

    2)  Delete the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers\Client Side Rendering Print Provider\Servers\YOUR_PRINT_SERVER_NAME_HERE registry key

    3)  Start the print spooler service.  you will get a flood of errors in the event log as it finds these missing registry entries and re-creates them for the printers that actually currently exist.  This set of errors in the event log will only happen on this first restart of the spooler service.

    4)  Go into the print management console and clear out any old drivers.


    So, anyone having this problem, please give this a shot and let us know if it works for you.  Seems to be working here, but as I said, it is hard to tell.


    • Proposed as answer by Althornin Monday, November 21, 2011 7:40 PM
    • Unproposed as answer by Althornin Monday, December 05, 2011 3:47 PM
    Monday, November 21, 2011 7:40 PM
  • This didn't work for me.

    On the following reboot after making the changes suggested by Althornin the spooler hung again at startup. I tried this on a few different PC's just to make sure.



    Friday, November 25, 2011 9:21 AM
  • On step 2), delete the entire HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print key

    That might work better.  I had to make that change to resolve the issue on a few PCs here.

    Tuesday, November 29, 2011 1:27 PM
  • Bah, never mind, it just came back on one of those PCs I thought was fixed.

    The intermittent nature of this problem makes troubleshooting a real pain.  I don't have a single workstation that ALWAYS experiences this issue on a reboot anymore, after applying the above "fix".  However, I've got a couple that still get it some of the time.

    Wednesday, November 30, 2011 1:57 PM
  • stop printer spooler service

    delete all printers under following keys

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Drivers

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Drivers\Version-3


    C:\Windows\System32\spool\drivers\x64\3 (example 3.old)

    Start printer spooler service

    Add printers back one by one untill you find out which one is having problems


    Wednesday, November 30, 2011 2:23 PM
  • stop printer spooler service

    delete all printers under following keys

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Drivers

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Drivers\Version-3


    C:\Windows\System32\spool\drivers\x64\3 (example 3.old)

    Start printer spooler service

    Add printers back one by one untill you find out which one is having problems


    Sure, we'll give this a shot, why not.
    Monday, December 05, 2011 4:14 PM
  • stop printer spooler service

    delete all printers under following keys

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Drivers

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Drivers\Version-3


    C:\Windows\System32\spool\drivers\x64\3 (example 3.old)

    Start printer spooler service

    Add printers back one by one untill you find out which one is having problems


    Sure, we'll give this a shot, why not.

    Quite a challenge when the problem doesn't show up immediately (sometimes could even take a week to show up) and users need access to all the printers every day...
    Tuesday, December 06, 2011 2:56 AM
  • Getting this too.

    The only two printers on this PC are:

    Brother MFC-9970CDW - Driver Version
    Brother HL-4570CDW -

    Wednesday, December 07, 2011 10:02 AM
  • And this is another reason why i don't think that this has anything to do with a specific printer or printer driver (unless it is one that windows ships with, like the XPS "printer").

    There are machines having this issue that have completely different sets of printers with no commonalities.

    Wednesday, December 07, 2011 3:13 PM
  • A question for you guys.  Are any of you using scripts to remove these printers and then re-add the printers all at log on?
    Thursday, December 08, 2011 12:40 PM
  • A question for you guys.  Are any of you using scripts to remove these printers and then re-add the printers all at log on?
    No, we push printers out via GPOs, by user.
    Thursday, December 08, 2011 1:20 PM
  • A question for you guys.  Are any of you using scripts to remove these printers and then re-add the printers all at log on?
    No, we push printers out via GPOs, by user.

    We have tried it via GPOs by user and also via logon script.
    Friday, December 09, 2011 2:13 AM
  • Upon removing the HP T2300ps plotter drivers via group policy, the problems have gone away. Even installing the T2300ps driver manually on a PC without pushing via GPO causes the problem to re-appear.
    Monday, December 19, 2011 2:34 AM
  • I at first thought it was down to an older local printer that was using the HP Universal Print driver.
    The PC would boot up but not tie the driver to the printer despite using it in the past with no issues.  Instead Windows would detect it as a new printer prompting to install a driver for the printer. 
    This was ruled out though when the same issue spooler service hang occurred on a users PC who only used two Brother network printers.

    Still testing my users.  I've asked them to delete the two network printers before they shutdown for the evening. My idea was the logon script that runs was removing and then adding the printers back in too quickly. I added a wait command of 4 seconds but it hasn't helped.  Still waiting for feedback but I have had positive replies so far.

    Monday, December 19, 2011 5:18 PM
  • Uncheck Enable Bidirectional on the Ports tab of the printer properties on the machine sharing the printer.  The HP language monitor needs access to a resource that only the local administrator has.  When you restart the spooler the jobs are scheduled in system context rather than the users context.
    Thursday, December 22, 2011 10:45 AM
  • Uncheck Enable Bidirectional on the Ports tab of the printer properties on the machine sharing the printer.  The HP language monitor needs access to a resource that only the local administrator has.  When you restart the spooler the jobs are scheduled in system context rather than the users context.

    I don't see how this can possibly be the solution:  I've got multiple users, with the same user rights, on machines made from a common image, using the same printers - and only a few of them have the issue in this thread.  I can't see how the above would only affect a few users in this case.

    In addition, we've got people above who have the same issue even with no HP printers installed.


    Saturday, December 24, 2011 4:50 AM
  • I am seeing this also.  Windows 7 Professional 64 bit.  Word 2010.

    I have made a habit now of checking my printers and devices each time i boot up, if they aren't there I restart the bluetooth services and reboot until the printers show up.

    I take my PC into many different clients offices, so am continually linking into different networks.

    When the printers don't show up, Outlook won't shut down, I cannot print or save in Word/Excel and RDP sessions won't end properly.

    This is a time consuming problem.  If there has been a solution since these posts that someone is aware of, I'd love to know!


    Diann Fariss
    Thursday, January 05, 2012 1:16 PM
  • Hi, I am also experiencing this issue with a client.  Although it's mainly on laptops that have a Bluetooth module installed.

    Have found this fix via MS but unable to download that actual patch itself.

    Think we may have to resort to removing printer drivers and install them one by one to find the problematic printer (if related!).


    Saturday, January 14, 2012 1:31 PM
  • Still having this issue.  The only message is in the event logs telling me "A timeout (30000 milliseconds) was reached while waiting for a transaction response from the Spooler service."


    Has anyone else had any luck on this?  I can't find a way of diagnosing spooler issues.

    Monday, January 16, 2012 11:17 AM
  • I was having the same issues in that the 'Devices and Printers' console not showing the printers and just hanging.

    Finally manage to resolve the issue, it was down to the printers being installed on the server and then shared via active directory.  We had a label printer which is connected to a usb-ethernet print server.  Once I removed that printer and associated drivers the console would display.

    I would make sure that the drivers used are the correct drivers for the printer, am only saying this as when installing the printer the driver from the Windows Update site was being used to deploy the drivers instead of the locally installed ones.

    Would recommend you remove all printers and drivers and then complete the following:

    1. First I removed printer in "Devices and Printers"
    2. Then I stopped print spooler
    3. In registry I opened

    HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Print Processors\

    4. I renamed all Print Processors that were listed. Like Winprint to Winprint.old, Hpcpp107 to Hpcpp107.old, and so on ...
    5. I started print spooler
    6. Removed problematic driver pack using printui /s /t2 from a command line with admin rights.
    7. Reopened registry location

    HKLM\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Print Processors\

    8. Renamed back all Print Processors to original name. Like Winprint.old to Winprint, Hpcpp107.old to Hpcpp107, and so on ...
    9. Restart print spooler
    10. Installed new printer drivers
    11. Tested printing

    Try then installing printer drivers one by one to see if the Devices and Printers window hangs again...

    Tuesday, January 17, 2012 9:14 AM
  • The problem is evident here on my home network. On my Win 7 Pro 64-bit installation, most times after a boot, no printers are available in the "Devices and Printers" window, and you cannot print from any software application (the application freezes up if you try to print). Stopping the print spooler and then starting it again, and then refreshing the "Devices and Printers" window populates it with all installed printers, and all then print normally. And yes, the problem is intermittent -- about 20% of the time, the machine will boot with the printers available and working.

    The same printers are installed on another machine using Win 7 Home Premium 32-bit, and the problem has not shown up there.


    Thursday, January 26, 2012 4:19 PM
  • Hello Canuck

    Two things I did with a client who was experiencing the same issues; 1) Update the printer drivers on the affected PC, the spooler queries the network and therefore is unable to find all devices and thus the spooler hangs.

    2) Remove all printer drivers as explained above, you need to ensure no printer drivers exist on the PC/laptop.

    If the issue is still occuring then like I did for the problematic printer was to install it as a local printer then create a new port and map that to the printer.  Someone above has explained that they did this too.  In our case it was because of a hub that is on the network and causing issues, installing the printer this way seem to fix the issue.

    Friday, January 27, 2012 8:29 AM
  • We are having the same issue in our corporate office. Checked the event logs on a few machines and it seems to start around Nov. 2011. We thought it's the Adobe Acrobat prof/standard were the cause. Isolated the Adobe PDF printer driver and that appeared to fix the issue at the moment. After a reboot, the issue came back. it happens randomly on certain users. We have replaced user's computers, re-created user profiles, etc.. None has worked. After reboot, some users lost all network printers. Restarted the print spooler and re-added one of the network printers and then all of network printers (previously mapped) started to show up. It would work in that state until the machine rebooted.

    Thursday, February 16, 2012 4:27 PM
  • Having the same problem, print spooler is creating a huge headache.  I posted here:

    but then reading this thread I thought I'd refer to my post as well as this seems to be a very well known issue but with no resolution.

    Tuesday, February 21, 2012 5:52 PM
  • I have a customer with the same problems mentioned in this thread
    - No printers are shown
    - Word/Excel won't start/open documents properly
    - AutoCAD won't start correctly
    - .vbs login script won't finish

    This usually happens at login after a reboot but some get problems while being logged in.

    The affected computers are a mix of HP Desktops and Lenovo Notebooks who all run Windows 7 64bit, we also have a variety of computers with Windows XP and Vista 32bit who are not affected at this point.

    Most of the users are using Microsoft Office 2007 and a few run 2010. Outlook 2007/2010 and Lync 2010 uses Office 365 for messaging. Some of them are running AutoCAD in different versions from 2008 and onwards.
    The antivirus software is Trendmicro Worry Free Business Security Advanced 6.0 SP3.

    The printer devices are a mix of HP and Oce large format printers, HP laser printers and Sharp Digital Copiers and the print server is running Windows Server 2003 R2 SP2 64bit.

    We used to install/connect the printers in a login script but have removed that but problem still occurs.

    Wednesday, February 22, 2012 9:53 AM
  • We are also having this problem, Device and Printers does not load and just sit there with a green loading bar. Microsoft Outlook 2010 also freezes.

    I have tried:

    Setting Bluetooth services to Automatic (as someone suggested)

    updated all drivers and software on the computer (HP Elite 6450p laptop)

    Disabling startup items and running as a clean bootup

    Ran Virus scan (just in case it was something stupid like that)

    I have also tried a few other things but nothing seems to work... The one thing i have noticed is if i restart the computer without the network cable plugged in and log into the computer everything will work (so i plug the network cable back in and everything is sweet until the next time the computer is restarted again)

    It is getting quite frustrating to troubleshoot such a problem.

    Thursday, February 23, 2012 4:24 AM
  • Is SP1 installed on all client computers that are having this problem?

    In my customers environment we have 19 W7 SP1 and 3 W7 and I haven't heard any problems reported from the ones without SP1.

    Friday, February 24, 2012 8:47 AM
  • we having the same problem in our network on windows 7 32/64 bit machines with and without sp1 installed. we could trigger the problem by uninstall the hp designjet T2300 driver. Uninstall -> no problem. Install -> problem. actual there was a driverupdate from microsoft among the optional windows updates. maybe the solution for the t2300 plotter...
    Friday, February 24, 2012 4:41 PM
  • Took a look on HP's site and they released a new driver for the T790 january 25 this year and under what it fixes it says the following:
    "Solved a crash of the spooler when using the driver in Windows Vista mainly using Office applications "

    So it's worth testing at least to see if there is any change.

    • Edited by jimmyu Monday, February 27, 2012 8:43 AM
    Monday, February 27, 2012 8:11 AM
  • with the new hp driver the problem is solved
    Sunday, March 18, 2012 10:11 AM
  • Hi everybody

    I do something that can save time.

    Each time I cannot launch Office, Autocad, etc, due to this problem, I open the Resource Monitor (pinned on my Task Bar), right-click on spoolsv.exe, select 'Analyse waiting list' (that's how I would translate from french). As spoolsv.exe is hanged, it should then display a list of threads. Then I go to the bottom of the list and kill the last thread.

    Spooler immediately restarts finely. I never had to do it twice. It is really easy, and avoids restarting the computer several times.

    No real solution was found by us.

    Windows Seven mostly
    Friday, March 30, 2012 11:56 AM
  • Hi guys,

    I didn't find a complete fix but I do have a workaround to get rid of this annoying issue:

    First I created a bat script that waits for 30 seconds, stops spoolsv.exe (not really necessary) and then starts the print spooler. I called it resetprintspooler.bat.

    echo ==========================================BEGIN NEW LOG===================================== >> c:\temp\resetprintspooler.log
    echo Reset print spooler script started at %date% %time% (first waits for 30 seconds) >> c:\temp\resetprintspooler.log
    TIMEOUT /T 30
    taskkill /IM spoolsv.exe /F >> c:\temp\resetprintspooler.log
    del %systemroot%\system32\spool\printers\*.shd
    del %systemroot%\system32\spool\printers\*.spl
    net start spooler >> c:\temp\resetprintspooler.log
    echo Reset print spooler script stopped at %date% %time% >> c:\temp\resetprintspooler.log
    echo Print Spooler script applied on %date% %time% on computer %COMPUTERNAME% >> \\Networkshare\%USERNAME%.txt

    I included some logging for troubleshooting purposes and to see on a networkshare to who the script was already applied

    Then I created a GPO:

    • That sets the print spooler service to manual (Computer Configuration\Policies\Windows Settings\Security Settings\System Services\Print Spooler -> Startup Mode Manual). This way the print spooler won't startup on computer startup.
    • That copies the script from a network share to c:\windows\temp (User Configuraton\Preferences\Windows Settings\Files)
    • That executes the local script c:\windows\temp\resetprintspooler.bat (User Configuration\Policies\Windows Settings\Scripts\Logon) This way the script certainly also gets executed when the network is unavailable.
    • That hides the login script from the user (User Configuration\Administrative Templates\System/Scripts -> Run legacy scripts hidden Enabled and Run logon scripts visible Disabled)
    • That uses loopback policy processing so it can be applied to a computer OU (Computer Configuration\Administrative Templates\System/Group Policy -> User Group Policy loopback processing enabled, Mode: merge)

    • Edited by DS_Kevin Friday, June 01, 2012 12:45 PM
    Friday, June 01, 2012 12:43 PM
  • i read the old thread

    and i can add something ...

    this probleme started a thurday morning after windows update is applicated from my windows update server ...

    i do a system restore ... and all working good  for a long time after that time ... i restart windows update and the probleme come back

    i mount a new pc with a fresh windows without any update and test it 2 week without problem ... but after put all the update problem is back ...

    i have hp brother and canon on network .... i

    now i remove all defaut printer to see if happen again ... but its hard to tell because its random ... but im almost sure a windows update cause this....

    and its before holidays ... like in november or december ... but im not sure on the date

    in 20 years of tecnical support this one its very hard to  find ... and i will find it ... the question is when lol

    and ty kevin i will use it ... the time i find the true bug

    the funny part in this bug ... i have half my users in 64 bits that dont have the problem and have the office 2010 too

    • Edited by theteck Thursday, June 28, 2012 7:22 PM
    Thursday, June 28, 2012 7:20 PM
  • can we have some microsoft to help on that

    im very good to find a problem

    but not im starting to think i will never find it

    i removed all driver try it 1 by one ... try another printer company ...

    i think its more with office problem

    after a update but witch one i never find it ... i restart a new computer from scrach and try to updating patch 1 by one but the random with this error kill me

    maybe with windows 8 this will be fixed

    but how i explain this to my user and my customer? ... in 20 years i always find a solution but  simple printer im stuck ?

    Wednesday, July 25, 2012 5:18 PM
  • I was having this issue, and it turned out to be a driver issue with our HP plotters.  An updated driver came out, and the issue has now gone away completely.

    I really didn't think it would end up being a driver problem (too many people having the issue, with no commonalities on printers, but that is what resolved it for us.

    Wednesday, July 25, 2012 5:22 PM
  • hi everyone...tossing my laptop in the hat here, similar issue

    when I boot...sometimes I won't be able to load "Devices and Printers" until I restart Print Spooler.  This can be streaky an happen for 10-15 reboots in a row, and then clear up for a few days.  Seems to occur more frequently when I switch networks.

    Windows 7 64 Pro, Lenovo T510, Office 2007

    My only workaround is to try to stop print spooler service, let it error out, then start it clean.   I've noticed that after sometime of running clean, it can go bad again, at which point I again apply the workaround.   This has been happening to me since I began using this laptop...Jan 2012 or so.   Previous laptop I don't recall having experience the issue.

    Will bookmark this thread and post if I dig something up.   Hopefully someone from MS will notice us here and can collect various traces and dumps from us for analysis.

    Tuesday, August 07, 2012 5:54 AM
  • i find the problem for me its the brother driver 2245

    i try it all and since the new driver its not working good i installer pcl 5 driver and seem to be stable i avised brother

    Monday, August 13, 2012 5:02 PM
  • We have an end user who took detailed notes about what they were doing before the print spooler crash (He was trying to print from Outlook 2010). We reimaged the laptop and the issue went away, however, when we tried to print an email from Outlook: PRINT SPOOLER LOCK UP.

    Is the issue at all related to printing from Office on Windows 7? Correlation or causation?

    We need to keep this thread going until we can all find a solution, because it is driving us absolutely crazy. I know others viewing this thread are feeling the same way.

    Tuesday, August 14, 2012 4:33 PM
  • All right, I don't have an answer per se, but I think we're really close. What got me thinking was the print spooler service.

    Recently I had my server fail. I'm smart enough to have backup but it still took three days to restore and although I got all the data I did not get the OS back (not worth it anyway). So the printers that were shared off the server before are NOT now. I restarted the print spooler service and deleted all the printers associated with the server. I have only two printers; an HP2200 and an OfficeJet 6200 (or something like that). The 6200 is on the server because it does scanning, etc. It's wireless so I don't have to connect it to print but the thing won't send scans over the network well unless it's USB connected and shared.

    I can't guarantee it will work but I'm almost sure reinstalling the 6200 is going to fill the bill. I mean, what are the odds of having a missing server with an attached missing printer with scanner drivers on it screw up? about 1 in 1.

    I highly recommend reinstalling as many of your printers as you possibly can after restarting the spooler service. Plus, this is the number one service to fail anyway....

    If I find out more, like it doesn't work, I'll repost to my own.

    Thursday, December 20, 2012 6:58 AM
  • Replying to Marcrates simply to end up at the bottom of the thread.

    Possible solutions from above (in preferred order):

    Make sure any Bluetooth services are either started and set to start automatically (if that doesn't work try both to never start)

    Restart the print spooler service. Immediately go to Devices and printers and remove any and all printers and reinstall them.

    Restart the spooler service whenever you have the issue

    Restart the computer and pray it works

    My two cents worth in what I got trying to find a solution to this silly issue.

    Thursday, December 20, 2012 7:04 AM
  • when we tried to print an email from Outlook: PRINT SPOOLER LOCK UP.

    Is the issue at all related to printing from Office on Windows 7? Correlation or causation?

    When our Win7 Pro user had same problem printing from Outlook 2010, I tried repairing the Office 2010 installation and got the following error:

    "Error 1310. Error writing to file C:\Config.Msi\lc5252.a.rbf.  Verify that you have access to that directory"

    The fix:  First view the hidden system files (Tools>Options>View).  Then RMB>Properties on C:\Config.Msi.  Add "everyone" with full permissions - all allowed.

    Never had a problem printing from Outlook 2010 again.

    • Edited by BlueDragon48 Thursday, December 20, 2012 4:14 PM
    Thursday, December 20, 2012 4:12 PM