none
Media Player 12 behavior when inserting audio CD

    General discussion

  • I've never used WMP much in the past and I'm not entirely familiar with its many options. I've noticed that if I am using it to play a video, and insert an audio CD, it will stop the video and begin playing the CD.

    It is not set as the default player for Audio CDs. There do not appear to be any options available within WMP itself to disable ripping/playing CDs. Am I missing something?
    • Changed type Linda Yan Monday, October 12, 2009 2:49 AM
    Thursday, October 08, 2009 3:33 AM

All replies

  • Hi Aiden R,

     

    You can change the AutoPlay settings under Control Panel to prevent audio CD from playing automatically. Choose "Take no action" for the media you would like stop AutoPlay. Or, simply uncheck "Use AutoPlay for all media and devices". Do not forget click Save button to save the changes.

     

    Regards,
    Linda

     

    Thursday, October 08, 2009 6:46 AM
  • I have Autoplay set to "Do Nothing". I also have itunes installed and set as the default player for Audio CDs (and pretty much all other audio files). If WMP is not open nothing will happen when an Audio CD is inserted, but if it is it stops what it i doing and begins playing the CD.
    Thursday, October 08, 2009 12:16 PM
  • Hi Aiden,

    According to my test, the issue could be reproduced. The CD auto plays while a video is played in Windows Media Player. I will help to report this issue to related team and they will look into it.

    Thank you very much for your feedback!

    Sincerely,
    Linda

    Monday, October 12, 2009 2:48 AM
  • Hi Linda Yan has there been any news on this issue yet ?
    Tuesday, November 10, 2009 1:00 PM
  • No ?

    well i have kicked MP12 into touch (shame as i actually like it) and i am now using VLC and thats working flawlessly

    Saturday, November 14, 2009 6:47 AM
  • ok i havedowngraded MP 12 to MP 11 and the whole thing is great again

    shame as MP 12 seemed quite good but that one annoying oh so helpful but really not helpful feature kills it for me
    Saturday, November 21, 2009 9:05 AM
  • I have Autoplay set to "Do Nothing". I also have itunes installed and set as the default player for Audio CDs (and pretty much all other audio files). If WMP is not open nothing will happen when an Audio CD is inserted, but if it is it stops what it i doing and begins playing the CD.

    Here's how I got this to stop:

    1.  Go to Control Panel, AutoPlay

    2.  Change the Audio CD to "? Ask me every time" and click save

    3.  When the AutoPlay window appears, after inserting a CD, check the "Always do this for Audio CDs:" checkbox

    4.  Click on the blue link on the bottom: "View more Auto Play options in control panel"

    5.  Change the Audio CD selection back to "Take no action" and click save

    6.  Click the red X to close the AutoPlay window.

    Windows Media Player 12 now will no longer kick into AutoPlay.  I don't understand why this worked.  Don't ask me why this worked, we will leave that question to be answered by the Microsoft people.

    I hope this helps everyone and works for them as well!

    • Edited by ItsTheMusic Sunday, May 23, 2010 2:03 PM clarification
    Sunday, May 23, 2010 1:55 PM
  • This does not affect WMP12's auto-play "feature".  This is most annoying, Microsoft.  Why, oh why do you not allow us to disable autoplay when a disc is inserted and WMP12 is playing something else.  

    PLEASE FIX THIS, please...

    Tuesday, July 06, 2010 9:26 PM
  • Third unanswered thread on the same regression bug, any MS mod reading this at all?

    Thursday, July 08, 2010 7:31 AM
  • I've never used WMP much in the past and I'm not entirely familiar with its many options. I've noticed that if I am using it to play a video, and insert an audio CD, it will stop the video and begin playing the CD.

    It is not set as the default player for Audio CDs. There do not appear to be any options available within WMP itself to disable ripping/playing CDs. Am I missing something?

    This solves the problem partially.

    Make the following additions in the registry and the playback is not "unrecoverable"

    1. Open Regedit

    2. Go to HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Preferences

    3. Create a DWORD with name "MediaFolderDetectionDepth" and set its value to "0"

    4. Create a DWORD with name "NonMediaCountToAbortMediaFolderDetection" and set its value to "0"

    Now, I put in a DVD with some media files, and mp3 playback does not stop. (previously this was stopping the playback)

    In case of inserting a DVD, then I had to stop the playback and press "Play Previous List" in the "Now Playing Window"

    Restart is not required. (I see that WMP12 is reading the key atleast one time when the drive is inserted). May be my answer is incomplete. If so, someone please help me (I will also work on this)
     
    I hope this was useful to some level.

    :) ChintuKPV
    Friday, February 04, 2011 1:16 PM