none
SimCity4 in x64

    Question

  • This is probably a long shot and I prob will have to give up on this game but has anybody got SimCity 4 Deluxe Edition to run on Windows 7?  The program has installed properly however it does not seem to load, it freezes on its loading image and does not actually go into the game.
    Wednesday, January 28, 2009 7:24 AM

Answers

  • I've tried a combination of compatibility mode and run as administrator.  I'm guessing the game is not comptabile with x64 in general (did a dual boot of vista x64 and win7 x64 and does not run on both OSes)
    Sunday, February 08, 2009 7:23 PM

All replies

  • Hello,

    Have you tried to run the game executable in Vista Compatibility Mode?  Right click on the icon, select properties.  There click the compatibility tab.  Check the box for Compatibility and select the OS you wish to use in the Drop Down menu.  After that check the box for Run as Admin and click Okay.  Then try to run the game.

    If this does not work then it will require a patch from the developers to get it working properly in Windows 7.

    Regards,

    ~Alex T.~
    ~Windows Desktop Experience MVP~
    Saturday, February 07, 2009 7:19 PM
    Moderator
  • it works fine with me even without compatibility to previous windows versions....

    try doing what alex has said, or maybe its just that the game can't run on a x64 system....
    Sunday, February 08, 2009 12:42 AM
  • I've tried a combination of compatibility mode and run as administrator.  I'm guessing the game is not comptabile with x64 in general (did a dual boot of vista x64 and win7 x64 and does not run on both OSes)
    Sunday, February 08, 2009 7:23 PM
  • I've managed to get Sim City 4 Deluxe running on  Windows 7 Pro 64 Bit. I didn't have any problems with the installation however the game is very unstable and frequently crashes so I have to save every 20 minutes or so. I've found that closing background tasks has helped, such as BBC iplayer, Steam and any internet browsers.

    There's the virtual XP thing that is downloadable from the Windows website: http://www.microsoft.com/windows/virtual-pc/

    However I found that the virtual XP thing is 32 bit only and won't work in 64 bit. Give it a go and it might work.

    I don't think EA will patch this as its such an old game and they've a newer Simcity released. 
    Wednesday, January 13, 2010 11:26 PM
  • How do you get the patch from the developers???  I've been working on this for far too long Please Help..

    if you  could post it or email me...      jtsous@gmail.com

     

     thank for your time....

    Saturday, July 24, 2010 8:27 PM
  • I installed this on my computer (Win7 Pro 64bit) and have had zero problems. The next day, I installed a copy for my girlfriend and she's had all sorts of problems. I've been looking around for answers and I think I've come up with a few.

    1) A lot of people have said that they have problems with ATI video cards. I have NVidia. If you have an ATI card, be sure to turn off as many background processes as possible before starting the game (as mentioned above). If there's any video program running (youtube, vlc, itunes, etc), definitely close them.

    2) Lower some of the video display settings in the game. Shadow rendering sucks up a lot of CPU power, and if you can only stand lowering 1 setting, this is it.

    3) Command lines are your friend. Even more so if you run a multi-core processor. Here's a couple you should use, or at least know for reference:

    -CPUCount:1 (For multicores, forces the game to a singlecore. Eliminates problems for many)

    -intro:off (Turns off the intro movie)

    -rXXXxYYYxBB (sets custom resolution, given by Width x Height x Color Depth 16 or 32. Great for widescreen displays)

    -CustomResolution:enabled (Must be used with the previous switch to work proper)

    -W (Forces windowed mode, for easier application switching)

    -CPUPriority:low (Lower priority helps when running windowed, not as necessary when running full screen)

     

    These are all added to the end of the Target Field wherever you're shortcut is. Right click the shortcut, then add those to the end of the Target. For example, I have a multicore cpu and a strange resolution, so mine now looks like this:

    "C:\Program Files\Maxis\SimCity 4\Apps\SimCity 4.exe" -CPUCount:1 -f -intro:off -CustomResolution:enabled -r1732x1289x32

     

    Wednesday, November 10, 2010 12:29 PM
  • After installing on my Windows 7 64-bit machine, I did find my Sim City 4 Rush Hour from the Sim City Box did crash often.

     

    I reduced my crashes from 95% of the time to about 2% of the time by the following:

    1) Create a desktop shortcut to Sim City 4

    2) Right-click on the shortcut and click on Properties

    3) Click the Compatibility tab

    3a) Check the box "Run this program in compatibility mode for:" and select "Windows 2000"

    3b) Make sure the first two settings (Run in 256 colors, Run in 640x480...) are not checked

    3c) Make sure the last three settings (Disable visual themes, composition, etc.) are checked

    3d) Check "Run this program as an administrator"

    4) Click the Shortcut tab and click the Advanced button and check "Run as Administrator"

    5) Click Ok on the Advanced dialog

    6) Click Ok on the Shortcut properties

     

    Hope this helps,

     

    Cindy Rae

     


    Cindy Rae
    Sunday, January 30, 2011 8:19 PM
  • it was so helpful.

    much appreciated

    Friday, February 11, 2011 6:17 AM