none
'Turn off the display' resets itself to 20 minutes instead of Never! RRS feed

  • Question

  • Hi all,

     

    I've had Windows 7 Home Premium installed for less than 2 weeks now and this is already getting on my nerves! I do NOT want my monitor to turn off if I leave my PC idle, so in the Power Options I have chosen 'Never' for 'Turn off the display'. However it keeps resetting itself to 20 minutes and turning off the monitor after that amount of time anyway!

     

    I first of all set this for the Balanced plan and I have also created my own power plan called 'Always on' and made sure the options are set to Never - but in both cases Windows is overriding my settings I have chosen - why?

     

    Please can someone tell me why this is happening and how to fix it.

     

    P.S. It's a standalone PC so no group policy or similar is in effect.

     

    Thanks in advance

    Steven

    Thursday, October 21, 2010 8:15 PM

All replies

  • Is there only me has this problem then? I also don't want my PC to lock when I resume from hibernation, so in the advanced settings I have changed 'Require a password on wakeup' to 'No', but that keeps resetting itself to Yes as well!

     

    Why won't Windows 7 remember the settings I've chosen?!!?

     

    Steven

    Saturday, October 23, 2010 12:50 PM
  • Hi,

     

    I would like to confirm if these settings have never been saved. What’s time power plan reset? Restart? Or just after some time?

     

    You could perform a Clean Boot to check if the issue still exists.

     

    Meanwhile, please confirm device drivers are latest, I suggest you could also update the BIOS and chipset driver.

     

    If the issue persists, try to create a new account for test:

     

    Create a user account

     

    Hope it helps.

     

    Regards,

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, October 26, 2010 11:02 AM
    Moderator
  • Hi all,

     

    I've had Windows 7 Home Premium installed for less than 2 weeks now and this is already getting on my nerves! I do NOT want my monitor to turn off if I leave my PC idle, so in the Power Options I have chosen 'Never' for 'Turn off the display'. However it keeps resetting itself to 20 minutes and turning off the monitor after that amount of time anyway!

     

    I first of all set this for the Balanced plan and I have also created my own power plan called 'Always on' and made sure the options are set to Never - but in both cases Windows is overriding my settings I have chosen - why?

     

    Please can someone tell me why this is happening and how to fix it.

     

    P.S. It's a standalone PC so no group policy or similar is in effect.

     

    Thanks in advance

    Steven


    You're not alone. I've been having this happen to me as well. On this machine (a custom gaming rig), my previous build (different motherboard & CPU), and my desktop machine before that (a Dell GX620 small desktop). Three vastly different machines, hardware-wise. All used Windows 7 Professional x64. All of them had the same problem, but only after a while did it show up - never right after a fresh install.

    For what it's worth, the Dell seemed to last the longest before succumbing to this bug.

    These are all stand-alone PCs, no group policy being used either, etc. Wish I didn't have to come back to my PC every few days to see my monitors in standby, knowing that after waking them up (one of which doesn't always wake up when a signal is introduced. Stupid Acer...), I have to dive into the Power settings panel to reset my preferences once again. It's VERY annoying.

    It's also not a corrupt user account as was suggested. The likelihood that I've had three different machines with three separate user accounts all go bad consecutively dictates I should probably have been hit by lightning, or won the lottery twice by now. In other words, the chances are near nil.

    It's a bug, and Microsoft needs to address it with a patch. Plain and simple.

    Friday, November 12, 2010 9:26 PM
  • Sorry, for some reason I never received any alerts saying there had been any replies!

     

    I was just returning now to say that after MULTIPLE attempts to get my 'Never' setting to take, it finally seems to have accepted my settings and saved them! Not sure why it took so many attempts but (fingers crossed) it seems to have obeyed my wishes now!

     

    Steven

    Friday, November 12, 2010 9:47 PM
  • I have the same problem. I set the turn off display setting to never and a few hours later its back to 20 minutes. I keep changing it back to never and it keeps reverting sometime later.

    My guess is that the lock screen has its own (unchangeable) power settings that, once they kick in after 20 minutes, override the user's settings after unlocking. Would have to experiment with it to see if that is the case.

    Friday, January 7, 2011 7:17 PM
  • I'm having the same problem, only in my case it takes a few days before power setting reset itself to default. Sometimes it takes days, sometimes month, but the reset is inevitable. I can't trace to when and why this happening, but it does happen on at least 2 systems I have.
    Monday, February 14, 2011 2:07 PM
  • I've been struggling with the power setting resetting itself back to Balanced for some time but I've now come across a solution that, so far, is working. The registry contains the name of the default power setting (Balanced as shipped) and no matter what setting you select via Control Panel it will reset to the registry power setting at every reboot. To change the deafult power setting in the registry you first need to know the GUID associated with each scheme. Open up a command prompt and type "powercfg list" to display all the power settings. The GUIDs are displayed for each power option (they are the long hex number strings punctuated with dashes). Make a note of the GUID for the power setting you want to use as the default. Now open the regsitry editor and navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\ControlPanel\NameSpace\{025A5937-A6BE-4686-A844-36FE4BEC8B6D}. Right-click the key called PreferredPlan and then click modify. Enter the GUID for the power setting you want to use as the default - BUT TYPE THE GUID WITHOUT THE DASHES "-" - if you include the dashes it won't work! Reboot and your selected power setting should be retained - along with all the associated values like sleep time etc. Tony C.
    Saturday, February 26, 2011 12:17 PM
  • Ok, I found the cause in my case: it's HD Tunes Pro

    That software is for hard drives testing and each time any test starts it resets power options. I've send an email to the creators, they didn't respond and released two more versions since then, with the same problem.

    • Proposed as answer by vanowm Saturday, December 24, 2011 5:14 PM
    Saturday, December 24, 2011 5:14 PM
  • I have none of the items mentioned here and in similar threads as suspected causes (e.g. java update, HD tune, etc.) and experience similar problems on a freshly installed Windows 7 Pro x64 SP1.  For me the issue is not monitor off; it is unwanted sleeping.  I have purposely disabled hibernate and set sleep to never in all accounts, and yet these are periodically reenabled for no apparent reason.  I also turned of NumLock, but now find it turned on when I try to login after an unexpected, unwanted sleep.
    Friday, November 23, 2012 5:09 PM
  • wow! you are a genius! thanks!

    This was driving me mad! Now I know what's causing it! Yes, I was using HD Tune a few times in the last weeks. It makes totally sense.

    I was wondering how the hell it can change from never to 20 minutes several times!

    Thursday, January 16, 2014 8:38 PM
  • I also have the same issue. I also have HD Tune not the Pro one. I am always testing hard drives. every time I come back to my computer the turn off display is set to 20 mins. I reset it two or three times a day. So did you find a fix?
    Sunday, May 11, 2014 12:34 AM
  • So did you find a fix?

    See HD Tune Options in the General section and uncheck: " _  Allow change of power settings during tests". That solved the issue for me.

    I would never have found the culprit myself and it was driving me nuts.

    Tuesday, August 19, 2014 1:16 PM