Net View no longer working, nor does network explorer RRS feed

  • Question

  • Problem:
    Unable to browser computers on network in windows explorer for file/printer shares
    and unable to run net view, unless specifically specifying the name of the network resource to view.
    Began in 1903 update, which was a clean install

    Windows version Windows 10 Pro 1903
    Microsoft Windows [Version 10.0.18362.295]

    typing net view returns this

    C:\Users\Ron>net view
    The service has not been started.

    More help is available by typing NET HELPMSG 2184.

    Service not started? What service? (see running services below)
    Naming the resource works as expected

    C:\Users\Ron>net view \\family-media
    Shared resources at \\family-media


    Share name           Type   Used as  Comment

    Canon MF5700 Series  Print           Canon MF5700 Series
    DEPOSIT EBOOKS       Disk
    DOCUMENTS2           Disk
    Music                Disk
    Pictures             Disk
    The Library          Disk
    Videos               Disk
    The command completed successfully.

    C:\Users\Ron>net view \\thor
    Shared resources at \\thor

    Ron's PC

    Share name    Type  Used as  Comment

    Music         Disk
    Music Videos  Disk
    The command completed successfully.

    So, technically we can see computers, but you can not browse computers at all.
    Though, you can see every computer that has media center set for sharing as a media device.
    But you can not see anything listed as a computer, so can not easily see any shared folders or printers

    SMBv1 is enabled, though i find that a strange requirement for sharing and such since it is actually to be disabled going forward, but with it off, you can not even type \\computer-name as it will return that the resource is not found.
    Seems network sharing should work without SMBv1, but without it, you can not even map a drive.


    And it is showing enabled in registry as well

    Now as for services.
    computer browser, workstation etc are all running, here is a full list

    These Windows services are started:

       Adobe Acrobat Update Service
       AMD External Events Utility
       AMD User Experience Program Launcher
       Application Information
       AVCTP service
       Background Tasks Infrastructure Service
       Base Filtering Engine
       Capability Access Manager Service
       Certificate Propagation
       Clipboard User Service_7c631
       CNG Key Isolation
       COM+ Event System
       Computer Browser
       Connected Devices Platform Service
       Connected Devices Platform User Service_7c631
       Connected User Experiences and Telemetry
       Contact Data_7c631
       Corel License Validation Service V2, Powered by arvato
       Credential Manager
       Cryptographic Services
       Data Usage
       DCOM Server Process Launcher
       Delivery Optimization
       Device Association Service
       DHCP Client
       Diagnostic Policy Service
       Diagnostic Service Host
       Display Policy Service
       Distributed Link Tracking Client
       DNS Client
       Function Discovery Provider Host
       Function Discovery Resource Publication
       Geolocation Service
       Group Policy Client
       Human Interface Device Service
       Intel Bluetooth Service
       Intel(R) PROSet/Wireless Event Log
       Intel(R) PROSet/Wireless Registry Service
       Intel(R) PROSet/Wireless Zero Configuration Service
       IP Helper
       IPsec Policy Agent
       Local Session Manager
       Logitech Gaming Registry Service
       Microsoft Passport
       Microsoft Passport Container
       Microsoft Store Install Service
       Network Connected Devices Auto-Setup
       Network Connection Broker
       Network Connections
       Network List Service
       Network Location Awareness
       Network Store Interface Service
       Payments and NFC/SE Manager
       Phone Service
       Plug and Play
       Print Spooler
       Program Compatibility Assistant Service
       Radio Management Service
       Remote Access Connection Manager
       Remote Desktop Configuration
       Remote Desktop Services
       Remote Desktop Services UserMode Port Redirector
       Remote Procedure Call (RPC)
       Routing and Remote Access
       RPC Endpoint Mapper
       Secure Socket Tunneling Protocol Service
       Security Accounts Manager
       Security Center
       Shell Hardware Detection
       SSDP Discovery
       State Repository Service
       Storage Service
       Sync Host_7c631
       System Event Notification Service
       System Events Broker
       System Guard Runtime Monitor Broker
       Task Scheduler
       TCP/IP NetBIOS Helper
       Time Broker
       Touch Keyboard and Handwriting Panel Service
       Update Orchestrator Service
       UPnP Device Host
       User Data Access_7c631
       User Data Storage_7c631
       User Manager
       User Profile Service
       Web Account Manager
       Windows Audio
       Windows Audio Endpoint Builder
       Windows Biometric Service
       Windows Connect Now - Config Registrar
       Windows Connection Manager
       Windows Defender Antivirus Network Inspection Service
       Windows Defender Antivirus Service
       Windows Defender Firewall
       Windows Event Log
       Windows Font Cache Service
       Windows Image Acquisition (WIA)
       Windows License Manager Service
       Windows Management Instrumentation
       Windows Media Player Network Sharing Service
       Windows Modules Installer
       Windows Push Notifications System Service
       Windows Push Notifications User Service_7c631
       Windows Search
       Windows Security Service
       Windows Update
       WinHTTP Web Proxy Auto-Discovery Service
       WLAN AutoConfig

    So service wise the net view error and the network browser situation make no sense
    everything is running for it to work and yet.....

    Network is Private
    Network discovery is enabled

    I have reinstalled, downloaded a new image and reinstalled

    And all computers are in the same workgroup name, just WORKGROUP (no domain)

    I am at a loss, i do not think i am missing anything?
    Did this just get broken in 1903? and why does it require SMBv1 to even work at all?
    Without it, you can not even bring something up by \\computer-name you get an error 53

    Sunday, August 25, 2019 6:27 AM

All replies

  • Hi,

    Thanks for your posting in this forum.

    This is not a normal behavior. Did you perform these operations on all computers in your workgroup?

    In addition, do you have firewall or anti-virus software enabled on these machines? If so, please temporarily turn them off to see if the issue is resolved.

    Best regards,


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact

    Monday, August 26, 2019 3:14 AM
  • net view has been broken since at least 1809. At least that's been my experience. I have to \\computername or \\ipaddress  to see a local or remote computer.

    I can see remote computers in windows file explorer as Icons....or if I use \\computer name

      net view /all or net view  returns:

    System error 6118 has occurred.

    The list of servers for this workgroup is not currently available.

    The same response across 4 windows 10 home/pro PC's all at 1903 18362.295

    I gave up on it. It hasn't worked on this PC for 10 months now.

    This is on a 48hr brand new install 1903 18362.295 

    and I'm not turning on SMBv1 because Microsoft has deprecated it and has said its a security risk

    Monday, August 26, 2019 3:38 AM
  • Hi,

    Was your issue resolved?


    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.

    If no, please reply and tell us the current situation in order to provide further help.


    Best Regards,


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact

    Monday, September 2, 2019 9:21 AM
  • No issue has not been resolved, sorry have been tied up with work.

    Every windows 10 PC i have that has updated to the latest build has same issue
    including a laptop which is a 100% virgin install from the ISO pulled direct from the website

    net view does not work
    and while you can look at any PC if you know it's name, you can not browse
    the network., same error code.

    And net view does not work on any of them
    Strangely enough, any PC with media player set to share media, shows up as a network device.

    No firewall or AV on these devices that does not come out of the box with windows 10.

    Now as a test for giggles, i took an ISO from before homegroup was removed, and loaded an HDD fresh with it.
    That machine, on that build, can browse the network fine, see all the PC's
    AND net view works on it.

    So, unless i have 11 computers here, with some freak manifestation of demonic possession that affects any
    up to date windows installation, the behavior, while not wanted, is in fact in the OS itself, some flaw in the release version.

    And i am noticing that it is actually widely noticed, by those of use that actually use home network file shares etc, it is just that on average, i guess we are a small minority among the whole of the windows user base.
    So in take 5000 windows users, and only 10 of us use or have an idea about this stuff.

    I saw only one response in other similar threads here on technet, that gave a "functioning" solution
    and that was that ms recommends not using computer browsing, but just map the drives.
    But that is not a great solution for things that may be dynamic or used infrequently etc.

    Wednesday, September 18, 2019 6:15 AM
  • That is correct. Microsoft does not recommend using SMB1 (and for a very good reason). In fact they strongly recommend that you do not use it. Without SMB1, the old-style computer browser service will not work, so anything which depends on it, like net view, will not work.

      If you feel you must browse the network, use a third party app like Advanced IP Scanner.


     I have it installed (obviously) but rarely use it. All my machines (physical and virtual) work well with the standard Windows network discovery system which was introduced in Vista. Only Windows XP or earlier really need SMB1. Here is the network display from a Windows 7 vm.

    The top line are physical machines all running Window 10 v1903. The second line are vms running on those physical machines.

    • Edited by Bill Grant Wednesday, September 18, 2019 7:59 AM typo
    Wednesday, September 18, 2019 7:20 AM
  • Does not do much good to be able to browse from windows 7 though, unless i feel like imaging a PC as windows 7, i already know it still works in vista and 7 and windows 10 earlier builds

    Nor would i be interested in any 3rd party apps

    Just interested in MS fixing the local network browsing so it doesnt require fiddling with smb1.0
    or any other stuff

    Friday, September 20, 2019 7:20 AM
  • Hello All,

    Just out of interest (because, fortunately, I neither need nor want the functionality), I took a look at why plain "net view" does not work in my workgroup of Windows 10 PCs.

    Plain "net view" (i.e. without any computername argument) is essentially just a simple call to the Windows API function NetServerEnum. There are other services that can be used for resource discovery and Windows (network) Explorer is able to use them.

    If "NetBIOS over TCP/IP" is enabled on at least one interface and the Browser service is running, Windows 10 1903 systems are able to function as master browsers, even when SMB1 is not installed/enabled. The "net view" command works on the master browser system. If the system is not the master browser, it knows who the master browser is.

    The fatal problem occurs when a client tries to issue a RPC to the master browser to obtain the list of servers. An ETW trace of the Microsoft-Windows-SMBClient provider during this process shows:

    After successfully negotiating the SMB dialect, the client suddenly disconnects the SMB connection. A look at the call stack at the time of the disconnection hints at the reason:


    Some code in mrxsmb20!MRxSmb2HandOverSrvCall decides that a disconnect is necessary and a quick look at that routine shows that the condition is ConnectionType == Tdi. Possible values for ConnectionType are Tdi (TDI - Transport Driver Interface), Wsk (Windows Kernel Sockets), Rdma (Remote Direct Access Memory) and VMBUS.

    TDI is a deprecated technology and is used by "NetBIOS over TCP/IP" (netbt.sys). It seems as though the client will refuse to use SMB2/3 in conjunction with "NetBIOS over TCP/IP".

    The ETW trace contains two entries showing "Packet (0 bytes)" - this is a bug in the tracing instrumentation when the connection type is TDI (another hint that this combination is not getting much love/attention).

    If the result of the SMB dialect negotiation had been an SMB1 dialect, then the routine MRxSmb2HandOverSrvCall would not have been called, but that is difficult to arrange - the client must support SMB1 and the server must choose SMB1 (e.g. SMB2 must be disabled or not present in the server).

    TDI has been deprecated for some time (one statement from Microsoft that I found was "TDI will not be supported in Microsoft Windows versions after Windows Vista") and I guess that it will soon disappear from Windows 10, taking "NetBIOS over TCP/IP" with it.


    Friday, September 20, 2019 9:37 AM
  •   NetBIOS over TCP/IP has been on borrowed time for ages. There is no support for it in IPv6. Only the reluctance to move to IPv6 has kept it alive.

       For a stopgap solution (when Microsoft finally decided to use TCP/IP instead of its proprietary protocols) it has had a good run.


    Saturday, September 21, 2019 4:58 AM
  • Hello Bill,

    I agree. I also noticed that I did not make the essential role of "NetBIOS over TCP/IP" in supporting "net view" clear. This image, taken from [MS-BRWS], shows the relationship to other protocols:

    The [MS-RAP] dependency supports, for example, RPC to the master browser. The [MS-MAIL] (Remote Mailslot Protocol) dependency supports the election and detection of the master browser and presence announcements - it is this functionality that depends on "NetBIOS over TCP/IP".

    [MS-MAIL] actually states:

    However, NetBEUI and "NetBIOS over IPX" are only of historical interest leaving just "NetBIOS over UDP".

    Browser information is maintained on a per interface basis and the NetServerEnum RPC is performed for each interface over the same transport that detected a master browser - that is why the TDI based "NetBIOS over TCP/IP" transport is used for the RPC rather than the normal WSK (Winsock Kernel) "Direct TCP" transport.


    Saturday, September 21, 2019 8:26 AM