none
DHCP issue on Windows Virtual machines RRS feed

  • Question

  • Hi, i have an issue with dhcp in a Windows virtual pc rtm scenario with 2 virtual machines (1 client and 1 server dhcp). All machine uses INTERNAL network configuration and i can ping, join to the domain etc. etc.
    The problem is the dhcp. The client machine cannot obtain an ip address from the server (Obtain apipa only). With network monitor i can view a nack response from dhcp but the configuration is OK. (i'am a microsoft trainer and i configured many dhcp servers). I have used many other virtual machine but the result is the same and many other friends had this same error. Is an issue??
    Thanx
    Valerio
    Monday, October 12, 2009 2:41 PM

Answers


  • Response from Microsoft:

    ************************************************************************************************************************************

    Yes this is a known issue that when you connect the virtual machines to internal network, it gets the IP address from the internal network inbuilt DHCP server.

    You can work around this as follows
    - Hibernate/Turn off all the VMs. From Task Manager, kill vpc.exe if it doesn`t exit on its own.
    -Edit "%localappdata%\microsoft\Windows Virtual PC\options.xml"
    -In the XML file -> Under the "internal network" node: i.e. "preferences\Virtual Network id =0\virtual_server\dhcp\" , set enabled = false.
    -Turn on the VMs and verify the scenario.

    *************************************************************************************************************************************

    Thanx to      KelvinChiggs Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals     for these news.

    Thursday, October 15, 2009 2:58 PM

All replies

  • Just to clarify, you have a client and server set up as VMs and the VM client is failing to get a DHCP address from the VM server?
    Monday, October 12, 2009 6:54 PM
  • Hi smjain, yes this is the scenario: a mv client and a vm server dhcp. I have seen many other threads with the same problem but no solution. Someone said that windows virtual pc assign an Apipa address (a sort of internal dhcp?) as a normal address, and this is the problem.

    Tuesday, October 13, 2009 5:56 AM
  • Hi, I have recreated the same set up as you desribed the problem is that with an internal network the VM machines have to have static ip address in the same network range (ie. 192.168.1.0 to 192.168.1.255 ) Virtual PC does not set this up Automatically in the way Vmware Server does. So the client can not see the DCHP Server. When set to get IP address Automatically. Therefore it gets the APIPA address. To get the results you need, you might have to use Microsofts other Virtual Software which is designed for what you want to do. Slan go foill, Paul 
    Tuesday, October 13, 2009 11:15 AM
  • Hi, I have recreated the same set up as you desribed the problem is that with an internal network the VM machines have to have static ip address in the same network range (ie. 192.168.1.0 to 192.168.1.255 ) Virtual PC does not set this up Automatically in the way Vmware Server does. So the client can not see the DCHP Server. When set to get IP address Automatically. Therefore it gets the APIPA address. To get the results you need, you might have to use Microsofts other Virtual Software which is designed for what you want to do. Slan go foill, Paul 

    Thanx, the temp solution is the use of loopback adapter of windows 7 host machine. This configuration is ok (i am using the loopback adapter in all windows guests), but i wait for a "real" solution by Microsoft.
    Thanx again

    valerio
    Tuesday, October 13, 2009 11:26 AM

  • Response from Microsoft:

    ************************************************************************************************************************************

    Yes this is a known issue that when you connect the virtual machines to internal network, it gets the IP address from the internal network inbuilt DHCP server.

    You can work around this as follows
    - Hibernate/Turn off all the VMs. From Task Manager, kill vpc.exe if it doesn`t exit on its own.
    -Edit "%localappdata%\microsoft\Windows Virtual PC\options.xml"
    -In the XML file -> Under the "internal network" node: i.e. "preferences\Virtual Network id =0\virtual_server\dhcp\" , set enabled = false.
    -Turn on the VMs and verify the scenario.

    *************************************************************************************************************************************

    Thanx to      KelvinChiggs Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals     for these news.

    Thursday, October 15, 2009 2:58 PM
  • I am new to XML and don't know how to script it. Could you please explain further on how to put the solution into the XML options file.

    Thanks,

    Matt
    Wednesday, November 18, 2009 3:29 PM
  • I am new to XML and don't know how to script it. Could you please explain further on how to put the solution into the XML options file.

    Thanks,

    Matt

    Hy matt, you can use a simple notepad to modify a XML file.
    Saturday, December 12, 2009 11:04 AM

  • Response from Microsoft:

    ************************************************************************************************************************************

    Yes this is a known issue that when you connect the virtual machines to internal network, it gets the IP address from the internal network inbuilt DHCP server.

    You can work around this as follows
    - Hibernate/Turn off all the VMs. From Task Manager, kill vpc.exe if it doesn`t exit on its own.
    -Edit "%localappdata%\microsoft\Windows Virtual PC\options.xml"
    -In the XML file -> Under the "internal network" node: i.e. "preferences\Virtual Network id =0\virtual_server\dhcp\" , set enabled = false.
    -Turn on the VMs and verify the scenario.

    *************************************************************************************************************************************

    Thanx to      KelvinChiggs Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals     for these news.

    Thanks this solved it for me. Having said this, why would Virtual PC have a DHCP server handing out APIPA addresses?!? This is redundant to say the least given every modern version of windows will assign itself an APIPA address IF there is no DCHP server. Just waisted 1 hour trying to resolved this... Not mad at you just wondering if I should have stuck with VMware...
    Wednesday, January 20, 2010 9:11 PM
  • I tried it this solution as well and it doesn't work.  I'm using windows7 and Virtual PC.  I downloaded WinXPSP3_IE7 and IE8 images...can't get either one to work for anything, but the Windows XP Mode image works fine OTB.  Go figure...

    Thursday, April 28, 2011 7:21 PM
  • Ok. So I managed to get mine fixed.  Scenario:

    1. using downloaded images IE7Compat.vhd and IE8Compat.vhd from the Microsoft Virtual PC site

    2. Using Microsoft (free) Virtual PC

    3. Windows XP Mode (the default image for Windows7) works fine

    4. Using Windows 7 Pro 64-bit

     

    At first when I created a virtual machine it dropped another vhd file onto the hard drive in the location I entered into the LOCATION field on screen 1 of the "Virtual Pc Wizard".  This led me to believe that it was the .vhd file I was supposed to use.  Probably because it was named following the convention of the .vmc and .vmx file that I provided in the NAME field on the first screen of the wizard.

    The reason was that I was telling the wizard to "Create a dynamically expanding virtual hard disk" on the third screen.  What I actually needed to do was to select the second (middle) radio option: "Use an existing virtual hard disk".  For that (location) field I browsed to, and selected, the downloaded vhd.

     

    That did the trick.  What was happening:

     

    1. if you choose to create your own dynamic .vhd, you'll have to install the OS yourself.

    2. Without an OS, the Virtual Machine tries to network boot, which results in the DHCP failure and the subsequent prompting for insertable bootable media.

     

    HOPE THIS HELPS!

     

     

    Thursday, April 28, 2011 10:01 PM
  • Hi all,

    I had a similar situation, my virtual machine was getting a 192.168 address and could not see our DC which was on 10.0.

    I went into xp virtual machine, tools, networking, and configured the network adapter to use shared, not shared (NAT)

    I then ran ipconfig /renew

    the machine was able to see the proper dhcp server, and now I can join the domain,

    I hope this helps,

    kind regards

    Grant Dickeson

     

    Tuesday, May 24, 2011 11:56 AM
  • It works! Many thanks for your support!

    APIPA address could be generated by windows system if IP address is set to DHCP but there is no active DHCP server in network.

    So I just can not understand why windows virtual pc still keep such a unnecessary default internal DHCP server to distribute APIPA address.


    Thursday, June 6, 2013 1:04 AM