Error Code-0x80070424-won't allow access to security center and says firewall is off


  • In an attempt to allow a program access through firewall, it said recommended settings were not in use.  Then when I click button for recommended settings it gave me Error Code 0x80070424.  When I attempted to open security center, it denied access (I was logged in as administrator) and it said that my firewall is off.  I really need some advice because I use my computer alot for college classes.  I do not know how long it has been like this, I just found the problem today.  I ran AdvancedSystemsCare, Glarys Utilities, Expired Cookies, Ccleaner, Disk cleanup, Disk defrag, then AVG Free, Spybot Free, and finally, Adware Free.  Adware found 3 problems-1major privacy problem.  I still have the original problem.  Do I need to get a Windows 7 clean install disc and format the hard drive and do a clean install?  None of the blogs that I have found so far have helped.  I did not receive any discs with my Dell when I purchased it.  I took A+ classes last spring and created 2 repair discs-1 for Win7 Home Premium and 1 for Win7 Pro but neither will boot up.  I suspect it is involved with the firewall problem.  I would appreciate any help.
    Monday, January 02, 2012 6:04 AM


All replies

  • I have exactly the same problem... I have an Acer laptop. Any help is very appreciated.
    Tuesday, January 03, 2012 6:20 PM
  • Same problem here.  

    Windows 7/64 Home Premium

    All current updates

    Microsoft Security Essentials, all current updates.   Now trojan indicators for  Alureon.TK, Sirefef.J, FakeRean, and Unruy.H

    After cleaning the trojans, the PC is toasted and no longer boots.  Windows Repair does not fix it.  System Restore to previous state works, but the firewall is still permanently disabled and the trojans are back.

    Let me know when there is a fix available.  Until a fix is available, the only option is a total clean rebuild.

    Tuesday, January 03, 2012 6:21 PM
  • what is the output of following commands(run them from admin cmd prompt)

    net start bfe

    net start mpssvc

    Please check what error you receive on executing these commands.

    If you see the service name invalid error then your registry keys for BFE and MPSSVC are most probably corrupt or missing. Please follow below thread in that case to restore your registry keys. and then try to restart these services.


    hope this helps.

    Tuesday, January 03, 2012 8:27 PM
  • And if those trojans don't go away, after following the previous directions, I'd recommend you run a scan with a tool such as Malwarebytes Anti-Malware or Super AntiSpyware and ensure that they are gone.  Win32/FakeRean is a rogue scanner installer, Win32/Sirefef is a multi-component family of malware capable of doing things that you wouldn't want happening, and once this is over, I'd also recommend that you create a new restore point on the infected computer, as infected you seem to be from the description of the problem that you are having.  Deleting old restore points after infection cleanup will often prevent you from becoming infected from an earlier point. 
    Wednesday, January 04, 2012 3:54 AM
  • Wednesday, January 04, 2012 6:43 AM
  • I am getting the same error. Disabled antivirus, logged in as Admin.. 

    I have tried the above steps and rebooted multiple times, still the same issue.. Any help is appreciated



    Tuesday, February 14, 2012 7:28 AM
  • You may check if Windows Firewall Service is Running on the affected PC.

    Click on Start> In Run Prompt Type Service.msc Hit Enter > Search for Windows Firewall Service. Right Click on it >Click on Stop then Start. Then try to enable Windows Firewall in Control panel.

    if this Service is missing. You need to reinstall the Windows Firewall Service. but most likely some Malware or Anti Virus program may have corrupted it and will require a OS repair, if not a complete reinstallation.



    Tuesday, April 10, 2012 4:42 AM