Errors while trying to install KB2251481 update: Security Update for Microsoft Visual Studio 2005 Service Pack 1 XML Editor


  • I am trying to install the KB2251481 update: 


    Security Update for Microsoft Visual Studio 2005 Service Pack 1 XML Editor


    When I run it on my computer from the Control Panel/Updates section it fails. I get an A66 error without any details.


    Here is a screenshot of the A66 error.


    I am running Vista Home Premium.


    One suggestion for this A66 error was to go to the Control Panel/Uninstall section, click on the "MS .Net Framework 4 Client Profile" and Repair it. I did that successfully. I tried running the update again; and, it failed again with the A66 error.


    I read a post on another MS forum that suggested downloading the patch from here:

    I downloaded it and tried to run it. I read the description. It said that it was for VS 2005 for Vista.

    It failed. I got another error:


    "The upgrade patch cannot be installed by the Windows Installer service because the program to be upgraded may be missing or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists on your computer and that you have the correct upgrade patch."

    Here is a screenshot in my Flickr account of this error.


    Can anyone help with these errors?

    Am I missing something?

     Can I provide more information?



    Friday, August 12, 2011 3:02 PM


All replies

  • I posted this on MS Answers and got an answer from an MS Pro

    One suggestion was to run MS Fix It:

    This was very fast. It found something and fixed it. I had to reboot. The Update installed successfully the first time.




    Saturday, August 13, 2011 2:03 PM
  • HOLD ON!!!

    I don't understand. I saw the window that stated that the update was installed successfully.]
    About ten minutes later I saw the little "New Updates" are available in my Taskbar.
    It is the SAME UPDATE.
    I checked my update history and it showed that the update FAILED to install.
    I am confused.

    So, the previous post did NOT show a solution.
    Saturday, August 13, 2011 3:16 PM
  • Saturday, August 13, 2011 5:44 PM
  • Hi,

    This issue may occur due to corrupt temp files that make Windows update think this update is not installed but actually it did. If the update can be installed successfully, my suggestion is to hide the update:

    1. Open the Control Panel. (Classic View)
    2. Click on the Windows Update icon.
    3. Click on View available updates. 

    4. Right click on the update you want to hide, and click Hide update. 
    5. Click the red X button in the upper right corner to close the window.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, August 19, 2011 8:01 AM
  • Solution is simple... as MS didn't change version of DLL.


    1. You need to uninstall previous version of this patch from Add/Remove Programs Panel.

    2. Run update process...


    No restart needed

    • Proposed as answer by RCC, Inc Tuesday, August 23, 2011 2:04 AM
    Monday, August 22, 2011 8:03 AM