none
WMI Service cannot be started when installing SQL Server Denali CTP3

    Question

  • After downloading and installing SQL Server Denali CTP3 on a Windows 7 machine that exceeds the minimum requirements, the only test that fails is WmiServiceStateCheck: "The Windows Management Instrumentation (WMI) service cannot be started. To continue with the installation, you must troubleshoot and repair your Windows Management Instrumentation (WMI) service."

    I've run sfc /scannow a couple of times to be sure there are no errors, and have run various scripts that turn the service on and off, repair/restore it, etc. to no avail. I've also tried the installation in safe mode to be sure virus checkers and the like are not interfering. I can't even generate any error message with the WMI service, but I include the question here rather than under a SQL installation heading.

    Here's what the Winmgmt service shows:

    Startup Type: Automatic; Local System Account ("Allow service to interact with desktop" not checked)

    Dependencies - Depends on Remote Procedure Call (RPC); Depended Upon by: Intel Matrix Storage Event Monitor, Internet Connection Sharing (ICS), IP Helper, and Security Center

    The computer has an Intel Core i5 processor 430M with 4G of memory, and thus is a 32 bit install, but in case it matters, a 64 bit install also failed. I'm starting to think it's something that even in safe mode is conflicting rather than the WMI service itself being corrupted, not set-up right, etc. 
    Ideas?
    Friday, July 29, 2011 3:32 AM

Answers

All replies

  • Since I appear to have stumped everyone, could it be possible the WMI namespace security is not set correctly?
    Using WmiMgmt, which permissions should be allowed and denied for which groups or user names? Currently, authenticated users, local service, and network service all have (only?) "execute methods", "provider write", and "enable account" checked off as allowed. For administrators, everything except "special permissions" is allowed. Nothing is denied for anyone. 
    Saturday, July 30, 2011 1:25 PM
  • I reinstalled .net framework 4.0, redownloaded the 64 bit version of Denali... once again to no avail. Surely someone must have an idea. 
    Sunday, July 31, 2011 6:45 PM
  • I downloaded SQL Server 2008 R2 for comparison. Same error, so it's obviously something with my computer. Keep those cards and letters coming. 
    Monday, August 01, 2011 1:02 AM
  • From the log:
    (05) 2011-08-01 00:28:19 Slp: Initializing rule      : Windows Management Instrumentation (WMI) service
    (05) 2011-08-01 00:28:19 Slp: Rule is will be executed  : True
    (05) 2011-08-01 00:28:19 Slp: Init rule target object: Microsoft.SqlServer.Configuration.SetupExtension.WmiServiceInfo
    (05) 2011-08-01 00:28:19 Slp: The type initializer for 'System.Management.MTAHelper' threw an exception.
    (05) 2011-08-01 00:28:19 Slp:    at System.Management.MTAHelper.IsNoContextMTA()
       at System.Management.MTAHelper.CreateInMTA(Type type)
       at System.Management.ManagementPath.CreateWbemPath(String path)
       at System.Management.ManagementPath..ctor(String path)
       at System.Management.ManagementScope..ctor(String path)
       at Microsoft.SqlServer.Configuration.SetupExtension.WmiServiceInfo.Microsoft.SqlServer.Configuration.RulesEngineExtension.IRuleInitialize.Init(String ruleId)
       at Microsoft.SqlServer.Configuration.RulesEngineExtension.RulesEngine.Execute(Boolean stopOnFailure)
    (05) 2011-08-01 00:28:19 Slp: Rule initialization failed - hence the rule result is assigned as Failed
    (05) 2011-08-01 00:28:19 Slp: Send result to channel : RulesEngineNotificationChannel
    Monday, August 01, 2011 5:11 AM
  • Hi jsmitchell_ct,

    Thanks for the post!

    Based on this Microsoft SQL Server Code_Named "Denali" CTP3 Release Notes.

    "Installing SQL Server Code-Named “Denali” is supported only on Windows 7 SP1 or Windows Server 2008 R2 SP1"

    Did you install the Service Pack 1?

    Please also ask this question in SQL server forum.

    Regards,

    Miya  


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, August 01, 2011 9:14 AM
    Moderator
  • Yes I have installed SP1. I'm running .net 4.0.30319. Per your request, I've reposted a comprehensive version of the above at:

    http://social.msdn.microsoft.com/Forums/en-US/sqlsetupandupgrade/thread/f317ef2f-7523-4a62-a365-d8244f5858c5

    Monday, August 01, 2011 2:24 PM