none
Can't connect to hidden SSIDs RRS feed

  • Question

  • We've seen Windows 8 unable to connect to hidden SSIDs through the Consumer Preview, Release Preview, and we continue to see it not working in the RTM. While we're basically still mostly stuck using XP, with a smattering of Windows 7 throughout the entirety of our state's Department of Education, staff are increasingly bringing their own devices to work. We use Cisco Aironet APs that blanket all our schools state-wide, with all our SSIDs hidden, though we're fairly certain this is not an issue specific to our APs, as the few techies we have that are early adopters have reported their Windows 8 devices fail to connect to any hidden SSIDs, whether ours at work, or theirs at home. 

    The only workaround seems to be to un-hide an SSID, allow a Windows 8 device to connect, and then hide the SSID. Then that Windows 8 device is able to connect to the hidden SSID again in the future. Suffice to say that this is an absolute no-go in terms of a solution for our workplace. Due to our lumbering size and bureaucracy, we aren't going to be shifting to permanently unhiding our workplace SSIDs either.

    We've been watching this issue all these months and have failed to see any real discussion concerning it; what little exists is filled with people's ad hominen attacks on the futility of hidden SSIDs, and/or completely pointless comments about making sure the network connections are set to connect to non-broadcasting SSIDs (as if the people presenting this issue were...stupid or something). While we agree that hidden SSIDs are rather...silly, to be polite, it doesn't change the fact that many large organizations and businesses use them, and by virtue of size and ennui, aren't likely going to stop any time soon.

    Our question is simple: Microsoft, are you even aware that this is a potentially huge issue barring use/adoption of Windows 8 in the workplace? And, with the increasingly fuzzy line between work and home devices, the potential this issue has to stymie home adoption as well?

    We just assumed through the two previews that those being previews, functionality was missing. That it's still not working in your RTM has begun to make us worried. 

    Thursday, September 20, 2012 7:37 AM

Answers

All replies

  • I have no trouble connecting to hidden SSIDs. I don’t know if it’s the way you set it up but what works for me is to set up the connection manually. i.e. go to the Network and Sharing Center > Set up a new connection or network > Manually Connect to a Wireless Network > Next. Type in the Network Name (SSID), select the Security Type and type in the Wireless key.

    You may want to tick ‘Start this connection automatically’ and ‘Connect even if the network is not broadcasting‘. Subsequent connections will be automatic.

    I should add that I have to cater for people who have older laptops, where the adapter uses WEP (another seemingly contentious issue on the forums). So, for me, a mixture of old XP laptops and newer Windows 8 computers all connect to a hidden SSID using WEP.

    Thursday, September 20, 2012 7:53 AM
  • Yes, we have manually created connections. Yes, we have made sure the relevant checkboxes are marked. We're not completely brain dead. ;) 

    We are using WPA2 Personal throughout the state, which also seems to be what the seven people in our office who have been testing Windows 8 have been using at home. I will ask them to try setting up their home routers using WEP instead, and see if they have better luck.

    The only other bit of info that may, or may not, be relevant is that our workplace networks broadcast exclusively on the N band. 

    A google search seems to indicate that this is not an isolated issue in regards to failure to connect to hidden SSIDs with various iterations of Windows 8. 

    Is it possibly a driver level issue instead? If BurrWalnut is able to connect to hidden SSIDs, then it would seem to hint that it isn't necessarily an issue inherent with the OS itself. 

    All seven test laptops are using Qualcom Atheros AR9285 802.11b/g/n adapters, if that matters. As far as we can tell, they are using drivers that Windows 8 installed during installation. An attempt to install the Windows 7 drivers, as a test, failed. 

    That said, we've asked people at the various schools throughout our state if anyone has had any luck getting a Windows 8 computer to connect to our hidden SSIDs, and not one person has given us an affirmative, so whatever the issue is, we really don't think it's all that isolated, though we haven't documented the various wireless adapters used. As I mentioned in my first post, the only way we can get it to connect is if the first time we connect, the network isn't hidden. Then, in the future, the computers are able to connect even with the network being hidden. 

    Any other input would be appreciated. Thanks. 

    Friday, September 21, 2012 12:12 AM
  • Hi,

    I also have no issue with Hidden SSID wireless network. When you manually define the Network Profile, what kind of prompt does this profile indicate in Profile List? I mean "is there a cross beside the Profile Entry?".


    Juke Chou

    TechNet Community Support

    Monday, September 24, 2012 3:33 PM
    Moderator
  • I began connecting to a hidden SSID (the private interface) from around februar 2012 untill early july 2012. So that was in the period of both the consumer and release preview.

    I connected almost each day. It worked wihtout any problems. Have not tried it with the RTM though.

    It was also the major network with both private and public interfaces in the school sector in Denmark - supported by the major telco and networking company in Denmark. Cisco equipment ...

    In the computer I used sits an Intel WLAN NIC.

    Tuesday, September 25, 2012 10:43 PM
  • Just saw this similar post though: http://social.technet.microsoft.com/Forums/en-US/w8itpronetworking/thread/cdfc6f7a-6f69-4816-87d7-841e18fc2f0d

    I don't recall what driver package I used - but it was from Intel. At the time may be the Win7 package.

    Tuesday, September 25, 2012 11:18 PM
  • I confirm the same issue with an old Linksys-Cisco WUSB54G Ver.1 wireless network adapter (Cisco-Linksys driver wusb20xp.sys, File Ver. 1.0.8 (2004)) using WEP security and Windows 8 Pro release (Ver. 6.2.9200 Build 9200):

    When SSID is not broadcast there is no automatic connection to the wireless network by Win 8.  I must log into my user account and then manually log into the network (enter SSID and WEP key), after which the connection survives until the next reboot.

    When SSID is broadcast, then the pc automatically connects to network as desired with no user interaction.

    As a further test, I rebooted with no SSID broadcast and let the pc sit at the login prompt (no user intervention).  Another pc tries to ping it, but ping fails.  I then change the router to broadcast SSID.  The pc immediately responds to ping, indicating network connectivity.

    I never had these issues with the same network and hardware running Win 7.

    MS:  Are you on a campaign to eliminate hidden SSIDs?  Please update the Win 8 driver and/or Win 8 itself to recognize hidden SSIDs, or else announce your intentions so we don't waste days debugging this issue. .













    Thursday, November 8, 2012 4:08 AM
  • Forget about windows 8 OS, I think MS is trying to eliminate hidden SSID from windows phone 8 as well. I purchased my Nokia 920 today and tried connecting to my wire2 router with SSID disabled and it wouldn't connect unless I enable SSID broadcast. This is crap as my apple devices are connecting fine with SSID disabled. Not sure if Nokia or MS messed up this wifi setting.
    Saturday, November 24, 2012 4:22 AM
  • I am having the problem with a hidden SSID, too.  I have a Samsung ATIV with Windows 8 and have tried it with multiple wireless units.  It will not reconnect to a hidden SSID.  It will connect when you add it initially, and stay connected as long as you do not reboot or leave the building.  But once it stops connecting it will not reconnect unless you re-add the connection again.

    Thursday, December 13, 2012 10:16 PM
  • Same problems here.  Linksys WRT54G Version 6 router with the latest firmware.  Works perfectly fine on multiple computers with Windows XP, Windows 7, Windows 7 on a Tablet, iPhone, and iPad.  It also works with the Windows 8 consumer preview on an older HP Laptop.  But my brand new Samsung ATIV Smart PC Tablet hasn't connected well since day 1 so I'm guessing it's a mixture of software and hardware.

    To make matters worse the IDIOTS (Yes the Windows 8 team is complete IDIOTS on many things) at Microsoft took away the ability to manage your wireless accounts.  So you have to search the internet to find the command line prompts to do it.  And now that I deleted it and redefined it things are even worse.  Do these guys not get out of their cubical and travel and want to delete a hotel or customer's network they will never use again.

    Even more idiotic is the fact that if you do try to redefine it you can't because the previous name is already used.  A simple, do you want to overwrite prompt would have been the logical thing to do.  Honestly a first grader could have figured that one out.

    Needless to say time to start developing apps for the iPad instead.  Microsoft completely shot themselves in the head with this one and all the great things they did do are far overshadowed by the horrible usability and idiotic moves they made.  It's a trainwreck on a desktop switching between desktop and tablet mode for even simple things like viewing images.  Not to mention their complete lack of listening to users complaints from day 1, not including the start menu, and the new IE 10 can't even work with the drop down menus on common sites such as Best Buy and Lowes.

    It's sad because Windows 8 could have been so much better if Microsoft would give the customers what they want instead of thinking that they know what we need.

    Friday, December 28, 2012 1:14 PM
  • Sure it's an old router but it's still one of the most robust ones out there and there's millions of these in use today I'm sure.  It's not some cheap off brand router that they shouldn't have tested against.  And amazing that all the other computers on XP and Windows 7 along with iPhone and iPad have no problems at all, but the latest and supposedly greatest does.

    I'll know more later but this morning it wouldn't connect at all today.  I tried yesterday changing the Beacon Interval on the router to 20 ms from the default 100 ms thinking that might help but seams to make it worse.  So I changed it the other direction to 1000 ms and now it connects.  So maybe Windows 8 on the Samsung Tablet just isn't fast enough for the default Beacon Interval of 100 ms?  Again strange though because one of my test tablets was a first generation flip screen running XP Tablet and then Windows 7 with no problems either.

    We'll see how well it connects over the next few days.

    Friday, December 28, 2012 1:33 PM
  • Again it's not the routers fault.  I have to SLOW the Beacon Interval down for Windows 8 on the Samsung Tablet to pick it up.  At the default 100 ms it was hit and miss with Windows 8, at 20 ms Windows 8 could never find the router, at 1000 ms Windows 8 hasn't had a problem in 2 days.  

    So apparently Windows 8 just isn't quick enough to detect it when Windows XP, Windows 7, the iPhone, and the iPad all have no problems at all on much older hardware at any of the Beacon Interval speeds I tested.

    Sunday, December 30, 2012 8:22 PM
  • Hello,

    I was looking into your problem with not being able to connect to Hidden Wireless-N only networks.  I have not tried to connect to hidden networks again after the first failed attempts on the first day.  I assumed that Microsoft would have fixed this by now.  I looked through the rest of the thread and I tried one of the proposed solutions, which was to use a windows 7 driver.  It wasn't an easy thing because Windows 8 tells you that you have the latest drivers when you try to replace them.

    I currently have a WMP600N PCI Wireless-N network card plugged into my tower.  You will have to updated the drivers through the 'Device Manager'.  Do not worry about uninstalling the device because it will install the windows default driver as soon as you hit the refresh button at the time.  All I did was go to the 'Network Adapters' tab within 'Device Manager' and right-clicked on the device I wanted to 'update'.  I chose "Browse my computer for driver software", followed by "Let me pick from a list of device drivers on my computer".  Once you see the list you will not use any of them.  Right below that box of digitally signed drivers is a "Have Disk..." button.  Choose that, then navigate to the downloaded drivers or old drivers that you have saved.  I highly recommend that you do not let Windows Update automatically update these drivers on their own.  I hope that this helps you out.  Keep in mind, that going about this update in any other matter, will keep the pre-installed drivers from Microsoft.  Good luck.

    Thursday, January 3, 2013 8:36 PM
  • From N2K solutions guy,

    I ran into this issue when I first got my Windows 8 laptop. Recently, we issued out Windows 8 tablets as a promotion and all our customers work under a hidden SSID network. The AP's are all Cisco. I myself have a Netgear at home with a hidden SSID. My office has a Linksys that is set up with a hidden SSID. Here's the kicker..... My Windows 8 phone connects to all three. My Windows 8 laptop only connects to my wireless at work. I elevated the issue to the manufacture as well as a Microsoft rep.

    This is what I've found..... On all my devices trying to connect, they are all 802.11n capable. My wireless router at work is restricted to only broadcast 802.11b/g because of an issue with some of our laptops. As soon as I turned off Wireless N on my home router, viola! My profile reconnected every time it was in range. Apparently is was the same issue with our other laptops. One thing in common is my laptop and the promotion tablets have the same Broadcom wireless adapter. Broadcom did not allow you to force Wireless B/G on the driver, therefore, turning it off on the router/AP is the only other option at this time. They are aware of the issue but haven't released a fix yet because they really want you to connect to N.

    My stance is that I rather connect at the slower B/G then not connect at all! Hope this helps you guys out that have been pulling your hair on this matter!

    Wednesday, March 6, 2013 11:56 PM
  • In my case where I have a Win XP SP3 device in a 802.11n environment not advertising its SSID, I went into [the latest version of] the Boardcom driver and capped its rate to 48 Mbps (54 Mbps is the max for 802.11g rate connections) and it suddenly worked.  I hope this helps.
    • Proposed as answer by Dunny W Friday, November 1, 2013 7:50 AM
    • Unproposed as answer by Dunny W Friday, November 1, 2013 7:51 AM
    • Proposed as answer by Dunny W Friday, November 1, 2013 7:51 AM
    • Unproposed as answer by Dunny W Friday, November 1, 2013 7:51 AM
    • Proposed as answer by Dunny W Friday, November 1, 2013 7:52 AM
    • Unproposed as answer by Dunny W Friday, November 1, 2013 7:52 AM
    • Proposed as answer by Dunny W Friday, November 1, 2013 8:02 AM
    • Unproposed as answer by Dunny W Friday, November 1, 2013 8:02 AM
    Thursday, October 3, 2013 5:23 PM
  • Please excuse the proposed answers blanks :). The new Chrome app on tablet does not offer a keyboard... Or BEBKAC

    I have not read all the responses above but I have struggled with a hidden wifi since day one of running 8 on two separate devices. One day works most days fail. Recreated each time and joins fine but you end up with "My network 1 2 3 4 5 6 7" by the end of the week :)

    So I finally stumbled on the answer a few days back after investigating a way to delete profiles after 8.1 would not let me delete all my multiple versions of the home network I end up creating. 

    Add a batch file to your desktop with one line in it.

    netsh wlan connect name="my network"

    where my network is you local profile. If the hidden SSID is not there when you login, run the batch file and open wifi networks again and it will be after a few seconds. 

    Hope that helps.


    Friday, November 1, 2013 8:12 AM
  • i have win7 using HP pavilion . .i have configured manually but still am facing the problem to connect i have made it automatic still its not connecting

    Wednesday, March 19, 2014 5:38 PM
  • 4 years later people still have same problem since MICrOSOFT employs Brain dead zombies
    Tuesday, February 2, 2016 5:34 AM