none
Command & Conquer Zero-hour startup crash fix

    General discussion

  • The game was crashing at the intro, I found this fix on the internet, and wanted to make sure people knew about it.

    URL OF FIX: http://www.vistaheads.com/forums/microsoft-public-windows-vista-games/326522-c-c-generals-zero-hour-help-plz.html

    I will paste the fix here in case the link dies in the future.

    CREATE THE FILE WITH THESE CONTENTS, (or perhaps modify it if you have other options necessary):

    C:\Users\<USERNAME>\Documents\Command and Conquer Generals Zero Hour Data\options.ini
    AntiAliasing = 0
    DrawScrollAnchor =
    FirewallBehavior = 0
    GameSpyIPAddress = 192.168.0.1 (make sure you use your own IP)
    Gamma = 50
    IPAddress = 192.168.0.1 (make sure you use your own IP)
    IdealStaticGameLOD = High
    LanguageFilter = false
    MoveScrollAnchor = 0
    MusicVolume = 61
    Resolution = 800 600
    Retaliation = yes
    SFX3DVolume = 58
    SFXVolume = 53
    ScrollFactor = 60
    SendDelay = no
    StaticGameLOD = lOW
    UseAlternateMouse = no
    UseDoubleClickAttackMove = no
    VoiceVolume = 70
    Friday, August 14, 2009 4:53 PM

All replies

  • Does not work on 64bit. Tested on 2 pcs and tried everything those forum posts said.
    Sunday, January 17, 2010 5:46 PM
  • try this In 'My Documents' (usually at C:\users\YOURNAME\documents) there should be a folder named 'Command and Conquer Generals Data' or 'Command and Conquer Generals Zero Hour Data', which was put there when you installed the game.  You need to create a text file using notepad and save it into this folder.  However, you must click 'save as' and change the type drop-down box  from text file (.txt) to 'all files'.  Then save the file as 'options.ini'

    Before you save, paste this text into the file to get you started:

    AntiAliasing = 1
    BuildingOcclusion = yes
    DrawScrollAnchor = 
    DynamicLOD = no
    ExtraAnimations = yes
    GameSpyIPAddress = 0.0.0.0
    Gamma = 50
    IPAddress = 0.0.0.0
    IdealStaticGameLOD = High
    LanguageFilter = true
    MaxParticleCount = 5000
    MoveScrollAnchor = 
    MusicVolume = 55
    Resolution = 1024 768
    Retaliation = yes
    SFX3DVolume = 79
    SFXVolume = 71
    ScrollFactor = 50
    SendDelay = no
    ShowSoftWaterEdge = yes
    ShowTrees = yes
    StaticGameLOD = Custom
    TextureReduction = 0
    UseAlternateMouse = no
    UseCloudMap = yes
    UseDoubleClickAttackMove = no
    UseLightMap = yes
    UseShadowDecals = yes
    UseShadowVolumes = yes
    VoiceVolume = 100

    This is simply how the game remembers what options you picked (music volume, brightness and the like) and  you can change them once the game is running using the options menu.

    Now the key bits - firstly, make sure that you have full read/write permissions for the Command and Conquer Generals Data folder - do this by right clicking on the folder, then  properties then the security tab and change the permissions for all users.  It might also be worth making sure no files are "Read-Only" in that folder.

    Then change the game's compatibility mode by right clicking on the game in the start menu, clicking on properties and then the Compatibility tab.  I used the "Change settings for all users" button at the bottom and changed to Windows XP (SP3), as well as checking the "Run as administrator box".

    Hey presto! It worked, debunking the myth that C&C Generals will not run on 64 bit systems (as some people have been saying).  In fairness, I haven't tried online multiplayer yet, just a few skirmishes.

    Good Luck!


    Tuesday, November 16, 2010 7:48 PM
  • eXCELLENT! it worked perfectly! thanks , on a Windows 7 Ultra 64bit using Amd Phenom II X4 250GT 8Gb DDR3


    try this In 'My Documents' (usually at C:\users\YOURNAME\documents) there should be a folder named 'Command and Conquer Generals Data' or 'Command and Conquer Generals Zero Hour Data', which was put there when you installed the game.  You need to create a text file using notepad and save it into this folder.  However, you must click 'save as' and change the type drop-down box  from text file (.txt) to 'all files'.  Then save the file as 'options.ini'

    Before you save, paste this text into the file to get you started:

    AntiAliasing = 1
    BuildingOcclusion = yes
    DrawScrollAnchor = 
    DynamicLOD = no
    ExtraAnimations = yes
    GameSpyIPAddress = 0.0.0.0
    Gamma = 50
    IPAddress = 0.0.0.0
    IdealStaticGameLOD = High
    LanguageFilter = true
    MaxParticleCount = 5000
    MoveScrollAnchor = 
    MusicVolume = 55
    Resolution = 1024 768
    Retaliation = yes
    SFX3DVolume = 79
    SFXVolume = 71
    ScrollFactor = 50
    SendDelay = no
    ShowSoftWaterEdge = yes
    ShowTrees = yes
    StaticGameLOD = Custom
    TextureReduction = 0
    UseAlternateMouse = no
    UseCloudMap = yes
    UseDoubleClickAttackMove = no
    UseLightMap = yes
    UseShadowDecals = yes
    UseShadowVolumes = yes
    VoiceVolume = 100

    This is simply how the game remembers what options you picked (music volume, brightness and the like) and  you can change them once the game is running using the options menu.

    Now the key bits - firstly, make sure that you have full read/write permissions for the Command and Conquer Generals Data folder - do this by right clicking on the folder, then  properties then the security tab and change the permissions for all users.  It might also be worth making sure no files are "Read-Only" in that folder.

    Then change the game's compatibility mode by right clicking on the game in the start menu, clicking on properties and then the Compatibility tab.  I used the "Change settings for all users" button at the bottom and changed to Windows XP (SP3), as well as checking the "Run as administrator box".

    Hey presto! It worked, debunking the myth that C&C Generals will not run on 64 bit systems (as some people have been saying).  In fairness, I haven't tried online multiplayer yet, just a few skirmishes.

    Good Luck!



    Sunday, November 28, 2010 3:31 AM
  • besides a incredible annoying error which is destroying my base after 5 min of play (it happened before and I know how to fix it) the game works perfectly...I am using Windows 7 Ultimate 32-bit OS with Intel Core i3 4GB RAM DDR3
    Saturday, December 04, 2010 5:47 PM
  • How did you fix the base destroying glitch?
    Sunday, January 09, 2011 3:26 PM
  • I did as Gamestar said but now i get the error "Please insert the correct CD-ROM, select OK and restart application", i have the cd in the drive and there's no scratches or anything it's the first time i use the cd.
    Tuesday, January 11, 2011 12:22 PM
  • I´ve tried to run the game on Win 7 64 bit and it runs even more stable on 64 bit than 32 bit. You´ll have to run it in compatibility mode, windows xp sp 2 and make sure you mark in run as administrator.

    It is another matter that EA can´t make a simple patch that fixes this simple error, because this is just an access violation error. I´ve tried to get them to fix this problem, they just don´t want to and don´t give a **** about their customers like always, but still, they are selling this game, just not for people who have windows 7. It is kind of ironic to get more help from Microsoft tech forum about a game that they didn´t develop, i tip my hat for them :-) Keep up the good work!

    Monday, January 17, 2011 4:00 PM
  • ok so i have did every thing here but one and thats the run as administer check and thats becaouse it wont let me check the thing but i have tryed right clicking the game and hitting run as administrer  ps sry for my bad english in other words the fix did not work for me i am running on windows vista BTW
    Saturday, January 29, 2011 12:00 AM
  • thank for the tips, now I'm able to playing General and zero hour both work perfectly and smooth. Thanks again and love you guy.
    Sunday, March 27, 2011 3:42 PM
  • It works in windows 8 - a million thanks, he he he Wow!

    mjra

    Wednesday, December 26, 2012 3:48 AM
  • hey man I need help installing it on windows 8 64-bit. Is yours also 64-bit? Please anybody that knows how to install it on windows 8 please tell me. Appreciate it!
    Sunday, December 08, 2013 6:48 AM
  • Hey guys I have windows 8 64 bit OS and after few nights doing research on zh error at startup, I was finally able to run the game =D. I did a lot of things such as creating the options.ini folder, deleting the dbghelp.dll file on C&C Zero-Hour folder in your Program Files, and installed the Microsoft Visual C++ 2008 Redistributable Package (x86). Important: On zero hour properties, uncheck the compatibility mode and do not run on administrator!

     

    Let me know if it helped!

    Saturday, December 14, 2013 9:59 AM
  • Hey Gang

    Finally after months of trying!

    I did the steps below and it worked! I am using Origin digital download with XP 32-Bit

    FIRST, I right clicked generals in Origin and selected "repair".

    THEN I did the following:

    To work your way around this issue, proceed to follow the steps below:

    1. Locate your C&C Generals or C&C Zero-Hour folder in your Program Files.
    2. Locate the file dbghelp.dll
    3. Delete the file.
    4. Attempt to start Generals again.

    Your game should now be running normally.

    Good Luck!
    Tuesday, January 21, 2014 6:49 AM
  • I do what you say, but still can't play

    Who have other ways to me some help

    I want to play this game
    Monday, April 28, 2014 5:52 PM
  • I do what you say, but still can't play

    Who have other ways to me some help

    I want to play this game

    Try this:

    Right click on the game (in Origin)

    Choose settings and select Disable Origin in Game.

    Worked for me (I was having troubles with both Generals and Red Alert 3).

    I have Windows 8.1 x 64. My problem was that Generals would not start at all, while Red Alert would start but I was unable to change the resolution. But after changing that setting everything was fine.



    Friday, December 12, 2014 10:35 PM
  •     1st ISSUE:  I'm running win7 on an icore7 8 Gig RAM DDR3 machine 1600 x1200 resolution, since it does not support WinXP; I am forced to use Win7. Since then, I have had nothing but issues on getting programs to run correctly without glitches.  I loaded C&C ZH with patch 1.04 (clean install) and it runs, then as soon as I install New Tech Mod, I get that annoying Overheat "catch all"error.  I have made several copies of the C&C ZH w/1.04patch so I can experiment with options. 

    ok nice thanks Win7+ Mozilla; just crashed after hitting sumit to an update here. 

    Clean install added patch 1.04 and it ran ok

    then added NTM and the game ran ok

    then tried copying my old copy of NTM over that one and it crashed after two minutes of play.

    REPAIR does not work at all so I have to start over with a new clean install.

    Ok uninstalled Zero Hour and cleaned the old files and reinstalled and it now crashes after 2 minutes. SO it looks like not only do I have to uninstall ZH but Generals also and re-install both programs. This is one giangantic pain in the butt!!!

         2nd ISSUE:  I moved all of my files from XP using the Win Transfer File program after I installed Win7, and have all of my old C&C folders with all of the game mods: Reborn, Remix, NTM, etc...After I couldn't get the new C&C ZH NTM to work I went back to the old copies of the mods. I get the old ones to work, but they crash after the 2 minute window. I tried the suggestions with the Options.ini but it made no difference. I fixed this once before on my WinXP, but I forgot how I fixed that issue. I am sure Win7 will not be the same solution!  

         Tried the regedit and changed the serial with dashes and the clean install does not work it crashes right off the bat so I changed it back.

         Tried changing the virtual memory page filing  initial to 15000 Mg from 16 Mg and max from 12500 Mb to 30000 Mg.

    nothing is working.

    Options.ini

    AntiAliasing = 4
    BuildingOcclusion = yes
    CampaignDifficulty = 0
    DrawScrollAnchor =
    DynamicLOD = yes
    ExtraAnimations = yes
    GameSpyIPAddress = 0.0.0.0
    Gamma = 50
    HeatEffects = yes
    IPAddress = 0.0.0.0
    IdealStaticGameLOD = High
    LanguageFilter = false
    MaxParticleCount = 5000
    MoveScrollAnchor =
    MusicVolume = 55
    Resolution = 1600 1200
    Retaliation = yes
    SFX3DVolume = 79
    SFXVolume = 71
    ScrollFactor = 42
    SendDelay = no
    ShowSoftWaterEdge = yes
    ShowTrees = yes
    StaticGameLOD = High
    TextureReduction = 0
    UseAlternateMouse = no
    UseCloudMap = yes
    UseDoubleClickAttackMove = no
    UseLightMap = yes
    UseShadowDecals = yes
    UseShadowVolumes = yes
    VoiceVolume = 70






    • Edited by casmaran Tuesday, March 10, 2015 1:01 AM
    Monday, March 09, 2015 6:10 PM
  • Ok Mozilla or the web site keeps crashing everytime I try to do an update this is my third attempt to update on this matter uhhhhhhhhhhh

    AS I WAS TRYING TO SAY.....

    added patch 1.04 to clean install and it ran ok

    then added NTM and it ran ok

    then I copied over the clean install with my old NTM to see if it would work and it crashed after 2 minutes.

    What is preventing it from working I never had issues like this on WinXP!!!!! WIN7 is one giant pain in the butt program!

    Monday, March 09, 2015 11:39 PM