none
because of a protocol error this session will be disconnected. please try connecting to remote computer again

    Question

  • Hi,

    When i remote desktop to a terminal server from windows 7 RC and run terminal services manager and remote control a terminal server session (which i do quite a bit, as i am an IT Administrator) it connects to the session for a split second but then disconnects and displays the following error:

    because of a protocol error this session will be disconnected. please try connecting to remote computer again

    It does this every time i try and connect to a terminal server session.... annoying much!

    Anyone had a similar problem or is this alreadya  known problem, i have search the forum but could not find anything related.

    Please could anyone help.
    Thanks.
    Thursday, May 7, 2009 8:06 AM

Answers

  • After three whole days of slamming my head in the car door, I have come to the conclusion that the problem is the mstscax.dll and mstsc.exe in the system 32 file

    and the other two files in the en-US or your language folder, that is the culprit,  that is giving the unstable connection, reason being is that I switched that file with a

    known good working rdc in vista and it works flawlessly in windows 7, let me know if you need any help!!
    Sunday, May 10, 2009 12:26 PM

All replies

  • After three whole days of slamming my head in the car door, I have come to the conclusion that the problem is the mstscax.dll and mstsc.exe in the system 32 file

    and the other two files in the en-US or your language folder, that is the culprit,  that is giving the unstable connection, reason being is that I switched that file with a

    known good working rdc in vista and it works flawlessly in windows 7, let me know if you need any help!!
    Sunday, May 10, 2009 12:26 PM
  • I'm having a similar problem.

    We use XP SP3 machines to connect to a 2008R2 RDS farm. If i'm remote controlling another user all goes well untill I stop remote controlling the user. When I stop i get exactly the same error on both sides (the session I was controlling and my own session).

    If i'm connected to the RDS farm from a 2003 machine the problem only exists on the cliënt side thats using XP.

    Edit:
    admin -> RDS -> remote controlled cliënt
    XP SP3 -> RDS -> XP SP3 (Both sides get the error)
    XP SP3 -> RDS -> 2003 (Only XP SP3 gets the error, when ending remote control)
    2003 -> RDS -> XP SP3 (Only XP SP3 gets the error, but this time when starting the remote control session, NOT when ending it)

    Any solution yet?

    EDIT: I didn't notice this is in the Windows 7 thread :/
    Wednesday, October 21, 2009 7:16 AM
  • Sorry javy.k i dont have access to any 2008 servers to test! we are running 2003 which works fine!

    AJ.
    Wednesday, October 21, 2009 10:28 AM
  • I have this exact problem.

    Windows 2008 R2 Terminal server and every time I stop remote controlling a session the user is disconnected.
    Unfortunately I don't have the option of running RDP 7.0 on them as most of the clients are Thin Terminals.

    This used to work fine in 2003 but since we have migrated to the new R2 server we have experienced this problem.
    Clients are not happy!

    Friday, November 6, 2009 4:33 AM
  • i have the same problem today.
    as soon as they accept the session it comes up with the error
    im going to copy some of the defected files from vista to my windows 7. Even though i hate windows 7 it does have some uses.
    Monday, November 30, 2009 2:56 PM
  • This sollution helps for me, all credits for the author

    SYMPTOMS

    When a user remote controls another user's session using Remote Desktop Services Manager or Terminal Services Manager on a Windows Server 2008-based computer, and then stops remote controlling, one or both sessions are disconnected with the following error:

    Remote Desktop Disconnected

    Because of a protocol error, this session will be disconnected. Please try connecting to the remote computer again.

    CAUSE

    This problem occurs if Remote Desktop Connection Client version 6.0.6001 or 6.0.6002 is used with the highest RDP Compression setting. Windows Server 2008 SP1/SP2 defaults to a lower RDP Compression setting, and thus will only exhibit the above symptoms if the setting has been changed to "Optimized to use less network bandwidth", which is the maximum. Windows Server 2008 R2 defaults to the maximum RDP Compression setting.

    WORKAROUND

    Change the RDP Compression setting on the server to "Balances memory and network bandwidth" (recommended) or "Optimized to use less memory" using Group Policy. If using Windows Server 2008 R2 you may also choose "Do not use an RDP compression algorithm". An alternative workaround is to use a different Remote Desktop Connection Client version than those mentioned above, however, this may not be practical. Below are instructions for making the change to the local group policy; if preferred you can use a domain group policy instead.

    Windows Server 2008 R2

    1. Logon to the Remote Desktop Services Session Host computer as an administrator
    2. Start--Run gpedit.msc
    3. In the left pane, under Computer Configuration, navigate to following:

    Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment

    4. In the right pane, double-click on Set compression algorithm for RDP data
    5. Select Enabled, and choose Balances memory and network bandwidth
    6. Click OK to save the change

    Windows Server 2008 (SP1 or SP2)

    1. Logon to the Terminal Services computer as an administrator
    2. Start--Run gpedit.msc, click Continue if prompted by UAC
    3. In the left pane, under Computer Configuration, navigate to following:

    Administrative Templates\Windows Components\Terminal Services\Terminal Server\Remote Session Environment

    4. In the right pane, double-click on Set compression algorithm for RDP data
    5. Select Enabled, and choose Balances memory and network bandwidth
    6. Click OK to save the change

    STEPS TO REPRODUCE

    Windows Server 2008 R2 x64

    1. Install 2008 R2 Standard (Full Installation) x64 from DVD using defaults
    2. Upon first logon, scroll down the initial configuration tasks window and click on Enable Remote Desktop
    3. Choose Allow connections from computers running any version of Remote Desktop (less secure), click OK
    4. Open up Computer Management and create a test user, make them a member of the Remote Desktop Users group, on the Remote Control tab, uncheck "Require user's permission"
    5. Connect from a PC using Remote Desktop Client version 6.0.6001 or 6.0.6002 to the server, logon as administrator
    6. Connect from a PC using Remote Desktop Client version 6.0.6001 or 6.0.6002 to the server, logon as the test user
    7. In the administrator's session, open up Remote Desktop Services Manager, right-click on the test user and choose Remote Control, click OK
    8. After you are viewing the test user's desktop, press Ctrl-Tab to end the Remote Control

    Windows Server 2008 x64

    1. Install 2008 Standard (Full Installation) x64 from DVD using defaults
    2. Upon first logon, scroll down the initial configuration tasks window and click on Enable Remote Desktop
    3. Choose Allow connections from computers running any version of Remote Desktop (less secure), click OK
    4. Open up Computer Management and create a test user, make them a member of the Remote Desktop Users group, on the Remote Control tab, uncheck "Require user's permission"
    5. Change RDP Compression algorithm to "Optimized to use less network bandwidth" using instructions above
    6. Connect from a PC using Remote Desktop Client version 6.0.6001 or 6.0.6002 to the server, logon as administrator
    7. Connect from a PC using Remote Desktop Client version 6.0.6001 or 6.0.6002 to the server, logon as the test user
    8. In the administrator's session, open up Terminal Services Manager, right-click on the test user and choose Remote Control, click OK
    9. After you are viewing the test user's desktop, press Ctrl-Tab to end the Remote Control

    NOTE: This problem may occur when connecting to a Windows Vista or Windows 7 host under similar conditions. I have not tested this theory, however.

    As always I welcome your comments/questions/corrections/suggestions/etc.

    Thank you for reading.

    -TP
    sjoerd
     
    Posts: 166
    Joined: Fri Apr 18, 2008 6:27 am
    • Proposed as answer by KeithM66 Wednesday, January 13, 2010 4:21 PM
    Tuesday, December 8, 2009 7:37 AM
  • Thanks Sjouwert. That fixed the problem for me (Server 2008 SP2).
    • Proposed as answer by Samodov Di Thursday, August 23, 2012 5:14 AM
    • Unproposed as answer by Samodov Di Thursday, August 23, 2012 5:14 AM
    Wednesday, January 13, 2010 4:23 PM
  • to fix this issue with SBS 2003, What I did is I extracted the registry file from a working server 2003.

    Registry file is located on HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\CONTROL\TERMINALSERVER\WINSTATION

    I exported the file. then backed up the registry in the server in question and then applied the exported registry.

    Tested okay for me. Hope this helps.

    Fernando
    Wednesday, February 10, 2010 9:28 AM
  • I have the same problem with RDP connection to Win 2008 r2. The problem occurs with windows xp sp3 and windows 7 as a RDP client..
    Sunday, March 7, 2010 9:50 PM
  • Hi,

    When i remote desktop to a terminal server from windows 7 RC and run terminal services manager and remote control a terminal server session (which i do quite a bit, as i am an IT Administrator) it connects to the session for a split second but then disconnects and displays the following error:

    because of a protocol error this session will be disconnected. please try connecting to remote computer again

    It does this every time i try and connect to a terminal server session.... annoying much!

    Anyone had a similar problem or is this alreadya  known problem, i have search the forum but could not find anything related.

    Please could anyone help.
    Thanks.

     

         I am experiencing this exact same problem when remoting in from my Windows 7 Professional Retail 64 bit workstation to a Windows 32 bit 2003 Terminal server.  The only way i can get this to work is to remote into one terminal server and from there remote in to the other one. Than it will work.  This is really a pain when you have to do this all the time.  Any fix for this

    -Ian


    • Proposed as answer by jor2k Monday, September 23, 2013 2:06 PM
    Friday, April 9, 2010 3:35 PM
  • I ran into this same error from a Win7 client to an x86 Windows 2003 R2 host. 

    Short answer:  disable bitmap caching. (use bitmapcachepersistenable:i:0 in an RDP file)  Note:  I've verified this only via. 1 client, but it was very consistent... toggling this ONE setting triggered the error every time.

    I tried a number of things to diagnose:

    ProcessMonitor to identify what was running at the time of the "error".  I subsequently tried to disable all startup apps because it appeared to drop the connection after/during some of those apps were initiated.  I also disabled all domain-level startup scripts.  At first, this actually seemed to work, however after re-enabling all these apps, I was still able to connect. 

    Tried to use WireShark sniff the packets & find any protocol flags/differences... there aren't any (that I could find) parsers for the RDP protocol, though.  And it's also encrypted/compressed... tried turning that off, but this looked like a dead-end.

    Co-worker suggested enablecredsspsupport:i:0.  This DID work, at least for the 1st connection.  Subsequent connections failed... this is what made me think of the caching-setting.

    ** edit

    ok, this bitmap caching gave us some other ideas... what bitmap was causing the problem?  As it turns out, this Dell server had it's default wallpaper file renamed/removed.  DellWall.bmp located in the win\system32 folder.  The registry, however, still referenced this file under:
    hkey_users\.default\Control Panel\Desktop\Wallpaper

    When we put this file back, the protocol errors went away regardless of the bitmap caching setting!

    • Edited by xyvyx Monday, August 16, 2010 9:15 PM more info
    • Proposed as answer by Jeff_ILHOD Monday, November 15, 2010 4:31 PM
    Monday, August 16, 2010 8:32 PM
  • ok, technet gets farbled up when I attempt to re-edit my prior post. 

    That said, restoring this wallpaper image DID resolve it for one user, but not for my account... however, when I disable this caching setting, it DOES still resolve the problem regardless of background image settings.

    Monday, August 16, 2010 10:37 PM
  • I just had this error with a Windows7 workstation trying to connect to Server 2003 Terminal server.  i was able to get the error resolved by remoting in as the user to the TS from the DC and logging off, then was able to log in to the Term server from the users workstation without any errors. 
    Monday, July 11, 2011 4:17 PM
  • Can you help please?  Which file did you switch?  The user is connecting via a thin client.
    Thursday, July 14, 2011 9:20 AM
  • Solved ! Solved ! Solved!

     

    its nothing simple solution.

     

    belongs to Resolution issue. Please find the answer in  the below link.

     

    http://tech2solution.com/forum/index.php?topic=4.0

     

    Tuesday, September 20, 2011 3:28 PM
  • Same problem here. RD from win 7 to server 2003 x86. My Rd window eventually just started shutting down even before I got to the login screen. After following xyvyx's post above and removing the bitmap caching I was able to connect. This has been going on for months, THank you!!!!
    Wednesday, February 22, 2012 1:22 PM
  • My dear,

    When I copy these two files into the Windows 7 system, even in safe mode using "Administrator" ID, I get the error: "Permission denied" and some time, "The user did not get permission from the windows Installer".

    This solution I am trying for the below problem, Kindly suggest how to get permission in WINdows 7 system, I could not give FULL permission for my local Admin.

    The nature of the problem: When I connect to WIN 7 System through remote Desktop, within 20 minutes it get disconnected with the error on the screen:

    " Your Remote Desktop Session has ended. your network Admin might have ended the connection. Try connecting again, or contact technical support for assistance".

    The Windows Security event err ID: 5152 at that time is pasted below: 

    The Windows Filtering Platform has blocked a packet.

    Application Information:

                    Process ID:                          0

                    Application Name:           -

    Network Information:

                    Direction:                            Inbound

                    Source Address:                               <------- >

                    Source Port:                       68

                    Destination Address:      255.255.255.255

                    Destination Port:                              67

                    Protocol:                              17

    Filter Information:

                    Filter Run-Time ID:          67245

                    Layer Name:                      Transport

                    Layer Run-Time ID:          13

    Wednesday, February 29, 2012 11:40 AM
  • Hello everyone,

    I was facing a similar issue today morning.

    Connecting from Operating System: Windows 7 Enterprise

    Version: 6.1

    Connecting to RD Session where

    Operating System: Windows Server 2003 Enterprise

    Version 5.2

    I was able to fix my problem with some tips in here; All I did is removed the "Persistent bitmap caching" as shown in the image below:

    Resolution for Remote Desktop Connection Error

    Hope this helps.


    Analyst (Technology Specialist)

    • Proposed as answer by jmiller2101 Tuesday, June 26, 2012 3:38 PM
    Wednesday, May 2, 2012 9:33 AM
  • Thanks a lot Sjouwert. This fixed the problem  (Server 2008 R2).
    Thursday, June 21, 2012 11:43 AM
  • Thanks Syhussaini, this solve my issue. (2003 x84 server & 2008 R2 x64 server)

    Justin Miller



    Tuesday, June 26, 2012 3:40 PM
  • This, along with disabling visual styles seems to have solidified connections we had here, From Win 7 Pro/Ult --> Server 2008R2 Sever 2012, that had previously been disconnecting without reason.

    Thanks, Good tip.

    Ian

    Thursday, May 9, 2013 6:58 PM
  • For me, nothing seemed to work - not even Sjoerd's GREAT write up. I even attempted to fix by disabled Visual Styles and Persistent Bitmap Caching.

    But I WAS able to find a ridiculously simple fix. In my case, running an RDC connection from a Win7 client to a Win 2003 Terminal Server:

    1) Logon to the Terminal Server
    2) Change the desktop background and save

    Believe it or not, that was it! We re-initiated the RDC connection and the issue was resolved. Don't ask me WHY it was, but the error did not re-occur. Maybe  Microsoft can identify why it worked. But I hope it helps some of you out there!

    Tuesday, February 25, 2014 2:35 PM
  • Hi ! I am facing the same problem . Can you please help me and send me these four files mstscax.dll and mstsc.exe in the system 32 file  and the other two files in the en-US or your language folder from vista to windows 7 so that rdp can work ? I have tried many things but problem is still persisting . 

    Thanks

    Tuesday, April 22, 2014 8:46 PM
  • WORKAROUND / SOLUTION:

    Change the RDP Compression setting on the server to "Balances memory and network bandwidth" (recommended) or "Optimized to use less memory" using Group Policy. If using Windows Server 2008 R2 you may also choose "Do not use an RDP compression algorithm". An alternative workaround is to use a different Remote Desktop Connection Client version than those mentioned above, however, this may not be practical. Below are instructions for making the change to the local group policy; if preferred you can use a domain group policy instead.

    Windows Server 2008 R2

    1. Logon to the Remote Desktop Services Session Host computer as an administrator
    2. Start--Run gpedit.msc
    3. In the left pane, under Computer Configuration, navigate to following:

    Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment

    4. In the right pane, double-click on Set compression algorithm for RDP data
    5. Select Enabled, and choose Balances memory and network bandwidth
    6. Click OK to save the change

    Windows Server 2008 (SP1 or SP2)

    1. Logon to the Terminal Services computer as an administrator
    2. Start--Run gpedit.msc, click Continue if prompted by UAC
    3. In the left pane, under Computer Configuration, navigate to following:

    Administrative Templates\Windows Components\Terminal Services\Terminal Server\Remote Session Environment

    4. In the right pane, double-click on Set compression algorithm for RDP data
    5. Select Enabled, and choose Balances memory and network bandwidth
    6. Click OK to save the change
    • Proposed as answer by STEVO731 Wednesday, December 17, 2014 2:47 AM
    • Unproposed as answer by STEVO731 Wednesday, December 17, 2014 2:47 AM
    Wednesday, June 4, 2014 8:36 PM
  • Dear,

    I had better results when I didn't connect full screen (I could log in!) but then still from time to time was kicked out.

    I was trying all kinds of things and it seems to be better now by disabling 2 options that were on by default:

    Local Resources > Untick Printers > click More... > untick Smartcards

    Now I can connect full screen, time will tell if it is a proper permanent fix...<img alt="Local Resources > Untick Printers > click More... > untick Smartcards" src="https://social.technet.microsoft.com/Forums/getfile/1113993" />


    • Edited by Peter__S Tuesday, August 22, 2017 2:57 PM
    Tuesday, August 22, 2017 2:56 PM