none
How to fix searchprotocolhost.exe error?

    Question

  • Searchprotocolhost.exe is running all of the time in my processes and pegging out my cpu at 100%.  I try to end process and it comes right back.  I try to end process tree and it comes back again.  If I reboot it still runs all of the time.  I am running vista w/ all of the latest updates.  Does anyone know of a fix for this?
    • Moved by Carey FrischMVP, Moderator Saturday, November 06, 2010 3:06 AM Moved to proper forum category (From:Windows Vista Announcements)
    Sunday, November 19, 2006 1:33 AM

Answers

  • OK, Im only running XP Pro as I find it a bit more stable. To get around the problem, I Start / Run and in the box type services.msc and press enter/click OK. Go down to Windows Search and double click on it. Stop the service and then disable it from starting. My machine now runs like a racehorse.

     

    Cheers

    Tim 

    Thursday, November 22, 2007 11:10 AM

All replies

  • Hi, what build do you use?

    I would suggest you to use RTM version too see whether you got the same problem.(Remark: You need to PAID to use RTM version)

    Sunday, November 19, 2006 7:59 PM
  • By the way, MS is looking on this problem too:

    https://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=863356&SiteID=1

    Sunday, November 19, 2006 8:01 PM
  • The download Beta of Vista that I am using is...

    vista_5600.16384.060829-2230_x86fre_client-lr1cfre_en_dvd.iso

    It has also got a couple of updates since I have installed it.

     

     

    Sunday, November 19, 2006 9:24 PM
  • It's quite a OLD build aready. I would suggest to use RTM now.(Sure, it's not free)
    Monday, November 20, 2006 2:45 AM
  • Although I wouldn't be too sure that i have the same problem I could use some advice.

    My PC seems to be in permanent overdrive leaving the tower very noisy. I recently installed Office 2007 Enterprise and since the following seem to be running permenantly. 

     

    searchprotocolhost.exe

    search filterhost.exe

    search indexerhost.exe.

     

    My system has a 250 Gig HD with around 100 Gigs free space.  I have also recently added a 400 Gig external backup drive and upgraded the Ram from 512 to 2512 by adding twin 1 Gig memories.

     

    Help please.

    Wednesday, April 25, 2007 11:17 AM
  • did you try reference the above link? MS is trying to fix it.
    Thursday, April 26, 2007 4:51 PM
  • Hola, mi maquina me está arrojando un error de 2Wire Gateway USB y de Windows Search Protocol Host, el primero es mi modem de internet alambrico en casa y el segundo desconosco la aplicación de el error.

     

    Espero algún tipo de auyuda, gracias.

     

    Saludos...

    Wednesday, August 08, 2007 4:35 AM
  • I was using my computer and i noticed it was taking a long time to go to place to place.This PC is only 2 months old and had always been fast.I wish i understood computers more than i do.As soon as you purchase a computer,you purchase a warranty thinking that you are in good shape.Not knowing that the warranty is ONLY for the hardware.The software is like,ok its yours,have fun.They throw you a  bone and you are on your on.

      I went to my control panel and clicked on Problem reports and Solutions and this is where i found

    out about Protocolhost.exe.

     

    This problem was caused by Windows Search Protocol Host. Windows Search Protocol Host was created by Microsoft Corporation.

    We are aware of this problem and working as quickly as possible to make a solution available to our customers. We apologize for any inconvenience this has caused you.

     

      Would this cause the PC to take longer to go from one site to another? I sure hope someone will help  me.

     

        Thank you for your time.  Richard

    By not putting in my e-mail address, how can anyone get back to me?
    Wednesday, August 29, 2007 5:57 PM
  • Monday, September 24, 2007 8:13 PM
  •  

    i already try different ways and I can't fix this
    Wednesday, October 03, 2007 5:24 PM
  • Same thing just started happening to me.  The Search Protocol is hanging up ever since I installed Outlook Connector!

    Saturday, October 13, 2007 9:22 PM
  • I think Vista search engine is useless I first index all files then disable windows search from services

    Wednesday, November 07, 2007 7:12 PM
  • OK, Im only running XP Pro as I find it a bit more stable. To get around the problem, I Start / Run and in the box type services.msc and press enter/click OK. Go down to Windows Search and double click on it. Stop the service and then disable it from starting. My machine now runs like a racehorse.

     

    Cheers

    Tim 

    Thursday, November 22, 2007 11:10 AM
  • hola mira, ami me pasa lo mismo, exactamente esos dos problemas, y se oye como mi máquina se detiene completamente, yo tengo Windows Vista, no se cual tengas tu, pero yo creo que el problema es con el vista
    Sunday, November 25, 2007 3:07 AM
  •  

    gracias
    Thursday, December 06, 2007 8:44 AM
  •  

    Top Man Flitch,

     

    I too am running XP Pro and my CPU went from maxing out to sleeping like a baby.

     

    Thanks for that.

     

    Hopefully no side effects.

     

     

    Wednesday, February 27, 2008 10:05 AM
  • AJ,

     

    the only thing that will not work is the Full Search. You can still use the old version but other than that, there are no side effects that I have come across other than a quiet PC.

     

    Cheers

    Tim

    Thursday, February 28, 2008 8:39 AM
  • I don't know if it has already been posted, but i managed to find a fix which works perfectly for me.
    http://forums.techarena.in/showthread.php?t=804884

    Enjoy guys!
    Saturday, May 10, 2008 11:03 AM
  •  brad006 wrote:
    Searchprotocolhost.exe is running all of the time in my processes and pegging out my cpu at 100%.  I try to end process and it comes right back.  I try to end process tree and it comes back again.  If I reboot it still runs all of the time.  I am running vista w/ all of the latest updates.  Does anyone know of a fix for this?
    \

     

    Seems that this garbage came in on "Windows Search 4.0"

     

    I'm DEEELEEETING it right now. There. It's gone, but it left pieces of it's crappy self in my what-used-to-be-pretty-clean Vista install

     

    It seems the whole search system BOGS up the regular running of Vista, which was horribly LOUSY to begin with.

     

    Why can't Microsoft make an update that REMOVES the service-driven Search Indexer and gives us something that works, like the search in Windows 2000?

     

    I don't WANT to search on the internet. I do not WANT to search my LAN or any other "AN"- I JUST want to search the files on my computer- ALL of the files even the hidden ones, like I can do with Windows 2000 and XP.

     

    Please, Please STOP developing these horrid things and give us back the WORKING search fucntions that we had in XP.

     

    The Vista Search is SO bad that I have to log off, and log back in using XP to find any file I may need.

     

    Ok.. the Windows Search 4.0 has to be DELETED, but you also have to SHUT OFF the Windows Search service.

    • Proposed as answer by wnmarsh Saturday, February 18, 2012 8:08 PM
    Tuesday, July 29, 2008 8:56 PM
  • Thank you--this works.

     

    • Proposed as answer by one_one Sunday, October 10, 2010 3:02 PM
    Wednesday, August 20, 2008 9:14 AM
  • Thank you--it works.

     

    • Proposed as answer by vrooyenl Thursday, December 08, 2011 12:31 PM
    Wednesday, August 20, 2008 9:15 AM
  • That thread is all about this problem affecting hotmail users and Outlook Express, and there is no helpful answer there since no one at Microsoft has been able to reproduce the problem and find a fix.  So maybe some others at MS should be looking into it?  I use neither hotmail nor OE, so how does this apply to me?  The problem is not liminted to the area the thread is.
    Thursday, October 09, 2008 11:57 AM
  • Clamo88,

     

    I'm confused. I think that you have posted in the wrong thread. Searchprotocolhost.exe only applied to the Microsoft Search facility as far as I am aware. Outlook Express files will be included in the search but absolutely nothing from your Hotmail account. Your Hotmail account is on the web, not your local machine so the Windows search will not look there. If it did, you would have your own search engine containing many terra bytes of data, from the whole web, on your local machine. 

     

    Cheers

    Tim

    Thursday, October 09, 2008 12:14 PM
  • I am having this on two VISTA machines... your answer as to RTM version makes no sense at all. what product is this associated with, and how do you remove it?
    Saturday, November 08, 2008 11:51 PM
  • RickGT,

     

    This is asociated with the Windows Search service. It is an authorised Windows Update which comes down when you perform your regular updates. To make this service stop using all your CPU you need to stop the service from running. Look back to Page 1 and follow the instructions that I posted there and your problem will go away.

     

    Cheers

    Tim

    Sunday, November 09, 2008 1:58 PM
  • Thank you so much! this worked for me and my XP Pro.

    Pam

    Friday, November 21, 2008 11:40 AM
  •  

    "Ok.. the Windows Search 4.0 has to be DELETED, but you also have to SHUT OFF the Windows Search service."

    Not sure why there is a comment about Windows Search service.
    Removing Windows Search 4.0 via add remove programs allowed the machine to become usable again, reduced the 100% CPU usage on a quad processor to the normal 2%.

    Thursday, January 01, 2009 12:33 PM
  • Hey Everyone,  this is caused from the new windows search feature...

    Here's a quick fix

    Go to Start>Run

    and type:

    services.msc

    click ok

    find windows search in the list and stop the service.  Now right click Windows Search and go to Properties.  Now change the startup type in the pull down menu to Disabled. 

    This Feature really is not great any way... they should make it easier to turn off...

    Good luck!!!
    • Proposed as answer by RedRob Sunday, August 08, 2010 3:54 AM
    Saturday, February 07, 2009 12:55 AM
  • Hi. two and a half years later and I, running xp, have just experienced this problem. I can't find any resolution at the link https://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=863356&SiteID=1. I stopped searchprotocolhost.exe as suggested by others, and that's fine except it kills Outlook instant search, which I depend on. Help, please.

    • Proposed as answer by navyjon1 Sunday, August 08, 2010 4:28 PM
    Saturday, April 25, 2009 3:39 PM
  • Installing Windows Search 4.0 for Windows XP (KB940157 resolved this issue.
    Thursday, August 13, 2009 3:00 PM
  • Thank you Tim. I was able to stop the service, but then I had to end the "searchprotocolhost.exe" process manually using Task Manager.

    Friday, December 11, 2009 5:02 PM
  • it worked tim thank you for being smarter than bill gates and his crew cause they cant figure it out



                                                                                                                                      mike
    Sunday, January 10, 2010 9:23 PM
  • Yup, Tim's soloution works.

    If like me, you can't even start services.msc from windows.... as the search has gone crazy,

    you should also start up in safe mode (which Windows7 will kindly do for you if you have to reset the machine like I did)

    In safe mode, the WindowsSearch service doesn't run, but you can still disable it

     

    Hint to microsoft guys:

       Seems to get hung up when indexing video files.

       (Seen in resource monitor, when looking for what's keeping the disk busy)

    Sunday, August 08, 2010 4:06 AM
  • Nice work, Tim, did the job, XP SP3.

    Cheers

    Sam

    Friday, November 05, 2010 12:16 PM
  • thanks g man gman means great man thanks bro  it fixed
    Wednesday, December 01, 2010 2:16 PM
  • Has anyone come across a real fix for this problem? Indexed Searching can be a useful feature, and is supposed to work. So disabling it is not really a fix, just a workaround if its bugging you too much.

    Clearing your indexed searches is also not a fix, as the problem reoccurs when it reindexes and reaches to problem again.

    Thursday, January 06, 2011 10:34 AM
  • You are my hero.. I hope this works.. do I need to reboot after changing the above setting?
    Saturday, February 22, 2014 3:17 PM